SQL Server Data Tools에서 패키지 복사Copy a Package in SQL Server Data Tools

이 항목에서는 기존 패키지를 복사하여 새 Integration ServicesIntegration Services 패키지를 만드는 방법과 새 패키지의 NameGUID 속성을 업데이트하는 방법에 대해 설명합니다.This topic describes how to create a new Integration ServicesIntegration Services package by copying an existing package, and how to update the Name and GUID properties of the new package.

패키지를 복사하려면To copy a package

  1. SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서 복사할 패키지가 들어 있는 Integration ServicesIntegration Services 프로젝트를 엽니다.In SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), open the Integration ServicesIntegration Services project that contains the package that you want to copy.

  2. 솔루션 탐색기에서 패키지를 두 번 클릭합니다.In Solution Explorer, double-click the package.

  3. 복사할 패키지를 솔루션 탐색기에서 선택했는지 또는 패키지가 포함된 SSIS 디자이너의 탭이 활성 상태인지 확인합니다.Verify either the package to copy is selected in Solution Explorer or the tab in SSIS Designer that contains the package is the active tab

  4. 파일 메뉴를 클릭 하 여 저장 <패키지 이름 >으로합니다.On the File menu, click Save <package name> As.

    참고

    SSIS 디자이너에서 패키지를 열어야 파일 메뉴에 다른 이름으로 저장 옵션이 표시됩니다.The package must be opened in SSIS Designer before the Save As option appears on the File menu.

  5. 필요에 따라 다른 폴더를 찾습니다.Optionally, browse to a different folder.

  6. 패키지 파일 이름을 업데이트합니다.Update the name of the package file. .dtsx 파일 확장명을 유지해야 합니다.Make sure that you retain the .dtsx file extension.

  7. 저장을 클릭합니다.Click Save.

  8. 프롬프트에서 파일 이름과 일치시킬 패키지 개체의 이름을 업데이트할 것인지 여부를 선택합니다.At the prompt, choose whether to update the name of the package object to match the file name. 를 클릭하면 패키지의 Name 속성이 업데이트됩니다.If you click Yes, the Name property of the package is updated. 새 패키지가 Integration ServicesIntegration Services 프로젝트에 추가되고 SSISSSIS 디자이너에서 열립니다.The new package is added to the Integration ServicesIntegration Services project and opened in SSISSSIS Designer.

  9. 필요에 따라 제어 흐름 탭의 배경을 클릭하고 속성을 클릭합니다.Optionally, click in the background of the Control Flow tab, and the click Properties.

  10. 속성 창에서 ID 속성을 선택한 다음 드롭다운 목록에서 값을 클릭 <새 ID 만들기 >합니다.In the Properties window, click the value of the ID property, and then in the drop-down list click <Generate New ID>.

  11. 파일 메뉴에서 선택한 항목 저장 을 클릭하여 새 패키지를 저장합니다.On the File menu, click Save Selected Items to save the new package.

관련 항목:See Also

패키지의 복사본 저장 Save a Copy of a Package
SQL Server Data Tools에서 패키지 만들기 Create Packages in SQL Server Data Tools
Integration Services ( Ssis) 패키지Integration Services (SSIS) Packages