스크립트 태스크 및 스크립트 구성 요소에서 중단점을 설정하여 스크립트 디버깅Debug a Script by Setting Breakpoints in a Script Task and Script Component

이 절차에서는 스크립트 태스크 및 스크립트 구성 요소에 사용되는 스크립트에서 중단점을 설정하는 방법에 대해 설명합니다.This procedure describes how to set breakpoints in the scripts that are used in the Script task and Script component.

스크립트에 중단점을 설정한 후의 중단점 설정- <개체 이름 > 대화 상자에 기본 제공 중단점 함께 나열 합니다.After you set breakpoints in the script, the Set Breakpoints - <object name> dialog box lists the breakpoints, along with the built-in breakpoints.

중요

스크립트 태스크 및 스크립트 구성 요소의 중단점이 무시되는 경우도 있습니다.Under certain circumstances, breakpoints in the Script task and Script component are ignored. 자세한 내용은 참조는 스크립트 태스크 디버깅 섹션 코딩 및 스크립트 태스크 디버깅Debugging the Script Component 섹션 코딩 및 스크립트 구성 요소 디버깅합니다.For more information, see the Debugging the Script Task section in Coding and Debugging the Script Task and the Debugging the Script Component section in Coding and Debugging the Script Component.

스크립트에 중단점을 설정하려면To set a breakpoint in script

  1. SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서 원하는 패키지가 들어 있는 Integration ServicesIntegration Services 프로젝트를 엽니다.In SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), open the Integration ServicesIntegration Services project that contains the package you want.

  2. 중단점을 설정하려는 스크립트를 포함하는 패키지를 두 번 클릭합니다.Double-click the package that contains the script in which you want to set breakpoints.

  3. 스크립트 태스크를 열려면는 제어 흐름 탭을 클릭 한 다음 스크립트 태스크를 두 번 클릭 합니다.To open the Script task, click the Control Flow tab, and then double-click the Script task.

  4. 스크립트 구성 요소를 열려면는 데이터 흐름 탭을 클릭 한 다음 스크립트 구성 요소를 두 번 클릭 합니다.To open the Script component, click the Data Flow tab, and then double-click the Script component.

  5. 클릭 스크립트 클릭 하 고 스크립트 편집합니다.Click Script and then click Edit Script.

  6. MicrosoftMicrosoft Visual StudioVisual Studio VSTA Tools for Applications (), 중단점을 설정, 해당 줄을 마우스 오른쪽 단추로 클릭 하 고, 가리킨 스크립트의 줄을 찾습니다 중단점, 클릭 하 고 중단점 삽입합니다.In MicrosoftMicrosoft Visual StudioVisual Studio Tools for Applications (VSTA), locate the line of script on which you want to set a breakpoint, right-click that line, point to Breakpoint, and then click Insert Breakpoint.

    코드 줄에 중단점 아이콘이 나타납니다.The breakpoint icon appears on the line of code.

  7. 파일 메뉴에서 끝내기를 클릭합니다.On the File menu, click Exit.

  8. 확인을 클릭합니다.Click OK.

  9. 패키지를 저장하려면 파일 메뉴에서 선택한 항목 저장 을 클릭합니다.To save the package, click Save Selected Items on the File menu.