Visual Studio를 사용 하 여 Linux에서 SQL Server에 대 한 데이터베이스를 만들 수Use Visual Studio to create databases for SQL Server on Linux

이 항목은 다음에 적용됩니다. 아니요Windows의 SQL Server예Linux의 SQL Server아니요Azure SQL Database아니요Azure SQL Data Warehouse아니요병렬 데이터 웨어하우스 THIS TOPIC APPLIES TO: noSQL Server on WindowsyesSQL Server on LinuxnoAzure SQL DatabasenoAzure SQL Data WarehousenoParallel Data Warehouse

SQL Server Data Tools (SSDT)는 Linux에서 SQL Server에 대 한 강력한 개발 및 데이터베이스 수명 주기 관리 (DLM) 환경으로 Visual Studio를 설정합니다.SQL Server Data Tools (SSDT) turns Visual Studio into a powerful development and database lifecycle management (DLM) environment for SQL Server on Linux. 개발 빌드 및 테스트 응용 프로그램 코드를 개발 하는 것 처럼 소스 제어 프로젝트에서 데이터베이스를 게시할 수 있습니다.You can develop, build, test and publish your database from a source controlled project, just like you develop your application code.

Visual Studio와 SQL Server Data Tools 설치Install Visual Studio and SQL Server Data Tools

  1. Windows 컴퓨터에 Visual Studio를 이미 설치 되지 않은 경우 다운로드 하 고 Visual Studio 설치합니다.If you have not already installed Visual Studio on your Windows machine, [Download and Install Visual Studio]. Visual Studio Community 버전 학생에 대 한 무료 이며 완전 한 기능의 IDE가 Visual Studio 라이선스가 없는 경우 오픈 소스 및 개별 개발자.If you do not have a Visual Studio license, Visual Studio Community edition is a free, fully-featured IDE for students, open-source and individual developers.

  2. Visual Studio를 설치 하는 동안 선택 사용자 지정 에 대 한는 설치 유형을 선택 옵션입니다.During the Visual Studio installation, select Custom for the Choose the type of installation option. 다음을 클릭합니다.Click Next

  3. 선택 Microsoft SQL Server Data Tools, Windows 용 Git, 및 Visual Studio 용 GitHub 확장 기능 선택 목록에서 합니다.Select Microsoft SQL Server Data Tools, Git for Windows, and GitHub Extension for Visual Studio from the feature selection list.

    ssdt setup

  4. 계속 하 고 Visual Studio의 설치를 마칩니다.Continue and finish the installation of Visual Studio. 몇 분 정도 걸릴 수 있습니다.It can take a few minutes.

SQL Server Data Tools를 SSDT 17.0 RC 버전으로 업그레이드Upgrade SQL Server Data Tools to SSDT 17.0 RC release

SQL Server 2017 Linux에서 SSDT 17.0 RC 이상 버전에서 지원 됩니다.SQL Server 2017 on Linux is supported by SSDT version 17.0 RC or later.

소스 제어에서 새 데이터베이스 프로젝트 만들기Create a new database project in source control

  1. Visual Studio를 시작 합니다.Launch Visual Studio.

  2. 선택 팀 탐색기보기 메뉴.Select Team Explorer on the View menu.

  3. 클릭 새로로컬 Git 리포지토리 섹션에서 연결 페이지.Click New in Local Git Repository section on the Connect page.

    local repository

  4. 만들기를 클릭합니다.Click Create. 로컬 Git 리포지토리를 만든 후 두 번 클릭 SSDTRepo합니다.After the local Git repository is created, double click SSDTRepo.

  5. 클릭 새로솔루션 섹션.Click New in the Solutions section. 선택 SQL Server 아래 다른 언어 에서 노드는 새 프로젝트 대화 상자.Select SQL Server under Other Languages node in the New Project dialog.

    local repository

  6. 에 입력 TutorialDB 이름과 클릭 확인 새 데이터베이스 프로젝트를 만듭니다.Type in TutorialDB for the name and click OK to create a new database project.

데이터베이스 프로젝트에 새 테이블을 만듭니다.Create a new table in the database project

  1. 선택 솔루션 탐색기보기 메뉴.Select Solution Explorer on the View menu.

  2. 마우스 오른쪽 단추로 클릭 하 여 데이터베이스 프로젝트 메뉴를 열고 TutorialDB 솔루션 탐색기에서 합니다.Open the database project menu by right-clicking on TutorialDB in Solution Explorer.

  3. 선택 테이블 아래 추가합니다.Select Table under Add.

    create table

  4. 테이블 디자이너를 사용 하 여 두 개의 열 이름 추가 nvarchar(50) 및 위치 nvarchar(50)그림에 표시 된 것 처럼 합니다.Using table designer, add two columns, Name nvarchar(50) and Location nvarchar(50), as shown in the picture. SSDT에서는 오류가 발생 하는 CREATE TABLE 디자이너에서 열을 추가한 것 처럼 스크립트입니다.SSDT generates the CREATE TABLE script as you add the columns in the designer.

    add columns

  5. 저장 된 Table1.sql 파일입니다.Save the Table1.sql file.

빌드 및 데이터베이스 유효성 검사Build and validate the database

  1. 데이터베이스 프로젝트 메뉴를 열고 TutorialDB 선택 빌드합니다.Open the database project menu on TutorialDB and select Build. SSDT은 프로젝트에서.sql 소스 코드 파일을 컴파일하고 데이터 계층 응용 프로그램 패키지 (dacpac) 파일을 작성 합니다.SSDT compiles .sql source code files in your project and builds a Data-tier Application package (dacpac) file. Linux에서 SQL Server 2017 인스턴스에 데이터베이스를 게시 데 될 수 있습니다.This can be used to publish a database to your SQL Server 2017 instance on Linux.

    add columns

  2. 빌드 성공 메시지 체크인 출력 Visual Studio의 창.Check the build success message in Output window in Visual Studio.

SQL Server 2017 Linux 인스턴스로 데이터베이스를 게시 합니다.Publish the database to SQL Server 2017 instance on Linux

  1. 데이터베이스 프로젝트 메뉴를 열고 TutorialDB 선택 게시합니다.Open the database project menu on TutorialDB and select Publish.

  2. 클릭 편집 Linux에서 SQL Server 인스턴스를 선택 합니다.Click Edit to select your SQL Server instance on Linux.

    publish dialog

  3. 연결 대화 상자에서 Linux, 사용자 이름 및 암호에 해당 SQL Server 인스턴스의 IP 주소 또는 호스트 이름을 입력 합니다.On the connection dialog, type in the IP address or host name of your SQL Server instance on Linux, user name and password.

    connection dialog

  4. 클릭는 게시 게시 대화 상자에서 단추입니다.Click the Publish button on the publish dialog.

  5. 게시 상태를 확인 합니다.는 데이터 도구 작업 창.Check the publish status in the Data Tools Operations window.

  6. 클릭 보기 Reulst 또는 스크립트 보기 결과 Linux에서 SQL Server에 게시 하는 목록의 세부 정보를 볼 수 있습니다.Click View Reulst or View Script to see details of the databsae publish result on your SQL Server on Linux.

    publish result

Linux에서 SQL Server 인스턴스에 새 데이터베이스를 생성 하 고 소스 제어 데이터베이스 프로젝트를 사용 하 여 데이터베이스 개발 자습서 했습니다 있습니다.You have successfully created a new database on SQL Server instance on Linux and learned the basics of developing a database with a source controlled database project.

다음 단계Next steps

T-SQL을 처음 접하는 경우 참조 자습서: TRANSACT-SQL 문 쓰기TRANSACT-SQL 참조 (데이터베이스 엔진)합니다.If you're new to T-SQL, see [Tutorial: Writing Transact-SQL Statements] and the [Transact-SQL Reference (Database Engine)].

SQL Data Tools를 사용 하 여 데이터베이스를 개발 하는 방법에 대 한 자세한 내용은 참조 SSDT MSDN 문서For more information about developing a database with SQL Data Tools, see [SSDT MSDN documents]