교착 상태 파일 열기, 보기 및 인쇄(SQL Server Management Studio)Open, view, and print a deadlock file (SQL Server Management Studio)

이 항목 적용 대상: 예SQL Server예Azure SQL 데이터베이스없습니다Azure SQL 데이터 웨어하우스 없습니다 병렬 데이터 웨어하우스THIS TOPIC APPLIES TO: yesSQL ServeryesAzure SQL DatabasenoAzure SQL Data Warehouse noParallel Data Warehouse SQL Server 프로파일러SQL Server Profiler에서 교착 상태가 생성되면 교착 상태 정보를 캡처하여 파일에 저장할 수 있습니다. When SQL Server 프로파일러SQL Server Profiler generates a deadlock, you can capture and save the deadlock information to a file. 교착 상태 파일을 저장한 다음 SQL Server Management StudioSQL Server Management Studio에서 해당 파일을 열어서 보거나 인쇄할 수 있습니다.After you've saved the deadlock file, you can open it in SQL Server Management StudioSQL Server Management Studio to view it or print it.

교착 상태 파일 열기 및 보기Open and view a deadlock file

  1. SQL Server Management StudioSQL Server Management Studio파일 메뉴에서 열기를 가리킨 다음 파일을 선택합니다.On the File menu in SQL Server Management StudioSQL Server Management Studio, point to Open, and then select File.

  2. 파일 열기 대화 상자의 파일 유형 확인란에서 .xdl 파일 유형을 선택합니다.In the Open File dialog box, select the .xdl file type in the Files of type box. 교착 상태 파일만 필터링한 목록이 남아 있을 것입니다.You now have a filtered list of only deadlock files.

  1. SQL Server Management StudioSQL Server Management Studio파일 메뉴에서 열기를 가리킨 다음 파일을 선택합니다.On the File menu in SQL Server Management StudioSQL Server Management Studio, point to Open, and then select File.

  2. 파일 열기 대화 상자의 파일 유형 확인란에서 .xdl 파일 유형을 선택합니다.In the Open File dialog box, select the .xdl file type in the Files of type box. 교착 상태 파일만 필터링한 목록이 남아 있을 것입니다.You now have a filtered list of only deadlock files.

  3. 인쇄할 교착 상태 파일을 선택하고 열기를 선택합니다.Select the deadlock file you want to print, and select Open.

  4. 파일 메뉴에서 인쇄를 선택합니다.On the File menu, select Print.

관련 항목:See also

교착 상태 그래프 저장(SQL Server Profiler)Save deadlock graphs (SQL Server Profiler)