XML 형식으로 실행 계획 저장Save an Execution Plan in XML Format

SQL Server Management StudioSQL Server Management Studio 를 사용하여 실행 계획을 XML 파일로 저장하고 열어서 볼 수 있습니다.Use SQL Server Management StudioSQL Server Management Studio to save execution plans as an XML file, and to open them for viewing.

Management StudioManagement Studio의 실행 계획 기능을 사용하거나 XML 실행 계획 SET 옵션을 사용하려면 사용자에게 실행 계획을 생성할 Transact-SQLTransact-SQL 쿼리를 실행하는 데 적합한 권한이 있어야 하며 쿼리에서 참조하는 모든 데이터베이스에 대한 SHOWPLAN 권한을 부여해야 합니다.To use the execution plan feature in Management StudioManagement Studio, or to use the XML Showplan SET options, users must have the appropriate permissions to execute the Transact-SQLTransact-SQL query for which an execution plan is being generated, and they must be granted the SHOWPLAN permission for all databases referenced by the query.

XML 실행 계획 SET 옵션을 사용하여 쿼리 계획을 저장하려면To save a query plan by using the XML Showplan SET options

  1. SQL Server Management StudioSQL Server Management Studio 에서 쿼리 편집기를 열고 데이터베이스 엔진Database Engine에 연결합니다.In SQL Server Management StudioSQL Server Management Studio open a query editor and connect to 데이터베이스 엔진Database Engine.

  2. 다음 문으로 SHOWPLAN_XML을 설정합니다.Turn SHOWPLAN_XML on with the following statement:

    SET SHOWPLAN_XML ON;  
    GO  
    

    STATISTICS XML을 설정하려면 다음 문을 사용합니다.To turn STATISTICS XML on, use the following statement:

    SET STATISTICS XML ON;  
    GO  
    

    SHOWPLAN_XML은 쿼리에 대한 컴파일 시간 쿼리 실행 계획 정보를 생성하지만 쿼리를 실행하지는 않습니다.SHOWPLAN_XML generates compile-time query execution plan information for a query, but does not execute the query. STATISTICS XML은 쿼리에 대한 런타임 쿼리 실행 계획 정보를 생성하고 쿼리를 실행합니다.STATISTICS XML generates run-time query execution plan information for a query, and executes the query.

  3. 쿼리를 실행합니다.Execute a query. 예:Example:

    USE AdventureWorks2012;  
    GO  
    SET SHOWPLAN_XML ON;  
    GO  
    -- Execute a query.  
    SELECT BusinessEntityID   
    FROM HumanResources.Employee  
    WHERE NationalIDNumber = '509647174';  
    GO  
    SET SHOWPLAN_XML OFF;  
    
  4. 결과 창에서 쿼리 계획을 포함하는 Microsoft SQL Server XML Showplan 을 마우스 오른쪽 단추로 클릭한 다음 다른 이름으로 결과 저장을 클릭합니다.In the Results pane, right-click the Microsoft SQL Server XML Showplan that contains the query plan, and then click Save Results As.

  5. 저장 <표 또는 텍스트> 결과 대화 상자의 파일 형식 상자에서 모든 파일(*.*)을 클릭합니다.In the Save <Grid or Text> Results dialog box, in the Save as type box, click All files (*.*).

  6. 파일 이름 상자에 <name>.sqlplan 형식으로 이름을 입력한 후 저장을 클릭합니다.In the File name box provide a name, in the format <name>.sqlplan, and then click Save.

SQL Server Management Studio 옵션을 사용하여 실행 계획을 저장하려면To save an execution plan by using SQL Server Management Studio options

  1. Management StudioManagement Studio를 사용하여 예상 실행 계획이나 실제 실행 계획을 생성합니다.Generate either an estimated execution plan or an actual execution plan by using Management StudioManagement Studio. 자세한 내용은 예상 실행 계획 표시 또는 실제 실행 계획 표시를 참조하세요.For more information, see Display the Estimated Execution Plan or Display an Actual Execution Plan.

  2. 결과 창의 실행 계획 탭에서 그래픽 실행 계획을 마우스 오른쪽 단추로 클릭하고 실행 계획을 다른 이름으로 저장을 선택합니다.In the Execution plan tab of the results pane, right-click the graphical execution plan, and choose Save Execution Plan As.

    또는 파일 메뉴에서 실행 계획을 다른 이름으로 저장 을 선택할 수도 있습니다.As an alternative, you can also choose Save Execution Plan As on the File menu.

  3. 다른 이름으로 저장 대화 상자에서 파일 형식실행 계획 파일(*.sqlplan)로 설정되어 있는지 확인합니다.In the Save As dialog box, make sure that the Save as type is set to Execution Plan Files (*.sqlplan).

  4. 파일 이름 상자에 <name>.sqlplan 형식으로 이름을 입력한 후 저장을 클릭합니다.In the File name box provide a name, in the format <name>.sqlplan, and then click Save.

SQL Server Management Studio에서 저장된 XML 쿼리 계획을 열려면To open a saved XML query plan in SQL Server Management Studio

  1. SQL Server Management StudioSQL Server Management Studio파일 메뉴에서 열기를 선택한 다음 파일을 클릭합니다.In SQL Server Management StudioSQL Server Management Studio, on the File menu, choose Open, and then click File.

  2. 파일 열기 대화 상자에서 파일 형식실행 계획 파일(*.sqlplan)로 설정하여 저장된 XML 쿼리 계획 파일의 필터링된 목록을 생성합니다.In the Open File dialog box, set Files of type to Execution Plan Files (*.sqlplan) to produce a filtered list of saved XML query plan files.

  3. 보려는 XML 쿼리 계획 파일을 선택하고 열기를 클릭합니다.Select the XML query plan file that you want to view, and click Open.

    또는 Windows 탐색기에서 확장명이 .sqlplan인 파일을 두 번 클릭합니다.As an alternative, in Windows Explorer, double-click a file with extension .sqlplan. 계획이 Management StudioManagement Studio에서 열립니다.The plan opens in Management StudioManagement Studio.

참고 항목See Also

SET SHOWPLAN_XML(Transact-SQL) SET SHOWPLAN_XML (Transact-SQL)
SET STATISTICS XML(Transact-SQL) SET STATISTICS XML (Transact-SQL)