교착 상태 그래프 저장(SQL Server Profiler)Save Deadlock Graphs (SQL Server Profiler)

이 항목에서는 SQL Server 프로파일러SQL Server Profiler를 사용하여 교착 상태 그래프를 저장하는 방법에 대해 설명합니다.This topic describes how to save a deadlock graph by using SQL Server 프로파일러SQL Server Profiler. 교착 상태 그래프는 XML 파일로 저장됩니다.Deadlock graphs are saved as XML files.

교착 상태 그래프 이벤트를 별도로 저장하려면To save deadlock graph events separately

  1. 파일 메뉴에서 새 추적을 클릭한 다음 SQL Server 인스턴스에 연결합니다.On the File menu, click New Trace, and then connect to an instance of SQL Server.

    추적 속성대화 상자가 표시됩니다.The Trace Propertiesdialog box appears.

    참고

    연결한 후 즉시 추적 시작 을 선택한 경우에는 추적 속성대화 상자가 나타나지 않고 추적이 시작됩니다.If Start tracing immediately after making connection is selected, the Trace Propertiesdialog box fails to appear, and the trace begins instead. 이 설정을 해제하려면 도구메뉴에서 옵션을 클릭한 다음 연결한 후 즉시 추적 시작 확인란의 선택을 취소합니다.To turn off this setting, on the Toolsmenu, click Options, and clear the Start tracing immediately after making connection check box.

  2. 추적 속성 대화 상자에서추적 이름 입력란에 추적의 이름을 입력합니다.In the Trace Properties dialog box, type a name for the trace in theTrace name box.

  3. 템플릿 사용 목록에서 추적의 기반이 되는 추적 템플릿을 선택하거나 템플릿을 사용하지 않을 경우 비어 있음 을 선택합니다.In the Use the template list, select a trace template on which to base the trace, or select Blank if you do not want to use a template.

  4. 다음 중 하나를 수행합니다.Do one of the following:

    • 추적을 데이터베이스 테이블에 캡처하려면파일에 저장 확인란을 선택하면 추적이 파일에 캡처됩니다.Select theSave to file check box to capture the trace to a file. 최대 파일 크기 설정에 대한 값을 지정합니다.Specify a value for Set maximum file size.

      필요에 따라 파일 롤오버 사용서버에서 추적 데이터 처리를 선택합니다.Optionally, select Enable file rollover and Server processes trace data.

    • 추적을 데이터베이스 테이블에 캡처하려면 테이블에 저장 확인란을 선택합니다.Select the Save to table check box to capture the trace to a database table.

      필요에 따라 최대 행 수 설정을 클릭하고 값을 지정합니다.Optionally, click Set maximum rows, and specify a value.

  5. 필요에 따라 추적 중지 시간 설정 확인란을 선택하여 중지 날짜 및 시간을 지정합니다.Optionally, select the Enable trace stop time check box, and specify a stop date and time.

  6. 이벤트 선택탭을 클릭합니다.Click the Events Selectiontab.

  7. 이벤트데이터 열에서 잠금이벤트 범주를 확장한 다음 교착 상태 그래프확인란을 선택합니다.In the Eventsdata column, expand the Locksevent category, and then select the Deadlock graphcheck box. Locks 이벤트 범주가 나타나지 않는 경우 모든 이벤트 표시 를 선택하여 이 범주를 표시합니다.If the Locks event category is not available, check Show all events to display it.

    이벤트 추출 설정탭이 추적 속성대화 상자에 추가됩니다.The Events Extraction Settingstab is added to the Trace Propertiesdialog box.

  8. 이벤트 추출 설정탭에서 별도로 교착 상태 XML 이벤트 저장을 클릭합니다.On the Events Extraction Settingstab, click Save Deadlock XML Events Separately.

  9. 다른 이름으로 저장 대화 상자에 교착 상태 그래프 이벤트를 저장할 파일의 이름을 입력합니다.In the Save As dialog box, enter the name of the file in which to store the deadlock graph events.

  10. 모든 교착 상태 XML 일괄 처리를 단일 파일로 저장 을 클릭하여 모든 교착 상태 그래프 이벤트를 단일 XML 파일로 저장하거나 각 교착 상태 XML 일괄 처리를 개별 파일로 저장을 클릭하여 각 교착 상태 그래프에 대해 새 XML 파일을 만듭니다.Click All Deadlock XML batches in a single file to save all deadlock graph events in a single XML file, or click Each Deadlock XML batch in a distinct fileto create a new XML file for each deadlock graph.

    교착 상태 파일을 저장한 다음 SQL Server Management StudioSQL Server Management Studio에서 파일을 열 수 있습니다.After you have saved the deadlock file, you can open the file in SQL Server Management StudioSQL Server Management Studio. 자세한 내용은 교착 상태 파일 열기, 보기 및 인쇄(SQL Server Management Studio)를 참조하세요.For more information, see Open, View, and Print a Deadlock File (SQL Server Management Studio).

관련 항목:See Also

SQL Server Profiler를 사용하여 교착 상태 분석Analyze Deadlocks with SQL Server Profiler