파일 확장명을 코드 편집기에 연결Associate File Extensions to a Code Editor

파일 확장명을 특정 코드 편집기에 연결하면 Windows 탐색기에서 파일을 두 번 클릭하여 해당 SQL Server Management StudioSQL Server Management Studio 코드 편집기에서 파일을 열 수 있습니다.Associating file extensions to a specific code editor allows you to open a file with the appropriate SQL Server Management StudioSQL Server Management Studio code editor when you double-click a file in Windows Explorer. .sql 및 .mdx와 같이 Management StudioManagement Studio에서 많이 사용되는 확장명은 설치 중에 연결됩니다.The extensions commonly used by Management StudioManagement Studio, such as .sql and .mdx, are associated during installation. 새 파일 확장명은 파일 시스템에서 Management StudioManagement Studio 에 연결해야 합니다.New file extensions must also be associated to Management StudioManagement Studio in the file system. 이 기능을 사용하여 다른 편집기로 만든 파일을 열거나 .sql 파일의 백업인 .bak 파일과 같이 이름이 바뀐 파일을 열 수 있습니다.You can use this feature to open files created with other editors, or to open files you have renamed, such as backups of .sql files that were renamed .bak.

이 과정은 두 단계로 구성됩니다.There are two steps in the process. 먼저 확장명을 Management StudioManagement Studio와 연결한 다음 해당 확장명을 특정 코드 편집기에 연결합니다.First associate the extension with Management StudioManagement Studio, and then associate the extension with a specific code editor.

새 파일 확장명을 SQL Server Management Studio와 연결하려면To associate a new file extension with SQL Server Management Studio

  1. 시작 메뉴에서 모든 프로그램, 보조프로그램을 차례로 가리키고 Windows 탐색기를 클릭합니다.On the Start menu, point to All Programs, point to Accessories, and then click Windows Explorer.

  2. Windows 탐색기의 도구 메뉴에서 폴더 옵션을 클릭합니다.In Windows Explorer, on the Tools menu, click Folder Options.

  3. 폴더 옵션 대화 상자에서 파일 형식 탭을 클릭하고 새로 만들기를 클릭합니다.In the Folder Options dialog box, on the File Types tab, click New.

  4. 새 확장명 만들기 대화 상자의 파일 확장명 상자에 연결하려는 새 파일 확장명을 입력한 다음 확인을 클릭합니다.In the Create New Extension dialog box, in the File Extension box, type the new file extension that you want to associate, and then click OK. 확장명 앞에 마침표를 입력하지 마십시오.Do not start the extension with a period.

  5. 등록된 파일 형식 상자에서 새 확장명을 클릭하고 변경을 클릭합니다.In the Registered file types box, click on your new extension, and then click Change.

  6. 연결 프로그램 대화 상자에서 SSMS - SQL Server Management Studio를 클릭한 다음 확인을 클릭합니다.In the Open With dialog box, click SSMS – SQL Server Management Studio, and then click OK.

  7. 닫기 를 클릭하여 폴더 옵션 대화 상자를 닫은 다음 Windows 탐색기를 닫습니다.Click Close to close the Folder Options dialog box, and then close Windows Explorer.

새 파일 확장명을 SQL Server Management Studio의 코드 편집기와 연결하려면To associate a new file extension with a code editor in SQL Server Management Studio

  1. SQL Server Management StudioSQL Server Management Studio도구 메뉴에서 옵션을 클릭합니다.In SQL Server Management StudioSQL Server Management Studio, from the Tools menu, click Options.

  2. 옵션 대화 상자에서 텍스트 편집기를 클릭하고 파일 확장명을 클릭합니다.In the Options dialog box, click Text Editor, and then click File Extension.

  3. 확장명 상자에 새 파일 확장명을 입력합니다.In the Extension box, type your new file extension.

  4. 편집기 상자에서 이 파일 형식을 열 때 사용할 코드 편집기를 클릭하고 추가를 클릭한 다음 확인을 클릭합니다.In the Editor box, click the code editor that you wish to use to open this file type, click Add, and then click OK.

참고 항목See Also

Ssms 유틸리티Ssms Utility