데이터베이스 엔진 쿼리 편집기(SQL Server Management Studio)Database Engine Query Editor (SQL Server Management Studio)

이 항목 적용 대상: 예SQL Server예Azure SQL 데이터베이스예Azure SQL 데이터 웨어하우스 예 병렬 데이터 웨어하우스THIS TOPIC APPLIES TO: yesSQL ServeryesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse 데이터베이스 엔진Database Engine 쿼리 편집기를 사용하여 Transact-SQLTransact-SQL 문을 포함하는 스크립트를 만들고 실행할 수 있습니다. Use the 데이터베이스 엔진Database Engine Query Editor to create and run scripts containing Transact-SQLTransact-SQL statements. 또한 편집기는 sqlcmd 명령을 포함하는 스크립트 실행을 지원합니다.The editor also supports running scripts that contain sqlcmd commands.

Transact-SQL F1 도움말Transact-SQL F1 Help

데이터베이스 엔진Database Engine 쿼리 편집기는 F1 키를 선택할 때 특정 Transact-SQLTransact-SQL 문에 대한 참조 항목을 연결할 수 있습니다.The 데이터베이스 엔진Database Engine Query Editor supports linking you to the reference topic for a specific Transact-SQLTransact-SQL statement when you select F1. 이렇게 하려면 Transact-SQL 문의 이름을 강조 표시하고 F1 키를 선택합니다.To do so, highlight the name of a Transact-SQL statement and then select F1. 그러면 도움말 검색 엔진에서 강조 표시된 문자열과 일치하는 F1 도움말 특성을 가진 항목을 검색합니다.The help search engine will then search for a topic that has an F1 help attribute that matches the string you highlighted.

도움말 검색 엔진에서 강조 표시된 문자열과 정확히 일치하는 F1 도움말 키워드를 포함하는 항목을 찾을 수 없을 경우 이 항목이 표시됩니다.If the help search engine does not find a topic with an F1 help keyword that exactly matches the string you highlighted, then this topic is displayed. 이 경우 다음과 같은 두 가지 방법으로 원하는 도움말을 찾을 수 있습니다.In that case, there are two approaches to finding the help you are looking for:

  • 편집기에서 선택한 문자열을 복사한 다음 SQL Server 온라인 설명서의 검색 탭에 붙여 넣고 검색을 수행합니다.Copy and paste the editor string you highlighted into the search tab of SQL Server Books Online and do a search.

  • 항목에 적용되는 F 도움말 키워드와 일치할 것으로 예상되는 Transact-SQL 문 부분만 선택한 다음 F1 키를 다시 누릅니다.Highlight only the part of the Transact-SQL statement likely to match an F1 help keyword applied to a topic and select F1 again. 그러면 검색 엔진에서 강조 표시된 문자열과 항목에 할당된 F1 도움말 키워드를 정확하게 일치시킵니다.The search engine requires an exact match between the string you highlighted and an F1 help keyword assigned to a topic. 강조 표시된 문자열에 열이나 매개 변수 이름과 같이 사용자 환경 고유의 요소가 포함되어 있을 경우 검색 엔진에서 일치하는 항목을 찾을 수 없습니다.If the string you highlighted contains elements unique to your environment, such as column or parameter names, the search engine will not get a match. 선택할 수 있는 문자열의 예는 다음과 같습니다.Examples of the strings to highlight include:

    • SELECT, CREATE DATABASE, BEGIN TRANSACTION 등의 Transact-SQL 문 이름The name of a Transact-SQL statement, such as SELECT, CREATE DATABASE or BEGIN TRANSACTION.

    • SERVERPROPERTY, @@VERSION 등의 기본 제공 함수 이름The name of a built-in function, such as SERVERPROPERTY, or @@VERSION.

    • sys.data_spaces, sp_tableoption 등의 시스템 저장 프로시저 테이블 또는 뷰 이름The name of a system stored procedure table, or view, such as sys.data_spaces or sp_tableoption.

데이터베이스 엔진 쿼리 편집기 작업Working With the Database Engine Query Editor

데이터베이스 엔진Database Engine 쿼리 편집기는 SQL Server Management StudioSQL Server Management Studio에서 구현되는 네 가지 편집기 중 하나입니다.The 데이터베이스 엔진Database Engine Query Editor is one of four editors implemented in SQL Server Management StudioSQL Server Management Studio. 데이터베이스 엔진Database Engine 쿼리 편집기에서 구현되는 기능과 이 편집기를 사용하여 수행할 수 있는 주요 태스크에 대한 자세한 내용은 쿼리 및 텍스트 편집기(SQL Server Management Studio)를 참조하세요.For a description of the functionality implemented in the 데이터베이스 엔진Database Engine Query Editor and the main tasks you can perform using the editor, see Query and Text Editors (SQL Server Management Studio).

SQL 편집기 도구 모음SQL Editor Toolbar

데이터베이스 엔진Database Engine 쿼리 편집기가 열려 있으면 다음 단추를 포함하는 SQL 편집기 도구 모음이 표시됩니다.When the 데이터베이스 엔진Database Engine Query Editor is open, the SQL Editor toolbar appears with the following buttons.

ConnectConnect
서버에 연결 대화 상자를 엽니다.Opens the Connect to Server dialog box. 이 대화 상자를 사용하여 서버에 연결합니다.Use this dialog box to establish a connection to a server.

연결 끊기Disconnect
현재 쿼리 편집기와 서버 간의 연결을 끊습니다.Disconnects the current Query Editor from the server.

연결 변경Change Connection
서버에 연결 대화 상자를 엽니다.Opens the Connect to Server dialog box. 이 대화 상자를 사용하여 다른 서버에 연결합니다.Use this dialog box to establish a connection to a different server.

현재 연결에서의 새 쿼리New Query with Current Connection
새 쿼리 편집기 창을 열고 현재 쿼리 편집기 창의 연결 정보를 사용합니다.Opens a new Query Editor window and uses the connection information from the current Query Editor window.

사용 가능한 데이터베이스Available Databases
같은 서버의 다른 데이터베이스로 연결을 변경합니다.Change the connection to a different database on the same server.

ExecuteExecute
선택한 코드를 실행하거나, 코드를 선택하지 않은 경우 쿼리 편집기에 있는 모든 코드를 실행합니다.Executes the selected code or, if no code is selected, executes all the code in the Query Editor.

디버그Debug
Transact-SQLTransact-SQL 디버거를 사용합니다.Enables the Transact-SQLTransact-SQL debugger. 이 디버거에서는 중단점 설정, 변수 조사 및 단계별 코드 실행과 같은 디버깅 동작을 지원합니다.This debugger supports debugging actions such as setting breakpoints, watching variables, and stepping through code.

쿼리 실행 취소Cancel Executing Query
취소 요청을 서버로 보냅니다.Sends a cancellation request to the server. 일부 쿼리는 바로 취소할 수 없으며 적절한 취소 조건이 될 때까지 기다려야 합니다.Some queries cannot be canceled immediately, but must wait for a suitable cancellation condition. 트랜잭션을 취소해도 트랜잭션이 롤백되는 동안 작업이 지연될 수 있습니다.When transactions are canceled, delays might occur while transactions are rolled back.

구문 분석Parse
선택한 코드의 구문을 확인합니다.Check the syntax of the selected code. 코드를 선택하지 않은 경우 쿼리 편집기 창에 있는 모든 코드의 구문을 확인합니다.If no code is selected, checks the syntax of the all code in the Query Editor window.

예상 실행 계획 표시Display Estimated Execution Plan
쿼리를 실제로 실행하지 않고 쿼리 프로세서에서 쿼리 실행 계획을 요청한 다음 실행 계획 창에 계획을 표시합니다.Requests a query execution plan from the query processor without actually executing the query, and displays the plan in the Execution plan window. 이 계획은 각 쿼리 부분을 실행하는 중 반환될 것으로 예상되는 행 수의 예측으로 인덱스 통계를 사용합니다.This plan uses index statistics as an estimate of the number of rows that are expected to be returned during each part of the query execution. 실제 사용되는 쿼리 계획은 예상 실행 계획과 다를 수 있습니다.The actual query plan that is used can be different from the estimated execution plan. 이러한 차이는 반환되는 행 수가 예상치와 크게 다를 경우에 발생할 수 있으며, 쿼리 프로세서는 쿼리 계획을 더 효율적으로 변경합니다.This can occur if the number of rows that are returned is significantly different from the estimate, and the query processor changes the plan to be more efficient.

쿼리 옵션Query Options
쿼리 옵션 대화 상자를 엽니다.Opens the Query Options dialog box. 이 대화 상자를 사용하여 쿼리 실행 및 쿼리 결과에 대한 기본 옵션을 구성합니다.Use this dialog box to configure the default options for query execution and for query results.

IntelliSense 사용IntelliSense Enabled
데이터베이스 엔진Database Engine 쿼리 편집기에서 IntelliSense 기능을 사용할지를 지정합니다.Specifies whether IntelliSense functionality is available in the 데이터베이스 엔진Database Engine Query Editor.

실제 실행 계획 포함Include Actual Execution Plan
쿼리를 실행한 후 쿼리 결과와 쿼리에 사용된 실행 계획을 반환합니다.Executes the query, returns the query results, and the execution plan that was used for the query. 이러한 결과는 실행 계획 창에 그래픽 쿼리 계획으로 표시됩니다.These appear as a graphical query plan in the Execution plan window.

클라이언트 통계 포함Include Client Statistics
쿼리 통계와 네트워크 패킷 통계 및 쿼리 경과 시간이 표시된 클라이언트 통계 창을 포함합니다.Includes a Client Statistics window that contains statistics about the query and about the network packets, and the elapsed time of the query.

텍스트로 결과 표시Results to Text
쿼리 결과를 텍스트로 결과 창에 반환합니다.Returns the query results as text in the Results window.

표 형태로 결과 표시Results to Grid
쿼리 결과를 하나 이상의 표로 결과 창에 반환합니다.Returns the query results as one or more grids in the Results window.

파일로 결과 저장Results to File
쿼리를 실행하면 결과 저장 대화 상자가 열립니다.When the query executes, the Save Results dialog box opens. 저장 위치에서 파일을 저장할 폴더를 선택합니다.In Save In, select the folder in which you want to save the file. 파일 이름에 파일 이름을 입력하고 저장 을 클릭하여 쿼리 결과를 확장명이 .rpt인 보고서 파일로 저장합니다.In File name, type the name of the file, and then click Save to save the query results as a Report file that has the .rpt extension. 고급 옵션을 보려면 저장 단추의 아래쪽 화살표를 클릭한 다음 인코딩하여 저장을 클릭합니다.For advanced options, click the down-arrow on the Save button, and then click Save with Encoding.

선택 영역을 주석으로 처리Comment Selection
줄의 시작 부분에 주석 기호(--)를 추가하여 현재 줄을 주석으로 처리합니다.Makes the current line a comment by adding a comment operator (--) at the beginning of the line.

선택 영역의 주석 처리 제거Uncomment Selection
줄의 시작 부분에서 주석 기호(--)를 제거하여 현재 줄을 활성 소스 코드 문으로 처리합니다.Makes the current line an active source statement by removing any comment operator (--) at the beginning of the line.

줄 내어쓰기Decrease Line Indent
줄의 시작 부분에서 공백을 제거하여 해당 줄의 텍스트를 왼쪽으로 이동합니다.Moves the text of the line to the left by removing blanks at the beginning of the line.

줄 들여쓰기Increase Line Indent
줄의 시작 부분에 공백을 추가하여 해당 줄의 텍스트를 오른쪽으로 이동합니다.Moves the text of the line to the right by adding blanks at the beginning of the line.

템플릿 매개 변수 값 지정Specify Values for Template Parameters
저장 프로시저 및 함수의 매개 변수 값을 지정하는 데 사용할 수 있는 대화 상자를 엽니다.Opens a dialog box that you can use to specify values for parameters in stored procedures and functions.

보기 메뉴를 선택하고 도구 모음을 선택한 다음 SQL 편집기를 선택하여 SQL 편집기 도구 모음을 추가할 수도 있습니다.You can also add the SQL Editor toolbar by selecting the View menu, selecting Toolbars, and then selecting SQL Editor. 데이터베이스 엔진Database Engine 쿼리 편집기 창이 열려 있지 않을 때 SQL 편집기 도구 모음을 추가하면 일부 단추를 사용하지 못할 수 있습니다.If you add the SQL Editor toolbar when no 데이터베이스 엔진Database Engine Query Editor windows are open, all the buttons are unavailable.

SQL 편집기 도구 모음SQL Editor Toolbar

데이터베이스 엔진Database Engine 쿼리 편집기 창을 열면 보기 메뉴, 도구 모음, 디버그를 차례로 선택하여 디버그 도구 모음을 추가할 수 있습니다.When a 데이터베이스 엔진Database Engine Query Editor window is open, you can add the Debug toolbar by selecting the View menu, selecting Toolbars, and then selecting Debug. 데이터베이스 엔진Database Engine 쿼리 편집기 창이 열려 있지 않을 때 디버그 도구 모음을 추가하면 일부 단추를 사용하지 못할 수 있습니다.If you add the Debug toolbar when no 데이터베이스 엔진Database Engine Query Editor windows are open, all the buttons are unavailable.

계속Continue
중단점이 나올 때까지 데이터베이스 엔진Database Engine 쿼리 편집기 창에서 코드를 실행합니다.Runs the code in the 데이터베이스 엔진Database Engine Query Editor window until a breakpoint is encountered.

모두 중단Break All
중단이 발생하면 디버거에 연결된 모든 프로세스를 중단하도록 디버거를 설정합니다.Sets the debugger to break all processes to which the debugger is attached when a break occurs.

디버깅 중지Stop Debugging
선택한 데이터베이스 엔진Database Engine 쿼리 편집기 창에서 디버그 모드를 종료하고 표준 실행 모드로 복원합니다.Takes the selected 데이터베이스 엔진Database Engine Query Editor window out of debug mode, and restores the standard execution mode.

다음 문 표시Show Next Statement
커서를 실행할 다음 문으로 이동합니다.Moves the cursor to the next statement to be executed.

한 단계씩 코드 실행Step Into
다음 문이 실행됩니다.The next statement is run. 문에서 Transact-SQL 저장 프로시저, 함수 또는 트리거를 호출하면 디버거에서 모듈 코드가 포함된 새 쿼리 편집기 창을 표시합니다.If the statement invokes a Transact-SQL stored procedure, function, or trigger, the debugger displays a new Query Editor window that contains the code of the module. 창이 디버그 모드에 있으며 모듈의 첫 번째 문에서 실행이 일시 중지됩니다.The window is in debug mode, and execution pauses on the first statement in the module. 그리고 나서 중단점을 설정하거나 코드를 단계별로 실행하여 모듈을 이동할 수 있습니다.You can then move through the module, for example, by setting breakpoints or stepping through the code.

프로시저 단위 실행Step Over
다음 문이 실행됩니다.The next statement is run. 문에서 Transact-SQL 저장 프로시저, 함수 또는 트리거를 호출하면 모듈이 완료될 때까지 실행되고 결과가 호출 코드에 반환됩니다.If the statement invokes a Transact-SQL stored procedure, function, or trigger, the module is run until it finishes and the results are returned to the calling code. 모듈에 오류가 없으면 모듈을 프로시저 단위로 실행할 수 있습니다.If you are sure there are no errors in the module, you can step over it. 이 경우 모듈 호출 이후의 문에서 실행이 일시 중지됩니다.Execution pauses on the statement that follows the call to the module.

프로시저 나가기Step Out
다음으로 가장 높은 호출 수준(함수, 저장 프로시저 또는 트리거)으로 돌아갑니다.Step back to the next highest calling level (function, stored procedure, or trigger). 저장 프로시저, 함수 또는 트리거를 호출한 후 문에서 실행이 일시 중지됩니다.Execution pauses on the statement that follows the call to the stored procedure, function, or trigger.

Windows
중단점 창 또는 직접 실행 창을 엽니다.Opens either the Breakpoint window or the Immediate window.

참고 항목See Also

SQL Server Management Studio 바로 가기 키SQL Server Management Studio Keyboard Shortcuts