편집기 및 보기 모드 관리Manage the Editor and View Mode

이 항목 적용 대상: 예SQL Server예Azure SQL 데이터베이스예Azure SQL 데이터 웨어하우스 예 병렬 데이터 웨어하우스THIS TOPIC APPLIES TO: yesSQL ServeryesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse 편집기에서 여러 가지 방법으로 코드 보기를 제어할 수 있습니다. The Editor gives you a number of ways to control the view of your code.

보기 모드 변경Changing the View Mode

SQL Server Management StudioSQL Server Management Studio 에는 탭 문서라는 보기 모드가 있는데 이 기능을 사용하면 여러 개의 편집기와 문서를 동시에 열어서 편집기 상단 탭을 통해 액세스할 수 있습니다. features a view mode called Tabbed Documents, which allows you to open multiple editors and documents simultaneously and access them through tabs at the top of the Editor. 또는 Management StudioManagement Studio 를 MDI(다중 문서 인터페이스) 모드로 열 수도 있습니다. 이 모드에서는 탭이 없는 창을 여러 개 열어 바둑판식으로 배열하거나 창 크기를 최소화할 수도 있습니다.You can alternatively open the Management StudioManagement Studio environment in Multiple Document Interface (MDI) mode, which joins windows without the tabs, and allows each window to be tiled, minimized, and so on.

보기 모드를 전환하려면To switch between view modes

  1. 도구 메뉴에서 옵션 을 클릭합니다.Click Options on the Tools menu.

  2. 환경을 클릭하고Click Environment. 일반을 클릭합니다.Click General.

  3. 탭 문서 또는 MDI 환경을 클릭합니다.Click Tabbed documents or MDI environment.

    참고

    SQL Server Management StudioSQL Server Management Studio 를 다시 시작할 때까지 변경 내용이 적용되지 않습니다.The changes will not take effect until SQL Server Management StudioSQL Server Management Studio is restarted.

보기 분할Splitting the View

보다 손쉽게 편집하기 위해 편집기 창을 두 부분으로 분할할 수 있습니다.An Editor window can be split into two separate parts for easier editing.

창을 분할하려면To split a window

  1. 스크롤 막대 위에 있는 분할 막대를 클릭합니다.Click the splitter bar (located above the scroll bar).

  2. 분할 막대를 아래로 끕니다.Drag the splitter bar downward.

  3. 단일 창으로 돌아가려면 두 창을 분할하는 분할 막대를 두 번 클릭합니다.To go back to a single pane, double-click the splitter bar dividing the two panes.

    새 창에는 동일한 문서가 포함되어 있습니다. 두 창에 동일한 문서 위치를 표시하고 한 창에서 내용을 변경하면 해당 내용이 다른 창에도 반영됩니다.The new pane contains the same document, and any changes made to one pane are reflected in the other pane as long as that pane displays the same place in the document.

자동 줄 바꿈Word Wrap

자동 줄 바꿈을 활성화하면 가로 스크롤 막대가 제거되고 편집기 창 너비를 초과하는 코드 줄은 창 밖으로 스크롤되지 않고 다음 줄로 자동 줄 바꿈되어 표시됩니다.When you activate Word Wrap, the horizontal scrollbar is removed and lines of code that exceed the width of the Editor's window size automatically wraps to the next displayed line rather than scrolling off the side of the window.

자동 줄 바꿈을 활성화하려면To activate word wrap

  1. 도구 메뉴에서 옵션 을 클릭합니다.Click Options on the Tools menu.

  2. 텍스트 편집기를 클릭합니다.Click Text Editor.

  3. 해당 언어 폴더(모든 언어에 적용하려면 모든 언어 )를 엽니다.Open the appropriate language folder (or All Languages to affect all languages).

  4. 자동 줄 바꿈을 선택합니다.Select Word wrap.

가상 공간 모드 설정Enabling Virtual Space Mode

가상 공간 모드로 편집기를 열면 각 줄의 끝을 넘어서는 공간은 무한한 공간처럼 보이기 때문에 표시되는 화면 영역 밖으로 코드 줄이 계속 이어집니다.In Virtual Space mode, the Editor acts as if the space past the end of each line is filled with an infinite number of spaces, allowing code lines to continue off the side of the visible screen area.

가상 공간 모드를 활성화하려면To enable Virtual Space mode

  1. 도구 메뉴에서 옵션 을 클릭합니다.Click Options on the Tools menu.

  2. 텍스트 편집기를 클릭합니다.Click Text Editor.

  3. 해당 언어 폴더(모든 언어에 적용하려면 모든 언어 )를 엽니다.Open the appropriate language folder (or All Languages to affect all languages).

  4. 가상 공간 활성화를 선택합니다.Select Enable virtual space.

    가상 공간 모드를 활성화하지 않은 경우 커서는 한 줄의 끝에서 다음 줄의 첫 번째 문자로 또는 그 반대로 줄 바꿈됩니다.When Virtual Space mode is not enabled, the cursor wraps from the end of one line to the first character of the next line and vice-versa.

줄 번호 표시Displaying Line Numbers

코드에 줄 번호 매기기를 설정할 수 있습니다.You can turn on line numbering in your code. 줄 번호는 코드를 이동할 때 유용합니다.Line numbers are useful for navigating code. 자세한 내용은 코드 및 텍스트 이동을 참조하세요.For more information, see Navigate Code and Text.

참고

줄 번호 매기기를 설정하더라도 문서에 자동으로 줄 번호가 표시되어 출력되지는 않습니다.Turning on line numbering does not mean that the document will print with line numbers. 줄 번호를 출력하려면 파일 메뉴의 페이지 설정 명령에서 줄 번호 확인란을 선택해야 합니다.For line numbers to print, you must select the Line numbers check box in the Page Setup command on the File menu.

코드에 줄 번호를 표시하려면To display line numbers in code

  1. 도구 메뉴에서 옵션 을 클릭합니다.Click Options on the Tools menu.

  2. 텍스트 편집기를 클릭합니다.Click Text Editor.

  3. 모든 언어를 클릭합니다.Click All Languages.

  4. 일반을 클릭합니다.Click General.

  5. 줄 번호를 선택합니다.Select Line numbers.

    일부 프로그래밍 언어에만 줄 번호 매기기를 지정하려면 해당 폴더에서 줄 번호 를 선택합니다.To specify line numbering for only some programming languages, select Line Numbers in the appropriate folder.

전체 화면 모드 설정Enabling Full Screen Mode

전체 화면 모드를 설정하면 모든 도구 창을 숨기고 문서 창만 볼 수 있습니다.You can choose to hide all tool windows and view only document windows by enabling Full Screen mode.

전체 화면 모드를 설정하려면To enable Full Screen mode

  1. Alt+Shift+Enter를 눌러 전체 화면 모드를 설정/해제합니다.Press ALT+SHIFT+ENTER to toggle Full Screen mode.

모두 자동 숨기기 사용Using Auto Hide All

모든 도구 창을 한 번에 숨기려면To hide all the tool windows at once

  1. 메뉴에서 모두 자동 숨기기 를 선택합니다.Select Auto Hide All on the Window menu.