편집기 열기(SQL Server Management Studio)Open an Editor (SQL Server Management Studio)

이 항목에서는 데이터베이스 엔진Database Engine 에서 SQL Server Management StudioSQL Server Management Studio쿼리, MDX, DMX 또는 XML/A 편집기를 여는 방법에 대해 설명합니다.This topic describes how to open the 데이터베이스 엔진Database Engine Query, MDX, DMX, or XML/A editors in SQL Server Management StudioSQL Server Management Studio. 편집기를 열면 각 편집기 창이 Management StudioManagement Studio가운데 창에 탭으로 표시됩니다.When opened, each editor window appears as a tab in the central pane of Management StudioManagement Studio.

시작하기 전에Before You Begin

Management StudioManagement Studio데이터베이스 엔진Database Engine 쿼리 편집기( Transact-SQLTransact-SQL 스크립트 편집용), DMX 및 MDX 편집기(해당 언어를 통한 스크립트 편집용) 및 XML/A 편집기(XML/A 스크립트 또는 XML 파일 편집용)의 네 가지 편집기를 지원합니다. scripts, the DMX and MDX editors for editing scripts using those languages, and the XML/A editor for editing XML/A scripts or XML files. 텍스트 파일은 어떠한 편집기로도 편집할 수 있습니다.Any of the editors can also be used to edit text files.

제한 사항Limitations and Restrictions

고유한 코드 페이지를 사용하는 다른 사이트의 사용자와 파일을 공유하는 경우에는 파일을 읽을 때 오류가 발생하지 않도록 적절한 유니코드 코드 페이지로 파일을 저장해야 합니다.If you share files with users at other sites that use distinct code pages, you should save your file with the appropriate Unicode code page to prevent errors when reading the file. 또한 UNIX나 Macintosh용으로 파일을 저장할 경우에는 적절한 문서 형식으로 파일을 저장해야 합니다.Also, when saving files for UNIX or Macintosh, be sure to save your files with the appropriate document format. 파일 메뉴의 저장단추 옆에 있는 아래쪽 화살표에서 다른 이름으로 저장 , 인코딩하여 저장 을 클릭한 다음 줄 끝 에서 Unix 또는 Macintosh를 선택합니다.On the File menu, click Save As, Save with Encoding from the down arrow next to the Save button, and then choose Unix or Macintosh under Line Endings.

사용 권한Permissions

코드 편집기에서 수행하는 작업에는 로그인하는 데 사용된 인증 계정에 부여된 사용 권한이 적용됩니다.Operations you perform in a code editor are subject to the permissions granted to the authentication account you used to log in. 예를 들어 Windows 인증을 사용하여 데이터베이스 엔진Database Engine 쿼리 편집기 창을 열 경우 Windows 로그인 계정에 액세스 권한이 없는 개체를 참조하는 Transact-SQLTransact-SQL 문을 실행할 수 없습니다.For example, if you open a 데이터베이스 엔진Database Engine Query Editor window using Windows Authentication, you cannot execute Transact-SQLTransact-SQL statements that reference objects your Windows login account does not have permissions to access.

방법: 편집기 열기How to: Open Editors

이 섹션에서는 SQL Server Management StudioSQL Server Management Studio에서 다양한 편집기를 여는 방법에 대해 설명합니다.This section explains how to open the various editors in SQL Server Management StudioSQL Server Management Studio.

파일/새로 만들기 메뉴 사용Using the File/New Menu

파일 메뉴에서 새로 만들기를 클릭한 다음 쿼리 편집기 옵션 중 하나를 선택합니다.On the File menu, click New, and then select one of the query editor options:

  • 현재 연결에서의 쿼리 - Management StudioManagement Studio에서 현재 연결에 연결된 유형의 새 편집기 창을 엽니다.Query with Current Connection –Opens a new editor window of the type associated with the current connection in Management StudioManagement Studio. 편집기 창에서는 현재 연결과 동일한 인증 정보를 사용합니다.The editor window uses the same authentication information as the current connection. 예를 들어 개체 탐색기에서 데이터베이스 엔진Database Engine 인스턴스를 선택한 다음 현재 연결에서의 쿼리를 사용할 경우 Management StudioManagement Studio 에서는 동일한 인증 정보를 사용하여 동일한 인스턴스에 연결된 데이터베이스 엔진Database Engine 쿼리 편집기를 엽니다.For example, if you select an instance of the 데이터베이스 엔진Database Engine in Object Explorer, and then use Query with Current Connection, Management StudioManagement Studio opens a 데이터베이스 엔진Database Engine Query Editor connected to the same instance using the same authentication information.

  • 데이터베이스 엔진 쿼리 - 데이터베이스 엔진Database Engine 쿼리 편집기와 대화 상자를 열어서 데이터베이스 엔진Database Engine인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Database Engine Query – Opens a new 데이터베이스 엔진Database Engine Query Editor and a dialog to get the information required to connect to an instance of the 데이터베이스 엔진Database Engine.

  • Analysis Services MDX 쿼리 - 새 Analysis ServicesAnalysis Services MDX 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services MDX Query - Opens a new Analysis ServicesAnalysis Services MDX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Analysis Services DMX 쿼리 - Analysis ServicesAnalysis Services DMX 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services DMX Query - Opens a new Analysis ServicesAnalysis Services DMX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Analysis Services XML/A 쿼리 - 새 Analysis ServicesAnalysis Services XML/A 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services XML/A Query - Opens a new Analysis ServicesAnalysis Services XML/A Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

파일/열기 메뉴 사용Using the File/Open Menu

파일 메뉴에서 열기를 클릭한 다음 파일을 찾아서 엽니다.On the File menu, click Open, and then navigate to a file and open it. Management StudioManagement Studio 에서는 파일 확장명에 적절한 유형의 편집기를 열고, 파일 내용을 편집기 창에 복사하며, 필요한 경우 연결 대화 상자를 엽니다. opens the appropriate type of editor for the file extension, copies the contents of the file into the editor window, and also opens a connection dialog if needed. 예를 들어 확장명이 .sql인 파일을 열 경우 Management StudioManagement Studio 에서는 데이터베이스 엔진Database Engine 쿼리 편집기 창을 열고 .sql 파일의 내용을 복사한 다음 연결 대화 상자를 엽니다.For example, if you open a file with a .sql extension, Management StudioManagement Studio opens a 데이터베이스 엔진Database Engine Query Editor window, copies in the contents of the .sql file, and opens a connection dialog. 특정 편집기에 연결되지 않은 확장명을 가진 파일을 열 경우 Management StudioManagement Studio 에서는 텍스트 편집기 창을 열고 파일 내용을 복사합니다.If you open a file with an extension not associated with a specific editor, Management StudioManagement Studio opens a text editor window and copies in the contents of the file.

자세한 내용은 파일 확장명을 코드 편집기에 연결을 참조하세요.For more information, see Associate File Extensions to a Code Editor.

도구 모음 사용Using the Toolbar

표준 도구 모음에서 다음 단추 중 하나를 클릭합니다.On the Standard toolbar, click one of the following buttons:

  • 새 쿼리 - Management StudioManagement Studio에서 현재 연결에 연결된 유형의 새 편집기 창을 엽니다.New Query - –Opens a new editor window of the type associated with the current connection in Management StudioManagement Studio. 편집기 창에서는 현재 연결과 동일한 인증 정보를 사용합니다.The editor window uses the same authentication information as the current connection. 예를 들어 개체 탐색기에서 데이터베이스 엔진Database Engine 인스턴스를 선택한 다음 새 쿼리 단추를 클릭하면 Management StudioManagement Studio 에서는 동일한 인증 정보를 사용하여 동일한 인스턴스에 연결된 데이터베이스 엔진Database Engine 쿼리 편집기를 엽니다.For example, if you select an instance of the 데이터베이스 엔진Database Engine in Object Explorer, and then click the New Query button, Management StudioManagement Studio opens a 데이터베이스 엔진Database Engine Query Editor connected to the same instance using the same authentication information.

  • 데이터베이스 엔진 쿼리 - 데이터베이스 엔진Database Engine 쿼리 편집기와 대화 상자를 열어서 데이터베이스 엔진Database Engine인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Database Engine Query – Opens a new 데이터베이스 엔진Database Engine Query Editor and a dialog to get the information required to connect to an instance of the 데이터베이스 엔진Database Engine.

  • Analysis Services MDX 쿼리 - 새 Analysis ServicesAnalysis Services MDX 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services MDX Query - Opens a new Analysis ServicesAnalysis Services MDX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Analysis Services DMX 쿼리 - Analysis ServicesAnalysis Services DMX 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services DMX Query - Opens a new Analysis ServicesAnalysis Services DMX Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

  • Analysis Services XML/A 쿼리 - 새 Analysis ServicesAnalysis Services XML/A 쿼리 편집기와 대화 상자를 열어서 Analysis ServicesAnalysis Services인스턴스에 연결하는 데 필요한 정보를 가져옵니다.Analysis Services XML/A Query - Opens a new Analysis ServicesAnalysis Services XML/A Query Editor and a dialog to get the information required to connect to an instance of Analysis ServicesAnalysis Services.

개체 탐색기 사용Using Object Explorer

개체 탐색기에서From Object Explorer:

  • 데이터베이스 엔진Database Engine인스턴스에 연결된 서버 노드를 마우스 오른쪽 단추로 클릭한 다음 새 쿼리를 선택합니다.Right-click the server node connected to an instance of the 데이터베이스 엔진Database Engine, then select New Query. 데이터베이스 엔진Database Engine 의 동일한 인스턴스에 연결된 데이터베이스 엔진Database Engine 쿼리 편집기 창이 열리면 창의 데이터베이스 컨텍스트를 로그인에 대한 기본 데이터베이스로 설정합니다.This will open a 데이터베이스 엔진Database Engine Query Editor window connected to the same instance of the 데이터베이스 엔진Database Engine and set the database context of the window to the default database for the login.

  • 데이터베이스 노드를 마우스 오른쪽 단추로 클릭하고 새 쿼리를 선택합니다.Right-click a database node, and then select New Query. 데이터베이스 엔진Database Engine 의 동일한 인스턴스에 연결된 데이터베이스 엔진Database Engine 쿼리 편집기 창이 열리면 창의 데이터베이스 컨텍스트를 동일한 데이터베이스로 설정합니다.This will open a 데이터베이스 엔진Database Engine Query Editor window connected to the same instance of the 데이터베이스 엔진Database Engine and set the database context of the window to the same database.

솔루션 탐색기 사용Using Solution Explorer

솔루션 탐색기에서 폴더를 확장하고 폴더 내의 항목을 마우스 오른쪽 단추로 클릭한 다음 열기 를 클릭하고 항목이나 파일을 두 번 클릭합니다.From Solution Explorer, expand a folder, right-click an item within the folder, and then click Open or double-click the item or file.

템플릿 브라우저를 사용하여 데이터베이스 엔진 쿼리 편집기 열기Using Template Browser to Open the Database Engine Query Editor

  • 보기 메뉴에서 템플릿 탐색기를 클릭합니다.On the View menu, click Template Explorer.

  • 오른쪽 창에 템플릿 브라우저 창이 표시됩니다.The Template Browser window appears in the right pane.

  • 템플릿을 두 번 클릭하여 데이터베이스 엔진 쿼리 창을 템플릿 텍스트와 함께 엽니다.Double-click a template to open a Database Engine Query window with the text of the template. 예를 들어 CREATE DATABASE 템플릿을 열려면 SQL Server 템플릿 폴더, 데이터베이스 폴더를 차례로 열고 데이터베이스 만들기를 두 번 클릭합니다.For example, to open a CREATE DATABASE template, open the SQL Server Templates folder, open the Databases folder, and double-click create database.