XML 편집기(SQL Server Management Studio)XML Editor (SQL Server Management Studio)

XML 스키마, ADO.NET 데이터 집합 및 XML 문서 작업에 사용할 수 있는 다양한 시각적 도구를 제공합니다.Provides a set of visual tools for working with XML Schemas, ADO.NET datasets, and XML documents. XML 디자이너는 WC3(World Wide Web Consortium)에서 정의한 XSD(XML 스키마 정의) 언어를 지원합니다.The XML Designer supports the XML Schema Definition (XSD) language defined by the World Wide Web Consortium (WC3). DTD(문서 유형 정의)나 XDR(XML-Data Reduced)와 같은 다른 XML 스키마 언어는 지원하지 않습니다.The designer does not support DTDs (document type definitions) or other XML schema languages, such as XDR (XML-Data Reduced).

디자이너를 표시하려면 데이터 집합, XML 스키마 또는 XML 파일을 프로젝트에 추가하거나 아래 표에 나오는 파일 형식을 여십시오.To display the designer, add a dataset, XML Schema, or XML file to your project or open any of the file types listed in the table below.

주의

스키마 뷰에서 작업할 때는 실행 취소 명령을 사용할 수 없으므로There is no Undo command when working in Schema view. 작업을 신중하게 계획하고 파일을 자주 저장하는 것이 좋습니다.Plan your work carefully and save your files often.

XML 디자이너는 XML 파일, XML 스키마 및 데이터 집합 작업에 다음 세 가지 뷰(또는 모드)를 제공합니다.The designer provides the following three views (or modes) to work on XML files, XML Schemas, and datasets:

보기View 설명Description 지원되는 파일 형식File types supported
스키마Schema XML 스키마 및 ADO.NET 데이터 집합을 시각적으로 만들고 수정할 때 사용For visually creating and modifying XML Schemas and ADO.NET datasets. .xsd.xsd
데이터Data 구조화된 데이터 표에서 XML 데이터 파일을 시각적으로 수정할 때 사용For visually modifying XML data files in a structured data grid. .xml.xml
XMLXML XML을 편집할 때 사용. 원본 편집기는 색 구분과 단어 자동 완성 및 멤버 목록 표시를 비롯한 IntelliSense 기능 제공For editing XML; the source editor provides color-coding and IntelliSense, including Complete Word and List Members. .xml .xsd .xslt .wsdl .web. resx .tdl. wsf .hta .disco .vsdisco .config.xml .xsd .xslt .wsdl.web.resx.tdl.wsf.hta.disco.vsdisco.config
실행 계획ShowPlan SET SHOWPLAN_XML ON 옵션을 사용하여 만든 xml 쿼리 계획 표시Displays xml query plans created using the SET SHOWPLAN_XML ON option. .showplan.showplan

스키마 뷰Schema View

스키마 뷰는 XML 스키마와 ADO.NET 데이터 집합을 구성하는 요소, 특성, 유형 등을 시각적으로 보여 줍니다.Schema view provides a visual representation of the elements, attributes, types, and so on, that make up XML Schemas and ADO.NET datasets.

스키마 뷰에서는 도구 상자의 XML 스키마 탭이나 서버 탐색기 중 하나에서 디자인 화면으로 요소를 끌어 놓아 스키마와 데이터 집합을 만들 수 있습니다.In Schema view you can construct schemas and datasets by dropping elements on the design surface from either the XML Schema tab of the Toolbox or from Server Explorer. 또한 디자인 화면을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴에서 추가를 선택하여 요소를 디자이너에 추가할 수도 있습니다.Additionally, you can add elements to the designer by right-clicking the design surface and selecting Add from the shortcut menu.

스키마 뷰에서는 다음 작업을 수행할 수 있습니다.In Schema view you can:

  • 기존 XML 스키마와 ADO.NET 데이터 집합 생성 및 수정Construct and modify existing XML Schemas and ADO.NET datasets

  • 테이블 간 관계 만들기 및 편집Create and edit relationships between tables

  • 키 만들기 및 편집Create and edit keys

  • XML 스키마에서 ADO.NET 데이터 집합 생성Generate ADO.NET datasets from XML Schemas

참고

스키마 뷰에서 요소의 레이아웃은 .xsx 파일로 저장됩니다. 솔루션 탐색기 도구 모음에서 모든 파일 표시 를 클릭한 다음 .xsd 파일을 확장하면 이 파일을 볼 수 있습니다.The layout of elements in Schema view is stored in the .xsx file, which can be seen by clicking Show All Files in the Solution Explorer toolbar, and then expanding the .xsd file. .xsx 파일이 표시되지 않으면 이전에 XML 디자이너에서 .xsd 파일을 열어본 적이 없는 것입니다.If there is no .xsx file present, it means the .xsd file has never been opened in the XML Designer.

스키마 뷰 사용자 지정Customizing Schema View

다음 기능은 스키마 뷰에서 요소의 시각적 레이아웃을 수정하는 데 사용됩니다.The following features modify the visual layout of elements in Schema view:

  • 확대/축소Zooming

  • 중첩된 요소 확장 또는 축소Expanding or collapsing of nested elements

  • 요소 레이아웃 자동 정렬Automatically arranging layout of elements

  • 축소된 요소의 기본 상태 다시 설정Resetting default state of collapsed elements

숨겨진 중첩 요소를 확장하려면To expand hidden nested elements
  • 요소 아래쪽의 더하기 아이콘을 클릭합니다.Click the plus icon on the bottom of the element.
중첩 요소를 축소하려면To collapse nested elements
  • 디자이너에 표시하려는 맨 아래 요소의 빼기 아이콘을 클릭합니다.Click the minus icon on the bottom-most element that you want to appear on the designer.

데이터 뷰Data View

데이터 뷰는 .xml 파일을 수정하는 데 사용할 수 있는 데이터 표를 제공합니다.Data view provides a data grid that can be used to modify .xml files. 데이터 뷰에서는 XML 파일의 내용만 편집할 수 있으며 태그와 구조는 편집할 수 없습니다.Only the content (but not the tags and structure) in an XML file can be edited in Data view.

데이터 뷰에는 데이터 테이블데이터의 두 가지 별도 영역이 있습니다.There are two separate areas in Data view: Data Tables and Data. 데이터 테이블 영역은 XML 파일에 정의되어 있는 관계를 중첩된 순서(바깥쪽에서부터 안쪽으로)대로 보여 주는 목록입니다.The Data Tables area is a list of relations defined in the XML file, in the order of its nesting (from the outermost to the innermost). 데이터 영역은 데이터 테이블 영역에서 선택한 내용에 따라 해당 데이터를 표시하는 데이터 표입니다.The Data area is a data grid that displays data based on the selection in the Data Tables area.

참고

새로 만든 XML 파일에는 데이터가 들어 있지 않으므로 데이터 뷰에서 표시할 수 없습니다.Newly created XML files contain no data and therefore cannot be displayed in Data view. 이외에도 일부 XML 문서에서는 데이터 뷰를 실행할 수 없습니다.There are also some instances of XML documents where data view cannot be invoked at all. XML의 형식이 올바르더라도 구조화된 데이터가 아닌 경우 데이터 뷰로 전환하려고 하면 "이 XML 문서는 형식이 올바르지만 데이터 뷰에서 표시할 수 없는 구조를 포함하고 있습니다"라는 메시지가 표시됩니다.Although the XML would be considered well formed, if it is not structured data trying to switch to Data view will generate the following message: "Although this document is well formed, it contains structure that Data View cannot display."

데이터 뷰에서는 다음 작업을 수행할 수 있습니다.In Data view you can:

  • 수동으로 데이터 테이블 채우기Manually populate data tables

  • 기존 데이터 테이블 편집Edit existing data tables

  • XML 문서에서 XML 스키마 생성Generate an XML Schema from an XML document

XML 뷰XML View

XML 뷰는 원시 XML을 편집할 수 있는 편집기와 IntelliSense 및 색 구분 기능을 제공합니다.XML view provides an editor for editing raw XML and provides IntelliSense and color coding. 스키마가 연결되어 있는 .xml 파일과 .xsd 파일로 작업할 때는 문 완성 기능을 사용할 수 있습니다.Statement completion is available when working on .xsd files and .xml files that have an associated schema. 태그를 시작하는 <를 입력하면 해당 위치에 들어갈 수 있는 요소가 목록으로 표시됩니다.Type < to initiate a tag and you will be presented with a list of elements that are valid at that location. 요소 이름을 입력한 후 스페이스바를 누르면 요소가 지원하는 특성이 목록으로 표시됩니다.After you type the element name and press the SPACEBAR, you will be presented with a list of attributes that the element supports.

참고

MicrosoftMicrosoft IntelliSense 옵션은 도구 모음에서 사용할 수 없습니다. MicrosoftMicrosoft IntelliSense options are not available on the toolbar. XML 편집기에서 이 옵션을 사용하려면 편집 메뉴에서 IntelliSense를 클릭합니다.When in the XML Editor, to access the options, on the Edit menu, click IntelliSense.

실행 계획 뷰SHOWPLAN view

SET SHOWPLAN_XML ON 옵션을 사용하여 만든 쿼리 계획을 XML 형식으로 저장할 수 있습니다.Query plans can be saved in XML format when created using SET SHOWPLAN_XML ON option. 쿼리 계획을 열려면 확장명이 .showplan인 파일을 두 번 클릭하십시오.Double-click a file with the .showplan extension to open the query plan.

참고 항목See Also

XML 형식으로 실행 계획 저장Save an Execution Plan in XML Format