테이블 복제Duplicate Tables

이 항목은 다음에 적용됩니다. 예SQL Server(2016부터)예Azure SQL Database예Azure SQL Data Warehouse 예병렬 데이터 웨어하우스 THIS TOPIC APPLIES TO: yesSQL Server (starting with 2016)yesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse

SQL Server 2017SQL Server 2017 에서는 SQL Server Management StudioSQL Server Management Studio 를 사용하거나 Transact-SQLTransact-SQL 을 사용하여 새 테이블을 만들고, 기존 테이블에서 열 정보를 복사하여 기존 테이블을 복제할 수 있습니다.You can duplicate an existing table in SQL Server 2017SQL Server 2017 by using SQL Server Management StudioSQL Server Management Studio or Transact-SQLTransact-SQL by creating a new table and then copying column information from an existing table.

중요

이 작업은 테이블의 구조만 복제하며 테이블 행은 복제하지 않습니다.This operation duplicates only the structure of a table; it does not duplicate any table rows.

항목 내용In This Topic

시작하기 전 주의 사항 Before You Begin

보안 Security

사용 권한 Permissions

대상 데이터베이스에서 CREATE TABLE 권한이 필요합니다.Requires CREATE TABLE permission in the destination database.

SQL Server Management Studio 사용 Using SQL Server Management Studio

테이블을 복제하려면To duplicate a table

  1. 테이블을 만들려는 데이터베이스에 연결되어 있는지 확인한 다음 개체 탐색기에서 데이터베이스를 선택했는지 확인합니다.Make sure you are connected to the database in which you want to create the table and that the database is selected in Object Explorer.

  2. 개체 탐색기에서 테이블 을 마우스 오른쪽 단추로 클릭하고 새 테이블을 클릭합니다.In Object Explorer, right-click Tables and click New Table.

  3. 개체 탐색기에서 복사할 테이블을 마우스 오른쪽 단추로 클릭한 다음 디자인을 클릭합니다.In Object Explorer right-click the table you want to copy and click Design.

  4. 기존 테이블에서 열을 선택하고 편집 메뉴에서 복사를 클릭합니다.Select the columns in the existing table and, from the Edit menu, click Copy.

  5. 새 테이블로 전환하고 첫 번째 행을 선택합니다.Switch back to the new table and select the first row.

  6. 편집 메뉴에서 붙여넣기를 클릭합니다.From the Edit menu, click Paste.

  7. 파일 메뉴에서 저장table name을 클릭합니다.From the File menu, click Savetable name.

  8. 이름 선택 대화 상자에서 새 테이블의 이름을 입력하고 확인을 클릭합니다.In the Choose Name dialog box, type a name for the new table and click OK.

Transact-SQL 사용 Using Transact-SQL

쿼리 편집기에서 테이블을 복제하려면To duplicate a table in Query Editor

  1. 테이블을 만들려는 데이터베이스에 연결되어 있는지 확인한 다음 개체 탐색기에서 데이터베이스를 선택했는지 확인합니다.Make sure you are connected to the database in which you want to create the table and that the database is selected in Object Explorer.

  2. 복제하려는 테이블을 마우스 오른쪽 단추로 클릭하고 테이블 스크립팅을 가리킨 후 CREATE를 가리키고 새 쿼리 편집기 창을 선택합니다.Right-click the table you wish to duplicate, point to Script Table as, then point to CREATE to, and then select New Query Editor Window.

  3. 테이블 이름을 변경합니다.Change the name of the table.

  4. 새 테이블에 필요하지 않은 모든 열을 제거합니다.Remove any columns that are not needed in the new table.

  5. 실행을 클릭합니다.Click Execute.