방법: 사용자 지정 어셈블리 디버깅How to: Debug Custom Assemblies

MicrosoftMicrosoft .NET Framework.NET Framework는 사용자 지정 어셈블리 코드를 분석하고 오류를 찾는 데 유용한 디버깅 도구를 다수 제공합니다.The MicrosoftMicrosoft .NET Framework.NET Framework provides several debugging tools that can help you analyze your custom assembly code and locate errors in it. 사용하기에 가장 좋은 도구는 수행하려는 작업에 따라 달라집니다.The best tool to use will depend on what you are trying to accomplish. 이 예에서는 Visual Studio 2008Visual Studio 2008를 사용합니다.This example uses Visual Studio 2008Visual Studio 2008.

Reporting ServicesReporting Services에 대한 사용자 지정 어셈블리 디자인, 개발 및 테스트를 위해 권장되는 방법은 테스트 보고서와 사용자 지정 어셈블리가 모두 포함된 솔루션을 만드는 것입니다.The recommended way to design, develop, and test custom assemblies for Reporting ServicesReporting Services is to create a solution that contains both your test reports and your custom assembly.

단일 인스턴스의 Visual Studio를 사용하여 어셈블리를 디버깅하려면To debug assemblies using a single instance of Visual Studio

  1. Visual StudioVisual Studio를 사용하여 새 보고서 프로젝트를 만듭니다.Create a new report project using Visual StudioVisual Studio.

    보고서 프로젝트를 만들 때 Visual StudioVisual Studio에서는 보고서 프로젝트를 포함할 솔루션이 만들어집니다.At the time you create a report project, Visual StudioVisual Studio also creates a solution to contain it.

  2. 새 클래스 라이브러리 프로젝트를 기존 솔루션에 추가합니다.Add a new Class Library project to the existing solution. 보고서 프로젝트가 시작 프로젝트로 설정되었는지 확인합니다.Make sure that the report project is set as the startup project. 이를 수행하는 방법은 Visual StudioVisual Studio 설명서를 참조하십시오.For more information about how to accomplish this, see your Visual StudioVisual Studio documentation.

  3. 솔루션 탐색기에서 솔루션을 선택합니다.In Solution Explorer, select the solution.

  4. 보기 메뉴에서 속성 페이지를 클릭합니다.On the View menu, click Property Pages.

    솔루션 속성 페이지 대화 상자가 열립니다.The Solution Property Pages dialog box opens.

  5. 왼쪽 창에서 필요한 경우 공용 속성을 확장한 다음 프로젝트 종속성을 클릭합니다.In the left pane, expand Common Properties if necessary, and click Project Dependencies. 프로젝트 드롭다운 목록에서 보고서 프로젝트를 선택합니다.Select the report project from the Project drop-down list. 다음에 종속 목록에서 어셈블리 프로젝트를 선택합니다.Select your assembly project in the Depends On list.

  6. 확인을 클릭하여 변경 내용을 저장하고 속성 페이지 대화 상자를 닫습니다.Click OK to save the changes, and close the Property Pages dialog.

  7. 솔루션 탐색기에서 사용자 지정 어셈블리 프로젝트를 선택합니다.In Solution Explorer, select your custom assembly project.

  8. 보기 메뉴에서 속성 페이지를 클릭합니다.On the View menu, click Property Pages.

    프로젝트 속성 페이지 대화 상자가 열립니다.The Project Property Pages dialog box opens.

  9. C# 프로젝트의 경우 빌드 탭을 클릭하고 Visual BasicVisual Basic 프로젝트의 경우 컴파일 탭을 클릭합니다.Click the Build tab if you're in a C# project or the Compile tab if you're in a Visual BasicVisual Basic project.

  10. 빌드/컴파일 페이지에서 보고서 디자이너 폴더 경로를 입력합니다.On the Build/Compile page, enter the path to the Report Designer folder. 기본적으로 이 경로는 출력 경로 입력란에 C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE로 표시됩니다.By default, this is C:\Program Files\Microsoft SQL Server\100\Tools\Binn\VSShell\Common7\IDE) in the Output Path text box. 그러면 보고서가 실행되기 전에 업데이트된 버전의 사용자 지정 어셈블리가 빌드되어 보고서 디자이너에 직접 배포됩니다.This builds and deploys an updated version of your custom assembly directly to Report Designer before your report is executed.

  11. 보고서를 디자인하고 사용자 지정 어셈블리를 개발했으면 사용자 지정 어셈블리 코드에서 중단점을 설정합니다.Once you have designed your report and developed your custom assembly, set breakpoints in your custom assembly code.

  12. F5 키를 눌러 DebugLocal 모드에서 보고서를 실행합니다.Run the report under DebugLocal mode by pressing the F5 key. 보고서가 팝업 미리 보기 창에서 실행되면 디버거는 어셈블리의 실행 코드에 해당하는 중단점에서 멈춥니다.When the report executes in the pop-up preview window, the debugger hits any breakpoints that correspond to executable code in your assembly. F11 키를 사용하여 사용자 지정 어셈블리 코드를 단계별로 분석합니다.Use F11 to step through your custom assembly code.

두 인스턴스의 Visual Studio를 사용하여 어셈블리를 디버깅하려면To debug assemblies using two instances of Visual Studio

  1. Visual StudioVisual Studio를 시작하고 사용자 지정 어셈블리 프로젝트를 엽니다.Start Visual StudioVisual Studio and open your custom assembly project.

  2. 프로젝트를 빌드하고 사용자 지정 어셈블리 및 해당하는 .pdb 파일을 보고서 디자이너에 배포합니다.Build the project, and deploy your custom assembly and the accompanying .pdb file to the Report Designer. 배포에 대한 자세한 내용은 사용자 지정 어셈블리 배포를 참조하세요.For more information about deployment, see Deploying a Custom Assembly.

  3. 사용자 지정 어셈블리 코드를 별도의 Visual StudioVisual Studio 인스턴스에서 열어 둔 상태로 사용자 지정 어셈블리가 사용된 보고서 프로젝트를 엽니다.Open up a report project that uses your custom assembly while leaving your custom assembly code open in a separate instance of Visual StudioVisual Studio.

  4. 사용자 지정 어셈블리 프로젝트를 포함하는 Visual StudioVisual Studio 인스턴스로 이동하고 코드에서 중단점을 설정합니다.Navigate to the instance of Visual StudioVisual Studio that contains your custom assembly project and set some break points in your code.

  5. 사용자 지정 어셈블리 프로젝트를 활성 창 상태로 두고 디버그 메뉴에서 프로세스에 연결을 클릭합니다.With the custom assembly project still the active window, click Attach to Process on the Debug menu.

    프로세스에 연결 대화 상자가 열립니다.The Attach to Process dialog opens.

  6. 프로세스 목록에서 보고서 프로젝트에 해당하는 devenv.exe 프로세스를 선택하고 연결을 클릭합니다.From the list of processes, select the devenv.exe process that corresponds to your Report Project and click Attach.

  7. 사용자 지정 어셈블리의 보고서에서 사용할 식을 정의하고 보고서를 디자인합니다.Define the expressions that you will use in your report from your custom assembly and design your report.

  8. 보고서 디자인을 마쳤으면 미리 보기 탭을 클릭합니다.When you are finished designing your report, click the Preview tab.

    보고서가 실행되며 사용자 지정 어셈블리 코드는 미리 정의된 중단점에서 멈추게 됩니다.The report executes, and the custom assembly code should break at your predefined break points.

    참고

    미리 보기 탭을 사용할 경우 어셈블리에 대한 코드 권한이 적용되지 않습니다.Using the Preview tab does not enforce code permissions for the assembly. 코드 액세스 보안 오류를 포함한 전체 테스트의 경우 DebugLocal 구성 설정에서 보고서 프로젝트를 시작합니다.For a complete test, which includes any code access security errors, start the report project under the DebugLocal configuration setting.

  9. F11 키를 사용하여 코드를 단계별로 실행합니다.Step through your code using the F11 key. Visual StudioVisual Studio를 사용하여 디버깅하는 방법은 Visual StudioVisual Studio 설명서를 참조하십시오.For more information about debugging using Visual StudioVisual Studio, see the Visual StudioVisual Studio documentation.

관련 항목:See Also

보고서에서 사용자 지정 어셈블리 사용Using Custom Assemblies with Reports