1단원: 보고서 서버 프로젝트 만들기(Reporting Services)Lesson 1: Creating a Report Server Project (Reporting Services)

이전 버전의 SQL Server와 관련 된 콘텐츠를 참조 하십시오. 1 단원: 보고서 서버 프로젝트 (Reporting Services)를 만들어합니다.For content related to previous versions of SQL Server, see Lesson 1: Creating a Report Server Project (Reporting Services).

이 섹션에서는Visual Studio 내의 에서 보고서 서버 프로젝트 보고서 정의(.rdl) SQL Server Data ToolsSQL Server Data Tools 파일을 만듭니다.In this lesson, you'll create a report server project and a report definition (.rdl) file in SQL Server Data ToolsSQL Server Data Tools within Visual Studio.

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서 보고서를 만들려면 먼저 보고서 정의 파일(.rdl) 및 보고서에 필요한 다른 리소스 파일을 저장할 수 있는 보고서 서버 프로젝트가 필요합니다.To create a report with SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), first you need a report server project where you can save your report definition (.rdl) file and other resource files you need for your report.

다음 단원에서는 실제 보고서 정의 파일을 만들고 보고서에 대한 데이터 원본, 데이터 집합 및 보고서 레이아웃을 정의합니다.In the following lessons, you define a data source for your report, define a dataset, and define the report layout. 보고서를 실행하면 데이터가 검색되어 레이아웃과 결합된 후 화면에 렌더링됩니다.When you run the report, the data is retrieved and combined with the layout, and then rendered on your screen. 여기에서 보고서를 내보내거나 인쇄하거나 저장할 수 있습니다.From there you can export it, print it, or save it.

보고서 서버 프로젝트를 만들려면To create a report server project

  1. SQL Server Data ToolsSQL Server Data Tools를 엽니다.Open SQL Server Data ToolsSQL Server Data Tools.

  2. 파일 메뉴에서 새로 만들기 > 프로젝트를 클릭합니다.On the File menu > New > Project.

    ssrs-ssdt-file-01-new-project

  3. 설치됨 > 템플릿 > 비즈니스 인텔리전스에서 Reporting Services를 클릭합니다.Under Installed > Templates > Business Intelligence, click Reporting Services.

    ssrs-ssdt-01-new-rs-project

  4. 보고서 서버 프로젝트 ssrs_ssdt_report_server_project를 클릭합니다.Click Report Server Project ssrs_ssdt_report_server_project.

    참고: 표시 되지 않으면는 Business Intelligence 또는 보고서 서버 프로젝트 Business Intelligence 템플릿으로 SSDT를 업데이트 해야 하는 옵션입니다.Note: If you don't see the Business Intelligence or Report Server Project options, you need to update SSDT with the Business Intelligence templates. SSDT(SQL Server Data Tools) 다운로드를 참조하세요.See Download SQL Server Data Tools (SSDT)

  5. 이름Tutorial을 입력합니다.In Name, type Tutorial.

    기본적으로 새 디렉터리에 Visual Studio 2015\Projects 폴더가 만들어집니다.By default, it's created in your Visual Studio 2015\Projects folder in a new directory.

    ssrs-ssdt-01-solution-location

  6. 확인 을 클릭하여 프로젝트를 만듭니다.Click OK to create the project.

    오른쪽의 솔루션 탐색기 페이지에 Tutorial 프로젝트가 표시됩니다.The Tutorial project is displayed in the Solution Explorer pane on the right.

새 보고서 정의 파일을 만들려면To create a new report definition file

  1. 솔루션 탐색기 창에서 보고서 > 추가 > 새 항목을 마우스 오른쪽 단추로 클릭합니다.In the Solution Explorer pane, right-click the Reports > Add > New Item.

    : 솔루션 탐색기 창이 열리지 않은 경우 보기 메뉴에서 솔루션 탐색기를 클릭합니다.Tip: If you don't see the Solution Explorer pane, on the View menu, click Solution Explorer.

    ssrs_ssdt_add_report

  2. 새 항목 추가 창에서 보고서 ssrs_ssdt_report를 클릭합니다.In the Add New Item window, click Report ssrs_ssdt_report.

  3. 이름Sales Orders.rdl 을 입력한 후 추가를 클릭합니다.In Name, type Sales Orders.rdl and then click Add.

    보고서 디자이너가 열리고 새 .rdl 파일이 디자인 뷰에 표시됩니다.Report Designer opens and displays the new .rdl file in Design view.

    ssrs-ssdt-01-new-report-designer

    보고서 디자이너는 Reporting ServicesReporting Services 에서 실행되는 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)구성 요소로,Report Designer is a Reporting ServicesReporting Services component that runs in SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT). 두 개의 뷰, 즉 디자인미리 보기뷰가 있습니다.It has two views: Design and Preview. 뷰를 변경하려면 각 탭을 클릭해야 합니다.Click each tab to change views.

    보고서 데이터 창에서 데이터를 정의합니다.You define your data in the Report Data pane. 디자인 뷰에서는 보고서 레이아웃을 정의합니다.You define your report layout in Design view. 보고서를 실행하고 미리 보기 뷰에서 보고서의 모양을 볼 수 있습니다.You can run the report and see what it looks like in Preview view.

다음 단원Next lesson

"Tutorial" 보고서 프로젝트를 만들고 보고서 정의 파일(.rdl)을 보고서 프로젝트에 추가했습니다.You have successfully created a report project called "Tutorial" and added a report definition (.rdl) file to the report project. 다음 단원에서는 보고서에 사용할 데이터 원본을 지정합니다.Next, you will specify a data source to use for the report. 2단원: 연결 정보 지정(Reporting Services)을 참조하세요.See Lesson 2: Specifying Connection Information (Reporting Services).

관련 항목:See Also

기본 테이블 보고서 만들기(SSRS 자습서)Create a Basic Table Report (SSRS Tutorial)