보고서에 Office 데이터 연결(.odc) 사용Use an Office Data Connection (.odc) with Reports

제한된 시나리오에서 기존 Office 데이터 연결 파일(.odc)을 사용하여 Reporting ServicesReporting Services 보고서에 연결 정보를 제공할 수 있습니다.For limited scenarios, you can use an existing Office Data Connection (.odc) file to provide connection information to a Reporting ServicesReporting Services report. 공유 데이터 원본을 만들 때 .rsds 파일 대신 .odc 파일을 사용할 수 있습니다.An .odc file can be used in place of an .rsds file when you create a shared data source. 보고서 서버는 .rsds 파일과 같은 방식으로 .odc 파일을 사용합니다. 즉, 이 파일을 읽어 데이터 원본 유형, 연결 문자열 및 자격 증명 정보를 확인합니다.The report server uses an .odc file in the same way it uses an .rsds file; it reads the file for the data source type, a connection string, and credential information.

모든 .odc 파일을 Reporting ServicesReporting Services 보고서에 사용할 수 있는 것은 아닙니다.Not all .odc files can be used with a Reporting ServicesReporting Services report. 보고서 및 .odc 파일의 데이터 처리 확장 프로그램과 특징에 따라 .odc의 사용 가능 여부가 결정됩니다.The data processing extension and characteristics of the report and .odc file determine whether an .odc can be used:

  • 보고서가 OLE DB 또는 ODBC 데이터 공급자에서 작동하도록 디자인되어야 합니다.The report must be designed to work with an OLE DB or ODBC data provider. 다른 데이터 처리 확장 프로그램을 사용하여 보고서를 만든 경우 보고서나 해당 쿼리에 OLE DB 또는 ODBC 데이터 공급자가 지원하지 않는 기능이 있을 수 있습니다.If you used a different data processing extension to create the report, the report or its queries might include functionality that is not supported by the OLE DB or ODBC data provider.

  • .odc 파일에 필요한 요소와 구조가 있어야 합니다.The .odc file must have the expected elements and structure. 데이터 공급자 및 자격 증명 설정이 보고서 서버에서 읽을 수 있도록 파일에 명시적으로 설정되어 있어야 합니다.The data provider and credential settings must be set explicitly in the file so that they can be read by the report server. 이러한 값을 설정하는 최상의 방법은 .odc 파일을 SharePoint 라이브러리로 업로드하기 전에 이 파일을 내보내는 것입니다.The best way to set these values is to export the .odc file before uploading it to the SharePoint library.

  • .odc 파일에서 OLE DB 또는 ODBC 연결 형식을 지정해야 합니다.The .odc file must specify a connection type of OLE DB or ODBC.

  • .odc 파일에서 연결 문자열을 지정해야 합니다.The .odc file must specify a connection string.

  • 자격 증명은 None, Stored또는 Integrated로 설정될 수 있습니다.Credentials can be set to None, Stored, or Integrated. 자격 증명 방법을 Stored로 설정하면 보고서 서버가 저장된 자격 증명을 사용하는 대신 사용자에게 자격 증명을 입력하라는 메시지를 표시합니다.If the credentials method is set to Stored, the report server will prompt the user for credentials instead of using the stored credentials. 보고서 서버는 .odc 파일에 정의된 대로 저장된 자격 증명을 사용할 수 없습니다.The report server cannot use stored credentials as defined in the .odc file.

  • 보고서를 만드는 데 사용된 스키마와 동일한 스키마가 데이터 원본에 있어야 합니다.The data source must have schema that is identical to the one used to create the report. 데이터 구조가 다른 경우 보고서가 실행되지 않습니다.If the data structures are different, the report will not run.

  • MicrosoftMicrosoft Office 2007에서 만든 .odc 파일이어야 합니다. 이전 버전의 .odc는 보고서 정의 파일과 호환되지 않습니다.The .odc file must be created in MicrosoftMicrosoft Office 2007 (older versions of .odc are not compatible with report definition files).

    .odc 데이터 원본 유형이 지원되는 데이터 원본 유형과 비슷해 보이지만 보고서 서버에서 처리할 수 없는 데이터 원본에 대한 연결을 지정하는 .odc 파일은 사용할 수 없습니다.You cannot use .odc files that specify connections to data sources that cannot be processed on a report server, even if the .odc data source types look similar to supported data source types. 특히 Microsoft Excel 2007에서 Microsoft Access, 웹 또는 텍스트 파일의 데이터를 검색하는 .odc 파일을 만든 경우 이 .odc 파일을 사용하여 보고서에 데이터를 제공할 수 없습니다.Specifically, if you created an .odc file in Microsoft Excel 2007 that retrieves data from Microsoft Access, the Web, or a text file, you cannot use that .odc file to provide data to a report.

    보고서 작성기 보고서와 모델은 .odc 파일에서 작동하지 않습니다.Report Builder reports and models do not work with .odc file. .odc 파일을 사용하여 모델을 생성할 수 없으며 .odc 파일에 연결된 공유 데이터 원본을 사용하도록 모델을 구성할 수도 없습니다.You cannot use an .odc file to generate a model, and you cannot configure the model to use a shared data source that links to an .odc file.

    .odc 파일에 익숙하지 않을 경우 다음 지침을 사용하여 .odc 파일을 만들고 내보낼 수 있습니다.If you are not familiar with .odc files, you can use the following instructions to create and export one. OLE DB 데이터 원본에 사용할 .odc 파일을 만드는 한 가지 쉬운 방법은 Excel 2007과 데이터 연결 마법사를 사용하는 것입니다.One easy way to create an .odc file for an OLE DB data source is to use Excel 2007 and the Data Connection Wizard. 이때 마법사에서 데이터 원본을 만들지 않으며 이미 정의된 외부 데이터 원본이 있어야 합니다.Note that the wizard does not create a data source; you must have an external data source that is already defined.

    기존 .odc 파일은 보고서 및 쿼리와 완전히 호환되는 경우에만 사용해야 합니다.An existing .odc file should only be used if it is fully compatible with the report and queries. 보고서나 .odc 파일을 완전히 수정해야 하는 오류가 발생하면 보고서에 대해 새 .rsds 파일을 만들어야 합니다.If you run into errors that require significant modifications to either the report or to the .odc file, you should create a new .rsds file for the report. .Rsds 파일을 사용 하는 공유 데이터 원본을 만드는 방법에 대 한 자세한 내용은 참조 하십시오. 만들기 및 공유 데이터 원본 관리 ( 모드 ) 통합 SharePoint의 reporting Services .For more information about how to create a shared data source that uses an .rsds file, see Create and Manage Shared Data Sources (Reporting Services in SharePoint Integrated Mode).

.odc 파일을 만들고 내보내려면To create and export an .odc file

  1. Excel 2007을 시작합니다.Start Excel 2007.

  2. 데이터 탭의 외부 데이터 가져오기 그룹에서 기타 원본을 클릭한 다음 데이터 연결 마법사를 클릭합니다.On the Data tab, in the Get External Data group, click From Other Sources, and then click From Data Connection Wizard.

  3. 기타/고급을 선택한 후 다음을 클릭합니다.Select Other/Advanced, and then click Next.

  4. Microsoft OLE DB Provider for SQL Server를 선택한 후 다음을 클릭합니다.Select Microsoft OLE DB Provider for SQL Server, and then click Next.

  5. 서버의 이름(기본적으로 컴퓨터의 네트워크 이름) 및 유효한 로그인과 데이터베이스 사용 권한을 가진 사용자 계정을 입력합니다.Enter the name of the server (by default, it is the network name of the computer) and a user account that has a valid login and database permissions. 다음을 클릭합니다.Click Next.

  6. 데이터베이스를 선택한 다음 확인 을 클릭하여 데이터 연결 대화 상자를 닫습니다.Select a database, and then click OK to close the Data Link dialog box.

  7. 특정 테이블에 연결 확인란은 기본적으로 선택되어 있으며The Connect to specific table check box is selected by default. 특정 테이블에서 데이터를 검색하는 데 사용됩니다.It is used to retrieve data from a specific table. 보고서 서버는 .odc 파일의 모든 쿼리를 무시하므로 이 확인란의 선택 여부는 상관이 없습니다.The report server ignores all queries in an .odc file, so it does not matter whether you select or clear the check box. 보고서 데이터를 검색하는 쿼리는 외부 파일이 아닌 보고서 정의에 포함되어 있습니다.Queries that retrieve data for a report are included in a report definition file and not in external files.

  8. 연결이 열려 있는 동안 속성을 편집하여 내보낼 수 있습니다.While the connection is open, you can edit properties and export it. 데이터 탭의 연결 그룹에서 속성을 클릭한 다음 연결 이름 옆에 있는 연결 속성 단추를 클릭합니다.On the Data tab, in the Connections group, click Properties, and then click the Connection Properties button next to the connection name.

  9. 정의 탭에서 연결 파일 내보내기를 클릭합니다.On the Definition tab, click Export Connection File.

  10. 파일 이름을 입력한 다음 저장을 클릭합니다.Enter a name for the file, and then click Save. 응용 프로그램과 열려 있는 모든 파일을 닫습니다.Close the application and all open files.

.odc 파일을 업로드하고 사용하려면To upload and use an .odc file

  1. 연결 파일을 업로드할 라이브러리를 엽니다.Open the library into which you want to upload the connection file.

  2. 업로드 메뉴에서 문서 업로드를 클릭합니다.On the Upload menu, click Upload document.

  3. 찾아보기를 클릭합니다.Click Browse.

  4. 직접 만든 .odc 파일을 선택합니다.Select the .odc file you created. 기본적으로 .odc 파일은 My Documents 폴더의 My Data Sources에 있습니다.By default, the .odc file is in the My Documents folder, in My Data Sources.

  5. 열기 를 클릭하여 파일을 선택하고 확인 을 클릭하여 선택 내용을 저장합니다.Click Open to select the file, click OK to save the selection. 새 항목의 속성 페이지가 자동으로 열립니다.The properties page for the new item opens automatically.

  6. 콘텐츠 형식에서 보고서 데이터 원본을 선택한 다음 확인을 클릭합니다.In Content Type, select Report Data Source, and then click OK.

  7. 보고서를 가리킵니다.Point to a report.

  8. 아래쪽 화살표를 클릭하고 데이터 원본 관리를 선택합니다.Click the down arrow, and select Manage Data Sources.

  9. 데이터 원본 이름을 클릭합니다.Click the data source name.

  10. 보고서에서 사용자 지정 데이터 원본 정보를 사용하는 경우 공유를 클릭합니다.If the report uses custom data source information, click Shared.

  11. 데이터 원본 연결에서 찾아보기(...) 단추를 클릭합니다.In Data Source Link, click the browse (...) button.

  12. 방금 업로드한 .odc 파일을 선택합니다.Select the .odc file you just uploaded.

  13. 확인 을 클릭하여 파일을 선택한 다음 확인 을 클릭하여 변경 내용을 저장합니다.Click OK to select the file, and then click OK to save your changes.

    AdventureWorks2012AdventureWorks2012 예제 데이터베이스와 예제 보고서를 사용하여 이러한 단계를 수행하는 경우 Company Sales 보고서만 .odc 파일에서 추가 작업 없이 작동한다는 사실에 유의하십시오.If you are trying these steps with the AdventureWorks2012AdventureWorks2012 sample database and sample reports, be aware that only the Company Sales report will work out-of-the-box with an .odc file. 다른 예제 보고서에는 OLE DB 공급자에서 작동하지 않는 쿼리 매개 변수와 기능이 들어 있습니다.The other sample reports contain query parameters and features that do not work with the OLE DB provider. 하지만 먼저 보고서 디자이너에서 이러한 보고서를 수정하면 OLE DB 공급자에서 작동하도록 만들 수 있습니다.However, you can make the reports work with the OLE DB provider if you modify them first in Report Designer.

관련 항목:See Also

공유 데이터 원본 만들기, 수정 및 삭제(SSRS)Create, Modify, and Delete Shared Data Sources (SSRS)