SQL Server Data Tools의 Reporting Services(SSDT)Reporting Services in SQL Server Data Tools (SSDT)

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) 비즈니스 인텔리전스 솔루션을 만들기 위한 MicrosoftMicrosoft Visual StudioVisual Studio 환경입니다. is a MicrosoftMicrosoft Visual StudioVisual Studio environment for creating business intelligence solutions. SSDT에서는 페이지를 매긴 Reporting ServicesReporting Services 보고서 정의, 공유 데이터 원본, 공유 데이터 집합 및 보고서 파트를 열고 수정하고 미리 보고 저장하고 배포할 수 있는 보고서 디자이너 제작 환경을 사용할 수 있습니다.SSDT features the Report Designer authoring environment, where you can open, modify, preview, save, and deploy Reporting ServicesReporting Services paginated report definitions, shared data sources, shared datasets, and report parts. SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)는 SQL Server에 포함되어 있지 않습니다. is not included with SQL Server. SQL Server Data Tools를 다운로드합니다.Download SQL Server Data Tools.

이 항목에서는 SQL Server Data ToolsSQL Server Data Tools 에 사용되는 Reporting ServicesReporting Services솔루션, 프로젝트, 프로젝트 템플릿 및 구성과 보고서 디자이너에서 사용할 수 있는 뷰, 메뉴, 도구 모음 및 바로 가기에 대해 설명합니다.This topic describes SQL Server Data ToolsSQL Server Data Tools solutions, projects, project templates, and configurations used for Reporting ServicesReporting Services, and the views, menus, toolbars, and shortcuts that you can use in Report Designer.

보고서 디자인을 시작하려면 보고서 디자이너로 보고서 디자인(SSRS)을 참조하세요.To get started designing reports, see Design Reports with Report Designer (SSRS).

솔루션 및 프로젝트 Solutions and Projects

보고서 프로젝트는 보고서 정의 및 리소스에 대한 컨테이너 역할을 합니다.A report project acts as a container for report definitions and resources. 보고서 프로젝트의 모든 파일은 프로젝트를 배포할 때 보고서 서버에 게시됩니다.Every file in the report project is published to the report server when the project is deployed. 처음 프로젝트를 만들면 해당 프로젝트의 컨테이너 역할을 하는 솔루션도 만들어집니다.When you create a project for the first time, a solution is also created as a container for the project. 하나의 솔루션에 여러 프로젝트를 추가할 수 있습니다.You can add multiple projects to a single solution.

구성 Configurations

엔터프라이즈 테스트 및 프로덕션 보고서 서버와 같은 배포 변형을 위한 여러 프로젝트 속성 집합을 만들려면 구성 관리자를 사용합니다.To create multiple sets of project properties for deployment variations such as enterprise test and production report servers, use the Configuration Manager. 자세한 내용은 SQL Server Data Tools의 배포 및 버전 지원(SSRS)에 포함되지 않습니다.For more information, see Deployment and Version Support in SQL Server Data Tools (SSRS).

보고서 서버 프로젝트 Report Server Projects

Reporting ServicesReporting Services를 설치하면 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서 다음 프로젝트 템플릿을 사용할 수 있습니다.When you install Reporting ServicesReporting Services, the following project templates are made available in SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT):

  • 보고서 서버 프로젝트Report Server Project. 보고서 서버 프로젝트를 선택하면 보고서 디자이너가 열립니다.When you select a Report Server Project, Report Designer opens. 보고서 서버 프로젝트는 Visual StudioVisual Studio 에 의해 설치되며 새 프로젝트 대화 상자에서 사용할 수 있는 비즈니스 인텔리전스 프로젝트 템플릿입니다.A Report Server Project is a Business Intelligence Projects template installed by Visual StudioVisual Studio that is available from the New Project dialog box. 자세한 내용은 참조 보고서 프로젝트 (에 새로운 또는 기존 보고서 추가 Ssrs) . 보고서 서버 프로젝트 속성 적용 모든 보고서 및 모든 공유 데이터 원본에 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) 프로젝트.For more information, see Add a New or Existing Report to a Report Project (SSRS).Report Server project properties apply to all reports and all shared data sources in a SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) project. 이러한 속성에는 보고서 서버의 URL과 보고서 및 공유 데이터 원본의 폴더 이름이 포함됩니다.These properties include the URL for the report server and the folder names for reports and shared data sources. 프로젝트 속성 페이지 대화 상자를 사용하여 현재 속성 값을 볼 수 있습니다.Use the Project Property Pages dialog box to view the current property values. 이 대화 상자를 열려면 프로젝트 메뉴에서 속성을 클릭합니다.To open this dialog box, on the Project menu, click Properties.

  • 보고서 서버 프로젝트 마법사Report Server Project Wizard. 보고서 서버 마법사 프로젝트를 선택하면 보고서 서버 프로젝트가 자동으로 만들어지고 보고서 마법사가 열립니다.When you select a Report Server Wizard Project, a report server project is automatically created, and the Report Wizard opens. 마법사에서는 각 페이지의 지침을 따라 데이터 원본에 대한 연결 문자열을 만들고, 데이터 원본 자격 증명을 설정하고, 쿼리를 디자인하고, 테이블 또는 행렬 데이터 영역을 추가하고, 보고서 데이터 및 그룹을 지정하고, 글꼴 및 색 스타일을 선택하고, 보고서 서버에 보고서를 게시하고, 보고서를 로컬에서 미리 보는 방법으로 보고서를 만들 수 있습니다.In the wizard, you can create a report by following instructions on each page to create a connection string to a data source, set data source credentials, design a query, add a table or matrix data region, specify report data and groups, pick a font and color style, publish the report to a report server, and preview the report locally. 마법사로 보고서를 만든 후에는 보고서 서버 프로젝트의 보고서 디자이너를 사용하여 보고서 데이터 및 보고서 디자이너를 변경할 수 있습니다.After you create a report with the wizard, you can change the report data and the report designer by using Report Designer in the Report Server project.

    SSDT에서 새 프로젝트 템플릿이New Project templates in SSDT

보고서 디자이너 창 및 하위 창 Report Designer Windows and Panes

보고서 디자이너는 두 가지 뷰를 지원합니다. 디자인 은 보고서 데이터 및 보고서 레이아웃을 정의하기 위한 뷰이고 미리 보기 는 보고서의 렌더링된 뷰를 표시하기 위한 뷰입니다.Report Designer supports two views: Design to define the report data and report layout, and Preview to display a rendered view of the the report. 각 뷰에서 여러 창을 표시하면 렌더링된 보고서를 디자인하거나 보는 데 도움이 됩니다.In each view, you can display multiple windows to help you design or view a rendered report.

보고서 데이터 창 Report Data Pane

보고서 데이터 창에는 기본 제공 필드, 데이터 원본, 데이터 집합, 필드 컬렉션, 보고서 매개 변수 및 이미지가 표시됩니다.The Report Data pane displays built-in fields, data sources, datasets, field collections, report parameters, and images.

보고서 데이터 창을 사용하여 볼 수 있는 항목은 다음과 같습니다.Use the Report Data pane to view:

  • 기본 제공 필드 보고서 이름 또는 보고서가 처리된 시간과 같은 미리 정의된 보고서 정보입니다.Built-in Fields Predefined report information such as the report name or the time the report was processed.

  • 데이터 원본 데이터 원본은 데이터 원본의 이름 및 이 원본에 대한 연결을 나타냅니다.Data sources A data source represents a name and connection to a source of data.

  • 데이터 집합 각 데이터 집합은 데이터 원본에서 검색할 데이터를 지정하는 쿼리를 포함합니다.Datasets Each dataset includes a query that specifies which data to retrieve from the data source. 데이터 집합을 확장하여 데이터 집합 쿼리로 지정된 필드 컬렉션을 볼 수 있습니다.Expand the dataset to view the collection of fields specified by the dataset query.

    다차원 데이터 집합에 대해 사용할 수 있는 일부 쿼리 디자이너에서는 필터 창의 필터를 지정하고 보고서 매개 변수를 만들지 여부를 나타낼 수 있습니다.In some query designers for multidimensional datasets, you can specify filters in the Filters pane and indicate whether to create report parameters. 보고서 매개 변수 옵션을 지정하면 매개 변수의 유효값 목록을 채우기 위해 특별한 데이터 집합이 자동으로 만들어집니다.If you specify the report parameter option, a special dataset is automatically created to populate the parameter’s valid values list. 기본적으로 이러한 데이터 집합은 보고서 데이터 창에 나타나지 않습니다.By default, the dataset does not appear in the Report Data Pane. 자세한 내용은 다차원 데이터의 매개 변수 값에 대해 숨겨진 데이터 집합 표시(보고서 작성기 및 SSRS)를 참조하세요.For more information, see Show Hidden Datasets for Parameter Values for Multidimensional Data (Report Builder and SSRS).

  • 보고서 매개 변수 보고서 매개 변수 목록입니다.Report parameters The list of report parameters. 매개 변수는 데이터 집합 쿼리에 쿼리 매개 변수가 포함되면 수동이나 자동으로 만들어질 수 있습니다.Parameters can be created manually or automatically when a dataset query includes query parameters.

  • 이미지 보고서에 이미지 보고서 항목으로 포함할 수 있는 이미지의 목록입니다.Images The list of images that are available to include as an Image report item in a report.

    보고서 데이터 창의 데이터 원본 및 데이터 집합은 보고서 정의의 요소를 나타냅니다.Data sources and datasets in the Report Data pane represent the elements in the report definition. 보고서 데이터 창은 여러 보고서 제작 환경에서 지원되는 기능입니다.The Report Data pane is a feature supported by multiple report authoring environments. 보고서 작성기에서 데이터 원본 및 데이터 집합 관리를 위해 사용할 수 있는 유일한 창입니다.In Report Builder, it is the only pane available for managing data sources and datasets. 보고서 디자이너의 보고서 데이터 창은 공유 데이터 원본과 공유 데이터 집합을 파일 형태로 나열하는 솔루션 탐색기와 함께 작동합니다.In Report Designer, the Report Data pane works with Solution Explorer, which lists shared data sources and shared datasets as files. 보고서 데이터 창의 공유 데이터 원본과 공유 데이터 집합은 솔루션 탐색기에 있는 해당 공유 데이터 원본 및 공유 데이터 집합을 가리켜야 합니다.Shared data sources and shared datasets in the Report Data pane must point to their corresponding Shared Data Sources and Shared Datasets in Solution Explorer. 또한 보고서 데이터 창의 요소가 솔루션 탐색기의 데이터 파일에 대한 참조를 포함해야 합니다.The Report Data pane elements then contain a reference to the data files in Solution Explorer. 프로젝트 속성은 공유 데이터 원본 및 공유 데이터 집합을 보고서 서버나 SharePoint 사이트에 배포할지 여부를 결정합니다.The project properties determine whether the shared data sources and shared datasets are deployed to the report server or SharePoint site. 자세한 내용은 참조 변환 데이터 원본 ( 보고서 작성기 및 SSRS ) .For more information, see Convert Data Sources (Report Builder and SSRS).

참고

보고서 데이터 창이 표시되지 않는 경우 디자인 영역을 클릭한 다음 보기 메뉴에서 보고서 데이터를 클릭합니다.If you do not see the Report Data pane, click in the Design area and then on the View menu, click Report Data. 보고서 데이터 창이 부동 창인 경우 고정할 수 있습니다.If the Report Data pane is floating, you can anchor it. 자세한 내용은 보고서 디자이너에서 보고서 데이터 창 도킹(SSRS)을 참조하세요.For more information, see Dock the Report Data Pane in Report Designer (SSRS).

그룹화 창 Grouping Pane

그룹화 창을 사용하여 테이블릭스 데이터 영역에 대한 그룹을 정의할 수 있습니다.Use the Grouping pane to define groups for a tablix data region. 테이블의 경우 행 그룹 및 세부 그룹을 정의하고 행렬의 경우 행 및 열 그룹을 정의할 수 있습니다.You can define row groups and detail groups for tables and row and column groups for matrices. 그룹화 창을 사용하여 차트 또는 다른 데이터 영역에 대한 그룹을 정의할 수 없습니다.You cannot use the Grouping pane to define groups for Charts or other data regions. 자세한 내용은 그룹 이해(보고서 작성기 및 SSRS)를 참조하세요.For more information, see Understanding Groups (Report Builder and SSRS).

그룹화 창에는 다음과 같은 두 가지 모드가 있습니다.The Grouping pane has two modes:

  • 기본.Default. 기본 모드를 사용하여 부모 그룹, 자식 그룹, 인접 그룹 및 세부 그룹의 관계를 보여 주는 계층 구조 형식으로 모든 행 및 열 그룹을 표시할 수 있습니다.Use the Default mode to display all row and column groups in a hierarchical format that shows the relationship of parent groups, child groups, adjacent groups, and detail groups. 자식 그룹은 해당 부모 그룹 아래와 다음 들여쓰기 수준에 나타납니다.A child group appears under and at the next indent level compared to its parent group. 인접 그룹은 해당 피어 또는 형제 그룹과 같은 들여쓰기 수준에 나타납니다.An adjacent group appears at the same indent level as its peer or sibling groups.

    기본 모드를 사용하여 그룹을 추가, 편집 또는 삭제할 수 있습니다.Use default mode to add, edit, or delete groups. 단일 데이터 집합 필드를 기반으로 하는 그룹의 경우 해당 필드를 행 그룹 또는 열 그룹 창으로 끕니다.For groups based a single dataset field, drag the field to the Row Groups or Column Groups pane. 그룹을 기존 그룹의 위 또는 아래에 삽입할 수 있습니다.You can insert the group above or below an existing group. 인접 그룹을 추가하려면 형제 그룹을 마우스 오른쪽 단추로 클릭하고 바로 가기 메뉴를 사용합니다.To add an adjacent group, right-click the sibling group, and use the shortcut menu. 그룹에 포함할 테이블릭스 셀을 표시하려면 그룹화 창에서 해당 그룹을 선택합니다.To display which tablix cells belong to a group, select the group in the Grouping pane.

  • 고급Advanced. 고급 모드를 사용하여 선택한 테이블릭스 데이터 영역의 정적/동적 행 및 열 그룹 멤버를 표시할 수 있습니다.Use the Advanced mode to display static and dynamic row and column group members of the selected tablix data region. 그룹 또는 그룹 멤버에 연결된 행 및 열의 표시 여부를 제어하는 속성을 설정하려면 그룹 멤버를 사용하거나 페이지에서 그룹이 함께 유지되도록 렌더러에 사용되는 규칙을 사용해야 합니다.You must use group members to set properties that control the visibility of the rows and columns associated with a group or group member, or the rules that renderers use to try to keep groups together on a page. 그룹 멤버는 디자인 화면에 행 그룹 및 열 그룹 영역의 셀로 나타납니다.Group members appear on the design surface as cells in the row group and column group areas.

참고

기본 모드와 고급 모드 사이를 토글하려면 열 그룹 아이콘의 오른쪽에 있는 아래쪽 화살표를 마우스 오른쪽 단추로 클릭합니다.To toggle between Default and Advanced modes, right-click the down arrow to the right of the Column Groups icon.

자세한 내용은 Grouping Pane을 참조하세요.For more information, see Grouping Pane.

도구 상자 Toolbox

도구 상자는 디자인 화면으로 끌 수 있는 보고서 항목을 포함합니다.The Toolbox contains report items that you can drag to the design surface. 데이터 영역은 보고서에서 데이터를 구성하는 데 사용하는 보고서 항목입니다.Data regions are report items that you use to organize data on the report. 테이블, 행렬, 목록, 차트, 계기, 데이터 막대, 스파크라인 및 표시기가 데이터 영역입니다.Table, Matrix, List, Chart, Gauge, Data Bar, Sparkline, and Indicator are data regions. 다른 보고서 항목에는 지도, 입력란, 사각형, 선, 이미지 및 하위 보고서가 있습니다.Other report items include Map, Text Box, Rectangle, Line, Image, and Subreport. 사용자 지정 보고서 항목은 시스템 관리자가 설치 및 등록한 경우 이 목록에도 나타날 수 있습니다.Custom report items might also appear on this list if they have been installed and registered by your system administrator.

속성 창 Properties Pane

속성 창은 속성 이름과 디자인 화면에서 현재 선택된 보고서 항목의 값을 보여 주는 표준 Visual StudioVisual Studio 창입니다.The Properties pane is a standard Visual StudioVisual Studio window that shows property names and values for the currently selected report item on the design surface. 대부분의 경우 속성 이름은 RDL(Report Definition Language) 파일의 요소 및 특성에 해당합니다.In most cases, property names correspond to elements and attributes in the Report Definition Language (RDL) file. 자주 사용하는 속성은 선택한 항목의 속성 대화 상자를 사용하여 설정할 수 있습니다.The most commonly used properties can be set by using the Properties dialog box for the selected item. 해당 대화 상자를 열려면 속성 창 도구 모음에서 속성 페이지 단추를 클릭합니다.To open the corresponding dialog box, click the Property Pages button on the Properties pane toolbar. 고급 사용자는 속성 창에서 직접 속성 값을 설정할 수 있습니다.Advanced users can set property values directly in the Properties pane.

속성 창을 사용하여 다음을 수행할 수 있습니다.Use the Properties pane to:

  • 디자인 화면에서 현재 선택한 항목의 속성을 설정합니다.Set properties for the currently selected item on the design surface. 일부 속성은 값이 포함된 드롭다운 목록을 제공합니다.Some properties provide a drop-down list of values. 셀에 직접 값을 입력할 수도 있습니다.You can also type the value directly in the cell. 일부 속성은 값 컬렉션을 포함하며 이는 값 (컬렉션)으로 표시됩니다.Some properties contain a collection of values, indicated by the value (Collection). 대부분의 속성 식을; 받아들일 수 있습니다. 복잡 한 식은 값으로 표시 된 <식 >합니다.Most properties can accept an expression; complex expressions are indicated by the value <Expression>. 클릭 <식 > 열려는 대화 상자.Click <Expression> to open the Expression dialog box. 자세한 내용은 Expression Dialog Box을 참조하세요.For more information, see Expression Dialog Box.

  • 속성 창의 도구 모음 단추를 사용하여 종류별 보기에서 사전순 보기로 표 형태 창을 변경할 수 있습니다.Use the Properties pane toolbar buttons to change the grid from category view to alphabetical view. 종류별 보기에서는 범주 내의 모든 속성을 보기 위해 해당 범주를 확장해야 할 수 있습니다.In category view, you may need to expand a category to see all the properties under it. 항목의 속성 대화 상자를 열려면 도구 모음에서 속성 페이지 단추를 클릭하거나 항목을 마우스 오른쪽 단추로 클릭하고 속성을 클릭합니다.To open an item's Properties dialog box, click the Property Pages button on the toolbar or by right-click the item and click Properties.

  • 그룹화 창에서 현재 선택 된 그룹 멤버에 대한 속성을 설정합니다.Set properties for the currently selected group member in the Grouping pane. 그룹 멤버 속성은 정적 그룹 머리글 및 바닥글 행을 각 그룹 인스턴스에 대해 반복하는 방식을 제어하는 데 유용합니다.Group member properties help control how static group header and footer rows repeat for each group instance. 자세한 내용은 참조 그룹 ( 함께 표시 머리글 및 바닥글 보고서 작성기 및 SSRS ) .For more information, see Display Headers and Footers with a Group (Report Builder and SSRS).

    속성 창을 표시하려면 보기 메뉴에서 속성 창을 클릭합니다.To display the Properties pane, from the View menu, click Properties Window. 이 창의 도킹을 해제하여 SQL Server Data ToolsSQL Server Data Tools창의 다른 영역으로 이동하거나 디자인 화면에서 해당 창을 탭 뷰로 표시할 수 있습니다.You can undock this pane and move it to another area of the SQL Server Data ToolsSQL Server Data Toolswindow, or display it as a tabbed view on the design surface.

솔루션 탐색기 Solution Explorer

솔루션 탐색기는 프로젝트에 있는 모든 항목을 표시하는 표준 Visual StudioVisual Studio 구성 요소입니다.Solution Explorer is a standard Visual StudioVisual Studio component that displays all the items in your project. 보고서 서버 프로젝트의 경우 이 구성 요소에는 공유 데이터 원본, 공유 데이터 집합, 보고서 및 리소스를 구성하는 폴더가 포함됩니다.For a Report Server project, this includes folders to organize shared data sources, shared datasets, reports and resources. 폴더 항목은 솔루션 파일을 열 때 사전순으로 자동 정렬됩니다.Folder items are automatically alphabetized when you open the solution file. 속성 창에서 항목 속성을 보려면 해당 항목을 선택합니다.To view item properties in the Properties pane, select the item.

출력 Output

출력 창은 보고서를 미리 볼 때에는 처리 오류를 표시하고 보고서 또는 공유 데이터 원본을 배포할 때에는 게시 오류를 표시합니다.The Output window displays processing errors when you preview a report, and publishing errors when you deploy a report or a shared data source.

출력 및 문서 개요 창을 사용하여 식에서 오류를 디버그할 수 있습니다.Use the Output and the Document Outline windows to help debug errors in expressions.

문서 개요 Document Outline

문서 개요 창은 보고서 정의에 있는 모든 보고서 항목의 계층 목록을 표시합니다.The Document Outline window displays a hierarchical list of all report items in the report definition. 문서 개요 창을 열려면 보기 메뉴에서 다른 창 을 가리키고 문서 창을 클릭합니다.To open the Document Outline pane, from the View menu, point to Other Windows and click Document Window.

문서 개요 창을 사용하여 입력란 및 기타 보고서 항목을 이름으로 식별할 수 있습니다.Use the Document Outline pane to help identify text boxes and other report items by name. 문서 개요 창에서 항목을 선택하면 해당 항목은 디자인 화면에서도 선택됩니다.When you select an item in the Document Outline, the item is also selected on the Design Surface.

작업 목록 Task List

태스크 목록 창은 MicrosoftMicrosoft Access와 같은 다른 응용 프로그램에서 보고서를 가져올 때 지원되지 않는 기능에 대한 빌드 오류를 표시합니다.The Task List window displays build errors for unsupported features when you import a report from another application, such as MicrosoftMicrosoft Access.

보고서 디자이너 디자인 뷰 Report Designer Design View

기본적으로 보고서 서버 프로젝트를 만들면 보고서 디자이너가 디자인 뷰에서 열리고 디자인 화면을 표시합니다.By default, when you create a Report Server project, Report Designer opens in Design view and displays the design surface. 기본적으로 디자인 화면에는 보고서 본문 및 배경이 표시됩니다.By default, the design surface displays the report body and the report background.

배경에 있는 바로 가기 메뉴는 페이지 머리글 및 페이지 바닥글을 추가하는 옵션을 제공하며 보기 메뉴를 통해 눈금자 및 그룹화 창을 표시하는 옵션을 제공합니다.The shortcut menu on the background provides options to add a page header and page footer, and from the View menu, display a ruler and the Grouping pane.

확대/축소 컨트롤을 사용하여 보고서의 배율을 늘리거나 줄일 수 있습니다.Use the zoom control to increase or decrease the magnification of the report.

보고서를 디자인하려면 보고서 항목을 도구 상자에서 끌어 디자인 화면에 놓은 다음 보고서에서 해당 속성을 구성하고 정렬을 변경합니다.To design a report, drag report items from the Toolbox to the design surface, and then configure their properties and alter their arrangement on the report.

보고서 디자이너 미리 보기 Report Designer Preview

미리 보기를 사용하여 보고서를 실행하고 렌더링된 보고서를 보고서 뷰어에서 볼 수 있습니다.Use Preview to run the report and view the rendered report in the report viewer. 미리 보기는 보고서 데이터를 로컬로 캐시합니다.Preview caches report data locally. 구성 속성을 설정하여 브라우저를 통해 디버그 뷰로 보고서를 실행할 수도 있습니다.You can also set configuration properties to run the report in debug view, using a browser.

보고서를 미리 보면 보고서 디자이너는 보고서 데이터 원본에 연결하고, 데이터 집합 쿼리를 실행하고, 로컬 컴퓨터에 데이터를 캐시하고, 보고서를 처리하여 데이터와 레이아웃을 결합하고, 보고서를 렌더링합니다.When you preview a report, Report Designer connects to the report data sources, runs dataset queries, caches the data on the local computer, processes the report to combine data and layout, and renders the report. 보고서를 미리 보기 탭에서 보거나 보고서를 디버그 모드로 표시하는 프로젝트 속성을 설정하여 보고서를 브라우저에서 직접 볼 수 있습니다.You can view the report in on the Preview tab or you can set up project properties to view the report in debug mode and view it directly in a browser.

  • 매개 변수가 있는 보고서 미리 보기Previewing Parameterized Reports. 보고서를 미리 보면 모든 보고서 매개 변수에 유효한 기본값이 있는 경우 해당 보고서가 자동으로 처리됩니다.When you preview a report, the report is processed automatically if all report parameters have valid default values. 하나 이상의 보고서 매개 변수에 유효한 기본값이 없는 경우에는 할당되지 않은 각 매개 변수의 값을 선택한 다음 보고서 도구 모음에서 보고서 보기를 클릭해야 합니다.If one or more report parameters do not have a valid default value, you must choose a value for each unassigned parameter, and then, on the report toolbar, click View Report.

  • 로컬 데이터 캐시 이해 보고서를 미리 보면 보고서 처리기는 현재 매개 변수 기본값을 사용하여 보고서에 있는 데이터 집합에 대한 모든 쿼리를 실행하고 결과를 로컬 데이터 캐시 파일(.rdl.data)로 저장합니다.Understanding the Local Data Cache When you preview a report, the report processor runs all the queries for datasets in the report using the current parameter defaults, and saves the results as a local data cache (.rdl.data) file. 보고서 데이터 집합 쿼리 또는 보고서 매개 변수를 변경하지 않을 경우 이 데이터를 다시 검색하는 오버헤드를 발생시키지 않고 계속해서 보고서를 디자인할 수 있습니다.You can continue to design your report without incurring the overhead of retrieving this data again if you make no changes to either the report dataset queries or the report parameters.

  • 구성 관리자 및 디버깅을 사용하여 보고서 미리 보기Previewing the Report using Configuration Manager and Debug. SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서는 프로젝트 속성으로 보고서 배포 및 디버깅 방법을 정의합니다.In SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), project properties define how you want to deploy and debug your reports. 이러한 속성은 프로젝트에 있는 모든 보고서 및 공유 데이터 원본에 적용됩니다.These properties apply to all reports and shared data sources in the project. 프로젝트 속성을 설정하려면 프로젝트 메뉴에서 속성을 클릭합니다.To set the project properties, from the Project menu, click Properties. 이러한 속성을 사용하여 보고서를 테스트하고 보고서 서버에 게시할 수 있습니다.Use these settings to test your reports and publish them to the report server.

  • 출력 창에서 오류 메시지 모니터링Monitoring the Output Pane for Error Messages. 보고서를 미리 보고 보고서 처리기가 문제를 검색하면 출력 창에 오류 메시지가 기록됩니다.When you preview a report and the report processor detects a problem, it writes error messages to the Output pane.

보고서 디자이너 메뉴 Report Designer Menus

SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT)에서 보고서 디자이너 프로젝트가 활성화되어 있으면 주 메뉴 모음에 다음 도구 모음이 추가됩니다.When a Report Designer project is active in SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT), the following toolbars are added to the main toolbar. 보고서 디자이너 메뉴는 디자인 뷰에 있을 때만 표시됩니다.The Report Designer menus are visible only when in Design view.

서식 메뉴 Format Menu

디자인 화면에서 항목을 선택하면 서식 메뉴에 다음 옵션이 포함됩니다.When you select an item on the design surface, the Format menu contains the following options:

  • 전경색 텍스트 색을 선택합니다.Foreground Color Select a text color. 기본 텍스트 색은 검정입니다.Black is the default text color.

  • 배경색 입력란과 데이터 영역의 배경색을 선택합니다.Background Color Select a background color for your text boxes and data regions.

  • 글꼴 텍스트에 굵게, 기울임꼴 또는 밑줄 서식을 적용합니다.Font Specify whether the text is bold, italic, or underlined.

  • 양쪽 맞춤 텍스트를 오른쪽에 맞출지, 가운데에 맞출지 또는 왼쪽에 맞출지 지정합니다.Justify Specify whether the text is right-aligned, centered, or left-aligned.

  • 맞춤 선택한 개체의 맞춤 방법을 보고서 내의 다른 개체를 기준으로 지정합니다.Align Specify how the selected objects are aligned in relation to one another within the report.

  • 같은 크기로 선택한 개체의 크기를 보고서 크기에 맞춰서 조정합니다.Make Same Size Adjust the size of the selected objects within the report.

  • 가로 간격 조정 보고서 내에서 선택한 개체 간에 가로 간격을 조정합니다.Horizontal Spacing Adjust the horizontal spacing between the selected objects within the report.

  • 세로 간격 조정 보고서 내에서 선택한 개체 간에 세로 간격을 조정합니다.Vertical Spacing Adjust the vertical spacing between the selected objects within the report.

  • 폼 가운데 맞춤 선택한 개체를 보고서 디자이너 창의 가로 및 세로를 기준으로 가운데에 맞춥니다.Center in Form Center the selected object vertically and horizontally in relation to the Report Designer window.

  • 순서 선택한 개체를 배경이나 전경으로 이동합니다.Order Move selected objects into the background or foreground.

보고서 메뉴 Report Menu

보고서 디자인 화면에 포커스가 있으면 보고서 메뉴에 다음 옵션이 포함됩니다.When the report design surface has focus, the Report menu contains the following options:

  • 보고서 속성 보고서 속성 대화 상자를 열려면 선택합니다.Report Properties Select to open the Report Properties dialog box. 이 대화 상자에서 작성자 이름, 눈금 간격 등의 일반 보고서 속성을 할당하고 열 개수 및 페이지 크기와 같은 보고서 레이아웃 속성을 지정할 수 있습니다.In this dialog box, you can assign general report properties, such as author name and grid spacing, and specify properties for the report layout, such as the number of columns and page size. 또한 데이터 출력 요소, 데이터 변환 및 데이터 스키마의 이름과 사용자 지정 코드, 어셈블리와 클래스에 대한 참조를 포함할 수 있습니다.You can also include custom code, references to assemblies and classes, and the names of data output elements, data transforms, and data schemas.

  • 보고서 디자이너의 디자인 탭과 미리 보기 탭 간에 전환합니다.View Switch between the two Report Designer tabs: Design and Preview.

  • 페이지 머리글 보고서에서 페이지 머리글을 추가하거나 삭제합니다.Page Header Add or delete a page header to the report. 페이지 머리글을 삭제하면 페이지 머리글의 모든 항목이 삭제됩니다.When you delete a page header, all items in the page header are deleted.

  • 페이지 바닥글 보고서에서 페이지 바닥글을 추가하거나 삭제합니다.Page Footer Add or delete a page footer to the report. 페이지 바닥글을 삭제하면 페이지 바닥글의 모든 항목이 삭제됩니다.When you delete a page footer, all items in the page footer are deleted.

  • 그룹화 창 그룹화 창을 표시하거나 숨깁니다.Grouping Pane Show or hide the Grouping pane.

보기 메뉴 View Menu

보기 메뉴를 사용하여 보고서 디자이너 창 및 도구 모음을 표시할 수 있습니다.Use the View menu to display Report Designer windows and toolbars

  • 오류 목록 보고서를 게시하거나 미리 볼 때 검색된 오류를 표시하려면 이 옵션을 사용합니다.Error List Use this option to display errors detected when publishing or previewing a report.

  • 출력 보고서를 게시하거나 처리할 때 검색된 오류를 표시하거나 보고서에 텍스트 "#오류"가 표시될 때의 식 오류에 대한 자세한 내용을 보려면 이 옵션을 사용합니다.Output Use this option to display errors detected when publishing or processing a report, or for more information about expression errors when a report displays the text "#Error".

  • 속성 창 디자인 화면에서 현재 선택한 보고서 항목의 속성 값을 표시하려면 이 옵션을 사용합니다.Properties Window Use this option to display the property values for the currently selected report item on the design surface. 중첩된 보고서 항목의 속성을 보려면 보고서 항목을 여러 번 클릭하여 보고서 항목 및 중첩된 해당 멤버의 계층 간을 전환해야 합니다.To see properties for nested report items, you must click a report item multiple times to cycle through the hierarchy for a report item and its nested members. 속성 창의 맨 위에 나타나는 항목의 이름을 확인하여 어떤 보고서 항목의 속성이 표시되는지 봅니다.Check the name of the item that appears at the top of the Properties pane to see which report item's properties are displayed.

  • 도구 상자 도구 상자를 표시하려면 이 옵션을 사용합니다.Toolbox Use this option to display the Toolbox.

  • 다른 창 다음 창을 표시하려면 이 옵션을 사용합니다.Other Windows Use this option to display the following pane:

    • 문서 개요 보고서에 있는 보고서 항목 및 해당 입력란 컬렉션의 계층 뷰를 표시하려면 이 옵션을 사용합니다.Document Outline Use this option to display a hierarchical view of report items and their collections of text boxes in a report.
  • 도구 모음 보고서 테두리보고서 서식을 비롯한 보고서 디자이너 기능을 지원하는 도구 모음을 표시하려면 이 옵션을 사용합니다.Toolbars Use this option to display toolbars that support Report Designer features, including Report Borders and Report Formatting. 자세한 내용은 보고서 디자이너 도구 모음을 참조하십시오.For more information, see Report Designer Toolbars.

  • 보고서 데이터 보고서 매개 변수, 데이터 원본, 데이터 집합, 이미지를 추가할 수 있는 보고서 데이터 창을 표시하려면 이 옵션을 사용합니다.Report Data Use this option to display the Report Data pane, where you can add report parameters, data sources, datasets, images.

프로젝트 메뉴 Project Menu

프로젝트 메뉴를 사용하여 프로젝트에 있는 공유 데이터 원본 및 보고서를 관리할 수 있습니다.Use the Project menu to manage shared data sources and reports in a project. 프로젝트에서 항목을 추가하거나 제거하면 솔루션 탐색기에서 프로젝트 항목의 계층 표시가 자동으로 업데이트됩니다.When you add or remove items from the project, the hierarchical display of project items in Solution Explorer is automatically updated.

  • 새 항목 추가 프로젝트에 새 공유 데이터 원본 또는 새 보고서를 추가합니다.Add New Item Add a new shared data source or new report to the project.

  • 기존 항목 추가 프로젝트에 기존 공유 데이터 원본 또는 기존 보고서를 추가합니다.Add Existing Item Add an existing shared data source or an existing report to the project.

  • 보고서 가져오기 Microsoft Access와 같은 다른 응용 프로그램에서 보고서를 가져옵니다.Import Reports Import reports from another application, for example, Microsoft Access.

  • 프로젝트에서 제외 프로젝트에서 항목을 제외합니다.Exclude from Project Exclude items from the project. 이 옵션을 사용해도 파일 시스템에서 해당 항목이 삭제되지는 않습니다.This option does not delete the item from your file system.

  • 모든 파일 표시 프로젝트에 있는 모든 파일을 표시합니다.Show All Files Show all files in a project.

  • 프로젝트 도구 상자 항목 새로 고침 프로젝트에 새로운 사용자 지정 보고서 항목을 설치할 때 도구 상자 캐시를 새로 고칩니다.Refresh Project Toolbox Items Refresh the toolbox cache when you install new custom report items in your project.

  • 속성 이 프로젝트의 속성 페이지 대화 상자를 엽니다.Properties Open the Property Pages dialog box for this project. 자세한 내용은 프로젝트 속성 페이지 대화 상자를 참조하세요.For more information, see Project Property Pages Dialog Box.

보고서 디자이너 도구 모음 Report Designer Toolbars

보고서 디자이너는 보고서 디자인 시 사용할 수 있는 다음과 같은 특수화된 도구 모음을 제공합니다.Report Designer provides the following specialized toolbars to use when designing reports:

  • 보고서 페이지 머리글 또는 페이지 바닥글을 추가하거나, 보고서 속성을 설정하거나, 눈금자 또는 그룹화 창을 토글하거나, 확대/축소를 사용하여 보고서 뷰를 변경합니다.Report Add a page header or page footer, set report properties, toggle the ruler or Grouping pane, or use zoom to change your view of the report.

  • 보고서 테두리 선택한 모든 보고서 항목의 모든 선택 선 및 테두리에 대한 색, 스타일 및 두께를 설정합니다.Report Borders Set the color, style, and width for all selected lines and the borders of all selected report items.

  • 보고서 서식 선택한 보고서 항목의 서식을 설정합니다.Report Formatting Set the format of selected report items. 입력란의 경우 도구 모음을 사용하여 변경할 수 있는 서식 유형은 글꼴 속성 및 텍스트 색, 배경색, 텍스트 양쪽 맞춤입니다.For text boxes, the following types of formatting can be changed using the toolbar: font properties and text color, background color, and text justification.

  • 레이아웃 데이터 영역 내에 있는 보고서 항목 및 병합 셀의 그리기 순서를 설정합니다.Layout Set the drawing order of report items and merging cells within a data region.

  • 표준 프로젝트를 열거나 저장하고, 창을 표시하고, 디버그 구성을 선택합니다.Standard Open or save projects, display windows, and select the Debug configuration.

    보기 메뉴를 사용하여 이러한 도구 모음을 표시할지 여부를 제어할 수 있습니다.Use the View menu to control whether to display these toolbars. 다른 Visual StudioVisual Studio 도구 모음의 기능이 보고서 디자이너 기능에 적용되지 않을 경우 해당 도구 모음이 비활성화될 수 있습니다.Other Visual StudioVisual Studio toolbars may be disabled if their functionality does not apply to Report Designer features.

원본 제어 Source Control

SQL Server Data ToolsSQL Server Data Tools 는 원본 플러그 인과 통합할 수 있습니다. can integrate with source plug-ins. 옵션 대화 상자의 프로젝트 및 솔루션 페이지를 사용하여 플러그 인 및 구성 속성을 지정할 수 있습니다.Use the Projects and Solutions pages in the Options dialog box to specify the plug-in and configure properties.

사용자 지정 보고서 템플릿 Custom Report Templates

사용자 지정 보고서를 새로운 보고서에 대한 템플릿으로 사용하려면 SQL Server Data ToolsSQL Server Data Tools 가 설치된 컴퓨터의 ReportProject 폴더에 이를 복사하기만 하면 됩니다.To use custom reports as templates for new reports, you simply copy them to the ReportProject folder on the computer on which SQL Server Data ToolsSQL Server Data Tools is installed. 기본적으로 다음 위치에이 폴더는: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject합니다.By default, this folder is in the following location: <drive>:\Program Files\Microsoft Visual Studio 14.0\Common7\IDE\Private Assemblies\ProjectItems\ReportProject. 보고서 프로젝트에 새 항목을 추가하면 사용자 지정 보고서가 템플릿 창에 표시됩니다.When you add a new item to the report project, your custom report appears in the Templates pane.

보고서 마법사에 사용자 지정 스타일을 추가할 수도 있습니다.You can also add custom styles to the report wizard.

SQL Server Data Tools에 대한 명령줄 지원 Command Line Support for SQL Server Data Tools

SQL Server Data ToolsSQL Server Data ToolsMicrosoftMicrosoft Visual StudioVisual Studio 및 기본 devenv.exe 응용 프로그램을 기반으로 합니다. is based on MicrosoftMicrosoft Visual StudioVisual Studio and the underlying devenv.exe application. 이러한 옵션을 사용하려면 먼저 다음 두 항목에 대한 올바른 값을 설정해야 합니다.Before you can use these options, you must set valid values for following two items:

  • OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder 및 TargetServerURL의 프로젝트 속성Project properties for OverwriteDataSources, TargetDataSourceFolder, TargetReportFolder, and TargetServerURL.

  • 디버그 또는 릴리스와 같은 구성 속성 집합 중 최소한 하나 이상At least one set of configuration properties, for example, Debug or Release.

    자세한 내용은 Publishing Data Sources and Reports을 참조하세요.For more information, see Publishing Data Sources and Reports.

    명령줄에서 보고서 서버 프로젝트에 대해 다음 옵션을 지정할 수 있습니다.For a report server project, you can specify the following options from the command line:

  • /deploy 구성 파일에 지정된 프로젝트 속성을 사용해서 보고서를 배포합니다./deploy Deploy reports by using the project properties specified in a configuration file. 예를 들어 다음 명령은 프로젝트 속성에 지정된 릴리스 구성 설정을 사용하여 Reports.sln 솔루션 파일에 지정된 보고서를 배포합니다.For example, the following command deploys the reports specified by the solution file Reports.sln by using the Release configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /deploy "Release"  
    
  • /build 솔루션 파일을 빌드만 하고 배포하지는 않습니다./build Build the solution file, but do not deploy it. 예를 들어 다음 명령은 프로젝트 속성에 지정된 디버그 구성 설정을 사용하여 Reports.sln 솔루션 파일에 지정된 보고서를 빌드합니다.For example, the following command builds the reports specified by the solution file Reports.sln by using the Debug configuration settings that are specified in the project properties:

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug"  
    
  • /out 솔루션을 빌드하여 생성된 출력을 지정된 파일로 리디렉션합니다./out Redirect the output generated by building a solution to the specified file. 예를 들어 다음 명령은 이전 예의 빌드 출력을 mybuildlog.txt라는 파일로 리디렉션합니다.For example, the following command redirects the output from the build in the previous example to a file named mybuildlog.txt.

    devenv.exe "C:\Users\MyUser\Documents\Visual Studio 2015\Projects\Reports\Reports.sln" /build "Debug" /out mybuildlog.txt  
    

Reporting Services의 바로 가기 키 Keyboard Shortcuts in Reporting Services

바로 가기 키를 사용하여 다음을 수행할 수 있습니다.Use keyboard shortcuts to:

  • SQL Server Data ToolsSQL Server Data Tools의 창 및 모드를 제어합니다.Control windows and modes in SQL Server Data ToolsSQL Server Data Tools:

    DescriptionDescription 키 조합Key Combination
    선택한 프로젝트 빌드Build the selected project Ctrl+Shift+BCTRL+SHIFT+B
    속성 창 표시Display Properties window F4F4
    데이터 창 표시Display Data window Ctrl+Alt+DCTRL+Alt+D
    디버깅 시작Start debugging F5F5
    열려 있는 특정 창에서 다음 창으로 이동Move from one open window to the next F6F6
  • 보고서 디자인 화면에서 항목을 제어합니다.Control items on the report design surface:

    DescriptionDescription 키 조합Key Combination
    특정 보고서 항목에서 다음 보고서 항목으로 포커스 이동Move focus from one report item to the next report item TabTAB
    선택한 보고서 항목 이동Move selected report item 화살표 키Arrow keys
    선택한 보고서 항목 조금 이동Nudge selected report item Ctrl+화살표 키CTRL+Arrow keys
    선택한 보고서 항목 크기 확대 또는 축소Increase or decrease the size of the selected report item Ctrl+Shift+화살표 키CTRL+SHIFT+Arrow keys
    입력란에서 표시되는 텍스트의 시작 부분으로 커서 이동In a text box, move cursor to the beginning of the display text that is visible Ctrl+HomeCTRL+HOME
    입력란에서 표시되는 텍스트의 끝 부분으로 커서 이동In a text box, move cursor to the end of the display text that is visible Ctrl+EndCTRL+END
    입력란에서 표시되는 텍스트의 현재 커서 위치에서 시작 부분에 이르는 텍스트 선택In a text box, select text from the current cursor position to the beginning of the display text that is visible Shift+HomeSHIFT+HOME
    입력란에서 표시되는 텍스트의 현재 커서 위치에서 끝 부분에 이르는 텍스트 선택In a text box, select text from the current cursor position to the end of the display text that is visible Shift+EndSHIFT+END
    입력란에서 식의 현재 커서 위치에서 시작 부분에 이르는 텍스트 선택In a text box, select text from the current cursor position to the beginning of the expression Ctrl+Shift+HomeCTRL+SHIFT+HOME
    입력란에서 식의 현재 커서 위치에서 끝 부분에 이르는 텍스트 선택In a text box, select text from the current cursor position to the end of the expression Ctrl+Shift+EndCTRL+SHIFT+END
    선택한 보고서 항목에 대한 바로 가기 메뉴를 엽니다.Open the shortcut menu for the selected report item Shift+F10+속성 키(최신 키보드에 있음)SHIFT+F10+Property Key on newer keyboards

다음 단계Next steps

SQL Server Data Tools 다운로드 솔루션 탐색기 Download SQL Server Data Tools Solution Explorer
Reporting Services 보고서 Reporting Services Reports
Report Definition Language Report Definition Language
SQL Server Data Tools의 배포 및 버전 지원Deployment and Version Support in SQL Server Data Tools

추가 질문이 있으신가요?More questions? Reporting Services 포럼에서 질문Try asking the Reporting Services forum