자습서: 드릴스루 보고서 및 주 보고서 만들기(보고서 작성기)Tutorial: Creating Drillthrough and Main Reports (Report Builder)

이 자습서에서는 두 종류의 페이지가 매겨진 Reporting ServicesReporting Services 보고서인 드릴스루 보고서와 주 보고서를 만드는 방법을 알아봅니다.This tutorial teaches you how to create two kinds of Reporting ServicesReporting Services paginated reports: a drillthrough report and a main report. 이러한 보고서에서 사용되는 샘플 판매 데이터는 Analysis Services 큐브에서 검색됩니다.The sample sales data used in these reports is retrieved from an Analysis Services cube.

다음 그림에서는 만들려는 보고서 및 주 보고서의 필드 값인 Games and Toys가 드릴스루 보고서의 제목에 표시되는 방식을 보여 줍니다.The following illustration shows the reports you will create, and shows how the field value, Games and Toys, in the main report displays in the drillthrough report’s title. 드릴스루 보고서의 데이터는 Games and Toys 제품 범주에 속합니다.The data in the drillthrough report pertains to the Games and Toys product category.

rs_DrillthroughCubeTutorialrs_DrillthroughCubeTutorial

이 자습서에 소요되는 예상 시간: 30분Estimated time to complete this tutorial: 30 minutes.

요구 사항Requirements

이 자습서를 실행하려면 드릴스루 보고서 및 주 보고서 둘 다에서 Contoso Sales 큐브에 액세스할 수 있어야 합니다.This tutorial requires access to the Contoso Sales cube for both the drillthrough and the main reports. 이 데이터 집합은 ContosoDW 데이터 웨어하우스와 Contoso_Retail OLAP(온라인 분석 처리) 데이터베이스로 구성되어 있습니다.This dataset comprises the ContosoDW data warehouse and the Contoso_Retail online analytical processing (OLAP) database. 이 자습서에서 만들 보고서는 Contoso Sales 큐브에서 보고서 데이터를 검색합니다.The reports you will create in this tutorial retrieve report data from the Contoso Sales cube. Contoso_Retail OLAP 데이터베이스는 Microsoft 다운로드 센터에서 다운로드할 수 있습니다.The Contoso_Retail OLAP database can be downloaded from Microsoft Download Center. ContosoBIdemoABF.exe 파일만 다운로드하면 됩니다.You need only download the file ContosoBIdemoABF.exe. 이 파일에 OLAP 데이터베이스가 포함되어 있습니다.It contains the OLAP database.

다른 파일인 ContosoBIdemoBAK.exe는 ContosoDW 데이터 웨어하우스를 위한 것으로, 이 자습서에서는 사용되지 않습니다.The other file, ContosoBIdemoBAK.exe, is for the ContosoDW data warehouse, which is not used in this tutorial.

ContosoRetail.abf 백업 파일을 추출하여 Contoso_Retail OLAP 데이터베이스로 복원하기 위한 지침은 이 웹 사이트에 포함되어 있습니다.The Web site includes instructions extracting and restoring the ContosoRetail.abf backup file to the Contoso_Retail OLAP database.

사용자는 OLAP 데이터베이스를 설치할 Analysis ServicesAnalysis Services 인스턴스에 액세스할 수 있어야 합니다.You must have access to an instance of Analysis ServicesAnalysis Services on which to install the OLAP database.

일반적인 요구 사항에 대한 자세한 내용은 자습서의 필수 조건(보고서 작성기)을 참조하세요.For more about general requirements, see Prerequisites for Tutorials (Report Builder).

1. 테이블 또는 행렬 마법사에서 드릴스루 보고서 만들기1. Create a Drillthrough Report from the Table or Matrix Wizard

시작 대화 상자에서 테이블 또는 행렬 마법사를 사용하여 행렬 보고서를 만듭니다.From the Getting Started dialog box, create a matrix report by using the Table or Matrix Wizard. 마법사에서는 두 가지 모드인 보고서 디자인 모드와 공유 데이터 집합 디자인 모드를 사용할 수 있습니다.There are two modes available in the wizard: report design and shared dataset design. 이 자습서에서는 보고서 디자인 모드를 사용합니다.In this tutorial, you will use the report design mode.

새 보고서를 만들려면To create a new report

  1. 컴퓨터,웹 포털 또는 SharePoint 통합 모드에서 보고서 작성기를 시작 Reporting ServicesReporting Services 합니다.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    새 보고서 또는 데이터 집합 대화 상자가 열립니다.The New Report or Dataset dialog box opens.

    새 보고서 또는 데이터 집합 대화 상자가 표시되지 않는 경우 파일 메뉴 > 새로 만들기를 클릭합니다.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. 왼쪽 창에 새 보고서 가 선택되어 있는지 확인합니다.In the left pane, verify that New Report is selected.

  3. 오른쪽 창에서 테이블 또는 행렬 마법사 가 선택되어 있는지 확인합니다.In the right pane, verify that Table or Matrix Wizard is selected.

1a.1a. 데이터 연결 지정Specify a Data Connection

데이터 연결은 Analysis Services 큐브 또는 SQL ServerSQL Server 데이터베이스와 같은 외부 데이터 원본에 연결하는 데 필요한 정보를 포함합니다.A data connection contains the information necessary to connect to an external data source such as an Analysis Services cube or a SQL ServerSQL Server database. 데이터 연결을 지정하기 위해 보고서 서버의 공유 데이터 원본을 사용하거나 이 보고서에만 사용되는 포함된 데이터 원본을 만들 수 있습니다.To specify a data connection, you can use a shared data source from the report server or create an embedded data source that is used only in this report. 이 자습서에서는 포함된 데이터 원본을 사용합니다.In this tutorial, you will use an embedded data source. 공유 데이터 원본을 사용 하는 방법에 대 한 자세한 참조 데이터 연결 (에 대 한 대체 방법 보고서 작성기 ) .To learn more about using a shared data source, see Alternative Ways to Get a Data Connection (Report Builder).

포함된 데이터 원본을 만들려면To create an embedded data source

  1. 데이터 집합 선택 페이지에서 데이터 집합 만들기를 선택하고 다음을 클릭합니다.On the Choose a dataset page, select Create a dataset, and then click Next. 데이터 원본에 대한 연결 선택 페이지가 열립니다.The Choose a connection to a data source page opens.

  2. 새로 만들기를 클릭합니다.Click New. 데이터 원본 속성 대화 상자가 열립니다.The Data Source Properties dialog box opens.

  3. 이름에 데이터 원본 이름으로 Online and Reseller Sales Detail 을 입력합니다.In Name, type Online and Reseller Sales Detail as the name for the data source.

  4. 연결 형식 선택에서 Microsoft SQL Server Analysis Services를 선택한 다음 빌드를 클릭합니다.In Select a connection type, select Microsoft SQL Server Analysis Services, and then click Build.

  5. 데이터 원본에서 데이터 원본이 Microsoft SQL Server Analysis Services(AdomdClient)인지 확인합니다.In Data source, verify that the data source is Microsoft SQL Server Analysis Services (AdomdClient).

  6. 서버 이름에 Analysis Services 인스턴스가 설치된 서버의 이름을 입력합니다.In Server name, type the name of a server where an instance of Analysis Services is installed.

  7. 데이터베이스 이름 선택 또는 입력에서 Contoso 큐브를 선택합니다.In Select or enter a database name, select the Contoso cube.

  8. 확인을 클릭합니다.Click OK.

  9. 연결 문자열 에 다음 구문이 포함되어 있는지 확인합니다.Verify that Connection string contains the following syntax:

    Data Source=<servername>; Initial Catalog = Contoso  
    

    <servername> 은 Analysis Services가 설치된 SQL ServerSQL Server 인스턴스의 이름입니다.The <servername> is the name of an instance of SQL ServerSQL Server with Analysis Services installed.

  10. 자격 증명 유형을 클릭합니다.Click Credentials type.

    참고

    데이터 원본에서 사용 권한이 구성된 방법에 따라 기본 인증 옵션을 변경해야 할 수 있습니다.Depending on how permissions are configured on the data source, you might need to change the default authentication options. 자세한 내용은 보안(보고서 작성기#41;을 참조하세요.For more information, see Security (Report Builder).

  11. 확인을 클릭합니다.Click OK.

    데이터 원본에 대한 연결 선택 페이지가 나타납니다.The Choose a connection to a data source page appears.

  12. 데이터 원본에 연결할 수 있는지 확인하려면 연결 테스트를 클릭합니다.To verify that you can connect to the data source, click Test Connection.

    연결되었습니다. 라는 메시지가 나타납니다.The message Connection created successfully appears.

  13. 확인을 클릭합니다.Click OK.

  14. 다음을 클릭합니다.Click Next.

1b.1b. MDX 쿼리 만들기Create an MDX Query

보고서에서는 미리 정의된 쿼리가 포함된 공유 데이터 집합을 사용하거나 해당 보고서에만 사용할 포함된 데이터 집합을 만들 수 있습니다.In a report, you can use a shared dataset that has a predefined query, or you can create an embedded dataset for use only in your report. 이 자습서에서는 포함된 데이터 집합을 만듭니다.In this tutorial, you will create an embedded dataset.

쿼리 필터를 만들려면To create query filters

  1. 쿼리 디자인 페이지의 메타데이터 창에서 (…)단추를 클릭합니다.On the Design a query page, in the Metadata pane, click the button (…).

  2. 큐브 선택 대화 상자에서 Sales를 클릭한 다음 확인을 클릭합니다.In the Cube Selection dialog box, click Sales, and then click OK.

    MDX 쿼리를 수동으로 작성 하지 않을 경우 클릭는 디자인 모드로 전환 아이콘, 쿼리 디자이너를 쿼리 모드로 토글하 완료 된 MDX 쿼리 디자이너를 붙여 넣고의 6 단계를 진행할 데이터 집합을 만들려면합니다.If you do not want to build the MDX query manually, click the Switch to Design mode icon, toggle the query designer to Query mode, paste the completed MDX to the query designer, and then proceed to step 6 in To create the dataset.

    SELECT NON EMPTY { [Measures].[Sales Amount], [Measures].[Sales Return Amount] } ON COLUMNS, NON EMPTY { ([Channel].[Channel Name].[Channel Name].ALLMEMBERS * [Product].[Product Category Name].[Product Category Name].ALLMEMBERS * [Product].[Product Subcategory Name].[Product Subcategory Name].ALLMEMBERS ) } DIMENSION PROPERTIES MEMBER_CAPTION, MEMBER_UNIQUE_NAME ON ROWS FROM ( SELECT ( { [Date].[Calendar Year].&[2009] } ) ON COLUMNS FROM ( SELECT ( { [Sales Territory].[Sales Territory Group].&[North America] } ) ON COLUMNS FROM ( SELECT ( STRTOSET(@ProductProductCategoryName, CONSTRAINED) ) ON COLUMNS FROM ( SELECT ( { [Channel].[Channel Name].&[2], [Channel].[Channel Name].&[4] } ) ON COLUMNS FROM [Sales])))) WHERE ( [Sales Territory].[Sales Territory Group].&[North America], [Date].[Calendar Year].&[2009] ) CELL PROPERTIES VALUE, BACK_COLOR, FORE_COLOR, FORMATTED_VALUE, FORMAT_STRING, FONT_NAME, FONT_SIZE, FONT_FLAGS  
    
  3. 측정값 그룹 창에서 Channel을 확장한 다음 Channel Name을 필터 창의 계층 열로 끕니다.In the Measure Group pane, expand Channel, and then drag Channel Name to the Hierarchy column in the filter pane.

    Channel이라는 차원 이름이 자동으로 차원 열에 추가됩니다.The dimension name, Channel, is automatically added to the Dimension column. 차원 또는 연산자 열을 변경하지 마세요.Do not change the Dimension or Operator columns.

  4. 필터 식 목록을 열려면 필터 식 열의 아래쪽 화살표를 클릭합니다.To open the Filter Expression list, click the down arrow in the Filter Expression column.

  5. 필터 식 목록에서 All Channel을 확장하고, Online, Reseller를 차례로 클릭한 다음 확인을 클릭합니다.In the filter expression list, expand All Channel, click Online, click Reseller, and then click OK.

    이제 쿼리에는 온라인과 대리점 채널만 포함할 필터가 제공됩니다.The query now includes a filter to include only these channels: Online and Reseller.

  6. Sales Territory 차원을 확장한 다음 Sales Territory Group을 Channel Name 아래에 있는 계층열로 끕니다.Expand the Sales Territory dimension, and then drag Sales Territory Group to the Hierarchy column (below Channel Name).

  7. 필터 식 목록을 열고 All Sales Territory를 확장한 다음 North America, 확인을 차례로 클릭합니다.Open the Filter Expression list, expand All Sales Territory, click North America, and then click OK.

    이제 쿼리에는 북미의 판매만 포함할 필터가 제공됩니다.The query now has a filter to include only sales in North America.

  8. 측정값 그룹 창에서 Date를 확장한 다음 Calendar Year를 필터 창의 계층 열로 끕니다.In the Measure Group pane, expand Date, and then drag Calendar Year to the Hierarchy column in the filter pane.

    Date라는 차원 이름이 자동으로 차원 열에 추가됩니다.The dimension name, Date, is automatically added to the Dimension column. 차원 또는 연산자 열을 변경하지 마세요.Do not change the Dimension or Operator columns.

  9. 필터 식 목록을 열려면 필터 식 열의 아래쪽 화살표를 클릭합니다.To open the Filter Expression list, click the down arrow in the Filter Expression column.

  10. 필터 식 목록에서 All Date를 확장하고, Year 2009를 클릭한 다음 확인을 클릭합니다.In the filter expression list, expand All Date, click Year 2009, and then click OK.

    이제 쿼리에는 2009년만 포함할 필터가 제공됩니다.The query now includes a filter to include only the calendar year 2009.

매개 변수를 만들려면To create the parameter

  1. Product 차원을 확장한 다음 Product Category Name 멤버를 Calendar Year 아래의 계층열로 끕니다.Expand the Product dimension, and then drag the Product Category Name member to the Hierarchy column below Calendar Year.

  2. 필터 식 목록에서 All Products를 클릭한 다음 확인을 클릭합니다.Open the Filter Expression list, click All Products, and then click OK.

  3. 매개 변수 확인란을 클릭합니다.Click the Parameter checkbox. 쿼리에는 이제 ProductProductCategoryName 매개 변수가 제공됩니다.The query now includes the parameter ProductProductCategoryName.

    참고

    매개 변수에는 제품 범주의 이름이 포함됩니다.The parameter contains the names of product categories. 주 보고서에서 제품 범주 이름을 클릭하면 해당 이름이 이 매개 변수를 사용하여 드릴스루 보고서로 전달됩니다.When you click a product category name in the main report, its name is passed to the drillthrough report by using this parameter.

데이터 집합을 만들려면To create the dataset

  1. Channel 차원에서 Channel Name을 데이터 창으로 끕니다.From the Channel dimension, drag Channel Name to the data pane.

  2. Product 차원에서 Product Category Name을 데이터 창으로 끌어 Channel Name의 오른쪽에 놓습니다.From the Product dimension, drag Product Category Name to the data pane, and then place it to the right of Channel Name.

  3. Product 차원에서 Product Subcategory Name을 데이터 창으로 끌어 Product Category Name의 오른쪽에 놓습니다.From the Product dimension, drag Product Subcategory Name to the data pane, and then place it to the right of Product Category Name.

  4. 메타데이터 창에서 측정값을 확장한 다음 Sales를 확장합니다.In the Metadata pane, expand Measure, and then expand Sales.

  5. Sales Amount 측정값을 데이터 창으로 끌어 Product Subcategory Name의 오른쪽에 놓습니다.Drag the Sales Amount measure to the data pane, and then place it to the right of Product Subcategory Name.

  6. 쿼리 디자이너 도구 모음에서 실행(!)을 클릭합니다.On the query designer toolbar, click Run (!).

  7. 다음을 클릭합니다.Click Next.

1c.1c. 데이터를 그룹으로 구성Organize Data into Groups

데이터를 그룹화할 필드를 선택할 때 세부 데이터와 집계 데이터가 표시되는 행과 열이 포함된 행렬을 디자인합니다.When you select the fields on which to group the data, you design a matrix with rows and columns that displays detail and aggregated data.

데이터를 그룹으로 구성하려면To organize data into groups

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 필드 정렬 페이지에서 Product_Subcategory_Name을 행 그룹으로 끌어옵니다.On the Arrange fields page, drag Product_Subcategory_Name to Row groups.

    참고

    이름의 공백이 밑줄()로 바뀝니다.The spaces in the names are replaced with underscores (). 예를 들어 Product Category Name이 Product_Category_Name이 됩니다.For example Product Category Name is Product_Category_Name.

  3. Channel_Name을 열 그룹으로 끌어옵니다.Drag Channel_Name to Column groups.

  4. Sales_Amount를 으로 끌어옵니다.Drag Sales_Amount to Values.

    Sales_Amount는 숫자 필드에 대한 기본 집계 함수인 Sum 함수를 통해 자동으로 집계됩니다.Sales_Amount is automatically aggregated by the Sum function, the default aggregate for numeric fields. 값이 [Sum(Sales_Amount)]입니다.The value is [Sum(Sales_Amount)].

    사용 가능한 다른 집계 함수를 보려면 집계 함수를 변경하지 않고 드롭다운 목록을 엽니다.To view the other aggregate functions available, open the drop-down list (do not change the aggregate function).

  5. Sales_Return_Amount를 으로 끌어 [Sum(Sales_Amount)]아래에 놓습니다.Drag Sales_Return_Amount to Values, and then place it below [Sum(Sales_Amount)].

    4 ~ 5단계에서는 행렬에 표시할 데이터를 지정했습니다.Steps 4 and 5 specify the data to display in the matrix.

  6. 다음을 클릭합니다.Click Next.

1d.1d. 부분합 및 합계 추가Add Subtotals and Totals

그룹을 만든 후 필드에 대한 집계 값을 표시할 행을 추가하고 행 서식을 지정할 수 있습니다.After you create groups, you can add and format rows where the aggregate values for the fields will display. 또한 모든 데이터를 표시할지 또는 사용자가 그룹화된 데이터를 대화형으로 확장하거나 축소할 수 있도록 할지 여부를 선택할 수 있습니다.You can also choose whether to show all the data or to let a user expand and collapse grouped data interactively.

부분합 및 합계를 추가하려면To add subtotals and totals

  1. 레이아웃 선택 페이지의 옵션에서 부분합 및 총합계 표시 가 선택되어 있는지 확인합니다.On the Choose the layout page, under Options, verify that Show subtotals and grand totals is selected.

    마법사 미리 보기 창에 4개의 행이 있는 행렬이 표시됩니다.The wizard Preview pane displays a matrix with four rows.

  2. 다음을 클릭합니다.Click Next.

  3. 마침을 클릭합니다.Click Finish.

    디자인 화면에 테이블이 추가됩니다.The table is added to the design surface.

  4. 보고서를 미리 보려면 실행(!)을 클릭합니다.To preview the report, click Run (!).

2. 데이터 형식을 통화로 지정2. Format Data as Currency

드릴스루 보고서의 판매량 필드에 통화 서식을 적용합니다.Apply currency formatting to the sales amount fields in the drillthrough report.

데이터 서식을 통화로 지정하려면To format data as currency

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 한 번에 여러 셀을 선택하고 서식 지정하려면 Ctrl 키를 누른 다음 숫자 판매 데이터가 들어 있는 셀을 선택합니다.To select and format multiple cells at one time, press the Ctrl key, and then select the cells that contain the numeric sales data.

  3. 탭의 숫자 그룹에서 통화를 클릭합니다.On the Home tab, in the Number group, click Currency.

3. 스파크라인에 판매 값을 표시하는 열 추가3. Add Columns to Show Sales Values in Sparklines

보고서는 판매량 및 판매 수익을 통화 값으로 표시하는 대신 스파크라인에서 값을 표시합니다.Instead of showing sales and sales returns as currency values, the report shows the values in a sparkline.

열에 스파크라인을 추가하려면To add sparklines to columns

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 행렬의 Total 그룹에서 Sales Amount 열을 마우스 오른쪽 단추로 클릭하고 열 삽입을 클릭한 다음 오른쪽을 클릭합니다.In the Total group of the matrix, right-click the Sales Amount column, click Insert Column, and then click Right.

    Sales Amount의 오른쪽에 빈 열이 추가됩니다.An empty column is added to the right of Sales Amount.

  3. 리본에서 사각형을 클릭한 다음 [Product_Subcategory] 행 그룹의 [Sum(Sales_Amount)] 셀 오른쪽에 있는 빈 셀을 클릭합니다.On the ribbon, click Rectangle, and then click the empty cell to the right of the [Sum(Sales_Amount)] cell in the [Product_Subcategory] row group.

  4. 리본에서 스파크라인 아이콘을 클릭한 다음 사각형이 추가된 셀을 클릭합니다.On the ribbon, click the Sparkline icon, and then click the cell where the rectangle was added.

  5. 스파크라인 유형 선택 대화 상자에서 유형이 선택되어 있는지 확인합니다.In the Select Sparkline Type dialog box, verify that Column type is selected.

  6. 확인을 클릭합니다.Click OK.

  7. 스파크라인을 마우스 오른쪽 단추로 클릭합니다.Right-click the sparkline.

  8. 차트 데이터 창에서 필드 추가 아이콘을 클릭한 다음 Sales_Amount를 클릭합니다.In the Chart Data pane, click the Add field icon, and then click Sales_Amount.

  9. Sales_Return_Amount 열을 마우스 오른쪽 단추로 클릭한 다음 이 열의 오른쪽에 열을 추가합니다.Right-click the Sales_Return_Amount column, and then add a column to the right of it.

  10. 2 ~ 6단계를 반복합니다.Repeat steps 2 through 6.

  11. 스파크라인을 마우스 오른쪽 단추로 클릭합니다.Right-click the sparkline.

  12. 차트 데이터 창에서 필드 추가 아이콘을 클릭한 다음 Sales_Return_Amount를 클릭합니다.In the Chart Data pane, click the Add field icon, and then click Sales_Return_Amount.

  13. 보고서를 미리 보려면 실행을 클릭합니다.To preview the report, click Run.

4. 제품 범주 이름의 보고서 제목 추가4. Add Report Title with Product Category Name

보고서 제목은 보고서 맨 위에 나타납니다.A report title appears at the top of the report. 보고서 제목을 보고서 머리글에 배치하거나, 보고서 머리글이 사용되지 않을 경우 보고서 본문의 맨 위에 있는 입력란에 배치할 수 있습니다.You can place the report title in a report header or, if the report does not use one, in a text box at the top of the report body. 이 자습서에서는 보고서 본문의 맨 위에 자동으로 표시되는 입력란을 사용합니다.In this tutorial, you will use the text box that is automatically placed at the top of the report body.

보고서 제목을 추가하려면To add a report title

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 디자인 화면에서 제목을 추가하려면 클릭하십시오.를 클릭합니다.On the design surface, click Click to add title.

  3. Sales and Returns for Category:를 입력합니다.Type Sales and Returns for Category:.

  4. 마우스 오른쪽 단추를 클릭한 다음 자리 표시자 만들기를 클릭합니다.Right-click, and then click Create Placeholder.

  5. 목록의 오른쪽에 있는 (fx) 단추를 클릭합니다.Click the (fx) button to the right of the Value list.

  6. 대화 상자의 범주 창에서 데이터 집합을 클릭한 다음 목록에서 First(Product_Category_Name)를 두 번 클릭합니다.In the Expression dialog box, in the Category pane, click Dataset, and then in the Values list double-click First(Product_Category_Name).

    입력란에 다음 식이 포함됩니다.The Expression box contains the following expression:

    =First(Fields!Product_Category_Name.Value, "DataSet1")  
    
  7. 보고서를 미리 보려면 실행을 클릭합니다.To preview the report, click Run.

보고서 제목에 첫 번째 제품 범주의 이름이 포함됩니다.The report title includes the name of the first product category. 나중에 이 보고서를 드릴스루 보고서로 실행하면 제품 범주 이름이 주 보고서에서 클릭된 제품 범주의 이름을 반영하도록 동적으로 변경됩니다.Later, after you run this report as a drillthrough report, the product category name will dynamically change to reflect the name of the product category that was clicked in the main report.

5. 매개 변수 속성 업데이트5. Update Parameter Properties

기본적으로 매개 변수가 표시되는데 이는 이 보고서의 경우 적합하지 않습니다.By default parameters are visible, which is not appropriate for this report. 따라서 드릴스루 보고서에 대한 매개 변수 속성을 업데이트할 것입니다.You will update the parameter properties for the drillthrough report.

매개 변수를 숨기려면To hide a parameter

  1. 보고서 데이터 창에서 매개 변수를 확장합니다.In the Report Data pane, expand Parameters.

  2. 마우스 오른쪽 단추로 클릭 @ProductProductCategoryName, 클릭 하 고 매개 변수 속성합니다.Right-click @ProductProductCategoryName, and then click Parameter Properties.

    참고

    이름 옆에 있는 @ 문자는 이것이 매개 변수임을 나타냅니다.The @ character next to the name indicates that this is a parameter.

  3. 일반 탭에서 숨김을 클릭합니다.On the General tab, click Hidden.

  4. 프롬프트 상자에 Product Category를 입력합니다.In the Prompt box, type Product Category.

    참고

    매개 변수가 숨겨져 있기 때문이 이 프롬프트는 사용되지 않습니다.Because the parameter is hidden, this prompt is never used.

  5. 필요에 따라 사용 가능한 값기본값 을 클릭하고 해당 옵션을 검토합니다.Optionally, click Available Values and Default Values and review their options. 이러한 탭에 대한 어떤 옵션도 변경하지 마십시오.Do not change any options on these tabs.

  6. 확인을 클릭합니다.Click OK.

6. SharePoint 라이브러리에 보고서 저장6. Save the Report to a SharePoint Library

보고서를 SharePoint 라이브러리, 보고서 서버 또는 컴퓨터에 저장할 수 있습니다.You can save the report to a SharePoint library, report server, or your computer. 보고서를 컴퓨터에 저장하면 보고서 파트 및 하위 보고서와 같은 여러 Reporting ServicesReporting Services 기능을 사용할 수 없습니다.If you save the report to your computer, a number of Reporting ServicesReporting Services features such as report parts and subreports are not available. 이 자습서에서는 이 보고서를 SharePoint 라이브러리에 저장합니다.In this tutorial, you will save the report to a SharePoint library.

보고서를 저장하려면To save the report

  1. 보고서 작성기 단추에서 저장을 클릭합니다.From the Report Builder button, click Save. 보고서로 저장 대화 상자가 열립니다.The Save As Report dialog box opens.

    참고

    보고서를 다시 저장하는 경우 보고서가 이전 위치에 자동으로 다시 저장됩니다.If you are resaving a report, it is automatically resaved to its previous location. 위치를 변경하려면 다른 이름으로 저장 옵션을 사용합니다.To change the location, use the Save As option.

  2. 최근에 사용한 보고서 서버와 SharePoint 사이트의 목록을 표시하려면 최근에 사용한 사이트 및 서버를 클릭합니다.To show a list of recently used report servers and SharePoint sites, click Recent Sites and Servers.

  3. 보고서를 저장할 수 있는 권한을 가진 SharePoint 사이트의 이름을 선택하거나 입력합니다.Select or type the name of the SharePoint site where you have permission to save reports.

    SharePoint 라이브러리의 URL에 다음 구문이 있습니다.The URL of the SharePoint library has the following syntax:

    Http://<ServerName>/<Sites>/  
    
  4. 저장을 클릭합니다.Click Save.

    최근에 사용한 사이트 및 서버 는 SharePoint 사이트의 라이브러리를 나열합니다.Recent Sites and Servers lists the libraries on the SharePoint site.

  5. 보고서를 저장할 라이브러리로 이동합니다.Navigate to the library where you will save the report.

  6. 이름 상자에서 기본 이름을 ResellerVSOnlineDrillthrough로 바꿉니다.In the Name box, replace the default name with ResellerVSOnlineDrillthrough.

    참고

    주 보고서를 동일한 위치에 저장합니다.You will save the main report to the same location. 주 보고서 및 드릴스루 보고서를 다른 사이트 또는 라이브러리에 저장할 경우 주 보고서에서 보고서로 이동 동작의 경로를 업데이트해야 합니다.If you want to save the main and drillthrough reports to different sites or libraries, you must update the path of the Go to report action in the main report.

  7. 저장을 클릭합니다.Click Save.

1. 테이블 또는 행렬 마법사에서 주 보고서 만들기1. Create the Main Report from the Table or Matrix Wizard

시작 대화 상자에서 테이블 또는 행렬 마법사를 사용하여 행렬 보고서를 만듭니다.From the Getting Started dialog box, create a matrix report by using the Table or Matrix Wizard.

주 보고서를 만들려면To create the main report

  1. 컴퓨터,웹 포털 또는 SharePoint 통합 모드에서 보고서 작성기를 시작 Reporting ServicesReporting Services 합니다.Start Report Builder either from your computer, the Reporting ServicesReporting Services web portal, or SharePoint integrated mode.

    새 보고서 또는 데이터 집합 대화 상자가 열립니다.The New Report or Dataset dialog box opens.

    새 보고서 또는 데이터 집합 대화 상자가 표시되지 않는 경우 파일 메뉴 > 새로 만들기를 클릭합니다.If you don't see the New Report or Dataset dialog box, on the File menu > New.

  2. 시작 대화 상자에서 새 보고서 가 선택되어 있는지 확인한 다음 테이블 또는 행렬 마법사를 클릭합니다.In the Getting Started dialog box, verify that New Report is selected, and then click Table or Matrix Wizard.

1a.1a. 데이터 연결 지정Specify a Data Connection

포함된 데이터 원본을 주 보고서에 추가합니다.You will add an embedded data source to the main report.

포함된 데이터 원본을 만들려면To create an embedded data source

  1. 데이터 집합 선택 페이지에서 데이터 집합 만들기를 선택하고 다음을 클릭합니다.On the Choose a dataset page, select Create a dataset, and then click Next.

  2. 새로 만들기를 클릭합니다.Click New.

  3. 이름에 데이터 원본 이름으로 Online and Reseller Sales Main 을 입력합니다.In Name, type Online and Reseller Sales Main as the name for the data source.

  4. 연결 형식 선택에서 Microsoft SQL Server Analysis Services를 선택한 다음 빌드를 클릭합니다.In Select a connection type, select Microsoft SQL Server Analysis Services, and then click Build.

  5. 데이터 원본에서 데이터 원본이 Microsoft SQL Server Analysis Services(AdomdClient)인지 확인합니다.In Data source, verify that the data source is Microsoft SQL Server Analysis Services (AdomdClient).

  6. 서버 이름MicrosoftMicrosoft Analysis ServicesAnalysis Services 인스턴스가 설치된 서버의 이름을 입력합니다.In Server name, type the name of a server where an instance of MicrosoftMicrosoft Analysis ServicesAnalysis Services is installed.

  7. 데이터베이스 이름 선택 또는 입력에서 Contoso 큐브를 선택합니다.In Select or enter a database name, select the Contoso cube.

  8. 확인을 클릭합니다.Click OK.

  9. 연결 문자열 에 다음 구문이 포함되어 있는지 확인합니다.Verify that the Connection string contains the following syntax:

    Data Source=<servername>; Initial Catalog = Contoso  
    
  10. 자격 증명 유형을 클릭합니다.Click Credentials type.

    데이터 원본에서 사용 권한이 구성된 방법에 따라 기본 인증을 변경해야 할 수 있습니다.Depending on how permissions are configured on the data source, you might need to change the default authentication.

  11. 확인을 클릭합니다.Click OK.

  12. 데이터 원본에 연결할 수 있는지 확인하려면 연결 테스트를 클릭합니다.To verify that you can connect to the data source, click Test Connection.

  13. 확인을 클릭합니다.Click OK.

  14. 다음을 클릭합니다.Click Next.

1b.1b. MDX 쿼리 만들기Create an MDX Query

다음으로, 포함된 데이터 집합을 만듭니다.Next, create an embedded dataset. 이렇게 하려면 쿼리 디자이너를 사용하여 필터, 매개 변수 및 계산 멤버는 물론 데이터 집합 자체를 만듭니다.To do so, you will use the query designer to create filters, parameters, and calculated members as well as the dataset itself.

쿼리 필터를 만들려면To create query filters

  1. 쿼리 디자인 페이지의 메타데이터 창에 있는 큐브 섹션에서 줄임표 (…)를 클릭합니다.On the Design a query page, in the Metadata pane, in the cube section, click the ellipsis (…).

  2. 큐브 선택 대화 상자에서 Sales를 클릭한 다음 확인을 클릭합니다.In the Cube Selection dialog box, click Sales, and then click OK.

    MDX 쿼리를 수동으로 작성 하지 않을 경우 클릭는 디자인 모드로 전환 아이콘, 쿼리 디자이너를 쿼리 모드로 토글하 완료 된 MDX 쿼리 디자이너를 붙여 넣고 다음의 5 단계를 진행 데이터 집합을 만들려면합니다.If you do not want to build the MDX query manually, click the Switch to Design mode icon, toggle the query designer to Query mode, paste the completed MDX to the query designer, and then proceed to step 5 in To create the dataset.

    WITH MEMBER [Measures].[Net QTY] AS [Measures].[Sales Quantity] -[Measures].[Sales Return Quantity] MEMBER [Measures].[Net Sales] AS [Measures].[Sales Amount] - [Measures].[Sales Return Amount] SELECT NON EMPTY { [Measures].[Net QTY], [Measures].[Net Sales] } ON COLUMNS, NON EMPTY { ([Channel].[Channel Name].[Channel Name].ALLMEMBERS * [Product].[Product Category Name].[Product Category Name].ALLMEMBERS ) } DIMENSION PROPERTIES MEMBER_CAPTION, MEMBER_UNIQUE_NAME ON ROWS FROM ( SELECT ( { [Date].[Calendar Year].&[2009] } ) ON COLUMNS FROM ( SELECT ( STRTOSET(@ProductProductCategoryName, CONSTRAINED) ) ON COLUMNS FROM ( SELECT ( { [Sales Territory].[Sales Territory Group].&[North America] } ) ON COLUMNS FROM ( SELECT ( { [Channel].[Channel Name].&[2], [Channel].[Channel Name].&[4] } ) ON COLUMNS FROM [Sales])))) WHERE ( [Sales Territory].[Sales Territory Group].&[North America], [Date].[Calendar Year].&[2009] ) CELL PROPERTIES VALUE, BACK_COLOR, FORE_COLOR, FORMATTED_VALUE, FORMAT_STRING, FONT_NAME, FONT_SIZE, FONT_FLAGSQuery text: Code.  
    
  3. 측정값 그룹 창에서 Channel을 확장한 다음 Channel Name을 필터 창의 계층 열로 끕니다.In the Measure Group pane, expand Channel, and then drag Channel Name to the Hierarchy column in the filter pane.

    Channel이라는 차원 이름이 자동으로 차원 열에 추가됩니다.The dimension name, Channel, is automatically added to the Dimension column. 차원 또는 연산자 열을 변경하지 마세요.Do not change the Dimension or Operator columns.

  4. 필터 식 목록을 열려면 필터 식 열의 아래쪽 화살표를 클릭합니다.To open the Filter Expression list, click the down arrow in the Filter Expression column.

  5. 필터 식 목록에서 All Channel을 확장하고, Online , Reseller를 차례로 클릭한 다음 확인을 클릭합니다.In the filter expression list, expand All Channel, click Online and Reseller, and then click OK.

    이제 쿼리에는 온라인과 대리점 채널만 포함할 필터가 제공됩니다.The query now includes a filter to include only these channels: Online and Reseller.

  6. Sales Territory 차원을 확장한 다음 Sales Territory Group을 Channel Name 아래에 있는 계층열로 끕니다.Expand the Sales Territory dimension, and then drag Sales Territory Group to the Hierarchy column, below Channel Name.

  7. 필터 식 목록을 열고 All Sales Territory를 확장한 다음 North America, 확인을 차례로 클릭합니다.Open the Filter Expression list, expand All Sales Territory, click North America, and then click OK.

    이제 쿼리에는 북미의 판매만 포함할 필터가 제공됩니다.The query now has a filter to include only sales in North America.

  8. 측정값 그룹 창에서 Date를 확장한 다음 Calendar Year를 필터 창의 계층 열로 끕니다.In the Measure Group pane, expand Date, and drag Calendar Year to the Hierarchy column in the filter pane.

    Date라는 차원 이름이 자동으로 차원 열에 추가됩니다.The dimension name, Date, is automatically added to the Dimension column. 차원 또는 연산자 열을 변경하지 마세요.Do not change the Dimension or Operator columns.

  9. 필터 식 목록을 열려면 필터 식 열의 아래쪽 화살표를 클릭합니다.To open the Filter Expression list, click the down arrow in the Filter Expression column.

  10. 필터 식 목록에서 All Date를 확장하고, Year 2009를 클릭한 다음 확인을 클릭합니다.In the filter expression list, expand All Date, click Year 2009, and then click OK.

    이제 쿼리에는 2009년만 포함할 필터가 제공됩니다.The query now includes a filter to include only the calendar year 2009.

매개 변수를 만들려면To create the parameter

  1. Product 차원을 확장한 다음 Product Category Name 멤버를 Sales Territory Group 아래의 계층열로 끕니다.Expand the Product dimension, and then drag the Product Category Name member to the Hierarchy column below Sales Territory Group.

  2. 필터 식 목록에서 All Products를 클릭한 다음 확인을 클릭합니다.Open the Filter Expression list, click All Products, and then click OK.

  3. 매개 변수 확인란을 클릭합니다.Click the Parameter checkbox. 쿼리에는 이제 ProductProductCategoryName 매개 변수가 제공됩니다.The query now includes the parameter ProductProductCategoryName.

계산 멤버를 만들려면To create calculated members

  1. 계산 멤버 창 내에 커서를 놓고 마우스 오른쪽 단추를 클릭한 다음 새 계산 멤버를 클릭합니다.Place the cursor inside the Calculated Members pane, right-click, and then click New Calculated Member.

  2. 메타데이터 창에서 측정값 을 확장한 다음 Sales를 확장합니다.In the Metadata pane, expand Measures and then expand Sales.

  3. Sales Quantity 측정값을 상자로 끌고, 빼기 문자(-)를 입력한 다음 Sales Return Quantity 측정값을 상자로 끌어 빼기 문자 뒤에 놓습니다.Drag the Sales Quantity measure to the Expression box, type the subtraction character (-), and then drag the Sales Return Quantity measure to the Expression box; place it after the subtraction character.

    다음 코드에서는 식을 보여 줍니다.The following code shows the expression:

    [Measures].[Sales Quantity] - [Measures].[Sales Return Quantity]  
    
  4. 이름 상자에 Net QTY를 입력한 다음 확인을 클릭합니다.In the Name box, type Net QTY, and then click OK.

    계산 멤버 창에 Net QTY 계산 멤버가 나열됩니다.The Calculated Members pane lists the Net QTY calculated member.

  5. 계산 멤버를 마우스 오른쪽 단추로 클릭한 다음 새 계산 멤버를 클릭합니다.Right-click Calculated Members, and then click New Calculated Member.

  6. 메타데이터 창에서 측정값을 확장한 다음 Sales를 확장합니다.In the Metadata pane, expand Measures, and then expand Sales.

  7. Sales Amount 측정값을 상자로 끌고, 빼기 문자(-)를 입력한 다음 Sales Return Amount 측정값을 상자로 끌어 빼기 문자 뒤에 놓습니다.Drag the Sales Amount measure to the Expression box, type the subtraction character (-), and then drag the Sales Return Amount measure to the Expression box; place it after the subtraction character.

    다음 코드에서는 식을 보여 줍니다.The following code shows the expression:

    [Measures].[Sales Amount] - [Measures].[Sales Return Amount]  
    
  8. 이름 상자에 Net Sales를 입력한 다음 확인을 클릭합니다. 계산 멤버 창에 Net Sales 계산 멤버가 나열됩니다.In the Name box, type Net Sales, and then click OK.The Calculated Members pane lists the Net Sales calculated member.

데이터 집합을 만들려면To create the dataset

  1. Channel 차원에서 Channel Name을 데이터 창으로 끕니다.From the Channel dimension, drag Channel Name to the data pane.

  2. Product 차원에서 Product Category Name을 데이터 창으로 끌어 Channel Name의 오른쪽에 놓습니다.From the Product dimension, drag Product Category Name to the data pane, and then place it to the right of Channel Name.

  3. 계산 멤버에서 Net QTY 를 데이터 창으로 끌어 Product Category Name의 오른쪽에 놓습니다.From Calculated Members, drag Net QTY to the data pane, and then place it to the right of Product Category Name.

  4. 계산 멤버에서 Net Sales를 데이터 창으로 끌어 Net QTY의 오른쪽에 놓습니다.From Calculated Members, drag Net Sales to the data pane, and then place it to the right of Net QTY.

  5. 쿼리 디자이너 도구 모음에서 실행(!)을 클릭합니다.On the query designer toolbar, click Run (!).

    쿼리 결과 집합을 검토합니다.Review the query result set.

  6. 다음을 클릭합니다.Click Next.

1c.1c. 데이터를 그룹으로 구성Organize Data into Groups

데이터를 그룹화할 필드를 선택할 때 세부 데이터와 집계 데이터가 표시되는 행과 열이 포함된 행렬을 디자인합니다.When you select the fields on which to group data, you design a matrix with rows and columns that displays detail and aggregated data.

데이터를 그룹으로 구성하려면To organize data into groups

  1. 필드 정렬 페이지에서 Product_Category_Name을 행 그룹으로 끌어옵니다.On the Arrange fields page, drag Product_Category_Name to Row groups.

  2. Channel_Name을 열 그룹으로 끌어옵니다.Drag Channel_Name to Column groups.

  3. Net_QTY으로 끌어옵니다.Drag Net_QTY to Values.

    Net_QTY 는 숫자 필드에 대한 기본 집계 함수인 Sum 함수를 통해 자동으로 집계됩니다.Net_QTY is automatically aggregated by the Sum function, the default aggregate for numeric fields. 값이 [Sum(Net_QTY)]입니다.The value is [Sum(Net_QTY)].

    사용 가능한 다른 집계 함수를 보려면 드롭다운 목록을 엽니다.To view the other aggregate functions available, open the drop-down list. 집계 함수를 변경하지 마십시오.Do not change the aggregate function.

  4. Net_Sales_Return 으로 끌어 [Sum(Net_QTY)]아래에 놓습니다.Drag Net_Sales_Return to Values and then place it below [Sum(Net_QTY)].

    3 ~ 4단계에서는 행렬에 표시할 데이터를 지정했습니다.Steps 3 and 4 specify the data to display in the matrix.

1d.1d. 부분합 및 합계 추가Add Subtotals and Totals

보고서에서 부분합 및 총합계를 표시할 수 있습니다.You can show subtotals and grand totals in reports. 주 보고서의 데이터가 표시기로 표시됩니다. 사용자는 마법사를 완료한 후 총합계를 제거합니다.The data in the main report displays as an indicator; you will remove the grand total after you complete the wizard.

부분합 및 총합계를 추가하려면To add subtotals and grand totals

  1. 레이아웃 선택 페이지의 옵션에서 부분합 및 총합계 표시 가 선택되어 있는지 확인합니다.On the Choose the layout page, under Options, verify that Show subtotals and grand totals is selected.

    마법사 미리 보기 창에 4개의 행이 있는 행렬이 표시됩니다.The wizard Preview pane displays a matrix with four rows. 보고서를 실행하면 각 행이 다음과 같은 방식으로 표시됩니다. 첫 번째 행은 열 그룹이며, 두 번째 행은 열 제목을 포함하며, 세 번째 행은 제품 범주 데이터([Sum(Net_ QTY)][Sum(Net_Sales)])를 포함하며, 네 번째 행은 합계를 포함합니다.When you run the report, each row will display in the following way: The first row is the column group, the second row contains the column headings, the third row contains the product category data ([Sum(Net_ QTY)] and [Sum(Net_Sales)], and the fourth row contains the totals.

  2. 다음을 클릭합니다.Click Next.

  3. 마침을 클릭합니다.Click Finish.

  4. 보고서를 미리 보려면 실행을 클릭합니다.To preview the report, click Run.

2. 총합계 행 제거2. Remove the Grand Total Row

데이터 값은 열 그룹 합계를 포함하여 표시기 상태로 표시됩니다.The data values are shown as indictor states, including the column group totals. 총합계를 표시하는 행을 제거합니다.Remove the row that displays the grand total.

총합계 행을 제거하려면To remove the grand total row

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 행렬의 마지막 행인 합계 행을 클릭하고 마우스 오른쪽 단추를 클릭한 다음 행 삭제를 클릭합니다.Click the Total row (the last row in the matrix), right-click, and then click Delete Rows.

  3. 보고서를 미리 보려면 실행을 클릭합니다.To preview the report, click Run.

3. 드릴스루에 대한 입력란 동작 구성3. Configure Text Box Action for Drillthrough

드릴스루를 활성화하려면 주 보고서에서 입력란에 대한 동작을 지정합니다.To enable the drillthrough, specify an action on a text box in the main report.

동작을 활성화하려면To enable an action

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. Product_Category_Name이 들어 있는 셀을 마우스 오른쪽 단추로 클릭한 다음 입력란 속성을 클릭합니다.Right-click the cell that contains Product_Category_Name, and then click Text Box Properties.

  3. 동작 탭을 클릭합니다.Click the Action tab.

  4. 보고서로 이동을 선택합니다.Select Go to report.

  5. 보고서 지정에서 찾아보기를 클릭한 다음 이름이 ResellerVSOnlineDrillthrough인 드릴스루 보고서를 찾습니다.In Specify a report, click Browse, and then locate the drillthrough report named ResellerVSOnlineDrillthrough.

  6. 드릴스루 보고서를 실행할 매개 변수를 추가하려면 추가를 클릭합니다.To add a parameter to run the drillthrough report, click Add.

  7. 이름 목록에서 ProductProductCategoryName을 선택합니다.In the Name list, select ProductProductCategoryName.

  8. [Product_Category_Name.UniqueName]를 입력합니다.In Value, type [Product_Category_Name.UniqueName].

    Product_Category_Name은 데이터 집합의 필드입니다.Product_Category_Name is a field in the dataset.

    중요

    드릴스루 동작의 경우 고유한 값이 필요하므로 UniqueName 속성을 포함해야 합니다.You must include the UniqueName property because the drillthrough action requires a unique value.

  9. 확인을 클릭합니다.Click OK.

드릴스루 필드의 서식을 지정하려면To format the drillthrough field

  1. Product_Category_Name이 들어 있는 셀을 마우스 오른쪽 단추로 클릭한 다음 입력란 속성을 클릭합니다.Right-click the cell that contains the Product_Category_Name, and then click Text Box Properties.

  2. 글꼴 탭을 클릭합니다.Click the Font tab.

  3. 효과 목록에서 밑줄을 선택합니다.In the Effects list, select Underline.

  4. 목록에서 파랑을 선택합니다.In the Color list, select Blue.

  5. 확인을 클릭합니다.Click OK.

  6. 보고서를 미리 보려면 실행을 클릭합니다.To preview your report, click Run.

제품 범주 이름은 파랑의 밑줄이 지정된 공통적인 링크 형식입니다.The product category names are in the common link format (blue and underlined).

4. 숫자 값을 표시기로 바꾸기4. Replace Numeric Values with Indicators

표시기를 사용하여 온라인 및 대리점 채널에 대한 수량 및 판매 상태를 표시합니다.Use indicators to show the state of quantities and sales for Online and Reseller channels.

Net QTY 값에 대한 표시기를 추가하려면To add an indicator for Net QTY values

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 리본에서 사각형 아이콘을 클릭한 다음 [Sum(Net QTY)] 열 그룹의 [Product_Category_Name] 행 그룹에 있는 Channel_Name 셀을 클릭합니다.On the ribbon, click the Rectangle icon, and then click in the [Sum(Net QTY)] cell in the [Product_Category_Name] row group in the Channel_Name column group.

  3. 리본에서 표시기 아이콘을 클릭한 다음 사각형 내부를 클릭합니다.On the ribbon, click the Indicator icon, and then click inside the rectangle. 방향 표시기가 선택된 표시기 유형 선택 대화 상자가 열립니다.The Select Indicator Type dialog box opens with the Directional indicator selected.

  4. 3가지 모양 유형을 클릭한 다음 확인을 클릭합니다.Click the 3 Signs type, and then click OK.

  5. 표시기를 마우스 오른쪽 단추로 클릭하고 계기 데이터 창에서 (지정하지 않음)옆에 있는 아래쪽 화살표를 클릭합니다.Right-click the indicator and in the Gauge Data pane, click the down arrow next to (Unspecified). Net_QTY을(를) 선택합니다.Select Net_QTY.

  6. [Sum(Net QTY)] Total [Product_Category_Name] 내의 행 그룹에 있는셀에 대해 2 ~ 5단계를 반복합니다.Repeat steps 2 through 5 for the [Sum(Net QTY)] cell in the [Product_Category_Name] row group within Total.

Net Sales 값에 대한 표시기를 추가하려면To add an indicator for Net Sales values

  1. 리본에서 사각형 아이콘을 클릭한 다음 [Sum(Net_Sales)] 열 그룹의 [Product_Category_Name] 행 그룹에 있는 Channel_Name 셀 안쪽을 클릭합니다.On the ribbon, click the Rectangle icon, and then click inside the [Sum(Net_Sales)] cell in the [Product_Category_Name] row group in the Channel_Name column group.

  2. 리본에서 표시기 아이콘을 클릭한 다음 사각형 내부를 클릭합니다.On the ribbon, click the Indicator icon, and then click inside the rectangle.

  3. 3가지 모양 유형을 클릭한 다음 확인을 클릭합니다.Click the 3 Signs type, and then click OK.

  4. 표시기를 마우스 오른쪽 단추로 클릭하고 계기 데이터 창에서 (지정하지 않음)옆에 있는 아래쪽 화살표를 클릭합니다.Right-click the indicator and in the Gauge Data pane, click the down arrow next to (Unspecified). Net_Sales을(를) 선택합니다.Select Net_Sales.

  5. [Sum(Net_Sales)] Total [Product_Category_Name] 내의 행 그룹에 있는셀에 대해 1 ~ 4단계를 반복합니다.Repeat steps 1 through 4 for the [Sum(Net_Sales)] cell in the [Product_Category_Name] row group within Total.

  6. 보고서를 미리 보려면 실행을 클릭합니다.To preview your report, click Run.

5. 매개 변수 속성 업데이트5. Update Parameter Properties

기본적으로 매개 변수가 표시되는데 이는 이 보고서의 경우 적합하지 않습니다.By default, parameters are visible, which is not appropriate for this report. 매개 변수를 내부 매개 변수로 만들도록 매개 변수 속성을 업데이트합니다.You will update the parameter properties to make the parameter internal.

매개 변수를 내부 매개 변수로 만들려면To make the parameter internal

  1. 보고서 데이터 창에서 매개 변수를 확장합니다.In the Report Data pane, expand Parameters.

  2. @ProductProductCategoryName, 을 마우스 오른쪽 단추로 클릭한 다음 매개 변수 속성을 클릭합니다.Right-click @ProductProductCategoryName, and then click Parameter Properties.

  3. 일반 탭에서 내부를 클릭합니다.On the General tab, click Internal.

  4. 필요에 따라 사용 가능한 값기본값 탭을 클릭하고 해당 옵션을 검토합니다.Optionally, click the Available Values and Default Values tabs and review their options. 이러한 탭에 대한 어떤 옵션도 변경하지 마십시오.Do not change any options on these tabs.

  5. 확인을 클릭합니다.Click OK.

6. 보고서 제목 추가6. Add a Report Title

주 보고서에 제목을 추가합니다.Add a title to the main report.

보고서 제목을 추가하려면To add a report title

  1. 디자인 화면에서 제목을 추가하려면 클릭하십시오.를 클릭합니다.On the design surface, click Click to add title.

  2. 2009 Product Category Sales: Online and Reseller Category:를 입력합니다.Type 2009 Product Category Sales: Online and Reseller Category:.

  3. 입력한 텍스트를 선택합니다.Select the text you typed.

  4. 리본의 탭에 있는 글꼴 그룹에서 Times New Roman 글꼴, 16pt 크기, 굵게기울임꼴 스타일을 선택합니다.On the Home tab of the ribbon, in the Font group, select the Times New Roman font, 16pt size, and the Bold and Italic styles.

  5. 보고서를 미리 보려면 실행을 클릭합니다.To preview your report, click Run.

7. SharePoint 라이브러리에 주 보고서 저장7. Save the Main Report to a SharePoint Library

SharePoint 라이브러리에 주 보고서를 저장합니다.Save the main report to a SharePoint library.

보고서를 저장하려면To save the report

  1. 디자인 뷰로 전환하려면 디자인을 클릭합니다.To switch to design view, click Design.

  2. 보고서 작성기 단추에서 저장을 클릭합니다.From the Report Builder button, click Save.

  3. 필요한 경우 최근에 사용한 보고서 서버와 SharePoint 사이트의 목록을 표시하려면 최근에 사용한 사이트 및 서버를 클릭합니다.Optionally, to show a list of recently used report servers and SharePoint sites, click Recent Sites and Servers.

  4. 보고서를 저장할 수 있는 권한을 가진 SharePoint 사이트의 이름을 선택하거나 입력합니다.Select or type the name of the SharePoint site where you have permission to save reports. SharePoint 라이브러리의 URL에 다음 구문이 있습니다.The URL of the SharePoint library has the following syntax:

    Http://<ServerName>/<Sites>/  
    
  5. 보고서를 저장할 라이브러리로 이동합니다.Navigate to the library where you want to save the report.

  6. 이름에서 기본 이름을 ResellerVSOnlineMain으로 바꿉니다.In Name, replace the default name with ResellerVSOnlineMain.

    중요

    드릴스루 보고서를 저장한 동일한 위치에 주 보고서를 저장합니다.Save the main report to the same location where you saved the drillthrough report. 주 보고서 및 드릴스루 보고서를 다른 사이트 또는 라이브러리에 저장하려면 주 보고서의 보고서로 이동 동작이 드릴스루 보고서의 올바른 위치를 가리키는지 확인합니다.To save the main and drillthrough reports to different sites or libraries, confirm that the Go to report action in the main report, points to the correct location of the drillthrough report.

  7. 저장을 클릭합니다.Click Save.

8. 주 보고서 및 드릴스루 보고서 실행8. Run the Main and Drillthrough Reports

주 보고서를 실행한 다음 제품 범주 열의 값을 클릭하여 드릴스루 보고서를 실행합니다.Run the main report, and then click values in the product category column to run the drillthrough report.

보고서를 실행하려면To run the reports

  1. 보고서가 저장된 SharePoint 라이브러리를 엽니다.Open the SharePoint library where the reports are saved.

  2. ResellerVSOnlineMain을 두 번 클릭합니다.Double-click ResellerVSOnlineMain.

    보고서에서 제품 범주 판매 정보를 실행하고 표시합니다.The report runs and displays product category sales information.

  3. 제품 범주 이름이 들어 있는 열에서 Games and Toys 링크를 클릭합니다.Click the Games and Toys link in the column that contains product category names.

    드릴스루 보고서가 실행되어 Games and Toys 제품 범주에 대한 값만 표시합니다.The drillthrough report runs, displaying only the values for the Games and Toys product category.

  4. 주 보고서로 돌아가려면 Internet Explorer에서 뒤로 단추를 클릭합니다.To return to the main report, click the Internet Explorer back button.

  5. 필요에 따라 다른 제품 범주의 이름을 클릭하여 해당 제품 범주를 탐색합니다.Optionally, explore other product categories by clicking their names.

관련 항목:See Also

보고서 작성기 자습서Report Builder tutorials