Access 데이터베이스 파일 (AccessToSQL) 추가 및 제거Adding and Removing Access Database Files (AccessToSQL)

로 Access 데이터를 마이그레이션하도록 SQL ServerSQL Server 또는 SQL Azure SSMA 프로젝트에 하나 이상의 Access 데이터베이스를 추가 해야 합니다.To migrate Access data to SQL ServerSQL Server or SQL Azure, you must add one or more Access databases to the SSMA project. 이러한 데이터베이스는 Access 97 또는 이후 버전 이어야 합니다.These databases must be Access 97 or later versions. 이전 버전의 Access에서 데이터베이스에 있는 경우 데이터베이스를 최신 버전으로 변환 해야 합니다.If you have databases from an earlier version of Access, you must convert the databases to a newer version. 열고 SSMA를 추가 하기 전에 Access 97 이상에서 데이터베이스를 저장 하 여이 작업을 수행 합니다.You do this by opening and saving the databases in Access 97 or a later version before you add them to SSMA.

Access 데이터베이스 파일을 추가 하면 어떻게 되나요?What Happens When You Add Access Database Files?

SSMA 프로젝트에 Access 데이터베이스를 추가 하면 SSMA는 데이터베이스 메타 데이터를 읽고 프로젝트 파일에이 메타 데이터를 추가 합니다.When you add an Access database to an SSMA project, SSMA reads database metadata, and then adds this metadata to the project file. 이 메타 데이터 데이터베이스 및 해당 개체를 설명 합니다.This metadata describes the database and its objects. SSMA는 개체를 변환할 때 메타 데이터를 사용 하 여 SQL ServerSQL Server 또는 SQL Azure 구문이 데이터를 마이그레이션한 경우 및 SQL ServerSQL Server 또는 SQL Azure입니다.SSMA uses the metadata when it converts objects to SQL ServerSQL Server or SQL Azure syntax, and when it migrates data to SQL ServerSQL Server or SQL Azure. 액세스 메타 데이터 탐색기에서이 메타 데이터를 찾아보고 개별 데이터베이스 개체의 속성을 검토할 수 있습니다.You can browse this metadata in Access Metadata Explorer and review properties of individual database objects.

참고

Access 데이터베이스를 여러 파일로 분할할 수 있습니다: 테이블을 포함 하는 백 엔드 데이터베이스 및 쿼리, 폼, 보고서, 매크로, 모듈 및 바로 가기 키를 포함 하는 프런트 엔드 데이터베이스입니다.An Access database can be split into multiple files: a back-end database that contains tables, and front-end databases that contain queries, forms, reports, macros, modules, and shortcuts. 분할 데이터베이스를 마이그레이션할 경우 SQL ServerSQL Server 또는 SQL Azure, SSMA에 프런트 엔드 데이터베이스를 추가 합니다.If you want to migrate a split database to SQL ServerSQL Server or SQL Azure, add the front-end database to SSMA.

SSMA에 필요한 사용 권한Permissions that are required by SSMA

Access 데이터베이스를 마이그레이션하려면 SQL ServerSQL Server 또는 SQL Azure 사용자 그룹 및 관리자 관리 권한이 있어야 합니다.To migrate an Access database to SQL ServerSQL Server or SQL Azure, the Users group and the Admin user must have Administer permissions. 작업 그룹 보호를 사용 하 여 데이터베이스를 마이그레이션하는 방법에 대 한 정보를 참조 하세요. 마이그레이션에 대 한 Access 데이터베이스 준비For information about how to migrate databases with workgroup protection, see Preparing Access Databases for Migration

추가할 데이터베이스 선택Selecting Databases to Add

SSMA 프로젝트를 하나 이상의 데이터베이스를 추가 하려는 경우 알려진된 한곳에서 모든 파일은 다음 절차를 사용 하 여 파일을 추가할 수 있습니다.If you want to add one or more databases to an SSMA project, and the files are all in one known location, you can add the files by using the following procedure.

개별 데이터베이스 파일을 추가 하려면To add individual database files

  1. 파일 메뉴에서 클릭 추가 데이터베이스합니다.On the File menu, click Add Databases.

  2. 열고 대화 상자에서 데이터베이스 파일 또는 파일을 포함 하는 폴더를 찾습니다.In the Open dialog box, locate the folder that contains the database file or files.

  3. 파일을 추가 하 고 클릭 하려는 선택 열려합니다.Select the files that you want to add, and then click Open.

추가할 데이터베이스 찾기Finding Databases to Add

SSMA 프로젝트를 다른 폴더에서 여러 Access 데이터베이스를 추가 하려는 경우 파일을 찾을 수 없지만 단일 파일을 추가 하려는 파일 하나 이상 찾아 프로젝트에 추가 하려면 다음이 단계를 수행 합니다.If you want to add multiple Access databases from different folders to an SSMA project, or you want to add a single file but have to find the file, you can follow these steps to locate one of more files and add them to the project.

찾아 데이터베이스를 추가 합니다.To find and add databases

  1. 파일 메뉴에서 클릭 찾을 데이터베이스합니다.On the File menu, click Find Databases.

  2. 데이터베이스 찾기 마법사에서 드라이브, 파일 경로 또는 UNC 경로 검색 하려는의 이름을 입력 합니다.In the Find Databases Wizard, enter the name of the drive, file path, or the UNC path that you want to search. 를 클릭할 찾아보기 드라이브 또는 네트워크 폴더를 찾습니다.Alternatively, click Browse to locate the drive or network folder.

  3. 클릭 추가 위치 목록에 추가 합니다.Click Add to add the location to the list.

    더 많은 검색 위치를 추가 하는 이전 두 단계를 반복 합니다.Repeat the previous two steps to add more search locations.

  4. 필요에 따라 반환 되는 데이터베이스의 목록을 구체화 하려면 검색 조건을 추가 합니다.Optionally, add search criteria to refine the list of databases that are returned.

    중요

    합니다 파일 이름의 일부나 전부 입력란 와일드 카드 문자를 지원 하지 않습니다.The All or part of the file name text box does not support wildcard characters.

  5. 클릭 스캔합니다.Click Scan.

    검색 페이지가 표시 됩니다.The Scan page appears. 검색 된 데이터베이스 및 검색의 진행률 표시 됩니다.This shows the databases that have been found and the progress of the search. 검색을 중지 하려면 클릭 중지합니다.To stop the search, click Stop.

  6. 파일 선택 페이지에서 프로젝트에 추가 하려는 데이터베이스를 선택 합니다.On the Select Files page, select the databases that you want to add to the project.

    사용할 수는 모두 선택 하 고 모두 지우기 선택 하거나 모든 데이터베이스를 선택 취소 목록의 맨 위에 있는 단추입니다.You can use the Select All and Clear All buttons at the top of the list to select or clear all databases. 여러 데이터베이스를 선택 하려면 CTRL 키를 길게 누른 또는 데이터베이스 범위 선택으로 SHIFT 키를 누른 채로 있습니다.You can hold the CTRL key down to select multiple databases, or hold the SHIFT key down to select a range of databases.

  7. 다음을 클릭합니다.Click Next.

  8. 확인 페이지에서 클릭 완료합니다.On the Verify page, click Finish.

메타 데이터에 액세스를 검색합니다.Browsing Access Metadata

프로젝트에 Access 데이터베이스를 추가한 후 프로젝트 메타 데이터 액세스 메타 데이터 탐색기에 나타납니다.After you add an Access database to a project, the project metadata appears in Access Metadata Explorer. 데이터베이스 및 데이터베이스 개체 탐색기에서 계층 구조를 찾아볼 수 있습니다.You can browse the hierarchy of databases and database objects in the explorer.

메타 데이터를 찾아보려면To browse metadata

  1. 액세스 메타 데이터 탐색기에서 확장 액세스-메타 베이스를 차례로 확장 하 고 데이터베이스합니다.In Access Metadata Explorer, expand access-metabase, and then expand Databases.

  2. 를 검토 한 다음를 확장 하려는 데이터베이스를 확장 쿼리합니다.Expand the database that you want to review, and then expand Queries.

    쿼리의 목록을 확인할 수 있습니다.Notice the list of queries. 쿼리를 선택 하는 경우는 SQL 탭 및 속성 탭이 오른쪽 창에 표시 합니다.If you select a query, an SQL tab and a Properties tab appear in the right pane.

  3. 확장 테이블 다음 테이블을 선택 합니다.Expand Tables and then select a table.

    4 개의 탭이 표시 되는지 확인: 테이블형식 매핑속성, 및 데이터입니다.Notice that four tabs appear: Table, Type Mapping, Properties, and Data.

  4. 테이블을 확장 하 고 , 한 다음 키를 선택 합니다.Expand a table, expand Keys, and then select a key.

    키 속성이 오른쪽 창에 나타납니다.The key properties appear in the right pane.

  5. 확장 인덱스, 한 다음 인덱스를 선택 합니다.Expand Indexes, and then select an index.

    인덱스 속성 오른쪽 창에 나타납니다.The index properties appear in the right pane.

데이터베이스를 새로 고침Refreshing Databases

Access 데이터베이스에 해당 파일을 추가한 후 변경 될 경우에 Access 데이터베이스의 메타 데이터를 업데이트할 수 있습니다.If an Access database changes after you add its file, you can update metadata from the Access database.

메타 데이터에 액세스를 업데이트 하려면To update Access metadata

  • 액세스 메타 데이터 탐색기에서 데이터베이스를 마우스 오른쪽 단추로 클릭 하 고 선택한 데이터베이스에서 새로 고침합니다.In Access Metadata Explorer, right-click the database, and then select Refresh from Database.

데이터베이스를 제거합니다.Removing Databases

다음이 단계를 수행 하 여 프로젝트에서 Access 데이터베이스를 제거할 수 있습니다.You can remove an Access database from a project by following these steps.

프로젝트에서 데이터베이스를 제거 하려면To remove a database from a project

  1. 액세스 메타 데이터 탐색기에서 확장 액세스-메타 베이스를 차례로 확장 하 고 데이터베이스합니다.In Access Metadata Explorer, expand access-metabase, and then expand Databases.

  2. 데이터베이스를 마우스 오른쪽 단추로 클릭 하 고 선택한 Remove Database합니다.Right-click the database, and then select Remove Database.

다음 단계Next Step

마이그레이션 프로세스에서 다음 단계 SQL Server에 연결합니다.The next step in the migration process is to connect to SQL Server.

관련 항목See Also

SQL Server에 대 한 액세스 데이터베이스 마이그레이션Migrating Access Databases to SQL Server
프로젝트 만들기 및 관리Creating and Managing Projects