변환 및 마이그레이션 옵션 (AccessToSQL) 설정Setting Conversion and Migration Options (AccessToSQL)

각 SSMA 프로젝트에 대해 프로젝트 수준의 옵션을 설정할 수 있습니다.For each SSMA project, you can set project-level options. 이러한 옵션에는 개체를 변환 하는 방법을, 데이터가 마이그레이션되는 방식 및 원본 데이터 형식이 대상 데이터 형식으로 매핑되는 방법을 지정 합니다.These options specify how objects are converted, how data is migrated, and how source data types map to target data types. 개체를 변환 하기 전에 SQL ServerSQL Server 또는 SQL Azure에 데이터를 마이그레이션하거나 SQL ServerSQL Server 또는 SQL Azure, 구성 옵션은 프로젝트에 대 한 적절 한지 확인 하십시오.Before you convert objects to SQL ServerSQL Server or SQL Azure or migrate data into SQL ServerSQL Server or SQL Azure, verify that the configuration options are appropriate for the project.

구성 옵션 및 모드Configuration Options and Modes

SSMA는 4 개의 집합이 구성 설정 및 구성이 설정에 대 한 네 가지 모드: 기본, Optimistic, Full, 및 사용자 지정 합니다.SSMA has four sets of configuration settings and four modes for configuring these settings: Default, Optimistic, Full, and Custom. 대부분의 사용자에 대 한 기본 모드를 사용 하는 것이 좋습니다.The Default mode is recommended for most users. 간단한 변환을 대 한 최적 모드를 사용 합니다.Use the Optimistic mode for simple conversions. 모든 메시지를 표시 하려는 경우 전체 모드를 사용 합니다.Use the Full mode if you want to see all messages. 사용자 지정 모드에서 옵션을 설정 합니다.In the Custom mode, you set the options.

설정은이 설명서의 "사용자 인터페이스 참조" 섹션에 설명 되어 있습니다.The settings are described in the "User Interface Reference" section of this documentation. 설정과 각 모드에서 설정이 적용 되는 방식을 대 한 자세한 내용은 다음 항목을 참조 합니다.For more information about the settings and how the settings are applied in each mode, see the following topics :

프로젝트 옵션 설정Setting Project Options

SSMA를 모든 프로젝트에 대 한 기본 설정을 구성할 수 있습니다.In SSMA, you can configure default settings for all projects. 이러한 설정은 SSMA 구성 파일에 저장 되며 만드는 모든 새 프로젝트에 적용 됩니다.These settings are saved to the SSMA configuration file and applied to any new project that you create.

기본 프로젝트 옵션을 설정 하려면To set default project options

  1. 도구 메뉴 선택 기본 프로젝트 설정합니다.On the Tools menu, select Default Project Settings.

  2. 기본 프로젝트 설정 대화 상자에서 다음 중 하나를 수행 합니다.In the Default Project Settings dialog box, do one of the following:

    • 설정을 볼 /에서 변경 하는 데 필요한는 마이그레이션 프로젝트 형식을 선택 마이그레이션 대상 버전 드롭다운을 클릭 일반 선택 고 왼쪽된 창 맨 아래에 변환 하거나 마이그레이션 또는 SQL Azure합니다.Select migration project type for which settings are required to be viewed / changed from Migration Target Version drop down, click General at the bottom of the left pane, and then select Conversion or Migration or SQL Azure.

      참고

      SQL Azure 옵션을 사용할 수는 일반 만들 프로젝트 형식에는 SQL Azure는 경우에을 탭 합니다.SQL Azure option is available in the General tab only if the project type created is SQL Azure.

    • 미리 정의 된 모드를 선택 하려면 선택 기본, Optimistic, 또는 전체모드 드롭다운 상자입니다.To select a pre-defined mode, select Default, Optimistic, or Full in the Mode drop-down box.

    • 사용자 지정 모드를 지정 하려면 사용자 지정모드 상자의 왼쪽된 창에서 옵션을 선택, 설정 또는 오른쪽 창에서 값을 클릭 한 다음 선택 하거나 새 설정 또는 값을 입력 합니다.To specify a custom mode, select Custom in the Mode box, select an option in the left pane, click the setting or value in the right pane, and then select or enter the new setting or value.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

현재 프로젝트에 대 한 설정을 사용자 지정할 수도 있습니다.You can also customize settings for the current project. 이러한 설정은 현재 프로젝트 파일에 저장 됩니다.These settings are saved to the current project file.

현재 프로젝트에 대 한 설정을 사용자 지정 하려면To customize settings for the current project

  1. 도구 메뉴 선택 프로젝트 설정합니다.On the Tools menu, select Project Settings.

  2. 프로젝트 설정 대화 상자에서 다음 중 하나를 수행 합니다.In the Project Settings dialog box, do one of the following:

    • 미리 정의 된 모드를 선택 하려면 선택 기본, Optimistic, 또는 전체모드 드롭다운 상자입니다.To select a pre-defined mode, select Default, Optimistic, or Full in the Mode drop-down box.

    • 사용자 지정 모드를 지정 하려면 사용자 지정모드 상자의 왼쪽된 창에서 옵션을 선택, 설정 또는 오른쪽 창에서 값을 클릭 한 다음 선택 하거나 새 설정 또는 값을 입력 합니다.To specify a custom mode, select Custom in the Mode box, select an option in the left pane, click the setting or value in the right pane, and then select or enter the new setting or value.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

다음 단계Next Steps

다음 단계는 마이그레이션에서 프로젝트 요구 사항에 따라 달라 집니다.The next step in the migration depends on your project needs:

참고 항목See Also

SQL Server에 대 한 액세스 데이터베이스 마이그레이션Migrating Access Databases to SQL Server