DB2 용 SSMA 시작 (DB2ToSQL)Getting Started with SSMA for DB2 (DB2ToSQL)

SQL ServerSQL Server Migration Assistant (SSMA) DB2 사용 하면 신속 하 게에 대 한 DB2 데이터베이스 스키마로 변환 SQL ServerSQL Server 스키마의 경우 결과 스키마를 업로드 SQL ServerSQL Server 를 DB2에서 데이터를 마이그레이션하고 SQL ServerSQL Server합니다. Migration Assistant (SSMA) for DB2 lets you quickly convert DB2 database schemas to SQL ServerSQL Server schemas, upload the resulting schemas into SQL ServerSQL Server and migrate data from DB2 to SQL ServerSQL Server.

이 항목에서는 설치 프로세스를 소개 하 고 SSMA 사용자 인터페이스에 익숙해질 수 있도록 돕습니다.This topic introduces the installation process, and then helps familiarize you with the SSMA user interface.

SSMA 설치Installing SSMA

SSMA를 사용 하려면 먼저 설치 해야 SSMA 클라이언트 프로그램 DB2 원본 데이터베이스와의 대상 인스턴스 모두에 액세스할 수 있는 컴퓨터 SQL ServerSQL Server합니다.To use SSMA, you first must install the SSMA client program on a computer that can access both the source DB2 database and the target instance of SQL ServerSQL Server. 실행 중인 컴퓨터의 DB2 OLEDB 공급자 SQL ServerSQL Server합니다.DB2 OLEDB providers on the computer that is running SQL ServerSQL Server. 이러한 구성 요소는 데이터 마이그레이션 및 DB2 시스템 함수의 에뮬레이션을 지원합니다.These components support data migration and the emulation of DB2 system functions. 설치 지침은 DB2 용 SSMA 설치 (DB2ToSQL)합니다.For installation instructions, see Installing SSMA for DB2 (DB2ToSQL).

SSMA를 시작 하려면 시작, 가리킨 모든 프로그램를 가리킨 SQL ServerSQL Server Migration Assistant for DB2를 클릭 하 고 SQL ServerSQL Server Migration Assistant for DB2합니다.To start SSMA, click Start, point to All Programs, point to SQL ServerSQL Server Migration Assistant for DB2, and then click SQL ServerSQL Server Migration Assistant for DB2.

DB2 사용자 인터페이스용 SSMASSMA for DB2 User Interface

DB2 데이터베이스를 마이그레이션하려면 SSMA SSMA를 설치한 후 사용할 수 있습니다 SQL ServerSQL Server합니다.After SSMA is installed, you can use SSMA to migrate DB2 databases to SQL ServerSQL Server. 시작 하기 전에 SSMA 사용자 인터페이스를 사용 하 여 친숙 한 될 수 있습니다.It helps to become familiar with the SSMA user interface before you start. 다음 다이어그램은 SSMA를 메타 데이터 탐색기, 메타 데이터, 도구 모음, 출력 창 및 오류 목록 창에 대 한 사용자 인터페이스를 보여줍니다.The following diagram shows the user interface for SSMA, including the metadata explorers, metadata, toolbars, output pane, and error list pane:

SSMA 사용자 인터페이스SSMA User Interface

마이그레이션을 시작 하려면 먼저 새 프로젝트를 만들어야 합니다.To start a migration, you must first create a new project. 그런 다음 DB2 데이터베이스에 연결할 수도 있습니다.Then, you connect to an DB2 database. 연결에 성공한 후 DB2 스키마는 DB2 메타 데이터 탐색기에 표시 됩니다.After a successful connection, DB2 schemas will appear in DB2 Metadata Explorer. 와 같은 작업을 수행 하는 DB2 메타 데이터 탐색기에서 마우스 오른쪽 단추로 클릭 개체 변환이 평가 하는 보고서를 만들 수 있습니다 SQL ServerSQL Server합니다.You can then right-click objects in DB2 Metadata Explorer to perform tasks such as create reports that assess conversions to SQL ServerSQL Server. 또한 도구 모음 및 메뉴를 사용 하 여 이러한 작업을 수행할 수 있습니다.You can also perform these tasks by using the toolbars and menus.

인스턴스에 연결 해야 합니다도 SQL ServerSQL Server합니다.You must also connect to an instance of SQL ServerSQL Server. 계층을 성공적으로 연결 되 면 SQL ServerSQL Server 데이터베이스에 표시 됩니다 SQL ServerSQL Server 메타 데이터 탐색기입니다.After a successful connection, a hierarchy of SQL ServerSQL Server databases will appear in SQL ServerSQL Server Metadata Explorer. DB2 스키마를 변환한 후 SQL ServerSQL Server 스키마에서 변환 된 스키마를 선택 SQL ServerSQL Server 메타 데이터 탐색기를 사용 하 여 스키마를 추가한 다음 동기화 SQL ServerSQL Server.After you convert DB2 schemas to SQL ServerSQL Server schemas, select those converted schemas in SQL ServerSQL Server Metadata Explorer, and then synchronize the schemas with SQL ServerSQL Server.

변환 된 스키마를 동기화 한 후 SQL ServerSQL Server를 DB2 메타 데이터 탐색기를 반환 하 고 DB2 스키마에서 데이터를 마이그레이션할 수 SQL ServerSQL Server 데이터베이스입니다.After you synchronize converted schemas with SQL ServerSQL Server, you can return to DB2 Metadata Explorer and migrate data from DB2 schemas into SQL ServerSQL Server databases.

이러한 작업 및 수행 하는 방법에 대 한 자세한 내용은 참조 하세요. DB2 데이터베이스를 SQL Server 마이그레이션 (DB2ToSQL)합니다.For more information about these tasks and how to perform them, see Migrating DB2 Databases to SQL Server (DB2ToSQL).

다음 섹션에서는 SSMA 사용자 인터페이스의 기능에 설명 합니다.The following sections describe the features of the SSMA user interface.

메타 데이터 탐색기Metadata Explorers

SSMA을 찾아서 DB2에서 작업을 수행 하는 두 명의 메타 데이터 탐색기를 포함 하 고 SQL ServerSQL Server 데이터베이스입니다.SSMA contains two metadata explorers to browse and perform actions on DB2 and SQL ServerSQL Server databases.

DB2 메타 데이터 탐색기DB2 Metadata Explorer

DB2 메타 데이터 탐색기는 DB2 스키마에 대 한 정보를 표시합니다.DB2 Metadata Explorer shows information about DB2 schemas. DB2 메타 데이터 탐색기를 사용 하 여 다음 작업을 수행할 수 있습니다.By using DB2 Metadata Explorer, you can perform the following tasks:

SQL Server 메타 데이터 탐색기SQL Server Metadata Explorer

SQL ServerSQL Server 인스턴스에 대 한 정보를 표시 하는 메타 데이터 탐색기 SQL ServerSQL Server합니다. Metadata Explorer shows information about an instance of SQL ServerSQL Server. 인스턴스에 연결 하는 경우 SQL ServerSQL Server, SSMA 해당 인스턴스에 대 한 메타 데이터를 검색 하 고 프로젝트 파일에 저장 합니다.When you connect to an instance of SQL ServerSQL Server, SSMA retrieves metadata about that instance and stores it in the project file.

사용할 수 있습니다 SQL ServerSQL Server 변환 된 DB2 데이터베이스 개체를 선택한 다음 해당 개체의 인스턴스를 사용 하 여 동기화 메타 데이터 탐색기 SQL ServerSQL Server합니다.You can use SQL ServerSQL Server Metadata Explorer to select converted DB2 database objects, and then synchronize those objects with the instance of SQL ServerSQL Server.

메타데이터Metadata

각 메타 데이터 탐색기의 오른쪽에는 선택한 개체를 설명 하는 탭 합니다.To the right of each metadata explorer are tabs that describe the selected object. 예를 들어 DB2 메타 데이터 탐색기에서 테이블을 선택 하면 6 개의 탭 표시 됩니다: 테이블, SQL하십시오 형식 매핑, 보고서, 속성, 및 데이터입니다.For example, if you select a table in DB2 Metadata Explorer, six tabs will appear: Table, SQL, Type Mapping,Report, Properties, and Data. 합니다 보고서 선택한 개체에 포함 된 보고서를 만든 후에 탭 정보를 포함 합니다.The Report tab contains information only after you create a report that contains the selected object. 테이블을 선택 하는 경우 SQL ServerSQL Server 메타 데이터 탐색기, 세 개의 탭 표시 됩니다. 테이블, SQL, 및 데이터.If you select a table in SQL ServerSQL Server Metadata Explorer, three tabs will appear: Table, SQL, and Data.

대부분의 메타 데이터 설정에는 읽기 전용입니다.Most metadata settings are read-only. 그러나 다음과 같은 메타 데이터를 변경할 수 있습니다.However, you can alter the following metadata:

  • DB2 메타 데이터 탐색기에서 프로시저를 변경 하 고 형식 매핑 수 있습니다.In DB2 Metadata Explorer, you can alter procedures and type mappings. 변경된 절차를 변환 및 형식 매핑, 스키마를 변환 하기 전에 변경 내용을 확인 합니다.To convert the altered procedures and type mappings, make changes before you convert schemas.

  • SQL ServerSQL Server 변경할 수 있습니다 메타 데이터 탐색기는 Transact-SQLTransact-SQL 저장된 프로시저에 대 한 합니다.In SQL ServerSQL Server Metadata Explorer, you can alter the Transact-SQLTransact-SQL for stored procedures. 이러한 변경 내용을 보려는 SQL ServerSQL Server, 스키마를 로드 하기 전에 이러한 변경 SQL ServerSQL Server합니다.To see these changes in SQL ServerSQL Server, make these changes before you load the schemas into SQL ServerSQL Server.

메타 데이터 탐색기에서 변경 내용은 원본 또는 대상 데이터베이스에 없는 프로젝트 메타 데이터에 반영 됩니다.Changes made in a metadata explorer are reflected in the project metadata, not in the source or target databases.

도구 모음Toolbars

SSMA는 두 개의 도구 모음: 프로젝트 도구 모음 및 마이그레이션 도구 모음입니다.SSMA has two toolbars: a project toolbar and a migration toolbar.

프로젝트 도구 모음The Project Toolbar

프로젝트 도구 모음 단추가 DB2에 연결 및 연결 프로젝트 작업의 SQL ServerSQL Server합니다.The project toolbar contains buttons for working with projects, connecting to DB2, and connecting to SQL ServerSQL Server. 이러한 단추는 명령에서 유사 합니다 파일 메뉴.These buttons resemble the commands on the File menu.

마이그레이션 도구 모음Migration Toolbar

다음 표에서 마이그레이션 도구 모음 명령을 보여 줍니다.The following table shows the migration toolbar commands:

단추Button 기능Function
보고서 만들기Create Report 선택한 DB2 개체를 변환 SQL ServerSQL Server 구문을 다음 얼마나 성공적인 변환 된 보여 주는 보고서를 만듭니다.Converts the selected DB2 objects to SQL ServerSQL Server syntax, and then creates a report that shows how successful the conversion was.

개체는 DB2 메타 데이터 탐색기에서 선택 하지 않으면이 명령이 비활성화 됩니다.This command is disabled unless objects are selected in DB2 Metadata Explorer.
스키마 변환Convert Schema 선택한 DB2 개체를 변환 SQL ServerSQL Server 개체입니다.Converts the selected DB2 objects to SQL ServerSQL Server objects.

개체는 DB2 메타 데이터 탐색기에서 선택 하지 않으면이 명령이 비활성화 됩니다.This command is disabled unless objects are selected in DB2 Metadata Explorer.
데이터 마이그레이션Migrate Data DB2 데이터베이스에서 데이터를 마이그레이션합니다 SQL ServerSQL Server합니다.Migrates data from the DB2 database to SQL ServerSQL Server. 이 명령은 실행 하기 전에 DB2 스키마를 변환 해야 합니다 SQL ServerSQL Server 스키마 개체를 로드 SQL ServerSQL Server합니다.Before you run this command, you must convert the DB2 schemas to SQL ServerSQL Server schemas, and then load the objects into SQL ServerSQL Server.

개체는 DB2 메타 데이터 탐색기에서 선택 하지 않으면이 명령이 비활성화 됩니다.This command is disabled unless objects are selected in DB2 Metadata Explorer.
중지Stop 현재 프로세스를 중지합니다.Stops the current process.

다음 표에서 SSMA 메뉴를 보여 줍니다.The following table shows the SSMA menus.

메뉴Menu DescriptionDescription
최근에 사용한 파일File 프로젝트, DB2에 연결 및 작업에 연결 하기 위한 명령을 포함 SQL ServerSQL Server합니다.Contains commands for working with projects, connecting to DB2, and connecting to SQL ServerSQL Server.
편집Edit 찾기 및 텍스트 세부 정보 페이지를 복사 하는 등의 작업에 대 한 명령을 포함 Transact-SQLTransact-SQL SQL 세부 정보 창에서.Contains commands for finding and working with text in the details pages, such as copying Transact-SQLTransact-SQL from the SQL details pane. 도 포함 되어 있습니다 합니다 책갈피 관리 옵션을 여기서 기존 책갈피의 목록을 볼 수는 있습니다.Also contains the Manage Bookmarks option, where you will be able to see a list of existing bookmarks. 책갈피를 관리 하는 대화 상자의 오른쪽에 단추를 사용할 수 있습니다.You can use the buttons on the right side of the dialog to manage the bookmarks.
보기View 포함 된 메타 데이터 탐색기 동기화 명령입니다.Contains the Synchronize Metadata Explorers command. DB2 메타 데이터 탐색기 간에 개체를 동기화 하 고 SQL ServerSQL Server 메타 데이터 탐색기입니다.That synchronizes the objects between DB2 Metadata Explorer and SQL ServerSQL Server Metadata Explorer. 표시 하거나 숨기려면 명령도 포함 됩니다는 출력오류 목록 창과 옵션 레이아웃 레이아웃을 관리 합니다.Also contains commands to show and hide the Output and Error List panes and an option Layouts to manage the Layouts.
ToolsTools 보고서를 만들고, 개체 및 데이터를 마이그레이션하는 명령을 포함 합니다.Contains commands to create reports, and migrate objects and data. 또한에 대 한 액세스를 제공 합니다 전역 설정 하 고 프로젝트 설정 대화 상자.Also provides access to the Global Settings and Project Settings dialog boxes.
도움말Help SSMA 데 및에 대 한 액세스를 제공 합니다 에 대 한 대화 상자.Provides access to SSMA Help and to the About dialog box.

출력 창과 오류 목록 창Output Pane and Error List Pane

합니다 보기 메뉴는 출력 창과 오류 목록 창 표시 유형을 전환 하려면 명령을 제공 합니다.The View menu provides commands to toggle the visibility of the Output pane and the Error List pane:

  • 출력 창 개체 변환과 개체 동기화 데이터 마이그레이션 중 SSMA에서 상태 메시지를 보여 줍니다.The output pane shows status messages from SSMA during object conversion, object synchronization, and data migration.

  • 오류 목록 창에 정렬 가능한 목록을의 오류, 경고 및 정보 메시지를 표시 합니다.The Error List pane shows error, warning, and informational messages in a sortable list.

관련 항목See Also

DB2 데이터를 SQL Server로 마이그레이션 (DB2ToSQL)Migrating DB2 Data into SQL Server (DB2ToSQL)
사용자 인터페이스 참조 (DB2ToSQL)User Interface Reference (DB2ToSQL)