SSMA for d b 2의에서 새로운 GUI 기능 (DB2ToSQL)New GUI features in SSMA for DB2 (DB2ToSQL)

SSMA 사용자 인터페이스의 새로운 기능을 설명합니다이.This chapter describes new features of SSMA User Interface.

레이아웃Layouts

이 기능을 사용 하면 두 개의 미리 정의 된 창 레이아웃 중 하나를 선택 하거나 자체 레이아웃을 만들 수 있습니다.This feature allows you to choose one of two predefined windows lay-out or create you own layout. 레이아웃 하위 메뉴에 액세스 하려면 보기 메뉴에서 가리키는 레이아웃 합니다.To access layout submenu, on the View menu point to Layouts. 하나를 선택할 수 있는 기존 레이아웃의 새 레이아웃을 추가 하거나 레이아웃을 관리 합니다.There you can choose one of the existing layouts, add new layout or manage layouts.

현재 레이아웃 추가Add Current Layout

현재 창 레이아웃을 저장 하려면 보기 메뉴의 레이아웃을 가리킨 다음 현재 레이아웃 추가 클릭 합니다.To save current windows layout, on the View menu point to Layouts, then click Add Current Layout.

미리 정의 된 레이아웃 선택Choose predefined layout

미리 정의 된 레이아웃 중 하나를 선택 하려면 보기 메뉴의 레이아웃을 가리킨 다음 기본 레이아웃 또는 없이 탐색기를 클릭 합니다.To choose one of the predefined layouts, on the View menu point to Layouts, then click Default Layout or Without Explorers. 또한 미리 정의 된 레이아웃에 대 한 바로 가기 키 Ctrl + Alt + 1 또는 Ctrl + Alt + 2를 사용할 수 있습니다.You can also use shortcuts Ctrl+Alt+1 or Ctrl+Alt+2 for predefined layouts.

사용자 지정 레이아웃 선택Choose user-defined layout

사용자 지정 레이아웃을 선택 하려면 보기 메뉴의 레이아웃을 가리킨 다음 사용자 지정 레이아웃 중 하나를 클릭 합니다.To choose user-defined layout, on the View menu point to Layouts, then click one of the user-defined layout. 레이아웃에 대해 정의 된 바로 가기 키를 사용할 수 있습니다.You can also use shortcuts defined for the layouts.

레이아웃 관리Manage layouts

레이아웃 관리 대화 상자를 열려면 보기 메뉴의 레이아웃 가리킨 레이아웃 관리를 클릭 합니다.To open Manage Layouts dialog, on the View menu point to Layouts and click Manage Layouts. 레이아웃 관리 대화 상자에서 있습니다 기존 레이아웃 목록이 대화 상자의 왼쪽에 있습니다.In the Manage Layouts dialog you will find a list of the existing layouts on the left side of the dialog. 없는 해당 설정을 변경 하려면 레이아웃을 선택할 수 있습니다.There you can select the layout to change its settings. 목록에서 레이아웃 순서를 변경 하거나 목록 맨 위에 있는 단추를 사용 하 여 레이아웃 삭제할 수도 있습니다.Also you can change layouts order in the list or delete the layout using buttons on the top of the list. 대화 상자 오른쪽에 다음과 같은 레이아웃 설정을 변경할 수 있습니다.On the right side of the dialog you can change the following layout settings:

  • 레이아웃 이름Layout name

  • 메타 데이터 탐색기의 동기화Synchronization of metadata explorers

  • 표시 유형 및 원본 및 대상 메타 데이터 탐색기의 너비Visibility and width of the source and target metadata explorers

  • 원본 또는 대상 창 및 해당 크기의 표시 유형Visibility of the source or target windows and their sizes

  • 표시 유형 및 보조 창의 높이Visibility and height of auxiliary windows

책갈피Bookmarks

이 기능을 사용 하면 소스에서 하나 이상의 책갈피를 설정할 수 있습니다 또는 빠른 대상 코드 바로 가기 키를 사용 하 여 책갈피를 찾을 수, 친숙 한 대화 상자와 책갈피 관리 합니다.This feature allows you to set one or more bookmarks in the source or target code, quick found a bookmark by using shortcuts, manage the bookmarks with a friendly dialog.

책갈피 설정/해제Toggle Bookmark

있습니다 수 집합/제거 책갈피 다음과 같은 방법으로:You can set/remove a bookmark in the following ways:

  • 책갈피 설정/해제 단추를 사용 하 여 원본 또는 대상 SQL 창의 맨 위에 표시Use button Toggle Bookmark on top of source or target SQL window

  • SQL 창 왼쪽에 회색 영역을 클릭 합니다.Click on the grey area on the left of the SQL window

  • Ctrl + Shift를 사용 하 여 +<0..9> 번호가 매겨진된 책갈피를 설정 하려면Use Ctrl+Shift+<0..9> to set numbered bookmark

책갈피 탐색Bookmark navigation

다음과 같은 방법으로 책갈피를 통해 연습할 수 있습니다.You can walk thru the bookmarks in the following ways:

  • 이전 책갈피 SQL 창 맨 위에 있는 단추 다음 책갈피를 사용 하 여Use buttons Next Bookmark, Previous Bookmark on the top of the SQL window

  • Ctrl +<0..9> 번호가 매겨진된 책갈피를 찾을 수Use Ctrl+<0..9> to find numbered bookmark

  • 책갈피 관리 대화 상자에서 이동 또는 소스 보기 단추를 사용 하 여Use buttons Go To or View Source in Manage Bookmarks dialog

책갈피를 제거합니다.Removing Bookmark

다음과 같은 방법으로 책갈피를 제거할 수 있습니다.You can remove a bookmark in the following ways:

  • SQL 창 맨 위에 있는 지우기 단추를 사용 하 여 현재 문서에서 모든 책갈피를 제거 하려면Use button Clear on the top of the SQL window to remove all bookmarks in the current document

  • 책갈피 관리 대화 상자에서 또는 모두 제거 단추를 사용 하 여Use buttons Remove or Remove All in Manage Bookmarks dialog

책갈피 관리Manage bookmarks

책갈피 관리 대화 상자를 열려면 편집 메뉴에서 관리 하는 책갈피를 클릭 합니다.To open Manage Bookmarks dialog, on the Edit menu click Manage Bookmarks. 대화 상자에서 기존 책갈피의 목록이 표시 됩니다.In the dialog you will see a list of existing bookmarks. 책갈피를 관리 하는 대화 상자의 오른쪽에 단추를 사용할 수 있습니다.You can use the buttons on the right side of the dialog to manage the bookmarks.

개체 기록Object History

GUI 개체 기록 하면 다음과 같은 이점을 개체를 탐색할 때:GUI Object History lets you the following advantages when you navigate objects:

  • 뒤로 이동 하 고 앞으로 이동 단추를 사용 하 여 이미 방문한 개체를 탐색할 수 있습니다.You can use Go Back and Go Forward buttons to navigate the objects you have already visited

  • 남아 있는 동일한 탭에 백업 하면 개체에 백업 하는 경우When you back to the object, you back to the same tab that you have left

  • 남아 있는 같은 커서 위치에 백업 하는 개체 고 탭 SQL 경우When you back to the object and the tab is SQL, you back to the same cursor position that you have left

고급 검색 기능Advanced search capabilities

고급 검색 기능 강력 하 고 유연한 검색 기능을 제공 하 고 개체 선언 찾기, 개체 정보를 얻을 빠른 검색을 수행, 고급 개체 등의 패턴을 사용 하 여 범주에서 검색을 수행할 수 있습니다.Advanced search capabilities provide the powerful and flexible searching features and let you to find object declaration, get object information, perform quick search, perform advanced object searching in categories using patterns etc.

빠른 정보 가져오기Get quick information

다음과 같은 방법으로 커서 위치에 있는 개체에 대 한 요약 정보를 얻을 수 있습니다.You can get quick information on the object at the cursor position in the following ways:

  • SQL 창 맨 위에 있는 요약 정보 단추를 클릭 합니다.Click button Quick Info on the top of SQL window

  • 요약 정보 팝업 오른쪽 클릭 메뉴에서 선택Select Quick Info in the right-click pop-up menu

  • Ctrl + Shift + 스페이스바를 누릅니다.Press Ctrl+Shift+Space

선언 찾기Find declaration

다음과 같은 방법으로 커서 위치에 있는 개체의 선언으로 이동할 수 있습니다.You can go to the declaration of the object at cursor position in the following ways:

  • SQL 창 맨 위에 선언으로 이동 단추를 클릭Click button Go To Declaration on top of the SQL window

  • 선언으로 이동 팝업 오른쪽 클릭 메뉴에서 선택Select Go To Declaration in the right-click pop-up menu

  • F12 키를 누릅니다Press F12

다음과 같은 기능을 사용 하 여 빠른 텍스트 검색을 수행할 수 있습니다.You can perform quick text search using the following features:

  • 바로 가기 Ctrl + F를 사용 하 여 검색을 시작할 수 있습니다.You can start searching by using Ctrl+F shortcut

  • F3를 사용 하 여 마지막 검색 앞으로 반복할 수 있습니다.You can repeat last search forward by using F3

  • Shift + f 3을 사용 하 여 이전 버전과 마지막 검색을 반복할 수 있습니다.You can repeat last search backward by using Shift+F3

  • Ctrl + f 3을 사용 하 여 커서 위치에 단어의 다음 항목을 찾을 수 있습니다.You can find next occurrence of the word at the cursor position by using Ctrl+F3

  • Ctrl + Shift + f 3을 사용 하 여 커서 위치에 단어의 이전 항목을 찾을 수 있습니다.You can find previous occurrence of the word at the cursor position by using Ctrl+Shift+F3

  • 메뉴 항목과 함께 이러한 모든 동작을 수행할 수도 있습니다.You can also perform all these actions with menu items.

편집 메뉴 지점 찾기에서 고급 검색 대화 상자를 열려면 고급 검색을 클릭 합니다.To open Advanced Search dialog, on the Edit menu point Find, then click Advanced Search. 대화 상자에서 패턴을 사용 하 여 모든 개체를 찾을 수 있습니다.In the dialog you will be able to find any object using pattern. 대화 상자 맨 위에 검색 영역 및 개체 범주를 선택할 수 있습니다.On the top of the dialog you can choose search area and object categories.