프로젝트 옵션 설정 (MySQLToSQL)Setting Project Options (MySQLToSQL)

각 SSMA 프로젝트에 대해 프로젝트 수준의 옵션을 설정할 수 있습니다.For each SSMA project, you can set project-level options. 이러한 옵션에는 개체를 변환 하는 방법을, 데이터가 마이그레이션되는 방식 및 원본 데이터 형식이 대상 데이터 형식으로 매핑되는 방법을 지정 합니다.These options specify how objects are converted, how data is migrated, and how source data types map to target data types. SQL Server 또는 SQL Azure에 개체를 변환 하거나 SQL Server 또는 SQL Azure로 데이터를 마이그레이션하려면 하기 전에 구성 옵션은 프로젝트에 적절 한지 확인 합니다.Before you convert objects to SQL Server or SQL Azure or migrate data into SQL Server or SQL Azure, verify that the configuration options are appropriate for the project.

SSMA를 사용 하면 모든 프로젝트에 대 한 기본 옵션을 구성할 수 있습니다.SSMA lets you configure the default options for all projects. 이러한 옵션은 만들어지는 모든 새 프로젝트에 적용 됩니다.These options are applied to any new project that you create. 그런 다음 각 프로젝트에 대 한 옵션을 사용자 지정할 수 있습니다.You can then customize the options for each project.

구성 옵션 및 모드Configuration Options and Modes

SSMA는 프로젝트 설정의 5 개 세트:SSMA has five sets of project settings:

  • 프로젝트 정보Project Information

  • 일반 (변환, 마이그레이션 및 SQL Azure)General (Conversion, Migration and SQL Azure)

  • SynchronizationSynchronization

  • GUIGUI

  • 형식 매핑Type Mapping

프로젝트 설정 네 가지 방법으로 구성할 수 있습니다.The project settings can be configured in four ways:

  • 기본값Default

  • OptimisticOptimistic

  • 전체Full

  • 사용자 지정Custom

대부분의 사용자에 대 한 기본 모드를 사용 하는 것이 좋습니다.The Default mode is recommended for most users. 최적 모드 중 현재 MySQL 구문을 유지 되며 더 쉽게 읽을 수 있습니다.The Optimistic mode keeps more of the current MySQL syntax, and is easier to read. 그러나 현재 구문을 유지 하지 정확할 수도 있습니다.However, keeping current syntax might not be accurate. MySQL 구문 해당 SQL Server 또는 SQL Azure 구문으로 변환 해야, 하는 경우 전체 모드에서 가장 완벽 변환을 수행 합니다.If the MySQL syntax must be converted to equivalent SQL Server or SQL Azure syntax, the Full mode performs the most complete conversion. 그러나 결과 코드를 수 있습니다 읽기가 더 어려워집니다.The resulting code, however, might be more difficult to read. 사용자 지정 모드 옵션을 설정할 수 있습니다.In the Custom mode, you can set the options.

설정과 각 모드에서 설정이 적용 되는 방식을 대 한 자세한 내용은 다음 항목을 참조 합니다.For more information about the settings and how the settings are applied in each mode, see the following topics:

프로젝트 옵션 설정Setting Project Options

SSMA를 모든 프로젝트에 대 한 기본 설정을 구성할 수 있습니다.In SSMA, you can configure default settings for all projects. 이러한 설정은 SSMA 구성 파일에 저장 되며 만드는 모든 새 프로젝트에 적용 됩니다.These settings are saved to the SSMA configuration file and applied to any new project that you create.

기본 프로젝트 옵션을 설정 하려면To set default project options

  1. 도구 메뉴를 클릭 하 여 기본 프로젝트 설정합니다.On the Tools menu, click Default Project Settings.

  2. 기본 프로젝트 설정 대화 상자에서 다음 절차 중 하나를 사용 합니다.In the Default Project Settings dialog box, use one of the following procedures:

    1. 설정을 볼 /에서 변경 하는 데 필요한는 마이그레이션 프로젝트 형식을 선택 마이그레이션 대상 버전 드롭다운을 클릭 일반 선택 고 왼쪽된 창 맨 아래에 변환 하거나 마이그레이션 또는 SQL Azure 옵션입니다.Select migration project type for which settings are required to be viewed / changed from Migration Target Version drop down, click General at the bottom of the left pane, and then select Conversion or Migration or SQL Azure option.

    2. 미리 정의 된 모드를 선택 하려면 선택 기본, Optimistic, 또는 전체 에서 모드 드롭다운 상자입니다.To select a predefined mode, select Default, Optimistic, or Full from the Mode drop-down box.

    3. 사용자 지정 설정을 지정 하려면에서 선택 하거나 새 설정이 나 값을 입력 합니다.To specify custom settings, select or enter the new settings or values.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

또한 현재 프로젝트에 대 한 설정을 사용자 지정할 수 있습니다.You can also customize the settings for the current project. 설정은 현재 프로젝트 파일에 저장 됩니다.The settings get saved to the current project file.

현재 프로젝트에 대 한 설정을 사용자 지정 하려면To customize settings for the current project

  1. 도구 메뉴를 클릭 하 여 ProjectSettings합니다.On the Tools menu, click ProjectSettings.

  2. ProjectSettings 대화 상자에서 다음 절차 중 하나를 사용 합니다.In the ProjectSettings dialog box, use one of the following procedures:

    1. 미리 정의 된 모드를 선택 하려면 선택 기본, Optimistic, 또는 전체 에서 모드 드롭다운 상자입니다.To select a predefined mode, select Default, Optimistic, or Full from the Mode drop-down box.

    2. 사용자 지정 모드를 지정 하려면 사용자 지정 에서 모드 드롭다운 상자입니다.To specify a custom mode, select Custom from the Mode drop-down box. 선택한 후 적절 한 프로젝트 설정 합니다.And then select the appropriate project settings.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

다음 단계Next Step

다음 단계는 마이그레이션에서 프로젝트 요구 사항에 따라 달라 집니다.The next step in the migration depends on your project needs:

관련 항목:See Also

MySQL 및 SQL Server 데이터 형식 ( 매핑 MySQLToSQL )Mapping MySQL and SQL Server Data Types (MySQLToSQL)