SSMA 프로젝트 (MySQLToSQL) 작업Working with SSMA Projects (MySQLToSQL)

MySQL 데이터베이스를 SQL Server 또는 SQL Azure에 마이그레이션하려면 SSMA 프로젝트를 먼저 만들어야 할 합니다.To migrate MySQL databases to SQL Server or SQL Azure, you must first create an SSMA project. 프로젝트는 다음 정보를 포함 하는 파일입니다.The project is a file that contains the following information:

  • SQL Server 또는 SQL Azure로 마이그레이션하려는 MySQL 데이터베이스에 대 한 메타 데이터입니다.Metadata about the MySQL databases that you want to migrate to SQL Server or SQL Azure.

  • 마이그레이션된 개체 및 데이터를 받을 SQL Azure 또는 SQL Server의 대상 인스턴스에 대 한 메타 데이터입니다.Metadata about the target instance of SQL Server or SQL Azure that will receive the migrated objects and data.

  • SQL Server 또는 SQL Azure 연결 정보입니다.SQL Server or SQL Azure connection information.

  • 프로젝트 설정 합니다.Project settings.

프로젝트를 열 때 MySQL 및 SQL Server 또는 SQL Azure에서 연결이 끊어지도록 합니다.When you open a project, it is disconnected from MySQL and SQL Server or SQL Azure. 기능을 사용 하면 오프 라인으로 작업할 수 있습니다.That lets you work offline. SQL Server에 다시 연결 하는 방법에 대 한 자세한 내용은 참조 SQL Server (에 연결 MySQLToSQL )For more information about reconnecting to SQL Server, see Connecting to SQL Server (MySQLToSQL)

기본 프로젝트 설정 검토Reviewing Default Project Settings

SSMA 변환 하 고 데이터베이스를 로드, 데이터를 마이그레이션 및 MySQL 및 SQL Server 또는 SQL Azure와 SSMA 동기화에 대 한 몇 가지 설정을 포함 합니다.SSMA contains several settings for converting and loading database, migrating data, and synchronizing SSMA with MySQL and SQL Server or SQL Azure. 기본 설정은 많은 사용자에 대 한 적절 한입니다.The default settings are appropriate for many users. 그러나 새 SSMA 프로젝트를 만들기 전에 설정을 검토 해야 합니다.However, before you create a new SSMA project, you should review the settings. 필요한 경우에 모든 새 프로젝트에 사용할 기본 설정을 변경할 수 있습니다.If required, you can change the default settings that will be used for all your new projects.

기본 프로젝트 설정을 검토 하려면To review default project settings
  1. 선택 기본 프로젝트 설정 에서 도구 메뉴.Select Default Project Settings from the Tools menu.

  2. 프로젝트 형식을 선택 마이그레이션 대상 버전 볼 / 변경할 수 있는 설정이 하 고 클릭 한 다음에 대 한 드롭다운 일반 탭 합니다.Select the project type in Migration Target Version drop down for which settings are to be viewed/ changed and then click General tab.

  3. 왼쪽된 창에서 클릭 변환합니다.In the left pane, click Conversion.

  4. 오른쪽 창에서 검토 하 고 필요에 따라 설정을 변경 합니다.In the right pane, review and change the settings as necessary. 이러한 설정에 대 한 자세한 내용은 참조 프로젝트 설정 ( 변환 ) ( MySQLToSQL ) .For more information about these settings, see Project Settings (Conversion) (MySQLToSQL) .

  5. 마이그레이션, 동기화, SQL Azure, GUI 및 유형 매핑 페이지에 대 한 1-3 단계를 반복 합니다.Repeat steps 1-3 for the Migration, Synchronization, SQL Azure, GUI, and Type Mapping pages.

참고

SQL Azure 설정을 선택한 경우에 표시 됩니다 SQL Azure로의 마이그레이션을 프로젝트를 만드는 동안 합니다.The SQL Azure settings will be displayed only when you select Migration to SQL Azure while creating a project.

새 프로젝트 만들기Creating New Projects

데이터를 마이그레이션하려면 MySQL 데이터베이스에서 SQL Server 또는 SQL Azure에 프로젝트를 만들어야 합니다.To migrate data from MySQL databases to SQL Server or SQL Azure, you must create a project.

새 프로젝트를 만들려면To create a new project
  1. 선택 새 프로젝트 에서 파일 메뉴.Select New Project from the File menu. 새 프로젝트 대화 상자가 나타납니다.The New Project dialog box appears. 파일 메뉴에서 새 프로젝트를 선택합니다.On the File menu, select New Project. 새 프로젝트 대화 상자가 나타납니다.The New Project dialog box appears.

  2. 이름 입력란에 프로젝트 이름을In the Name box, enter a name for your project.

  3. 위치 입력란에 입력 하거나 프로젝트에 대 한 폴더를 선택 합니다.In the Location box, enter or select a folder for the project.

  4. 마이그레이션에 대상 버전을 선택한 SQL ServerSQL Server 마이그레이션에 사용 합니다.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. 사용할 수 있는 옵션이 있습니다.The options available are:

    • SQL ServerSQL Server 2005 2005

    • SQL ServerSQL Server 2008 2008

    • SQL ServerSQL Server 2012 2012

    • SQL ServerSQL Server 2014 2014

    • Azure SQL DBAzure SQL DB

클릭 하 고 확인And then Click OK

SSMA는 프로젝트 파일을 만듭니다.SSMA creates the project file.

프로젝트 설정 사용자 지정Customizing Project Settings

기본값 정의 외에도 모든 새 SSMA 프로젝트에 적용 되는 프로젝트 설정 각 프로젝트에 대 한 설정을 사용자 지정할 수도 있습니다.In addition to defining the default project settings that apply to all the new SSMA projects you can also customize the settings for each project. 자세한 내용은 참조 프로젝트 옵션 설정 ( MySQLToSQL ) .For more information, see Setting Project Options (MySQLToSQL).

원본 및 대상 데이터베이스 간에 데이터 형식 매핑을 사용자 지정 프로젝트, 데이터베이스 또는 개체 수준에서 매핑 정의할 수 있습니다.When you customize data type mappings between the source and target databases, you can define mappings at the project, database, or object level. 자세한 내용은 참조 매핑 MySQL 및 SQL Server 데이터 형식 ( MySQLToSQL ) .For more information, see Mapping MySQL and SQL Server Data Types (MySQLToSQL).

프로젝트 저장Saving Projects

프로젝트 저장 기능에 사용자를를 기본적으로 SSMA 프로젝트 파일을 프로젝트 설정 및 필요에 따라 데이터베이스 메타 데이터를 저장할 수 있습니다.The Saving Projects feature allows the user to essentially save the project settings and, optionally, the database metadata to the SSMA project file.

프로젝트를 저장 하려면To save a project
  • 파일 메뉴 선택 저장 프로젝트.On the File menu, select Save Project.

데이터베이스 프로젝트 내에서 변경 된 변환 하지 않은 경우 SSMA 하 라는 메시지가 나타납니다 로드 하 고 메타 데이터를 저장 합니다.If databases within the project have changed or have not been converted, SSMA will prompt you to load and save metadata. 로드 및 메타 데이터를 저장 합니다. 오프 라인으로 작업할 수 있습니다.Loading and saving metadata lets you work offline. 또한 기술 지원 담당자와 같은 다른 사람에 게 전체 프로젝트 파일을 보낼 수 있습니다.It also lets you send a complete project file to other people, such as technical support personnel. 메타 데이터를 저장 하는 메시지가 다음을 수행 합니다.If you are prompted to save metadata, do the following:

  1. 상태를 보여 주는 각 데이터베이스에 대해 메타 데이터 누락, 데이터베이스 이름 옆에 있는 확인란을 선택 합니다.For each database that shows a status of Metadata missing, select the check box next to the database name. 메타 데이터를 저장 하면 몇 분 정도 걸릴 수 있습니다.Saving metadata might take several minutes. 이 시점에서 메타 데이터를 저장 하지 않을 경우 모든 확인란을 선택 하지 마십시오.If you do not want to save metadata at this point, do not select any check boxes.

  2. 저장을 클릭합니다.Click Save.

SSMA는 MySQL 스키마를 구문 분석 하 고 프로젝트 파일에 메타 데이터를 저장 합니다.SSMA will parse the MySQL schemas and save the metadata to the project file.

프로젝트 열기Opening Projects

프로젝트를 열 때 MySQL 및 SQL Server 또는 SQL Azure에서 연결이 끊어집니다.When you open a project, it is disconnected from MySQL and from SQL Server or SQL Azure. 이렇게 하면 오프 라인으로 작업할 수 있습니다.This lets you work offline. 메타 데이터를 업데이트 하려면 SQL Server 또는 SQL Azure에 데이터베이스 개체를 로드 합니다.To update metadata, load database objects into SQL Server or SQL Azure. 데이터를 마이그레이션하려면 SQL Server 또는 SQL Azure에 다시 연결 해야 합니다.To migrate data, you must reconnect to SQL Server or SQL Azure.

프로젝트를 열려면To open a project
  1. 다음 절차 중 하나를 사용 합니다.Use one of the following procedures:

    1. 파일 메뉴에서 최근에 사용한 프로젝트합니다.On the File menu, point to Recent Projects.

    2. 열려는 프로젝트를 선택 합니다.Select the project you want to open.

    3. 파일 메뉴 선택 프로젝트 열기,.m2ssproj 프로젝트 파일, 파일을 찾은 다음 클릭 열려합니다.On the File menu, select Open Project, locate the .m2ssproj project file, select the file, and then click Open.

  2. MySQL에 다시 연결 하는 파일 메뉴 선택 MySQL에 다시 연결합니다.To reconnect to MySQL, on the File menu, select Reconnect to MySQL.

  3. SQL server에 다시 연결 하는 파일 메뉴 선택 SQL Server에 다시 연결합니다.To reconnect to SQL Server, on the File menu, select Reconnect to SQL Server.

  4. SQL Azure에 다시 연결 하는 파일 메뉴 선택 SQL Azure에 다시 연결 합니다.To reconnect to SQL Azure, on the File menu, select Reconnect to SQL Azure.

다음 단계Next Step

마이그레이션 프로세스의 다음 단계는 MySQL (에 연결 MySQLToSQL )The next step in the migration process is Connecting to MySQL (MySQLToSQL)

관련 항목:See Also

MySQL (에 연결 MySQLToSQL )Connecting to MySQL (MySQLToSQL)
Azure SQL DB ( SQL Server-MySQL 데이터베이스 마이그레이션 MySQLToSql )Migrating MySQL Databases to SQL Server - Azure SQL DB (MySQLToSql)
SQL Server (에 연결 MySQLToSQL )Connecting to SQL Server (MySQLToSQL)
Azure SQL DB (에 연결 MySQLToSQL )Connecting to Azure SQL DB (MySQLToSQL)