SSMA 프로젝트 (OracleToSQL) 작업Working with SSMA Projects (OracleToSQL)

Oracle 데이터베이스를 마이그레이션하려면 SQL ServerSQL Server, SSMA 프로젝트를 만들어야 합니다.To migrate Oracle databases to SQL ServerSQL Server, you first create an SSMA project. 프로젝트는 다음 정보를 포함 하는 파일입니다.The project is a file that contains the following information:

  • 로 마이그레이션하려는 Oracle 데이터베이스에 대 한 메타 데이터 SQL ServerSQL Server합니다.Metadata about the Oracle databases you want to migrate to SQL ServerSQL Server.

  • 대상 인스턴스에 대 한 메타 데이터 SQL ServerSQL Server 마이그레이션된 개체 및 데이터를 받습니다.Metadata about the target instance of SQL ServerSQL Server that will receive the migrated objects and data.

  • SQL ServerSQL Server연결 정보입니다. connection information.

  • 프로젝트 설정 합니다.Project settings.

프로젝트를 열 때 Oracle에서 연결이 끊어지도록 및 SQL ServerSQL Server합니다.When you open a project, it is disconnected from Oracle and SQL ServerSQL Server. 기능을 사용 하면 오프 라인으로 작업할 수 있습니다.That lets you work offline. 에 다시 연결 하는 방법에 대 한 내용은 SQL ServerSQL Server, 참조 SQL Server ( OracleToSQL )에 연결합니다.For information about reconnecting to SQL ServerSQL Server, see Connecting to SQL Server (OracleToSQL).

기본 프로젝트 설정 검토Reviewing Default Project Settings

SSMA 변환 및 마이그레이션 데이터를 데이터베이스 개체를 로드 및 Oracle과 SSMA를 동기화에 대 한 몇 가지 설정을 포함 하 고 SQL ServerSQL Server합니다.SSMA contains several settings for converting and loading database objects, migrating data, and synchronizing SSMA with Oracle and SQL ServerSQL Server. 기본 설정은 많은 사용자에 대 한 적절 한입니다.The default settings are appropriate for many users. 그러나 새 SSMA 프로젝트를 만들기 전에 설정을 검토 해야 합니다.However, before you create a new SSMA project, you should review the settings. 원하는 경우에 모든 새 프로젝트에 사용할 기본 설정을 변경할 수 있습니다.If you want to, you can change the default settings that will be used for all your new projects.

기본 프로젝트 설정을 검토 하려면To review default project settings

  1. 도구 메뉴를 클릭 하 여 기본 프로젝트 설정합니다.On the Tools menu, click Default Project Settings.

  2. 프로젝트 형식을 선택 마이그레이션 대상 버전 어떤 설정이 보거나 변경 하는 데 필요 하 고 클릭 한 다음에 대 한 드롭다운 일반 탭 합니다.Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. 왼쪽된 창에서 클릭 변환합니다.In the left pane, click Conversion.

  4. 오른쪽 창에서 검토 하 고 필요에 따라 설정을 변경 합니다.In the right pane, review and change the settings as necessary. 이러한 설정에 대 한 자세한 내용은 참조 프로젝트 설정 ( 변환 ) ( OracleToSQL ) .For more information about these settings, see Project Settings (Conversion) (OracleToSQL).

  5. 마이그레이션, 동기화, 시스템 개체를 로드, GUI 및 유형 매핑 페이지에 대 한 1-3 단계를 반복 합니다.Repeat Steps 1-3 for the Migration, Synchronization, Loading System Objects, GUI, and Type Mapping pages.

새 프로젝트 만들기Creating New Projects

Oracle 데이터베이스에서 데이터를 마이그레이션하도록 SQL ServerSQL Server, 프로젝트를 먼저 만들어야 합니다.To migrate data from Oracle databases to SQL ServerSQL Server, you must first create a project.

프로젝트를 만들려면To create a project

  1. 파일 메뉴를 클릭 하 여 새 프로젝트합니다.On the File menu, click New Project.

    새 프로젝트 대화 상자가 나타납니다.The New Project dialog box appears.

  2. 이름 입력란에 프로젝트 이름을In the Name box, enter a name for your project.

  3. 위치 상자 입력 하거나 프로젝트에 대 한 폴더를 선택 하 고 클릭 확인합니다.In the Location box, enter or select a folder for the project, and then click OK.

  4. 마이그레이션에 대상 버전을 선택한 SQL ServerSQL Server 마이그레이션에 사용 합니다.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. 사용할 수 있는 옵션이 있습니다.The options available are:

    • SQL ServerSQL Server 2005 2005

    • SQL ServerSQL Server 2008 2008

    • SQL ServerSQL Server 2014 2014

    • SQL ServerSQL Server 2016 2016

    • Azure SQL DBAzure SQL DB

프로젝트 설정 사용자 지정Customizing Project Settings

에 모든 새 SSMA 프로젝트에 적용 되는 기본 프로젝트 설정을 정의 하는 것 외에도 각 프로젝트에 대 한 설정을 사용자 지정할 수 있습니다.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. 자세한 내용은 참조 프로젝트 옵션 설정 ( OracleToSQL )합니다.For more information, see Setting Project Options (OracleToSQL).

원본 및 대상 데이터베이스 간에 데이터 형식 매핑을 사용자 지정 프로젝트, 데이터베이스 또는 개체 수준에서 매핑 정의할 수 있습니다.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. 자세한 내용은 참조 매핑 Oracle 및 SQL Server 데이터 형식 ( OracleToSQL )합니다.For more information, see Mapping Oracle and SQL Server Data Types (OracleToSQL).

프로젝트 저장Saving Projects

프로젝트를 저장 하면 SSMA 프로젝트 설정 및 필요에 따라 프로젝트 파일에는 데이터베이스 메타 데이터를 유지 합니다.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

프로젝트를 저장 하려면To save a project

  • 파일 메뉴를 클릭 하 여 프로젝트 저장합니다.On the File menu, click Save Project.

    프로젝트의 스키마 변경 변환 하지 않은 경우 SSMA 하 라는 메시지가 나타납니다 로드 하 고 메타 데이터를 저장 합니다.If schemas in the project have changed or have not been converted, SSMA will prompt you to load and save metadata. 로드 및 메타 데이터를 저장 하면 오프 라인으로 작업 합니다.Loading and saving metadata will let you work offline. 또한 기술 지원 담당자와 같은 다른 사람에 게 전체 프로젝트 파일을 보낼 수 있습니다.It also lets you send a complete project file to other people, such as technical support personnel. 메타 데이터를 저장 하는 메시지가 다음을 수행 합니다.If you are prompted to save metadata, do the following:

    1. 상태를 보여 주는 각 스키마에 대해 메타 데이터 누락, 데이터베이스 이름 옆에 있는 확인란을 선택 합니다.For each schema that shows a status of Metadata missing, select the check box next to the database name.

      메타 데이터를 저장 하면 몇 분 정도 걸릴 수 있습니다.Saving metadata might take several minutes. 메타 데이터를 아직 저장 하지 않을 경우 모든 확인란을 선택 하지 마십시오.If you do not want to save metadata yet, do not select any check boxes.

    2. 클릭는 저장 단추입니다.Click the Save button.

      SSMA는 Oracle 스키마를 구문 분석 하 고 프로젝트 파일에 메타 데이터를 저장 합니다.SSMA will parse the Oracle schemas and save the metadata to the project file.

프로젝트 열기Opening Projects

프로젝트를 열 때 연결이 끊어지도록 및 Oracle에서 SQL ServerSQL Server합니다.When you open a project, it is disconnected from Oracle and from SQL ServerSQL Server. 기능을 사용 하면 오프 라인으로 작업할 수 있습니다.That lets you work offline. 메타 데이터를 업데이트 하려면 데이터베이스 개체에 로드 SQL ServerSQL Server합니다.To update metadata, load database objects into SQL ServerSQL Server. Oracle에 연결 해야 데이터를 마이그레이션하려면 및 SQL ServerSQL Server합니다.To migrate data, you must reconnect to Oracle and SQL ServerSQL Server.

프로젝트를 열려면To open a project

  1. 다음 절차 중 하나를 사용 합니다.Use one of the following procedures:

    • 파일 메뉴에서 최근에 사용한 프로젝트, 한 다음 열려는 프로젝트를 클릭 합니다.On the File menu, point to Recent Projects, and then click the project you want to open.

    • 파일 메뉴 선택 프로젝트 열기,.o2ssproj 프로젝트 파일, 파일을 찾은 다음 클릭 열려합니다.On the File menu, select Open Project, locate the .o2ssproj project file, select the file, and then click Open.

  2. Oracle에 다시 연결할는 파일 메뉴를 클릭 하 여 Oracle에 다시 연결합니다.To reconnect to Oracle, on the File menu, click Reconnect to Oracle.

  3. 에 다시 연결할 SQL ServerSQL Server파일 메뉴를 클릭 하 여 SQL Server에 다시 연결합니다.To reconnect to SQL ServerSQL Server, on the File menu, click Reconnect to SQL Server.

다음 단계Next Step

마이그레이션 프로세스의 다음 단계에서는 Oracle 데이터베이스 (OracleToSQL)에 연결합니다.The next step in the migration process is to Connecting to Oracle Database (OracleToSQL).

관련 항목:See Also

SQL Server ( OracleToSQL ) Oracle 데이터베이스 마이그레이션Migrating Oracle Databases to SQL Server (OracleToSQL)
Oracle 데이터베이스 ( OracleToSQL )에 연결Connecting to Oracle Database (OracleToSQL)
SQL Server ( OracleToSQL )에 연결Connecting to SQL Server (OracleToSQL)