프로젝트 옵션 설정 (SybaseToSQL)Setting Project Options (SybaseToSQL)

각 SSMA 프로젝트에 대 한 프로젝트 수준 옵션을 설정할 수 있습니다.For each SSMA project, you can set project level options. 이러한 옵션에는 변환 개체, 개체 로드, SQL azure, 사용자 인터페이스 및 데이터 마이그레이션 설정을 지정합니다.These options specify object conversion, object loading, SQL azure, user interface, and data migration settings. 개체를 변환 하기 전에 SQL ServerSQL Server 또는 SQL Azure에 데이터를 마이그레이션하거나 SQL ServerSQL Server 또는 SQL Azure, 구성 옵션은 프로젝트에 대 한 적절 한지 확인 하십시오.Before you convert objects to SQL ServerSQL Server or SQL Azure or migrate data into SQL ServerSQL Server or SQL Azure, verify that the configuration options are appropriate for the project.

SSMA를 사용 하면 모든 프로젝트에 대 한 기본 옵션을 구성할 수 있습니다.SSMA lets you configure default options for all projects. 이러한 옵션은 만들 새 프로젝트에 적용 됩니다.These options are applied to any new project you create. 그런 다음 각 프로젝트에 대 한 옵션을 사용자 지정할 수 있습니다.You can then customize the options for each project.

구성 옵션 및 모드Configuration Options and Modes

SSMA는 프로젝트 설정의 5 개 세트:SSMA has five sets of project settings:

  1. 프로젝트 정보Project Information

  2. 일반 (변환, 마이그레이션 및 데이터 수집)General (Conversion, Migration and Collecting Data)

  3. SynchronizationSynchronization

  4. GUIGUI

  5. 형식 매핑Type Mapping

구성이 설정에 대 한 네 가지 모드에 있습니다.It also has four modes for configuring these settings:

  1. 기본값Default

  2. OptimisticOptimistic

  3. 전체Full

  4. 사용자 지정Custom

대부분의 사용자에 대 한 기본 모드를 사용 하는 것이 좋습니다.The Default mode is recommended for most users. 최적 모드 중 현재 Sybase 적응형 Server Enterprise (ASE) 구문을 유지 되며 더 쉽게 읽을 수 있습니다.The Optimistic mode keeps more of the current Sybase Adaptive Server Enterprise (ASE) syntax, and is easier to read. 그러나 현재 구문을 유지 하지 정확할 수도 있습니다.However, keeping current syntax might not be accurate. ASE 구문으로 변환 해야 SQL ServerSQL Server 또는 SQL Azure 구문, 전체 모드 전체 변환을 수행 하지만 결과 코드를 읽기가 어려울 수 있습니다.If the ASE syntax must be converted to equivalent SQL ServerSQL Server or SQL Azure syntax, the Full mode performs a complete conversion, but the resulting code might be more difficult to read. 사용자 지정 모드에서 옵션을 설정 합니다.In the Custom mode, you set the options.

설정은이 설명서의 사용자 인터페이스 참조 섹션에 설명 되어 있습니다.The settings are described in the User Interface Reference section of this documentation. 설정과 각 모드에서 설정이 적용 되는 방식을 대 한 자세한 내용은 다음 항목을 참조 합니다.For more information about the settings and how the settings are applied in each mode, see the following topics:

프로젝트 옵션 설정Setting Project Options

SSMA를 모든 프로젝트에 대 한 기본 설정을 구성할 수 있습니다.In SSMA, you can configure default settings for all projects. 이러한 설정은 SSMA 구성 파일에 저장 되며 만드는 모든 새 프로젝트에 적용 됩니다.These settings are saved to the SSMA configuration file and applied to any new project that you create.

기본 프로젝트 옵션을 설정 하려면To set default project options

  1. 도구 메뉴 선택 기본 프로젝트 설정합니다.On the Tools menu, select Default Project Settings.

  2. 기본 프로젝트 설정 대화 상자에서 다음 절차 중 하나를 사용 합니다.In the Default Project Settings dialog box, use one of the following procedures:

    • 설정을 보거나에서 변경 하는 데 필요한는 마이그레이션 프로젝트 형식을 선택 마이그레이션 대상 버전 drop 아래로 왼쪽 창의 맨 아래에 일반을 클릭 한 다음 변환 하거나 마이그레이션 또는 SQL Azure를 선택 합니다.Select migration project type for which settings are required to be viewed or changed from Migration Target Version drop down click General at the bottom of the left pane, and then select Conversion or Migration or SQL Azure.

    • 미리 정의 된 모드를 선택 하 고 모드 드롭다운 상자 기본, Optimistic, 또는 전체합니다.To select a predefined mode, in the Mode drop-down box, select Default, Optimistic, or Full.

    • 사용자 지정 설정을 지정 하려면에서 단순히 선택 하거나 새 설정이 나 값을 입력 합니다.To specify custom settings, simply select or enter the new settings or values.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

현재 프로젝트에 대 한 설정을 사용자 지정할 수도 있습니다.You can also customize settings for the current project. 이러한 설정은 현재 프로젝트 파일에 저장 됩니다.These settings are saved to the current project file.

현재 프로젝트에 대 한 설정을 사용자 지정 하려면To customize settings for the current project

  1. 도구 메뉴 선택 프로젝트 설정합니다.On the Tools menu, select Project Settings.

  2. 프로젝트 설정 대화 상자에서 다음 절차 중 하나를 사용 합니다.In the Project Settings dialog box, use one of the following procedures:

    • 미리 정의 된 모드를 선택 하 고 모드 드롭다운 상자 기본, Optimistic, 또는 전체합니다.To select a predefined mode, in the Mode drop-down box, select Default, Optimistic, or Full.

    • 사용자 지정 모드를 지정 하는 모드 드롭다운 선택 상자 사용자 지정에서 왼쪽된 창에서 옵션을 선택, 설정 또는 오른쪽 창에서 값을 클릭 한 다음 선택 하거나 새 설정 또는 값을 입력 합니다.To specify a custom mode, in the Mode drop down box, select Custom, select an option in the left pane, click the setting or value in the right pane, and then select or enter the new setting or value.

  3. 클릭 확인 설정을 저장할 수 있습니다.Click OK to save the settings.

다음 단계Next Steps

다음 단계는 마이그레이션에서 프로젝트 요구 사항에 따라 달라 집니다.The next step in the migration depends on your project needs:

참고 항목See Also

Azure SQL DB ( SQL Server-Sybase ASE 데이터베이스 마이그레이션 SybaseToSQL )Migrating Sybase ASE Databases to SQL Server - Azure SQL DB (SybaseToSQL)