메뉴 및 바로 가기 키 사용자 지정Customize Menus and Shortcut Keys

키보드 액셀러레이터를 사용하면 Alt+를 눌러 메뉴 명령이나 단추를 선택할 수 있습니다.A keyboard accelerator allows you to select a menu command or button by pressing ALT+. 예를 들어 편집 메뉴를 열려면 Alt+E를 누릅니다.For example, to open the Edit menu, press ALT+E. 사용자 지정 대화 상자를 사용하여 도구 모음 단추, 메뉴 및 메뉴 명령을 다시 정렬하고 수정할 수 있습니다.You can rearrange and modify toolbar buttons, menus, and menu commands by using the Customize dialog box. 여기에서는 마우스를 사용하거나 키보드만 사용하여 설정을 변경하기 위한 지침이 제공됩니다.Instructions are provided for changing the settings using the mouse and using only the keyboard.

Ctrl 키를 사용하는 저장 프로시저에 대한 키보드 액셀러레이터는 도구 옵션 대화 상자의/키보드 페이지에서 만들 수 있습니다.Keyboard accelerators for stored procedures using the Ctrl key can be created from the Keyboard page of the Tools/Options dialog box.

참고

이 페이지 상단의 모두 축소 를 클릭하면 제목만 표시됩니다.Click Collapse All at the top of this page to show only the headings.

마우스를 사용하여 키보드 액셀러레이터 대화 상자 열기Opening the Keyboard Accelerator Dialog Box Using the Mouse

마우스를 사용하여 키보드 액셀러레이터를 할당 또는 변경하기 위한 대화 상자에 액세스하려면To access the dialog box for assigning or changing a keyboard accelerator (using the mouse)

  1. 도구 메뉴에서 사용자 지정을 클릭합니다.On the Tools menu, click Customize.

  2. 변경할 도구 모음이 표시되는지 확인합니다.Make sure the toolbar you want to change is visible.

    1. 사용자 지정 대화 상자에서 도구 모음 탭을 클릭합니다.In the Customize dialog box, click the Toolbars tab.

    2. 표시할 도구 모음의 확인란을 선택합니다.Select the check box for the toolbar you want to display.

  3. 사용자 지정 대화 상자에서 명령 탭을 클릭합니다.In the Customize dialog box, click the Commands tab.

마우스를 사용하여 도구 모음 단추 액셀러레이터 키 변경Changing a Toolbar Buttons Accelerator Key Using the Mouse

마우스를 사용하여 도구 모음 단추의 키보드 액셀러레이터를 할당하거나 변경하려면To assign or change a toolbar button's keyboard accelerator (using the mouse)

  1. 도구 모음에서 단추를 클릭합니다.Click the button on the toolbar.

  2. 사용자 지정 대화 상자의 명령 탭에서 선택 사항 수정을 클릭합니다.In the Customize dialog box, on the Commands tab, click Modify Selection.

  3. 바로 가기 메뉴의 이름 상자에서 도구 모음 단추의 이름과 함께 키보드 액셀러레이터로 사용할 문자의 앞에 앰퍼샌드(&)를 입력합니다.In the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  4. Enter 키를 누릅니다.Press ENTER.

  5. 사용자 지정 대화 상자에서 닫기를 클릭합니다.In the Customize dialog box, click Close.

마우스를 사용하여 메뉴 명령 액셀러레이터 키 변경Changing a Menu Commands Accelerator Key Using the Mouse

마우스를 사용하여 메뉴 명령의 키보드 액셀러레이터를 할당하거나 변경하려면To assign or change a menu command's keyboard accelerator (using the mouse)

  1. 메뉴 모음이나 도구 모음에서 메뉴 이름을 클릭합니다.Click the menu name on the menu bar or toolbar.

  2. 메뉴 명령을 클릭합니다.Click the menu command.

  3. 사용자 지정 대화 상자에서 선택 사항 수정을 클릭합니다.In the Customize dialog box, click Modify Selection.

  4. 바로 가기 메뉴의 이름 상자에서 메뉴 명령의 이름과 함께 키보드 액셀러레이터로 사용할 문자의 앞에 앰퍼샌드(&)를 입력합니다.In the Name box on the shortcut menu, type a name for the menu command with an ampersand (&) before the letter that you want as the keyboard accelerator.

  5. Enter 키를 누릅니다.Press ENTER.

  6. 사용자 지정 대화 상자에서 닫기를 클릭합니다.In the Customize dialog box, click Close.

키보드를 사용하여 키보드 액셀러레이터 대화 상자 열기Opening the Keyboard Accelerator Dialog Box Using the Keyboard

키보드를 사용하여 키보드 액셀러레이터를 할당 또는 변경하기 위한 대화 상자에 액세스하려면To access the dialog box for assigning or changing a keyboard accelerator (using the keyboard)

  1. Alt+T를 누르고 C를 입력하여 사용자 지정 대화 상자를 엽니다.Press ALT+T, then type C, to open the Customize dialog box.

  2. 변경할 도구 모음이 표시되는지 확인합니다.Make sure the toolbar you want to change is visible.

    1. 사용자 지정 대화 상자에서 Alt+B를 눌러 도구 모음 탭을 표시합니다.In the Customize dialog box, press ALT+B to show the Toolbars tab.

    2. 화살표 키를 사용하여 표시할 도구 모음을 선택한 다음 스페이스바 를 사용하여 확인란을 선택합니다.Use the arrow keys to select the toolbar you want to display, then SPACE to select the check box.

  3. 사용자 지정 대화 상자에서 Alt+C를 눌러 명령 탭을 표시합니다.In the Customize dialog box, press ALT+C to display the Commands tab.

키보드를 사용하여 도구 모음 단추 액셀러레이터 키 변경Changing a Toolbar Buttons Accelerator Key Using the Keyboard

키보드를 사용하여 도구 모음 단추의 키보드 액셀러레이터를 할당하거나 변경하려면To assign or change a toolbar button's keyboard accelerator (using the keyboard)

  1. Alt+R을 눌러 명령 다시 정렬 대화 상자를 표시합니다.Press ALT+R to display the Rearrange Commands dialog box.

  2. 명령 다시 정렬 대화 상자에서 화살표 키를 사용하여 도구 모음을 선택합니다.In the Rearrange Commands dialog box, use the arrow keys to select Toolbar.

  3. 도구 모음 목록으로 이동한 다음 화살표 키를 사용하여 변경할 단추가 포함된 도구 모음을 선택하고 Enter키를 누릅니다.Tab to the Toolbar list, and use the arrow keys to select the toolbar that contains the button you want to change, and then press ENTER.

  4. 컨트롤 목록으로 이동한 다음 화살표 키를 사용하여 변경할 단추를 선택합니다.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  5. Alt+M을 눌러 선택 사항 수정을 선택합니다.Press ALT+M, to select Modify Selection.

  6. 바로 가기 메뉴의 이름 상자로 이동한 다음 도구 모음 단추의 이름과 함께 키보드 액셀러레이터로 사용할 문자의 앞에 앰퍼샌드(&)를 입력합니다.Tab to the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  7. Enter 키를 누릅니다.Press ENTER.

  8. 닫기 단추로 이동한 다음 Enter키를 누릅니다.Tab to the Close button, and then press ENTER.

키보드를 사용하여 메뉴 명령 액셀러레이터 키 변경Changing a Menu Commands Accelerator Key Using the Keyboard

키보드를 사용하여 메뉴 명령의 키보드 액셀러레이터를 할당하거나 변경하려면To assign or change a menu command's keyboard accelerator (using the keyboard)

  1. Alt+R을 눌러 명령 다시 정렬 대화 상자를 표시합니다.Press ALT+R to display the Rearrange Commands dialog box.

  2. 메뉴 모음 으로 이동한 다음 화살표 키를 사용하여 메뉴 모음 목록에서 원하는 메뉴를 선택하고 Enter키를 누릅니다.Tab to Menu Bar and then use the arrow keys to click the menu you want in the Menu Bar list, and then press ENTER.

  3. 컨트롤 목록으로 이동한 다음 화살표 키를 사용하여 변경할 단추를 선택합니다.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  4. Alt+M을 눌러 선택 사항 수정을 선택합니다.Press ALT+M, to select Modify Selection.

  5. 바로 가기 메뉴의 이름 상자로 이동한 다음 도구 모음 단추의 이름과 함께 키보드 액셀러레이터로 사용할 문자의 앞에 앰퍼샌드(&)를 입력합니다.Tab to the Name box on the shortcut menu, and type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  6. Enter 키를 누릅니다.Press ENTER.

  7. 사용자 지정 대화 상자에서 닫기를 클릭합니다.In the Customize dialog box, click Close.

저장 프로시저에 대한 키보드 액셀러레이터 만들기Creating a Keyboard Accelerator for a Stored Procedure

저장 프로시저에 대한 키보드 액셀러레이터를 만들려면To create a keyboard accelerator for a stored procedure

  1. 도구 메뉴에서 옵션을 클릭합니다.On the Tools menu, click Options.

  2. 키보드 페이지의 바로 가기 목록에서 사용되지 않는 키보드 조합을 선택합니다.On the Keyboard page, select an unused keyboard combination in the Shortcut list.

  3. 저장 프로시저 상자에 저장 프로시저 이름을 입력한 다음 확인을 클릭합니다.In the Stored Procedure box, type the stored procedure name, and then click OK.

메뉴에 새 항목 추가Adding a New Item to the Menu

메뉴에 새 항목을 추가하려면To add a new item to the menu

  1. 도구 메뉴에서 옵션을 클릭합니다.On the Tools menu, click Options.

  2. 사용자 지정 대화 상자의 명령 탭에서 새 메뉴를 클릭합니다.In the Customize dialog box, on the Commands tab, click New Menu.

  3. 명령 상자에서 새 메뉴 를 메뉴 모음으로 끌어 새 메뉴를 표시할 위치에 놓습니다.On the Commands box, drag New Menu to the menu bar and drop it where you want the new menu to appear.

  4. 메뉴에서 새 메뉴를 마우스 오른쪽 단추로 클릭하고 이름 상자에 새 메뉴의 이름을 입력합니다.On the menu, right-click New Menu, and in the Name box, type a name for the new menu.

  5. 사용자 지정 대화 상자에서 파일과 같은 범주를 선택하고 파일 열기와 같은 명령을 선택합니다.In the Customize dialog box, select category such as File, and select a command such as Open File. 명령을 새 메뉴로 끕니다.Drag the command to the new menu. 새 메뉴를 가리키면 메뉴가 확장됩니다.As you point to the new menu, the menu will expand. 명령을 확장된 메뉴에 놓습니다.Drop the command onto the expanded menu.

  6. 사용자 지정 대화 상자에서 닫기를 클릭합니다.In the Customize dialog box, click Close.

참고

일부 명령은 SQL Server Management StudioSQL Server Management Studio 에 관련 내용이 표시되는 경우에만 사용할 수 있습니다.Some commands are available only when SQL Server Management StudioSQL Server Management Studio is displaying relevant content. 메뉴에 사용할 수 있는 명령이 없으면 메뉴 항목을 사용할 수 없습니다.If no commands on the menu are available, the menu item will not be available.

관련 항목:See Also

SQL Server Management Studio의 기능Features in SQL Server Management Studio