외부 도구External Tools

이 항목 적용 대상: 예SQL Server예Azure SQL 데이터베이스예Azure SQL 데이터 웨어하우스 예 병렬 데이터 웨어하우스THIS TOPIC APPLIES TO: yesSQL ServeryesAzure SQL DatabaseyesAzure SQL Data Warehouse yesParallel Data Warehouse 이 대화 상자를 사용하여 SQL Server 구성 관리자 또는 메모장과 같은 외부 도구를 도구 메뉴에 추가할 수 있습니다. Use this dialog box to add external tools, such as SQL Server Configuration Manager or Notepad, to the Tools menu. 외부 도구를 추가하면 SQL Server Management StudioSQL Server Management Studio에서 작업하는 동안 간편하게 다른 응용 프로그램을 실행할 수 있습니다.Adding external tools allows you to easily launch other applications while working in SQL Server Management StudioSQL Server Management Studio. 도구를 실행할 때 인수 및 작업 디렉터리를 지정할 수 있습니다.You can specify arguments and a working directory when launching the tool. 또한 일부 도구의 출력을 출력 창에 표시할 수도 있습니다.In addition, the outputs from some tools can be displayed in the Output window. 외부 도구 대화 상자는 도구 메뉴에서 사용할 수 있습니다.The External Tools dialog box is available on the Tools menu.

옵션Options

메뉴 내용Menu Contents
현재 도구 메뉴에 추가된 항목의 제목을 나열합니다.Lists the titles of the items currently added to the Tools menu. 위로 이동아래로 이동 화살표를 사용하여 메뉴에 나타나는 항목의 순서를 변경할 수 있습니다.Use the Move Up and Move Down arrows to change the order the items that appear on the menu. 삭제 단추를 사용하여 메뉴에서 항목을 제거할 수 있습니다.Use the Delete button to remove an item from the menu.

위로 이동Move Up
선택한 도구를 도구 메뉴에 나타나는 도구 목록에서 위로 이동합니다.Move the selected tool higher in the list of tools that appear on the Tools menu.

아래로 이동Move Down
선택한 도구를 도구 메뉴에 나타나는 도구 목록에서 아래로 이동합니다.Move the selected tool lower in the list of tools that appear on the Tools menu.

추가Add
입력란의 내용을 지우고 새 도구를 지정할 수 있습니다.Clear the text boxes so you can specify a new tool.

삭제Delete
메뉴 내용 목록과 도구 메뉴에서 도구나 명령을 제거합니다.Remove the tool or command from the Menu Contents list as well as from the Tools menu.

TitleTitle
도구 메뉴의 외부 도구 하위 메뉴에 나타날 도구 또는 명령의 이름입니다.The name of the tool or command that will appear on the External Tools submenu of the Tools menu. 이름의 특정 문자를 도구의 액셀러레이터 키로 사용하려면 해당 문자 앞에 앰퍼샌드를 넣습니다.Place an ampersand before a letter in the name of the tool to use that letter as an accelerator key for the tool. 예를 들어 &Spy++도구 메뉴에 Spy++ 와 같이 표시됩니다.For example, &Spy++ would display Spy++ on the Tools menu.

CommandCommand
실행할 .exe, .com, .pif, .bat, .cmd 또는 기타 파일의 경로를 지정합니다.Specify the path to the .exe, .com, .pif, .bat, .cmd, or other file that you intend to launch. .bat출력 창 사용 .com확인란을 선택하면 출력 창에 , 및 기타 파일의 출력이 표시됩니다.The output from .bat, .com, and other files can be viewed in the Output window if you select the Use output window check box.

인수Arguments
메뉴에서 도구를 선택했을 때 도구로 전달되는 변수를 지정합니다.Specify the variables that are passed to the tool when the tool is selected on the menu. 인수는 도구 또는 명령이 실행될 때 도구 또는 명령에 전달되는 값을 지정할 수 있습니다.Arguments can specify values that are passed to the tool or command when it is launched. 예를 들어 값은 파일 이름 또는 디렉터리를 지정할 수 있습니다.For example, a value can specify a file name or directory. 화살표 단추를 사용하여 미리 정의된 인수 목록에서 인수를 선택합니다.Use the Arrow button to select from a list of predefined arguments. 인수를 두 개 이상 추가할 수도 있습니다.You can add more than one. 미리 정의된 인수 및 인수 정의의 전체 목록은 Arguments for External Tools를 참조하십시오.For a complete list of predefined arguments and their definitions, see Arguments for External Tools. 사용하는 명령 또는 도구에 따라 명령 프롬프트 스위치와 같은 사용자 지정 인수를 입력할 수도 있습니다.You can also enter custom arguments (command-prompt switches, for example), depending on the command or tool you use.

초기 디렉터리Initial directory
도구의 작업 디렉터리를 지정합니다.Specify the working directory of the tool. 디렉터리를 선택하려면 화살표 단추를 사용합니다.Use the Arrow button to select directories. 두 개 이상 선택할 수도 있습니다.You can select more than one.

Use output WindowUse output Window
도구의 결과를 출력 창에 표시할지 여부를 지정합니다.Specify whether or not results from the tool are displayed in the Output window. 이 옵션은 일반적으로 명령 프롬프트 창에 출력이 표시되는 .bat 및 .com 등의 파일에만 사용할 수 있습니다.This option is only available for files, such as .bat and .com files, that normally display output in the command prompt window. 이 옵션을 설정하면 도구를 사용하여 작업을 진행할 때 창을 쉽게 관리할 수 있습니다.When enabled, this option eases window management when you are following the progress of a tool.

인수 확인Prompt for arguments
외부 도구를 실행할 때마다 인수 값을 입력하거나 편집할 수 있는 인수 대화 상자를 표시합니다.Display the Arguments dialog box to enable you to enter or edit values for the arguments each time you launch the external tool.

출력을 유니코드로 처리Treat output as Unicode
출력 창에 유니코드가 표시되도록 허용합니다.Allow the Output window to accept Unicode.

끝낼 때 닫기Close On Exit
도구를 끝낼 때 도구에 의해 열린 창을 닫습니다.Close the window opened by the tool when the tool is closed.

예제Example

도구 메뉴에 SQL Server 구성 관리자를 추가하려면To add SQL Server Configuration Manager to the Tools menu

  1. 도구 메뉴에서 외부 도구를 클릭합니다.On the Tools menu, click External Tools.

  2. 제목 입력란에 SQL Server 구성 관리자를 입력합니다.In the Title box, type SQL Server Configuration Manager.

  3. 명령 입력란에 MicrosoftMicrosoft Management Console 실행 파일의 경로(예: C:\WINNT\system32\mmc.exe)를 입력합니다.In the Command box, type the path to the MicrosoftMicrosoft Management Console executable, such as C:\WINNT\system32\mmc.exe

  4. 인수 입력란에 .msc 파일의 경로(예: "C:\WINNT\system32\SQLServerManager.msc")를 입력합니다.In the Arguments box, type the path to the .msc file, such as "C:\WINNT\system32\SQLServerManager.msc"

참고

SQL Server Management StudioSQL Server Management Studio 시작 메뉴에서 바로 가기 속성을 보고 컴퓨터에 있는 파일의 위치를 확인합니다.View the properties of the SQL Server Management StudioSQL Server Management Studio shortcut on the Start menu to confirm the location of the files on your computer.