옵션(환경 - 일반 페이지)Options (Environment - General Page)

옵션 대화 상자를 사용하여 MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio 시작 동작, 일반 창 관리 옵션 및 기타 일반 설정을 구성할 수 있습니다.Use the Options dialog box to configure MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio startup actions, general window management options, and other general settings. 도구 메뉴에서 옵션을 클릭하고 환경 폴더를 확장한 다음 일반을 클릭합니다.On the Tools menu, click Options, expand the Environment folder, and then click General.

UIElement 목록UIElement List

시작 시At startup
SQL Server Management StudioSQL Server Management Studio 를 시작할 때 수행할 동작을 선택합니다.Select the action for SQL Server Management StudioSQL Server Management Studio to perform when it is started. 다음 옵션을 사용할 수 있습니다.The options are:

  • 개체 탐색기 열기 를 선택하면 연결 설정 대화 상자를 표시한 다음 개체 탐색기를 엽니다.Open Object Explorer prompts for a connection and then opens Object Explorer.

  • 새 쿼리 창 열기 를 선택하면 연결 설정 대화 상자를 표시한 다음 SQL 쿼리 편집기를 엽니다.Open new query window prompts for a connection and then opens SQL Query Editor.

  • 개체 탐색기 및 새 쿼리 열기 를 선택하면 연결 설정 대화 상자를 표시한 다음 해당 연결을 사용하여 개체 탐색기와 SQL 쿼리 편집기를 엽니다.Open Object Explorer and new query prompts for a connection, then opens both Object Explorer and SQL Query Editor with that connection.

  • 빈 환경 열기 를 선택하면 SQL 쿼리 편집기 창을 열거나 개체 편집기를 서버에 연결하지 않고 SQL Server Management StudioSQL Server Management Studio 를 엽니다.Open empty environment opens SQL Server Management StudioSQL Server Management Studio without a SQL Query editor window and without connecting Object Explorer to a server.

개체 탐색기에서 시스템 개체 숨기기Hide system objects in Object Explorer
개체 탐색기의 트리 뷰에서 시스템 데이터베이스, 시스템 테이블, 시스템 뷰 및 시스템 저장 프로시저를 제거하려면 이 확인란을 선택합니다.Select this check box to remove the system databases, system tables, system views, and system stored procedures from tree view in Object Explorer. 시스템 함수와 시스템 데이터 형식은 숨겨지지 않습니다.System functions and system data types are not hidden. 이 옵션은 SQL ServerSQL Server 의 인스턴스에만 적용되고 개체 탐색기에 이미 연결되어 있는 서버에는 영향을 주지 않습니다.This option only applies to instances of SQL ServerSQL Server and does not affect servers already connected in Object Explorer.

환경 레이아웃Environment Layout

탭 문서 및 MDI(다중 문서 인터페이스) 환경 모드 간에 전환하려면 SQL Server Management StudioSQL Server Management Studio 를 닫은 다음 다시 열어야 합니다.You must close and reopen SQL Server Management StudioSQL Server Management Studio to change between tabbed document and multiple-document interface (MDI) environment mode.

탭 문서Tabbed documents
편집기에서 탭으로 분류되어 있는 문서 창을 표시하려면 이 옵션을 선택합니다.Select this option to display document windows that are tabbed together within editors. 탭 문서 창은 열려 있는 여러 문서를 구성하거나 여러 문서 간에 전환하려는 경우에 유용합니다.Tabbed document windows are useful for organizing and switching between multiple open documents.

MDI 환경MDI environment
MDI 환경에서 문서를 열려면 이 옵션을 선택합니다.Select this option to open documents in a MDI environment. MDI 문서 창을 사용하면 탭 문서 환경에서 탭이 차지하는 화면 공간을 확보할 수 있습니다.MDI document windows are useful for gaining the screen space that is otherwise taken up by the tabs in the tabbed documents environment. MDI 모드로 작업하는 경우 Ctrl+Tab을 눌러 문서 간에 전환하거나 메뉴에 있는 바둑판식 배열 옵션을 사용할 수 있습니다.When working in MDI mode, you can switch between documents by pressing CTRL+TAB, or you can use the tile options located on the Window menu.

도킹된 도구 창 동작Docked Tool Window Behavior

[닫기] 단추를 누르면 활성 탭만 닫힘Close button affects active tab only
이 확인란을 선택하면 도킹된 집합의 모든 도구 창을 닫는 것이 아니라 현재 포커스가 있는 도구 창만 닫습니다.Specifies that when this check box is selected, only the tool window that has focus currently is closed and not all of the tool windows in the docked set. 이 확인란은 기본적으로 선택되어 있습니다.By default, this check box is selected.

[자동 숨기기] 단추를 누르면 활성 탭만 숨김Auto Hide button affects active tab only
이 확인란을 선택하면 도킹된 집합의 모든 도구 창을 숨기는 것이 아니라 현재 포커스가 있는 도구 창만 자동으로 숨깁니다.Specifies that when this check box is selected, only the tool window that has focus currently is hidden automatically, not all of the tool windows in the docked set. 이 확인란은 기본적으로 선택되어 있지 않습니다.By default, this check box is cleared.

디스플레이Display

최근 사용 목록에 n개 파일 표시Display n files in recently used list
파일 메뉴에 표시할 최근 프로젝트 및 최근 파일 수를 지정합니다.Customizes the number of recent projects and recent files that appear on the File menu. 1과 24 사이의 숫자를 입력하며Type a number between 1 and 24. 기본값은 4입니다.The default is 4. 이 옵션을 사용하면 최근에 사용한 스크립트 프로젝트 및 파일은 물론 다른 스크립트 프로젝트도 쉽게 검색할 수 있습니다.This is an easy way to retrieve recently used script projects and files and script projects.