Management Studio에 사용자 지정 보고서 추가Add a Custom Report to Management Studio

이 항목에서는 .rdl 파일로 저장되는 간단한 Reporting ServicesReporting Services 보고서를 만든 다음 이 rdl 파일을 SQL Server Management StudioSQL Server Management Studio 에 사용자 지정 보고서로 추가하는 방법에 대해 설명합니다.This topic describes how to create a simple Reporting ServicesReporting Services report that is saved as an .rdl file, and then add that rdl file to SQL Server Management StudioSQL Server Management Studio as a custom report. SSRSSSRS 다양한 고급 보고서를 만들 수 있습니다. can create a wide variety of sophisticated reports. 이 항목을 사용하여 보고서를 만들려면 컴퓨터에 SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) 가 설치되어 있어야 합니다.To create a report by using this topic, you must have SQL Server Data Tools(SSDT)SQL Server Data Tools (SSDT) installed on the computer. SSRSSSRS 를 사용하여 사용자 지정 보고서를 실행하기 위해 SQL ServerSQL ServerManagement StudioManagement Studio를 설치할 필요는 없습니다.You do not have to install SSRSSSRS on SQL ServerSQL Server to run a custom report using Management StudioManagement Studio.

.rdl 파일로 저장되는 간단한 보고서를 만들려면To create a simple report saved as an .rdl file

  1. 시작을 클릭하고 프로그램, Microsoft SQL Server를 차례로 가리킨 후 SQL Server Data Tools를 클릭합니다.Click Start, point to Programs, point to Microsoft SQL Server, and then click SQL Server Data Tools.

  2. 파일 메뉴에서 새로 만들기를 가리킨 다음 프로젝트를 클릭합니다.On the File menu, point to New, and then click Project.

  3. 프로젝트 형식 목록에서 비즈니스 인텔리전스 프로젝트를 클릭합니다.In the Project Types list, click Business Intelligence Projects.

  4. 템플릿 목록에서 보고서 서버 프로젝트 마법사를 클릭합니다.In the Templates list, click Report Server Project Wizard.

  5. 이름ConnectionsReport를 입력한 다음 확인을 클릭합니다.In Name, type ConnectionsReport, and then click OK.

  6. 보고서 마법사 시작 페이지에서 다음을 클릭합니다.On the Report Wizard introduction page, click Next.

  7. 데이터 원본 선택 페이지의 이름 입력란에 데이터베이스 엔진Database Engine에 대한 이 연결의 이름을 입력한 다음 편집을 클릭합니다.On the Select the Data Source page, in the Name box type a name for this connection to your 데이터베이스 엔진Database Engine, and then click Edit.

  8. 연결 속성 대화 상자의 서버 이름 입력란에 데이터베이스 엔진Database Engine인스턴스 이름을 입력합니다.In the Connection Properties dialog box, in the Server name box, type the name of your instance of the 데이터베이스 엔진Database Engine.

  9. 데이터베이스 이름 선택 또는 입력 상자에 SQL ServerSQL Server에 있는 AdventureWorks2012AdventureWorks2012등의 데이터베이스 이름을 입력한 다음 확인을 클릭합니다.In the Select or enter a database name box, type the name of any database on your SQL ServerSQL Server, such as AdventureWorks2012AdventureWorks2012, and then click OK.

  10. 데이터 원본 선택 페이지에서 다음을 클릭합니다.On the Select the Data Source page, click Next.

  11. 쿼리 디자인 페이지의 쿼리 문자열 입력란에 Transact-SQLTransact-SQL 에 대한 현재 연결을 나열하는 다음 데이터베이스 엔진Database Engine문을 입력한 후 다음을 클릭합니다.On the Design the Query page, in the Query string box, type the following Transact-SQLTransact-SQL statement that lists the current connections to your 데이터베이스 엔진Database Engine, and then click Next. 보고서 마법사 쿼리 문자열 입력란에는 보고서 매개 변수를 사용할 수 없습니다.The Report Wizard Query string box will not accept report parameters. 더 복잡한 사용자 지정 보고서는 수동으로 만들어야 합니다.More complex custom reports must be created manually.

    SELECT session_id, net_transport FROM sys.dm_exec_connections;SELECT session_id, net_transport FROM sys.dm_exec_connections;

  12. 보고서 유형 선택 페이지에서 테이블 형식을 선택한 다음 마침을 클릭합니다.On the Select the Report Type page, select Tabular, and then click Finish.

  13. 마법사 완료 페이지의 보고서 이름 입력란에 ConnectionsReport를 입력한 다음 마침 을 클릭하여 보고서를 만들고 저장합니다.On the Completing the Wizard page, in the Report name box, type ConnectionsReport, and then click Finish to create and save the report.

  14. SQL Server Data ToolsSQL Server Data Tools를 닫습니다.Close SQL Server Data ToolsSQL Server Data Tools.

  15. 사용자 지정 보고서를 위해 데이터베이스 서버에 만든 폴더에 ConnectionsReport.rdl 을 복사합니다.Copy ConnectionsReport.rdl to a folder that you created on the database server for custom reports.

Management Studio에 보고서를 추가하려면To add a report to Management Studio

  • Management StudioManagement Studio에서 개체 탐색기의 노드를 마우스 오른쪽 단추로 클릭하고 보고서를 가리킨 다음 사용자 지정 보고서를 클릭합니다.In Management StudioManagement Studio, right-click a node in Object Explorer, point to Reports, click Custom Reports. 파일 열기 대화 상자에서 사용자 지정 보고서 폴더를 찾고 ConnectionsReport.rdl 파일을 선택한 다음 열기를 클릭합니다.In the Open File dialog box, locate the custom reports folder and select the ConnectionsReport.rdl file, and then click Open.

    개체 탐색기 노드에서 새 사용자 지정 보고서를 처음으로 열면 해당 노드의 바로 가기 메뉴에 있는 사용자 지정 보고서 의 가장 최근에 사용한 목록에 이 보고서가 추가됩니다.When a new custom report is first opened from an Object Explorer node, the custom report is added to the most recently used list under Custom Reports on the shortcut menu of that node. 표준 보고서를 처음으로 열면 이 보고서도 사용자 지정 보고서의 가장 최근에 사용한 목록에 표시됩니다.When a standard report is opened for the first time, it will also appear on the most recently used list under Custom Reports. 사용자 지정 보고서 파일을 삭제하면 다음에 이 항목을 선택할 때 가장 최근에 사용한 목록에서 해당 항목을 삭제하라는 메시지가 표시됩니다.If a custom report file is deleted, the next time that the item is selected, a prompt will appear to delete the item from the most recently used list.

    1. 최근에 사용한 목록에 표시되는 파일 수를 변경하려면 도구 메뉴에서 옵션 을 클릭하고 환경 폴더를 확장한 다음 일반을 클릭합니다.To change the number of files that are displayed on the recently used list, on the Tools menu, click Options, expand the Environment folder, and then click General.

    2. 최근 사용 목록에 n개 파일 표시의 개수를 조정합니다.Adjust the number for Display files in recently used list.

관련 항목:See Also

Management Studio의 사용자 지정 보고서Custom Reports in Management Studio
개체 탐색기 노드 속성과 함께 사용자 지정 보고서 사용Use Custom Reports with Object Explorer Node Properties
사용자 지정 보고서 실행 경고 표시Unsuppress Run Custom Report Warnings
SQL Server Reporting ServicesSQL Server Reporting Services