3-3단원 - 스크립트를 프로젝트 또는 솔루션으로 저장Lesson 3-3 - Save Scripts as Projects or Solutions

MicrosoftMicrosoft Visual Studio에 익숙한 개발자라면 SQL Server Management StudioSQL Server Management Studio의 솔루션 탐색기를 쉽게 활용할 수 있을 것입니다.Developers familiar with MicrosoftMicrosoft Visual Studio will welcome Solution Explorer in SQL Server Management StudioSQL Server Management Studio. 업무 지원 스크립트를 스크립트 프로젝트로 그룹화하고 스크립트 프로젝트를 하나의 솔루션으로 함께 관리할 수 있습니다.The scripts that support your business can be grouped into script projects, and the script projects can be managed together as a solution. 스크립트 프로젝트와 솔루션에 배치된 스크립트는 하나의 그룹으로 함께 열거나 Visual SourceSafe와 같은 원본 제어 제품에 함께 저장할 수 있습니다.When scripts are placed in script projects and solutions they can be opened together as a group, or saved together to a source control product such as Visual SourceSafe. 스크립트 프로젝트에는 스크립트를 제대로 실행하기 위한 연결 정보가 포함되며 지원 텍스트 파일 같이 스크립트가 아닌 파일이 포함될 수 있습니다.Script projects include the connection information for the scripts to execute properly, and can include non-script files such as a supporting text file.

다음 연습에서는 스크립트 프로젝트와 솔루션에 배치되어 AdventureWorks2012AdventureWorks2012 데이터베이스를 쿼리하는 간단한 스크립트를 만듭니다.The following practice creates a short script that queries the AdventureWorks2012AdventureWorks2012 database, placed in a script project and solution.

스크립트 프로젝트 및 솔루션 사용Using Script Projects and Solutions

스크립트 프로젝트와 솔루션을 만들려면To create a script project and solution

  1. Management StudioManagement Studio를 열고 개체 탐색기로 서버에 연결합니다.Open Management StudioManagement Studio, and connect to a server with Object Explorer.

  2. 파일 메뉴에서 새로 만들기를 가리킨 다음 프로젝트를 클릭합니다.On the File menu, point to New, and then click Project. 새 프로젝트 대화 상자가 열립니다.The New Project dialog box opens.

  3. 이름 입력란에 StatusCheck를 입력하고 템플릿 에서 SQL Server 스크립트를 클릭한 다음 확인 을 클릭하여 새 솔루션과 스크립트 프로젝트를 엽니다.In the Name text box, type StatusCheck, click SQL Server Scripts in Templates, and then click OK to open a new solution and script project.

  4. 솔루션 탐색기에서 연결을 마우스 오른쪽 단추로 클릭한 다음 새 연결을 클릭합니다.In Solution Explorer, right-click Connections, and then click New Connection. 서버에 연결 대화 상자가 열립니다.The Connect to Server dialog box opens.

  5. 서버 이름 목록 상자에 서버 이름을 입력합니다.In the Server name list box, type the name of your server.

  6. 옵션을 클릭한 다음 연결 속성 탭을 클릭합니다.Click Options, and then click the Connection Properties tab.

  7. 연결할 데이터베이스 상자에서 서버를 찾아보고 AdventureWorks2012AdventureWorks2012 데이터베이스를 선택한 다음 연결을 클릭합니다.In the Connect to database box, browse the server, select the AdventureWorks2012AdventureWorks2012 database, and then click Connect. 데이터베이스를 포함한 연결 정보가 프로젝트에 추가됩니다.The connection information including the database is added to the project.

  8. 속성 창이 표시되지 않으면 솔루션 탐색기에서 새 연결을 클릭한 다음 F4 키를 누릅니다.If the Properties window is not displayed, click the new connection in Solution Explorer, and then press F4. 연결 속성이 나타나고 초기 데이터베이스 AdventureWorks2012AdventureWorks2012를 포함하는 연결 정보가 표시됩니다.The properties for the connection appear, and show information about the connection including the Initial Database as AdventureWorks2012AdventureWorks2012.

  9. 솔루션 탐색기에서 연결을 마우스 오른쪽 단추로 클릭한 다음 새 쿼리를 클릭합니다.In Solution Explorer, right-click the connection, and then click New Query. 서버의 데이터베이스에 연결된 SQLQuery1.sql AdventureWorks2012AdventureWorks2012 이라는 새 쿼리가 생성되어 스크립트 프로젝트에 추가됩니다.A new query called SQLQuery1.sql is created, connected to the AdventureWorks2012AdventureWorks2012 database on your server, and added to your script project.

  10. 쿼리 편집기에 다음 쿼리를 입력하여 작업 주문 시작 날짜 전 기한이 있는 작업 주문 수를 확인합니다.In Query Editor, type the following query to determine how many work orders have due dates, before the work order starting dates. 자습서 창에서 코드를 복사하여 붙여 넣을 수 있습니다.(You can copy and paste the code from the Tutorial window.)

    USE AdventureWorks2012;  
    GO  
    SELECT COUNT(WorkOrderID)  
    FROM Production.WorkOrder  
    WHERE DueDate < StartDate;  
    

    참고

    쿼리를 입력할 공간이 더 필요하면 Shift+Alt+Enter를 눌러 전체 화면 모드로 전환합니다.If you need more room to type your query, press SHIFT+ALT+ENTER, to switch to full-screen mode.

  11. 솔루션 탐색기에서 SQLQuery1을 마우스 오른쪽 단추로 클릭한 다음 이름 바꾸기를 클릭합니다.In Solution Explorer, right-click SQLQuery1, and then click Rename. 쿼리의 새 이름으로 Check Workorders.sql 을 입력하고 Enter 키를 누릅니다.Type Check Workorders.sql as the new name for the query and press ENTER.

  12. 솔루션과 스크립트 프로젝트를 저장하려면 파일 메뉴에서 모두 저장을 클릭합니다.To save your solution and script project, on the File menu, click Save All.

단원의 다음 태스크Next Task in Lesson

요약: 솔루션 및 스크립트 프로젝트Summary: Solutions and Script Projects