연습: 데이터베이스 다이어그램 추가 및 변경Walkthrough: Adding and Changing a Database Diagram

이 연습에서는 데이터베이스 다이어그램을 만들고 수정하는 방법과 데이터베이스 다이어그램 구성 요소를 통해 데이터베이스를 변경하는 방법을 설명합니다.This walkthrough illustrates how to create and modify a database diagram and make changes to the database through the database diagrams component. 또한 다이어그램에 테이블을 추가하고, 테이블 간에 관계를 만들고, 열에 대해 제약 조건과 인덱스를 만들며 각 테이블에 대해 표시할 정보 수준을 변경하는 방법을 설명합니다.You will see how to add tables to diagrams, create relationships between tables, create constraints and indexes on columns, and change the level of information you see for each table.

필수 구성 요소Prerequisites

이 연습을 완료하려면 다음이 필요합니다.In order to complete this walkthrough, you will need:

  • SQL ServerSQL Server 예제 데이터베이스를 포함하는 AdventureWorks2012AdventureWorks2012 에 대한 액세스 권한Access to SQL ServerSQL Server with the AdventureWorks2012AdventureWorks2012 sample database

  • 데이터베이스 소유자 dbo 권한이 있는 계정An account with database owner dbo privileges

참고

충분한 권한이 없는 계정을 사용하여 테이블을 변경하려고 시도하면 오류 메시지가 나타납니다.If you attempt to make changes when using an account without sufficient privileges to make changes to tables, then an error message appears.

다이어그램 만들기Creating a Diagram

새 데이터베이스 다이어그램을 만들려면To create a new database diagram

  1. 보기 메뉴에서 개체 탐색기를 클릭합니다.On the View menu, click Object Explorer.

  2. 데이터베이스 노드를 연 다음 AdventureWorks2012AdventureWorks2012 노드를 엽니다.Open the Databases node and then open the AdventureWorks2012AdventureWorks2012 node.

  3. 데이터베이스 다이어그램 노드를 마우스 오른쪽 단추로 클릭한 다음 새 데이터베이스 다이어그램을 선택합니다.Right-click the Database Diagrams node and choose New Database Diagram.

    데이터베이스에 다이어그램을 만드는 데 필요한 개체가 없는 경우에는 다음과 같은 메시지가 나타납니다. 이 데이터베이스에는 데이터베이스 다이어그램을 사용하는 데 필요한 지원 개체가 하나 이상 없습니다. 지원 개체를 만드시겠습니까?라는 메시지가 나타납니다.If the database does not have objects necessary to create diagrams, the following message appears: This database does not have one or more of the support objects required to use database diagramming. Do you wish to create them? 를 선택합니다.Choose Yes.

    테이블 추가 대화 상자가 표시됩니다.The Add Table dialog box appears.

  4. AddressType (Person)Address (Person) 를 선택하고 추가를 클릭합니다.Select AddressType (Person) and Address (Person) and click Add.

    다이어그램에 두 개의 테이블이 추가됩니다.Two tables are added to the diagram.

  5. 테이블 추가 대화 상자를 닫습니다.Close the Add Table dialog box.

서로 다른 열 데이터를 보려면To view different column data

  1. Address 테이블을 마우스 오른쪽 단추로 클릭합니다.Right-click the Address table. 바로 가기 메뉴에서 테이블 뷰를 가리킨 다음 표준을 클릭합니다.On the shortcut menu, point to Table View, and then click Standard.

    테이블 표에 열 이름, 데이터 형식Null 허용의 세 열이 표시됩니다.The table grid shows three columns: Column Name, Data Type, and Allow Nulls.

  2. Address 테이블을 마우스 오른쪽 단추로 클릭하고 테이블 뷰 를 클릭한 다음 를 선택합니다.Right-click the Address table, click Table View and select Keys.

    테이블 표에 테이블 열 이름이 있는 하나의 열이 표시됩니다.The table grid shows one column, with the table-column names. 이때 인덱스에 참여하는 열만 나타납니다.Only those columns participating in indexes appear.

새 테이블 만들기Creating New Tables

다이어그램 디자이너 내에서 테이블을 만들려면To create tables within Diagram Designer

  1. 기존 테이블 외부에서 다이어그램 디자이너를 마우스 오른쪽 단추로 클릭한 다음 새 테이블을 선택합니다.Right-click the Diagram Designer outside the existing tables and choose New Table.

  2. 이름 선택 대화 상자에서 확인 을 클릭하여 기본 이름인 Table1을 적용합니다.In the Choose Name dialog box, click OK to accept the default name Table1.

    새 테이블 표에 열 이름, 데이터 형식Null 허용의 세 열이 나타납니다.A new table grid appears with three columns: Column Name, Data Type, and Allow Nulls.

  3. Table1에 다음 정보를 추가합니다.Add the following information to Table1:

    열 이름Column Name 데이터 형식Data Type Null 허용Allow Nulls
    T1col1T1col1 intint 선택checked
    T1col2T1col2 varchar(50)varchar(50) 선택checked
    T1col3T1col3 floatfloat 선택checked
  4. T1col1 을 마우스 오른쪽 단추로 클릭한 다음 기본 키 설정을 선택합니다.Right-click T1col1 and select Set Primary Key.

    열 이름 옆에 키 아이콘이 나타납니다.A key icon will appear beside the column name.

  5. 파일 메뉴에서 Diagram1 저장을 클릭합니다.From the File menu, click Save Diagram1.

  6. 이름 선택 대화 상자에서 확인 을 클릭하여 기본 이름인 Diagram1을 적용합니다.In the Choose Name dialog box, click OK to accept the default name Diagram1.

  7. 을 데이터베이스에 저장한다는 메시지가 포함된 저장 Table1 대화 상자가 나타납니다.The Save dialog box appears with a message that Table1 will be saved to the database. 를 클릭합니다.Click Yes.

테이블 구조 수정Modifying Table Structure

다이어그램 디자이너에서 CHECK 제약 조건을 추가하고 테이블 간에 관계를 만들 수 있습니다.You can add check constraints and make relationships between tables in Diagram Designer.

CHECK 제약 조건을 만들려면To create check constraints

  1. Table1에서 T1col3 행을 마우스 오른쪽 단추로 클릭한 다음 CHECK 제약 조건을 선택합니다.In Table1, right-click the T1col3 row and choose Check Constraints.

    CHECK 제약 조건 대화 상자가 나타납니다.The Check Constraints dialog box appears.

  2. 추가를 클릭합니다.Click Add.

    선택한 CHECK 제약 조건 목록에 새 제약 조건은 기본 이름인 CK_Table1로 나타납니다.A new constraint appears in the Selected Check Constraint list, with the default name CK_Table1.

  3. 표에서 행을 선택하고 줄임표 단추를 클릭합니다.Select the Expression row in the grid and click the ellipsis button.

    CHECK 제약 조건 식 대화 상자가 나타납니다.The Check Constraint Expression dialog box appears.

  4. T1col3 > 5를 입력하고 확인을 클릭합니다.Type T1col3 > 5 and click OK.

    Table1 이제 T1col3 에 입력하는 모든 값이 5보다 커야 한다는 제약 조건이 지정됩니다.Table1 now has a constraint that all values entered into T1col3 must be greater than 5.

  5. 닫기를 클릭합니다.Click Close.

테이블 간에 관계를 만들려면To create relationships between tables

  1. 다이어그램 디자이너에서 다음 열이 있는 Table2 라는 새 테이블을 만듭니다.Create a new table in Diagram designer named Table2 with the following columns:

    열 이름Column Name 데이터 형식Data Type Null 허용Allow Nulls
    T2col1T2col1 intint 선택 안 함not checked
    T2col2T2col2 varchar(50)varchar(50) 선택checked
    T2col3T2col3 xmlxml 선택checked
    참고

    외래 키 관계의 기본 키 쪽에 있는 열은 기본 키나 UNIQUE 제약 조건에 참여해야 합니다.The columns on the primary key side of a foreign key relationship must participate in either a Primary Key or a Unique Constraint.

  2. T2col1T1col1로 끕니다.Drag T2col1 to T1col1.

    백그라운드의 외래 키 관계 대화 상자와 포그라운드의 테이블 및 열 대화 상자 두 개가 나타납니다.Two dialog boxes appear: Foreign Key Relationship in the background and Tables and Columns in the foreground.

  3. 확인 을 클릭하여 새 관계를 저장합니다.Click OK to save the new relationship.

  4. 확인 을 다시 클릭합니다.Click OK again.

인덱스 만들기Creating Indexes

XML을 포함하여 대부분의 데이터 형식에 대해 인덱스를 만들 수 있습니다.You can create indexes on most types of data, including XML.

표준 인덱스를 만들려면To create a standard index

  1. Table1 을 마우스 오른쪽 단추로 클릭한 다음 인덱스/키를 선택합니다.Right-click Table1 and choose Indexes/Keys.

    인덱스/키 대화 상자가 나타납니다.The Indexes/Keys dialog box appears.

  2. 추가를 클릭합니다.Click Add.

    선택한 Primary/Unique 키 또는 인덱스 목록에 새 인덱스가 IX_Table1과 비슷한 기본 이름으로 나타납니다.A new index appears in the Selected Primary/Unique Key or Index list, with a default name similar to IX_Table1.

  3. 행을 선택하고 줄임표 단추를 클릭합니다.Select the Columns row and click the ellipsis button.

    인덱스 열 대화 상자가 나타납니다.The Index Columns dialog box appears.

  4. 열 이름 아래의 드롭다운 화살표를 클릭하고 T1col2를 선택합니다.Click the drop-down arrow under Column Name and select T1col2.

    참고

    T1col2 아래의 셀을 선택하고 다른 열 이름을 선택하여 이 인덱스에 열을 추가할 수 있습니다.You may add additional columns to this index by selecting the cell below T1col2 and choosing another column name.

  5. 확인 을 클릭하여 이 인덱스를 저장합니다.Click OK to save this index.

  6. 인덱스/키 대화 상자에서 닫기 를 클릭합니다.Click Close in the Indexes/Keys dialog box.

XML 인덱스를 만들려면To create an XML index

  1. T2col1 을 마우스 오른쪽 단추로 클릭한 다음 기본 키 설정을 선택합니다.Right-click T2col1 and choose Set Primary Key.

    참고

    XML 인덱스를 추가하려면 테이블의 다른 열을 클러스터형 기본 키로 설정해야 합니다.Adding an XML index requires that another column in the table be set as a clustered primary key.

  2. T2col3Table2 행을 마우스 오른쪽 단추로 클릭한 다음 XML 인덱스를 선택합니다.Right-click the T2col3 row in Table2 and select XML Indexes.

    XML 인덱스 대화 상자가 나타납니다.The XML Indexes dialog box appears.

  3. 추가를 클릭합니다.Click Add.

    선택한 XML 인덱스 목록에 기본값이 지정된 XML 인덱스가 추가됩니다.An XML index with default values will be added to the Selected XML Index list.

  4. 닫기를 클릭합니다.Click Close.

    참고

    XML 인덱스는 열별로 생성됩니다.XML indexes are created per-column. 첫 번째 XML 인덱스는 기본 인덱스이고 추가 인덱스는 모두 보조 인덱스입니다.The first XML index is primary; any additional indexes are secondary.

다이어그램 저장Saving the Diagram

저장하기 전까지는 다이어그램에 대한 변경 내용이 데이터베이스에 게시되지 않습니다.All of the changes you make to a diagram are not posted to the database until you save it. 문제 또는 충돌이 있을 경우 대화 상자에 추가 정보가 나타납니다.If there are problems or conflicts, a dialog box appears with more information.

데이터베이스 다이어그램을 저장하려면To save a database diagram

  1. 파일 메뉴에서 Diagram1 저장을 선택합니다.On the File menu, select Save Diagram1.

    저장 대화 상자가 나타납니다.The Save dialog box appears. 영향을 받는 테이블 경고 를 선택하면 새 테이블이나 변경된 테이블에 대한 정보가 표시됩니다.If Warn about Tables Affected is selected, information about new or changed tables is listed.

  2. 확인을 클릭합니다.Click OK.

  3. 오류가 발생하면 저장 후 알림 대화 상자에 오류와 원인이 나타납니다.If any errors occurred, the Post-Save Notifications dialog box appears with the errors and their causes. 오류를 수정하고 다이어그램을 다시 저장합니다.Fix the errors and save the diagram again.

다음 단계Next Steps

이는 기존 테이블 두 개와 새 테이블 두 개만으로 이루어진 기본 다이어그램이지만 이 다이어그램을 만들어본 사용자라면 시각적으로 새 스키마를 만들거나 기존 데이터베이스를 다이어그램으로 만들 수 있습니다.This is a basic diagram with just two existing and two new tables, but it illustrates the potential for diagramming an existing database or creating a new schema visually. 다음을 추가로 살펴볼 수 있습니다.Suggestions for more exploration include:

  • 관련 테이블 그룹을 포함하는 새 다이어그램 만들기Create new diagrams containing groups of related tables

  • 각 테이블에 대해 표시되는 정보의 양 사용자 지정Customize the amount of information shown for each table

  • 레이아웃 변경 및 주석 추가Change the layout and add annotations

  • 비트맵으로 다이어그램 복사Copy the diagram to a bitmap

참고 항목See Also

다이어그램에 표시된 정보의 양 사용자 지정(Visual Database Tools)Customize the Amount of Information Displayed in Diagrams (Visual Database Tools)
데이터베이스 다이어그램 디자이너 설정(Visual Database Tools)Set Up Database Diagram Designer (Visual Database Tools)
다이어그램에 테이블 추가(Visual Database Tools)Add Tables to Diagrams (Visual Database Tools)
다이어그램에서 테이블 간의 관계 만들기(Visual Database Tools)Create Relationships Between Tables on a Diagram (Visual Database Tools)
XML 인덱스 만들기Create XML Indexes
데이터베이스 다이어그램의 이미지를 클립보드로 복사(Visual Database Tools)Copy an Image of a Database Diagram to the Clipboard (Visual Database Tools)
다이어그램 레이아웃 작업(Visual Database Tools)Work with Diagram Layout (Visual Database Tools)