테이블에 추적 결과 저장(SQL Server Profiler)Save Trace Results to a Table (SQL Server Profiler)

이 항목에서는 SQL Server 프로파일러SQL Server Profiler를 사용하여 추적 결과를 데이터베이스 테이블에 저장하는 방법에 대해 설명합니다.This topic describes how to save trace results to a database table by using SQL Server 프로파일러SQL Server Profiler.

추적 결과를 테이블에 저장하려면To save trace results to a table

  1. 파일 메뉴에서 새 추적을 클릭한 다음 SQL ServerSQL Server인스턴스에 연결합니다.On the File menu, click New Trace, and then connect to an instance of SQL ServerSQL Server.

    추적 속성대화 상자가 표시됩니다.The Trace Propertiesdialog box appears.

    참고

    연결한 후 즉시 추적 시작을 선택한 경우에는 추적 속성대화 상자가 나타나지 않고 추적이 시작됩니다.If Start tracing immediately after making connectionis selected, the Trace Propertiesdialog box fails to appear and the trace begins instead. 이 설정을 해제하려면 도구메뉴에서 옵션을 클릭한 다음 연결한 후 즉시 추적 시작 확인란의 선택을 취소합니다.To turn off this setting, on the Toolsmenu, click Options, and clear the Start tracing immediately after making connection check box.

  2. 추적 이름 입력란에 추적 이름을 입력한 다음 테이블에 저장을 클릭합니다.In the Trace name box, type a name for the trace, and then click Save to table.

  3. 서버에 연결 대화 상자에서 추적 테이블을 포함할 SQL ServerSQL Server 데이터베이스에 연결합니다.In the Connect to server dialog box, connect to the SQL ServerSQL Server database that will contain the trace table.

  4. 대상 테이블 대화 상자의 데이터베이스목록에서 데이터베이스를 선택합니다.In the Destination Table dialog box, select a database from the Databaselist.

  5. 소유자 목록에서 추적의 소유자를 선택합니다.In the Owner list, select the owner for the trace.

  6. 테이블 목록에서 추적 결과에 대한 테이블 이름을 입력하거나 선택합니다.In the Table list, type or select the table name for the trace results. 확인.Click OK.

  7. 추적 속성 대화 상자에서 최대 행 수 설정(천 단위)확인란을 선택하여 저장할 최대 행 수를 지정합니다.In the Trace Properties dialog box, select the Set maximum rows (in thousands)check box to specify the maximum number of rows to save.

참고 항목See Also

SQL Server 프로파일러SQL Server Profiler