Visual Studio Code를 사용하여 Transact-SQL 스크립트 만들기 및 실행Use Visual Studio Code to create and run Transact-SQL scripts

적용 대상:Applies to: 예SQL ServerSQL Server(지원되는 모든 버전)yesSQL ServerSQL Server (all supported versions) - Linux적용 대상:Applies to: 예SQL ServerSQL Server(지원되는 모든 버전)yesSQL ServerSQL Server (all supported versions) - Linux

이 문서에서는 Visual Studio Code mssql 확장을 사용하여 SQL Server 데이터베이스를 개발하는 방법을 보여 줍니다.This article shows how to use the mssql extension for Visual Studio Code to develop SQL Server databases. Visual Studio Code는 플랫폼 간에 지원되므로 Linux, macOS 및 Windows에서 mssql 확장을 사용할 수 있습니다.Because Visual Studio Code is cross-platform, you can use mssql extension on Linux, macOS, and Windows.

Visual Studio Code 설치 및 시작Install and start Visual Studio Code

Visual Studio Code는 확장을 지원하는 플랫폼 간 그래픽 코드 편집기입니다.Visual Studio Code is a cross-platform, graphical code editor that supports extensions.

  1. 머신에서 Visual Studio Code를 다운로드하여 설치합니다.Download and install Visual Studio Code on your machine.

  2. Visual Studio Code를 시작합니다.Start Visual Studio Code.

    참고

    xrdp 원격 데스크톱 세션을 통해 연결된 경우 Visual Studio Code가 시작되지 않으면 XRDP를 사용하여 연결된 경우 Ubuntu에서 VS Code가 작동하지 않음을 참조하세요.If Visual Studio Code does not start when you are connected through an xrdp remote desktop session, see VS Code not working on Ubuntu when connected using XRDP.

mssql 확장 설치Install the mssql extension

Visual Studio Code mssql 확장을 사용하면 SQL Server에 연결하고 T-SQL(Transact-SQL)을 사용하여 쿼리한 다음, 결과를 볼 수 있습니다.The mssql extension for Visual Studio Code lets you connect to a SQL Server, query with Transact-SQL (T-SQL), and view the results.

  1. Visual Studio Code에서 보기 > 명령 팔레트를 선택하거나, Ctrl+Shift+P 또는 F1 키를 눌러 명령 팔레트를 엽니다.In Visual Studio Code, select View > Command Palette, or press Ctrl+Shift+P, or press F1 to open the Command Palette.

  2. 명령 팔레트의 드롭다운에서 확장: 확장 설치를 선택합니다.In the Command Palette, select Extensions: Install Extensions from the dropdown.

  3. 확장 창에서 mssql을 입력합니다.In the Extensions pane, type mssql.

  4. SQL Server(mssql) 확장을 선택한 다음, 설치를 선택합니다.Select the SQL Server (mssql) extension, and then select Install.

    mssql 확장 설치

  5. 설치가 완료되면 다시 로드를 선택하여 확장을 사용하도록 설정합니다.After the installation completes, select Reload to enable the extension.

SQL 파일 만들기 또는 열기Create or open a SQL file

mssql 확장은 언어 모드가 SQL로 설정된 경우 코드 편집기에서 mssql 명령과 T-SQL IntelliSense를 사용하도록 설정합니다.The mssql extension enables mssql commands and T-SQL IntelliSense in the code editor when the language mode is set to SQL.

  1. 파일 > 새 파일을 선택하거나 Ctrl+N을 누릅니다.Select File > New File or press Ctrl+N. Visual Studio Code는 기본적으로 새 일반 텍스트 파일을 엽니다.Visual Studio Code opens a new Plain Text file by default.

  2. 아래쪽 상태 표시줄에서 일반 텍스트를 선택하거나, Ctrl+K > M을 누르고 언어 드롭다운에서 SQL을 선택합니다.Select Plain Text on the lower status bar, or press Ctrl+K > M, and select SQL from the languages dropdown.

    SQL 언어 모드

    참고

    확장을 처음 사용하는 경우 확장에서 지원하는 SQL Server 도구를 설치합니다.If this is the first time you have used the extension, the extension installs supporting SQL Server tools.

.sql 파일 확장명을 가진 기존 파일을 열면 언어 모드가 자동으로 SQL로 설정됩니다.If you open an existing file that has a .sql file extension, the language mode is automatically set to SQL.

SQL Server에 연결Connect to SQL Server

연결 프로필을 만들고 SQL Server에 연결하려면 다음 단계를 수행합니다.Follow these steps to create a connection profile and connect to a SQL Server.

  1. Ctrl+Shift+P 또는 F1 키를 눌러 명령 팔레트를 엽니다.Press Ctrl+Shift+P or F1 to open the Command Palette.

  2. sql을 입력하여 mssql 명령을 표시하거나, sqlcon을 입력하고 드롭다운에서 MS SQL: 연결을 선택합니다.Type sql to display the mssql commands, or type sqlcon, and then select MS SQL: Connect from the dropdown.

    mssql 명령

    참고

    사용자가 만든 빈 SQL 파일 등의 SQL 파일은 코드 편집기에서 포커스가 있어야 mssql 명령을 실행할 수 있습니다.A SQL file, such as the empty SQL file you created, must have focus in the code editor before you can execute the mssql commands.

  3. MS SQL: 연결 프로필 관리 명령을 선택합니다.Select the MS SQL: Manage Connection Profiles command.

  4. 만들기를 선택하여 SQL Server의 새 연결 프로필을 만듭니다.Then select Create to create a new connection profile for your SQL Server.

  5. 프롬프트에 따라 새 연결 프로필의 속성을 지정합니다.Follow the prompts to specify the properties for the new connection profile. 각 값을 지정한 후 Enter 키를 눌러 계속합니다.After specifying each value, press Enter to continue.

    연결 속성Connection property DescriptionDescription
    서버 이름 또는 ADO 연결 문자열Server name or ADO connection string SQL Server 인스턴스 이름을 지정합니다.Specify the SQL Server instance name. localhost를 사용하여 로컬 머신의 SQL Server 인스턴스에 연결합니다.Use localhost to connect to a SQL Server instance on your local machine. 원격 SQL Server에 연결하려면 대상 SQL Server의 이름 또는 해당 IP 주소를 입력합니다.To connect to a remote SQL Server, enter the name of the target SQL Server, or its IP address. SQL Server 컨테이너에 연결하려면 컨테이너 호스트 머신의 IP 주소를 지정합니다.To connect to a SQL Server container, specify the IP address of the container's host machine. 포트를 지정해야 하는 경우 쉼표를 사용하여 이름과 구분합니다.If you need to specify a port, use a comma to separate it from the name. 예를 들어 포트 1401에서 수신 대기하는 서버의 경우 <servername or IP>,1401을 입력합니다.For example, for a server listening on port 1401, enter <servername or IP>,1401.

    또는 여기서 데이터베이스의 ADO 연결 문자열을 입력할 수 있습니다.As an alternative, you can enter the ADO connection string for your database here.
    데이터베이스 이름(선택 사항)Database name (optional) 사용하려는 데이터베이스입니다.The database that you want to use. 기본 데이터베이스에 연결하려면 여기서 데이터베이스 이름을 지정하지 않습니다.To connect to the default database, don't specify a database name here.
    인증 유형Authentication Type 통합 또는 SQL 로그인을 선택합니다.Choose either Integrated or SQL Login.
    사용자 이름User name SQL 로그인을 선택한 경우 서버의 데이터베이스에 대한 액세스 권한이 있는 사용자의 이름을 입력합니다.If you selected SQL Login, enter the name of a user with access to a database on the server.
    암호Password 지정된 사용자의 암호를 입력합니다.Enter the password for the specified user.
    암호 저장Save Password Enter 키를 눌러 를 선택하고 암호를 저장합니다.Press Enter to select Yes and save the password. 연결 프로필을 사용할 때마다 암호 확인 메시지를 표시하려면 아니요를 선택합니다.Select No to be prompted for the password each time the connection profile is used.
    프로필 이름(선택 사항)Profile Name (optional) 연결 프로필의 이름(예: localhost profile)을 입력합니다.Type a name for the connection profile, such as localhost profile.

    모든 값을 입력하고 Enter 키를 선택하면 Visual Studio Code에서 연결 프로필을 만들고 SQL Server에 연결합니다.After you enter all values and select Enter, Visual Studio Code creates the connection profile and connects to the SQL Server.

    연결에 실패하면 Visual Studio Code 출력 패널의 오류 메시지를 통해 문제를 진단해 봅니다.If the connection fails, try to diagnose the problem from the error message in the Output panel in Visual Studio Code. 출력 패널을 열려면 보기 > 출력을 선택합니다.To open the Output panel, select View > Output. 또한 연결 문제 해결 권장 사항을 검토합니다.Also review the connection troubleshooting recommendations.

  6. 아래쪽 상태 표시줄에서 연결을 확인합니다.Verify your connection in the lower status bar.

    연결 상태

이전 단계 대신 사용자 설정 파일(settings.json)에서 연결 프로필을 만들고 편집할 수도 있습니다.As an alternative to the previous steps, you can also create and edit connection profiles in the User Settings file (settings.json). 설정 파일을 열려면 파일 > 기본 설정 > 설정을 선택합니다.To open the settings file, select File > Preferences > Settings. 자세한 내용은 연결 프로필 관리를 참조하세요.For more information, see Manage connection profiles.

SQL 데이터베이스 만들기Create a SQL database

  1. 앞에서 시작한 새 SQL 파일에서 sql을 입력하여 편집 가능한 코드 조각 목록을 표시합니다.In the new SQL file that you started earlier, type sql to display a list of editable code snippets.

    SQL 코드 조각

  2. sqlCreateDatabaseSelect sqlCreateDatabase.

  3. 코드 조각에서 TutorialDB를 입력하여 ‘DatabaseName’을 바꿉니다.In the snippet, type TutorialDB to replace 'DatabaseName':

    -- Create a new database called 'TutorialDB'
    -- Connect to the 'master' database to run this snippet
    USE master
    GO
    IF NOT EXISTS (
       SELECT name
       FROM sys.databases
       WHERE name = N'TutorialDB'
    )
    CREATE DATABASE [TutorialDB]
    GO
    
  4. Ctrl+Shift+E를 눌러 Transact-SQL 명령을 실행합니다.Press Ctrl+Shift+E to execute the Transact-SQL commands. 쿼리 창에서 결과를 확인합니다.View the results in the query window.

    데이터베이스 메시지 만들기

    mssql 명령의 바로 가기 키를 사용자 지정할 수 있습니다.You can customize the shortcut keys for the mssql commands. 바로 가기 사용자 지정을 참조하세요.See Customize shortcuts.

테이블 만들기Create a table

  1. 코드 편집기 창의 내용을 삭제합니다.Delete the contents of the code editor window.

  2. Ctrl+Shift+P 또는 F1 키를 눌러 명령 팔레트를 엽니다.Press Ctrl+Shift+P or F1 to open the Command Palette.

  3. sql을 입력하여 mssql 명령을 표시하거나, sqluse를 입력하고 MS SQL: 데이터베이스 사용 명령을 선택합니다.Type sql to display the mssql commands, or type sqluse, and then select the MS SQL: Use Database command.

  4. TutorialDB 데이터베이스를 선택합니다.Select the new TutorialDB database.

    데이터베이스 사용

  5. 코드 편집기에서 sql을 입력하여 코드 조각을 표시하고 sqlCreateTable을 선택한 다음, Enter 키를 누릅니다.In the code editor, type sql to display the snippets, select sqlCreateTable, and then press Enter.

  6. 코드 조각에서 테이블 이름으로 Employees를 입력합니다.In the snippet, type Employees for the table name.

  7. Tab 키를 눌러 다음 필드로 이동한 다음, 스키마 이름으로 dbo를 입력합니다.Press Tab to get to the next field, and then type dbo for the schema name.

  8. 열 정의를 다음 열로 바꿉니다.Replace the column definitions with the following columns:

    EmployeesId INT NOT NULL PRIMARY KEY,
    Name [NVARCHAR](50)  NOT NULL,
    Location [NVARCHAR](50)  NOT NULL
    
  9. Ctrl+Shift+E를 눌러 테이블을 만듭니다.Press Ctrl+Shift+E to create the table.

삽입 및 쿼리Insert and query

  1. 다음 문을 추가하여 Employees 테이블에 행 4개를 삽입합니다.Add the following statements to insert four rows into the Employees table.

    -- Insert rows into table 'Employees'
    INSERT INTO Employees
       ([EmployeesId],[Name],[Location])
    VALUES
       ( 1, N'Jared', N'Australia'),
       ( 2, N'Nikita', N'India'),
       ( 3, N'Tom', N'Germany'),
       ( 4, N'Jake', N'United States')
    GO
    -- Query the total count of employees
    SELECT COUNT(*) as EmployeeCount FROM dbo.Employees;
    -- Query all employee information
    SELECT e.EmployeesId, e.Name, e.Location
    FROM dbo.Employees as e
    GO
    

    입력하는 동안 T-SQL IntelliSense에서 문을 완성할 수 있도록 지원합니다.While you type, T-SQL IntelliSense helps you to complete the statements:

    T-SQL IntelliSense

    mssql 확장에는 INSERT 및 SELECT 문을 만드는 데 도움이 되는 명령도 있습니다.The mssql extension also has commands to help create INSERT and SELECT statements. 이 명령은 앞의 예제에서 사용되지 않았습니다.These were not used in the previous example.

  2. Ctrl+Shift+E를 눌러 명령을 실행합니다.Press Ctrl+Shift+E to execute the commands. 결과 창에 두 개의 결과 집합이 표시됩니다.The two result sets display in the Results window.

    결과

결과 보기 및 저장View and save the result

  1. 보기 > 편집기 레이아웃 > 레이아웃 대칭 이동을 선택하여 세로 또는 가로 분할 레이아웃으로 전환합니다.Select View > Editor Layout > Flip Layout to switch to a vertical or horizontal split layout.

  2. 결과메시지 패널 헤더를 선택하여 패널을 축소하거나 확장합니다.Select the Results and Messages panel headers to collapse and expand the panels.

    헤더 설정/해제

    mssql 확장의 기본 동작을 사용자 지정할 수 있습니다.You can customize the default behavior of the mssql extension. 확장 옵션 사용자 지정을 참조하세요.See Customize extension options.

  3. 두 번째 결과 그리드에서 그리드 최대화 아이콘을 선택하여 해당 결과를 확대합니다.Select the maximize grid icon on the second result grid to zoom in to those results.

    그리드 최대화

    참고

    T-SQL 스크립트에서 두 개 이상의 결과 그리드를 생성하면 최대화 아이콘이 표시됩니다.The maximize icon displays when your T-SQL script produces two or more result grids.

  4. 그리드를 마우스 오른쪽 단추로 클릭하여 그리드 상황에 맞는 메뉴를 엽니다.Open the grid context menu by right-clicking on the grid.

    상황에 맞는 메뉴

  5. 모두 선택을 선택합니다.Select Select All.

  6. 그리드 상황에 맞는 메뉴를 다시 열고 JSON으로 저장을 선택하여 결과를 .json 파일에 저장합니다.Open the grid context menu again and select Save as JSON to save the result to a .json file.

  7. JSON 파일의 파일 이름을 지정합니다.Specify a file name for the JSON file.

  8. JSON 파일이 저장되고 Visual Studio Code에서 열리는지 확인합니다.Verify that the JSON file saves and opens in Visual Studio Code.

    JSON으로 저장

나중에 관리 또는 대규모 개발 프로젝트를 위해 SQL 스크립트를 저장하고 실행해야 하는 경우 스크립트를 .sql 확장명으로 저장합니다.If you need to save and run SQL scripts later, for administration or a larger development project, save the scripts with a .sql extension.

다음 단계Next steps

T-SQL을 처음 사용하는 경우 자습서: Transact-SQL 문 작성Transact-SQL 참조(데이터베이스 엔진)를 참조하세요.If you're new to T-SQL, see Tutorial: Write Transact-SQL statements and the Transact-SQL Reference (Database Engine).

mssql 확장을 사용하거나 참여하는 방법에 대한 자세한 내용은 mssql 확장 프로젝트 wiki를 참조하세요.For more information on using or contributing to the mssql extension, see the mssql extension project wiki.

Visual Studio Code 사용 방법에 대한 자세한 내용은 Visual Studio Code 설명서를 참조하세요.For more information on using Visual Studio Code, see the Visual Studio Code documentation.