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노드 준비 안 됨 오류 문제 해결 후 복구

이 문서는 AKS(Microsoft Azure Kubernetes Service) 클러스터 내의 노드가 노드 준비되지 않음 상태 표시하지만 자동으로 정상 상태로 복구되는 시나리오를 해결하는 데 도움이 됩니다.

증상

노드에 준비되지 않음 상태 보고하는 동안 애플리케이션의 응답이 중지됩니다. 그러나 노드는 자동으로 복구되며 이제 RCA(근본 원인 분석)를 찾고 있습니다.

원인

이 문제의 가능한 원인에는 다음 시나리오가 포함됩니다.

  • API 서버를 사용할 수 없으며 배포에 대한 준비 프로브를 사용하고 있습니다.

    Pod가 실행 중이지만 준비되지 않은 경우 해당 상황은 준비 프로브가 실패함을 의미합니다. 준비 프로브가 실패하면 Pod가 서비스에 연결되지 않고 트래픽이 Pod instance 전달되지 않습니다.

  • VM(가상 머신) 호스트 오류가 발생합니다. VM 호스트 오류가 발생했는지 여부를 확인하려면 다음 정보 원본을 검사.

예방

나중에 이 문제가 발생하지 않도록 하려면 다음 작업 중 하나 이상을 수행합니다.

  • 서비스 계층이 완전히 지불되었는지 확인합니다.
  • API 서버에 대한 및 get 요청 수를 watch 줄입니다.
  • 노드 풀을 정상 노드 풀로 바꿉 있습니다.

추가 정보