XCode 프로젝트 가져오기Import an XCode Project

플랫폼 간 모바일 개발용 Microsoft Visual C++에서는 Visual Studio로 XCode 프로젝트 이동을 지원하여 플랫폼 간 라이브러리를 만들고 다른 프로젝트와 코드를 공유할 수 있습니다.Microsoft Visual C++ for Cross-Platform Mobile Development includes support for moving your XCode projects into Visual Studio, where you can create cross-platform libraries and share code with other projects. XCode에서 가져오기 마법사를 사용하면 정적 라이브러리 또는 공유 코드 프로젝트로 사용하기 위해 프로젝트를 가져오고 XCode 대상에서 C++ 코드를 분할하는 프로세스가 간단해집니다.The Import from XCode wizard simplifies the process of importing projects and splitting out the C++ code in your XCode targets for use as a static library or shared code project. Visual Studio에서 iOS 관련 코드를 관리할 수 있으며 XCode를 계속 사용하여 스토리보드 및 빌드를 수행할 수 있습니다.You can manage your iOS-specific code in Visual Studio and still use XCode to do storyboards and builds. Visual Studio와 XCode 간에 코드를 쉽게 이동하는 방법에 대한 자세한 내용은 XCode와 Visual Studio 간에 변경 내용 이동을 참조하세요.For information on how to easily move code back and forth between Visual Studio and XCode, see Move Changes Between XCode and Visual Studio.

XCode에서 가져오기 마법사 사용Using the Import From XCode wizard

이 항목에서는 XCode 프로젝트를 Visual Studio로 이동하여 코드 공유 및 플랫폼 간 솔루션을 활용하는 방법을 보여 줍니다.This topic shows you how to move an XCode project into Visual Studio to take advantage of code sharing and cross-platform solutions. 프로젝트를 가져오고, 내보내고, 빌드할 수 있으려면 필수 조건으로 Mac을 Visual Studio에 연결해야 합니다.As a prerequisite, you must pair your Mac to Visual Studio to be able to import, export, and build your project. 연결 설정 방법에 대한 지침은 iOS를 사용하여 빌드할 도구 설치 및 구성을 참조하세요.For instructions on how to set up pairing, see Install And Configure Tools to Build using iOS. 또한 네트워크를 통해 XCode 프로젝트를 공유하거나 Visual Studio 컴퓨터로 Xcode 프로젝트를 옮겨 XCode에서 가져오기 마법사를 사용해야 합니다.You must also share your XCode project over the network or move it to your Visual Studio computer to use the Import from XCode wizard.

XCode에서 가져오기Import from XCode

  1. 파일 메뉴에서 새로 만들기, 가져오기, XCode에서 가져오기를 선택합니다.On the File menu, choose New, Import, Import from XCode. 그러면 XCode에서 가져오기 마법사 대화 상자가 시작됩니다.This starts the Import from XCode wizard dialog.

    가져올 XCode 대상 프로젝트 선택Choose the XCode target project to import

  2. 프로젝트 선택 창에서 [찾아보기] 단추를 선택하여 XCode.pbxproj 파일을 선택합니다.In the Choose a project pane, choose the Browse button to select an XCode .pbxproj file. XCode 프로젝트 파일 선택 대화 상자에서 프로젝트 파일로 이동한 다음 열기를 선택합니다.Navigate to the project file in the Select XCode project file dialog, and then choose Open.

    Xcode 프로젝트 파일 선택 대화 상자에서 프로젝트 파일 선택Select a project file in the Select Xcode project file dialog

    XCode에서 가져오기 마법사에서 다음을 선택합니다.In the Import from XCode wizard, choose Next.

  3. 대상 창에서 Visual Studio 프로젝트로 가져올 XCode 프로젝트의 대상을 선택합니다.In the Destination targets pane, choose the targets from the XCode project to import into Visual Studio projects. XCode 대상은 Visual Studio 프로젝트와 유사합니다. 대부분은 이진을 생성하는 리소스 및 코드의 컬렉션입니다.XCode targets are similar to Visual Studio projects; most are a collection of code and resources that produce a binary. XCode에서 가져오기 마법사에서는 정적 라이브러리가 아닌 이진을 대상으로 생성하는 대상의 가져오기만 허용합니다.The Import from XCode wizard only allows import of targets that produce a binary, but not a static library, as destination targets. XCode 정적 라이브러리 대상은 다음 단계의 주제입니다.XCode static library targets are the subject of the next step.

    XCode에서 가져오기 마법사 대상 창Import from XCode wizard Destination Targets pane

    가져올 대상에서 선택한 각 대상에 대해 마법사는 별도의 정적 라이브러리 프로젝트로 분할할 수 있는 C++ 코드 파일을 자동으로 검색하여 C++ 프로젝트 항목 섹션에 넣습니다.For each target selected in Targets to import, the wizard automatically detects C++ code files that can be split into a separate static library project, and puts them in the C++ project items section. 다른 코드 및 리소스는 XCode 프로젝트 항목 섹션에 그대로 유지됩니다.Other code and resources are left in the XCode project items section. 마법사에서 가져오기 프로세스를 완료하면 이러한 항목은 Visual Studio에서 별도의 정적 라이브러리 및 응용 프로그램 프로젝트가 됩니다.These become separate static library and application projects in Visual Studio when the wizard completes the import process. 기본적으로 단위 테스트 및 프레임워크 대상은 마법사에서 별도의 프로젝트로 분할되지 않습니다.By default, unit test and framework targets are not split into separate projects by the wizard.

    각 프로젝트에 있는 파일을 변경하려면 위로 및 아래로 단추를 사용합니다.To change which files are in each project, use the up and down buttons. 각 프로젝트의 파일에 만족하는 경우 다음을 선택하여 계속합니다.When you are satisfied with the files in each project, choose Next to continue.

  4. 라이브러리 대상 창에서 Visual Studio 프로젝트로 가져올 XCode 프로젝트의 정적 라이브러리 대상을 선택합니다.In the Library targets pane, choose which static library targets from the XCode project to import into Visual Studio projects. 이 창에서 공유 코드 프로젝트에 배치되는 파일과 정적 라이브러리 프로젝트에 배치되는 파일을 선택할 수 있습니다.In this pane, you can choose which files are placed in a Shared Code project, and which are placed in a static library project. 가져올 대상 목록의 각 대상에서 위로 및 아래로 단추를 사용하여 공유 코드 프로젝트 항목정적 라이브러리 프로젝트 항목에 배치되는 파일을 제어할 수 있습니다.In each of targets in the Targets to import list, you can control which files are placed in the Shared Code project items and the Static Library project items by using the up and down buttons.

    XCode에서 가져오기 라이브러리 대상 창Import from XCode Library Targets pane

    공유 코드 프로젝트는 Visual Studio에서 프로젝트 간에 소스 코드 파일 집합을 공유하는 방법입니다.A Shared Code project is a way of sharing a set of source code files between projects in Visual Studio. 코드는 자체 프로젝트가 아니라 코드를 포함하는 프로젝트의 일부로 빌드됩니다.The code is built as part of the project that includes it, not as a project of its own. 공유 코드를 포함하는 프로젝트마다 아키텍처 및 구성이 다를 수 있으므로 이 방법은 많은 종류의 플랫폼에 대해 빌드될 수 있는 코드가 포함된 단일 프로젝트를 제공하는 데 가장 좋습니다.Because the projects that include the shared code may have different architectures and configurations, this is the best way to provide a single project that contains code that may be built for many kinds of platforms.

    각 프로젝트의 파일에 만족하는 경우 다음을 선택하여 계속합니다.When you are satisfied with the files in each project, choose Next to continue.

  5. 전역 속성 창을 사용하면 Visual Studio에서 모든 iOS 프로젝트에 대해 프레임워크 검색 경로 및 헤더 검색 경로 포함을 설정할 수 있습니다.The Global Properties pane can be used to set a framework search path and an include header search path for all iOS projects in Visual Studio. Visual Studio는 소스 코드 검색 및 IntelliSense에 이러한 경로를 사용합니다.Visual Studio uses these paths for source code browsing and for IntelliSense. 이러한 전역 경로는 헤더 및 프레임워크 공통 집합을 사용하는 iOS 프로젝트를 만들 때 유용합니다.These global paths are useful when you create iOS projects that use a common set of headers and frameworks.

    XCode에서 가져오기 전역 속성 창Import from XCode Global Properties pane

    이러한 전역 경로는 Visual studio의 옵션 대화 상자에서도 설정할 수 있습니다.These global paths can also be set in Visual Studio in the Options dialog. 이 대화 상자를 찾으려면 도구 메뉴에서 옵션을 선택합니다.To find them, on the Tools menu, select Options. 옵션 대화 상자에서 플랫폼 간, C++, iOS, 전역 속성을 확장합니다.In the Options dialog, expand Cross Platform, C++, iOS, Global Properties.

    다음 을 선택하여 계속 진행합니다.Choose Next to continue.

  6. 프레임워크 창은 Visual Studio에서 프로젝트에 대한 검색 및 IntelliSense를 위해 사용하는 경로를 구성하는 데 사용됩니다.The Frameworks pane is used to configure the paths used by Visual Studio for browsing and IntelliSense for your project. 경로를 통해 XCode 프로젝트에서 참조하는 각 프레임워크에 대해 Visual Studio에 액세스할 수 있어야 합니다.The paths must be accessible to Visual Studio for each framework referenced by your XCode project. 마법사는 XCode 프로젝트에서 프레임워크 참조를 확인하고 Visual Studio에서 프레임워크를 찾을 수 있는지 여부를 표시합니다.The wizard checks the framework references in the XCode projects and displays whether Visual Studio can find the framework. 전역 속성에서 이미 설정한 모든 경로는 Visual Studio에서 검색되어야 합니다.Any path you have already set up in the Global Properties should be discovered by Visual Studio. 예외는 프레임워크 목록에 나열됩니다.The exceptions are listed in the Frameworks list. X 표시와 함께 나열된 각 프레임워크에 대해 Visual Studio에서 프레임워크를 찾을 수 있도록 PC에서 액세스할 수 있는 경로를 제공합니다.For each framework listed with an X, provide a PC accessible path for Visual Studio to find the framework. 찾아보기 단추 [...]를 사용하면 폴더 선택 대화 상자를 사용하여 경로를 찾을 수 있습니다.You can use the browse button [...] to use a Select Folder dialog to find the path. 프레임워크 경로는 로컬 복사본이거나 Mac에서 네트워크를 통해 액세스할 수 있는 공유일 수 있습니다.The framework path can be either to a local copy, or to a network-accessible share on your Mac.

    XCode에서 가져오기 프레임워크 창Import from XCode Frameworks pane

    다음 을 선택하여 계속 진행합니다.Choose Next to continue.

  7. 프로젝트 설정 창에서는 프레임워크를 변경하고 마법사에서 만드는 각 프로젝트에 대한 헤더 검색 경로 설정을 포함할 수 있습니다.The Project Settings pane allows you to change the framework and include header search path settings for each project the wizard creates. 이 창을 사용하여 전역 설정과 다른 프로젝트 관련 경로를 설정합니다.Use this pane to set project-specific paths that differ from the global settings.

    특정 프로젝트에 대한 경로를 설정하려면 대상 프로젝트 드롭다운에서 프로젝트 파일을 선택한 다음 프레임워크 검색 경로헤더 검색 경로 포함 컨트롤에서 값을 설정합니다.To set a path for a specific project, In the Destination project drop-down, select the project file, then set the values in the Framework Search Path and Include Header Search Path controls. 각 컨트롤 옆에 있는 찾아보기 단추 [...]를 사용하면 폴더 선택 대화 상자를 사용하여 경로를 찾을 수 있습니다.You can use the browse button [...] next to each control to use a Select Folder dialog to find the path.

    XCode에서 가져오기 프로젝트 창Import from XCode Projects pane

    원격 Mac이 Visual Studio에서 이 PC와 연결되지 않은 경우 [원격 컴퓨터 구성] 링크가 표시됩니다.If no remote Mac has been paired with this PC in Visual Studio, the Configure a Remote Machine link is shown. 연결 설정 방법에 대한 지침은 iOS를 사용하여 빌드할 도구 설치 및 구성을 참조하세요.For instructions on how to set up pairing, see Install And Configure Tools to Build using iOS.

    마법사 설정을 사용하여 XCode 프로젝트를 가져오려면 가져오기를 선택합니다.To import the XCode project by using the wizard settings, choose Import.

    XCode에서 가져오기 마법사는 선택한 XCode 프로젝트 대상에 해당하는 프로젝트를 Visual Studio에 만듭니다.The Import from XCode wizard creates projects in Visual Studio that correspond to the selected XCode project targets. 다른 C++ 프로젝트와 공유할 수 있는 코드는 별도의 공유 코드 및 정적 라이브러리 프로젝트로 분할됩니다.The code that can be shared with other C++ projects is split into separate Shared Code and static library projects. 나머지 코드는 Visual Studio에서 원격으로 빌드할 수 있는 iOS 라이브러리 및 응용 프로그램 프로젝트에 배치됩니다.The remaining code is placed in iOS library and application projects that can be built remotely by Visual Studio. Visual Studio와 XCode 간에 코드를 이동하는 방법에 대한 자세한 내용은 XCode와 Visual Studio 간에 변경 내용 동기화를 참조하세요.For more information about moving code between Visual Studio and XCode, see Sync Changes Between XCode and Visual Studio.