Visual Studio Tools for Unity 사용Using Visual Studio Tools for Unity

이 섹션에서는 Visual Studio Tools for Unity의 통합 및 생산성 기능을 사용하는 방법과 Unity 개발을 위해 Visual Studio 디버거를 사용하는 방법에 대해 배워 봅니다.In this section, you'll learn how to use Visual Studio Tools for Unity's integration and productivity features, and how to use the Visual Studio debugger for Unity development.

Unity 통합 및 생산성Unity Integration and Productivity

Visual Studio Tools for Unity가 생산성을 높일 수 있도록 Unity 편집기와 통합되었습니다.Visual Studio Tools for Unity integrates with the Unity Editor to help you be more productive. 이러한 생산성 향상 기능은 일반적인 스크립팅 작업을 자동화하고 Unity에서 Visual Studio로 정보를 가져오므로 Unity 편집기로 전환하여 찾지 않아도 됩니다.These productivity-enhancing features automate common scripting tasks and bring information from Unity into Visual Studio so that you don't have to switch to the Unity Editor to find it.

Unity 설명서 액세스Unity documentation access

Visual Studio에서 신속하게 Unity 스크립팅 설명서에 액세스할 수 있습니다.You can access the Unity scripting documentation quickly from Visual Studio. Visual Studio Tools for Unity에서 로컬에 있는 API 설명서를 찾지 못하는 경우 온라인으로 찾기를 시도합니다.If Visual Studio Tools for Unity doesn't find the API documentation locally, it will try to find it online.

Unity 설명서에 액세스하려면To access Unity documentation
  • Visual Studio에서 알아보려는 Unity API를 강조 표시하거나 그 위로 커서를 가져간 다음 Ctrl+Alt+M, Ctrl+H를 누릅니다.In Visual Studio, highlight or place the cursor over the Unity API you want to learn about, then press Ctrl+Alt+M, Ctrl+H

Unity MonoBehavior 스크립팅 마법사Unity MonoBehavior scripting wizard

Unity에서 대부분의 스크립트는 MonoBehavior 클래스에서 파생하고 해당 메서드 중 일부를 재정의하여 구현됩니다.In Unity, most scripts are implemented by deriving from the MonoBehavior class and overriding some of its methods. MonoBehavior 마법사를 사용하여 오버로드하려는 MonoBehavior 메서드의 빈 정의를 신속하게 만들 수 있습니다.You can use the MonoBehavior wizard to quickly create empty definitions of the MonoBehavior methods you want to overload. 이 마법사를 사용하여 사용할 수 있는 메서드의 목록에서 오버로드하려는 하나 이상의 메서드를 지정하고, 코드에서 메서드를 삽입할 위치를 선택하고, 메서드가 사용되는 방법에 대한 설명을 포함할지 여부를 결정할 수 있습니다.Using this wizard, you can specify one or more methods that you want to overload from the list of available methods, choose where they will be inserted into your code, and decide whether to include comments about how they are used.

monobehavior 마법사 대화 상자입니다.The monobehavior wizard dialog.

MonoBehavior 마법사를 사용하여 빈 MonoBehavior 메서드 정의를 만들려면To create empty MonoBehavior method definitions by using the MonoBehavior wizard
  1. Visual Studio에서 메서드를 삽입할 위치에 커서를 놓은 다음 Ctrl+Shift+M을 눌러 MonoBehavior 마법사를 시작합니다.In Visual Studio, position the cursor where you might want the methods to be inserted, then press Ctrl+Shift+M to launch the MonoBehavior wizard. 또는 이미 하나가 구현된 후 새로운 메서드를 삽입하려는 경우 나중에 지정할 수 있습니다. Ctrl+Shift+M을 누르기만 하면 됩니다.Or, if you want to insert the new methods after one that's already been implemented, you can specify that later; just press Ctrl+Shift+M.

  2. 오버로드하려는 메서드를 선택합니다.Select the methods you want to overload. 스크립트 메서드 만들기 창의 만들 메서드 선택에서 오버로드하려는 각 메서드 이름 옆의 확인란에 표시합니다.In the Create script methods window, under Select methods to create, mark the checkbox next to the name of each method you want to overload.

  3. 프레임워크 버전 드롭다운에 표시된 프레임워크 버전이 사용 중인 버전과 일치하는지 확인합니다.Ensure that the framework version displayed in the Framework version dropdown matches the version you're using. 일치하지 않으면 사용하려는 버전의 드롭다운 값을 변경합니다.If it doesn't match, change the value of the dropdown to the version you want to use.

  4. 메서드를 삽입할 위치를 선택합니다.Choose where the methods will be inserted. 기본적으로 메서드는 커서의 위치에 삽입됩니다. 다른 위치에 삽입하려면 클래스에서 이미 구현된 메서드 뒤에 삽입하도록 선택할 수 있습니다.By default, the methods are inserted at the position of the cursor; if you want to insert them somewhere else, you can choose to insert them after any method that's already implemented in your class. 이러한 위치 중 하나를 선택하려면 삽입점 드롭다운의 값을 원하는 위치로 변경합니다.To choose one of these locations, change the value of the Insertion point drop down to the location you want.

  5. 마법사가 선택한 방법에 대한 주석을 생성하게 하려면 메서드 주석 생성 확인란에 표시합니다.If you want the wizard to generate comments for the methods you selected, mark the Generate method comments checkbox. 이러한 주석은 해당 메서드를 호출하는 때가 언제인지, 해당 메서드가 담당하는 역할이 무엇인지 이해할 수 있기 위해 생성합니다.These comments are meant to help you understand when the method is called and what its general responsibilities are.

  6. 확인 단추를 선택하여 마법사를 종료하고 메서드를 코드에 삽입합니다.Choose the OK button to exit the wizard and insert the methods into your code.

    MonoBehavior 마법사는 아직 Unity API를 배우는 중이거나 익숙하지 않은 메서드를 오버로드해야 하는 경우에 특히 유용합니다.The MonoBehavior wizard is especially helpful while you're still learning the Unity API, or when you need to overload a method you're not familiar with. Unity API를 사용한 경험이 많은 사람은 이미 익숙한 메서드를 신속하게 만들기 위해 빠른 MonoBehavior 마법사를 선호할 수도 있습니다.As you become more experienced with the Unity API, you might prefer the Quick MonoBehavior wizard for quickly creating methods you're already familiar with.

빠른 MonoBehavior 스크립팅 마법사Quick MonoBehavior scripting wizard

이미 Unity API에 익숙한 경우 빠른 MonoBehavior 마법사를 사용하여 훨씬 더 빠르게 오버로드된 메서드를 구현할 수 있습니다.When you're already familiar with the Unity API, you can implement overloaded methods even more quickly by using the Quick MonoBehavior Wizard. 이 마법사를 사용하여 커서 위치에서 메서드 주석 없이 삽입되는 단 하나의 메서드를 지정할 수 있습니다.Using this wizard, you can specify just one method that's inserted without method comments at the cursor location.

빠른 monobehavior 마법사 대화 상자입니다.The quick monobehavior wizard dialog.

빠른 MonoBehavior 마법사를 사용하여 빈 MonoBehavior 메서드 정의를 만들려면To create an empty MonoBehavior method definition by using the Quick MonoBehavior wizard
  1. Visual Studio에서 메서드를 삽입할 위치에 커서를 놓은 다음 Ctrl+Shift+Q를 눌러 빠른 MonoBehavior 마법사를 시작합니다.In Visual Studio, position the cursor where you want the method to be inserted, then press Ctrl+Shift+Q to launch the Quick MonoBehavior wizard. 새 메서드는 항상 그곳에 삽입되어 있으므로 다른 MonoBehavior 마법사와는 달리 이 마법사를 사용할 때는 의도적으로 커서를 배치해야 합니다.Unlike the other MonoBehavior wizard, you must position the cursor intentionally when using this wizard because the new method is always inserted there.

  2. 스크립트 메서드 만들기 창의 오른쪽 상단 모서리에 표시되는 프레임워크 버전이 사용 중인 버전과 일치하는지 확인합니다.Ensure that the framework version displayed in the upper right-hand corner of the Create script method window matches the version you're using. 일치하지 않으면 사용하려는 버전의 드롭다운 값을 변경합니다.If it doesn't match, change the value of the dropdown to the version you want to use.

  3. 오버로드하려는 메서드를 찾습니다.Find the method that you want to overload. 스크립트 메서드 만들기 창에서 텍스트 상자에 메서드의 이름을 입력하기 시작합니다.In the Create script method window, begin typing the name of the method in the textbox. 입력한 이름과 일치하는 메서드 목록이 표시됩니다.A list of the methods whose names match what you've entered will appear.

  4. 오버로드하려는 메서드를 선택합니다.Choose the method you want to overload. 원하는 메서드가 목록에 표시되면 마우스 또는 화살표 키로 선택한 다음 Enter 키를 누릅니다.When the method you want is displayed in the list, select it with the mouse or arrow keys, then press Enter. 목록에 메서드가 하나만 표시되는 경우 Enter 키를 누르기만 하면 됩니다.If it's the only method in the list, you can just press Enter. 메서드는 코드에 삽입됩니다.The method is inserted into your code.

Unity 프로젝트 탐색기Unity Project Explorer

Unity 프로젝트 탐색기를 사용하여 Visual Studio 내의 Unity 프로젝트를 탐색할 수 있습니다.You can use the Unity Project Explorer to navigate your Unity project inside Visual Studio.

Unity 프로젝트 탐색기 창입니다.The Unity Project Explorer window.

Unity 프로젝트 탐색기를 보려면To view the Unity Project Explorer
  • Visual Studio의 주 메뉴에서 보기, Unity 프로젝트 탐색기를 선택합니다.In Visual Studio, on the main menu, choose View, Unity Project Explorer. 키보드: Alt+Shift+EKeyboard: Alt+Shift+E

    Unity 프로젝트 탐색기 창을 봅니다.View the Unity Project Explorer window.

    Unity 프로젝트 탐색기는 Unity 편집기와 동일한 방식으로 모든 Unity 프로젝트 파일 및 디렉터리를 표시합니다. 이는 Visual Studio Tools for Unity에서 생성한 프로젝트와 솔루션이 구성하는 대로 스크립트 파일만 포함하고 이를 표시하는 솔루션 탐색기를 사용하여 Unity 스크립트를 탐색하는 것과는 다릅니다.The Unity Project Explorer shows all of your Unity project files and directories in the same way that the Unity Editor does - this is different than navigating your unity scripts with the Solution Explorer, which contains only your script files and displays them as the projects and solution generated by Visual Studio Tools for Unity organizes them. 특히 대규모 프로젝트에서 Unity 프로젝트 탐색기를 사용하면 수정하려는 스크립트를 일반적으로 더 쉽게 찾을 수 있습니다. 또한 Visual Studio 솔루션에서 프로젝트 중 하나로 추가하지 않고 Visual Studio에서 다른 종류의 파일(예: 텍스트 기반 구성 파일)을 쉽게 수정할 수 있습니다.Especially in large projects, it's often easier to locate the script you want to modify by using the Unity Project Explorer; it also makes it easy to modify other kinds of files—for example, text-based configuration files—in Visual studio without adding them to one of the projects in the Visual Studio solution.

Unity 오류 목록Unity Error List

Unity 인스턴스에 연결된 경우 Visual Studio 내의 Unity 콘솔로부터의 메시지를 볼 수 있습니다.You can view messages from the Unity console inside Visual Studio when it's connected to a Unity instance. 여기에는 Unity에서의 오류 및 경고가 포함됩니다.This includes errors and warnings from Unity. 메시지는 Visual Studio의 오류 목록 창에 표시됩니다. Unity의 오류 메시지는 오류 탭에, 경고 메시지는 경고 탭에, 기타 메시지(예:Debug.Log Unity API를 사용하여 보낸 메시지)는 메시지 탭에 표시됩니다.The messages are displayed in Visual Studio's Error List window; error messages from Unity are displayed on the Errors tab, warning messages on the Warnings tab, and other messages—for example, messages sent by using the Debug.Log Unity API—are displayed on the Messages tab.

메시지를 보려면 Unity 프로젝트가 Unity 플레이어에서 프로젝트를 디버그하고 있어서 스크립트 디버깅을 지원하고 사용 중인 Visual Studio 버전에 적합한 Visual Studio Tools for Unity 패키지를 가져올 수 있어야 하며 Visual Studio가 Unity에 연결되어 있어야 합니다.In order to see the messages, your Unity project must be Debugging your project in a Unity Player to support Script Debugging and to import the Visual Studio Tools for Unity package that's right for your version of Visual Studio, and Visual Studio must be Connecting Visual Studio to Unity.

Visual Studio의 오류 목록 창에서 Unity의 오류, 경고 및 메시지를 보지 않으려면 구성 메뉴에서 비활성화할 수 있습니다.If you don't want to see errors, warnings, and messages from Unity in Visual Studio's Error List window, you can disable them in the Configuration menu.

바로 가기 키Keyboard shortcuts

바로 가기 키를 사용하여 Visual Studio 기능에 대한 Unity 도구에 신속하게 액세스할 수 있습니다.You can quickly access the Unity Tools for Visual Studio functionality by using their keyboard shortcuts. 다음은 사용할 수 있는 바로 가기를 정리한 것입니다.Here's a summary of the shortcuts that are available.

명령Command 바로 가기Shortcut 바로 가기 명령 이름Shortcut command name
MonoBehavior 마법사 열기Open the MonoBehavior Wizard Ctrl+Shift+MCtrl+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
빠른 monobehavior 마법사 열기Open the Quick MonoBehavior Wizard Ctrl+Shift+QCtrl+Shift+Q EditorContextMenus.CodeWindow.QuickMonoBehavioursEditorContextMenus.CodeWindow.QuickMonoBehaviours
Unity 프로젝트 탐색기 열기Open the Unity Project Explorer Alt+Shift+EAlt+Shift+E View.UnityProjectExplorerView.UnityProjectExplorer
Unity 설명서 액세스Access Unity documentation Ctrl+Alt+M, Ctrl+HCtrl+Alt+M, Ctrl+H Help.UnityAPIReferenceHelp.UnityAPIReference
Unity 디버거(플레이어 또는 편집기)에 연결Attach to Unity debugger (player or editor) 기본값이 없습니다.no default Debug.AttachUnityDebuggerDebug.AttachUnityDebugger

기본값이 마음에 들지 않는 경우 바로 가기 키 조합을 변경할 수 있습니다.You can change the shortcut key combinations if you don't like the default. 변경 방법에 대한 자세한 내용은 Visual Studio에서 바로 가기 키 식별 및 사용자 지정을 참조하세요.For information on how to change it, see Identifying and Customizing Keyboard Shortcuts in Visual Studio.

Unity 디버깅Unity Debugging

Visual Studio Tools for Unity를 통해 Visual Studio의 강력한 디버거를 사용하여 Unity 프로젝트에 대해 편집기와 게임 스크립트를 모두 디버그할 수 있습니다.Visual Studio Tools for Unity lets you debug both editor and game scripts for your Unity project using Visual Studio's powerful debugger.

Unity에 Visual Studio 연결Connecting Visual Studio to Unity

Visual Studio Tools for Unity는 UDP 연결을 통해 Unity와 통신합니다.Visual Studio Tools for Unity communicates with Unity through a UDP connection. 즉, 로컬 또는 네트워크 어느 곳에서나 실행되는 Unity 인스턴스에 완전히 동일한 방식으로 연결할 수 있습니다.This means that you can connect to a Unity instance running locally or anywhere on your network in exactly the same way. Unity 인스턴스 선택 대화 상자를 사용하여 네트워크에서 볼 수 있는 모든 Unity 인스턴스에 연결할 수 있습니다.You can connect to any of the Unity instances you can see on your network by using the Select Unity Instance dialog.

Unity 인스턴스 선택 대화 상자를 열려면To open the Select Unity Instance dialog
  • Visual Studio의 주 메뉴에서 디버그, Unity 디버거 연결을 선택합니다.In Visual Studio, on the main menu, choose Debug, Attach Unity Debugger.

    Unity 디버거를 연결합니다.Attach the debugger of Unity.

  • 또는 Visual Studio의 상태 표시줄에서 Visual Studio의 오른쪽 아래 모서리에 있는 플러그 아이콘을 선택합니다.Or, in Visual Studio, on the status bar, choose the plug icon in the lower right-hand corner of Visual Studio.

    이 아이콘은 VSTU가 Unity에 연결되었음을 보여 줍니다.This icon shows VSTU is connected to Unity.

플러그 아이콘에 확인 표시가 보이면 Unity 인스턴스에 이미 연결되어 있는 것입니다.If the plug icon shows a checkmark, you're already connected to a Unity instance.

Unity 인스턴스 선택 대화 상자는 연결할 수 있는 각 Unity 인스턴스에 대한 일부 정보를 표시합니다.The Select Unity Instance dialog displays some information about each Unity instance that you can connect to.

연결할 Unity 인스턴스를 선택합니다.Choose an instance of Unity to connect to.

프로젝트 이 Unity의 인스턴스에서 실행되는 Unity 프로젝트의 이름입니다.Project The name of the Unity project that's running in this instance of Unity.

컴퓨터 이 Unity가 실행되고 있는 컴퓨터 또는 장치의 이름입니다.Machine The name of the computer or device that this instance of Unity is running on.

형식 이 Unity의 인스턴스가 Unity 편집기의 일부로 실행 중인 경우 편집기이며 이 Unity의 인스턴스가 독립 실행형 플레이어인 경우 플레이어입니다.Type Editor if this instance of Unity is running as part of the Unity Editor; Player if this instance of Unity is a stand-alone player.

포트 이 Unity의 인스턴스에서 통신하는 데 사용하는 UDP 소켓의 포트 번호입니다.Port The port number of the UDP socket that this instance of Unity is communicating over.

중요

Visual Studio Tools for Unity 및 Unity 인스턴스가 UDP 네트워크 소켓을 통해 통신 중이므로 방화벽이 이를 감지할 수 있습니다.Because Visual Studio Tools for Unity and the Unity instance are communicating over a UDP network socket, your firewall might ask about it. 이 경우 VSTU 및 Unity가 통신할 수 있도록 연결 권한을 부여해야 합니다.If this happens, you'll have to authorize the connection so that VSTU and Unity can communicate.

Unity와 Visual Studio 간의 연결 문제 해결Troubleshooting the connection between Unity and Visual Studio

편집기 연결이 사용하도록 설정되어 있는지 확인Confirm Editor Attaching is enabled

Unity 메뉴에서 편집 > 기본 설정을 선택한 다음, 외부 도구 탭을 선택합니다. 편집기 연결 확인 상자가 사용하도록 설정되어 있는지 확인합니다.In the Unity Menu, select Edit > Preferences and then select the External Tools tab. Confirm that the Editor Attaching checkbox is enabled. 자세한 내용은 Unity 기본 설정 설명서를 참조합니다.For more information, consult the Unity Preferences documentation.

Unity 플레이어에서 프로젝트 디버그Debugging your project in a Unity Player

Unity 편집기를 실행 중이지 않은 경우 Visual Studio Tools for Unity를 독립 실행형 플레이어에서 실행 중인 Unity 앱으로 직접 연결하거나 플랫폼 특정적인 문제를 디버그할 수 있습니다.You can connect Visual Studio Tools for Unity directly to your Unity app running in a stand-alone player when you are not running Unity Editor, or to debug problems that are platform specific.

Unity 플레이어에서 스크립트 디버깅을 활성화하려면To enable script debugging in a Unity player
  • 스크립트 디버깅이 활성화된 상태로 개발 빌드를 만들고 있는지 확인합니다.Make sure you are creating a development build with script debugging enabled. Unity 프로젝트의 빌드 설정에서 개발 빌드스크립트 디버깅 확인란에 표시합니다.In the build settings of your Unity project, mark the Development Build and Script Debugging checkboxes.

    디버깅을 위해 Unity 빌드 설정을 구성합니다.Configure the Unity build settings for debugging.

    또한 Unity 웹 플레이어에서 실행 중인 Unity 앱을 디버그하려면 개발 릴리스 채널을 사용하도록 구성해야 합니다.Additionally, to debug a Unity app running in the Unity Web Player, you also need to configure it to use the Development Release Channel.

Unity 웹 플레이어에서 개발 릴리스 채널을 구성하려면To configure the Development Release Channel in Unity Web Player
  • Unity 웹 플레이어의 상황에 맞는 메뉴에서 릴리스 채널을 선택하고 개발 옵션이 활성화되어 있는지 확인합니다.In the Unity Web Player, on the context menu, choose Release Channel and make sure that the Development option is enabled.

    중요

    Unity 4.2 이상 버전에서는 웹 플레이어 상황에 맞는 메뉴에서 릴리스 채널 상황에 맞는 메뉴 항목을 사용하려면 상황에 맞는 메뉴를 열 때 Alt 키를 누르고 있어야 합니다.In Unity 4.2 and later, the Release Channel context menu item is only available on the Web Player context menu when the Alt key is pressed as the context menu is opened. 웹 플레이어가 Mac OS X에서 실행 중인 경우 Option 키를 대신 누릅니다.If the Web Player is running on Mac OS X, press the Option key instead.

    마지막으로 디버그하려는 Unity 인스턴스에 연결되어 있는지 확인합니다.Finally, make sure you're connected to the Unity instance that you want to debug. 그렇게 하는 방법에 대한 내용은 Unity에 Visual Studio 연결 섹션을 참조하세요.For information on how to do that, see the Connecting Visual Studio to Unity section.

Unity 프로젝트에서 DLL 디버깅Debugging a DLL in your Unity project

많은 Unity 개발자가 개발하는 기능을 쉽게 다른 프로젝트와 공유할 수 있도록 코드 구성 요소를 외부 DLL로 작하고 있습니다.Many Unity developers are writing code components as external DLLs so that the functionality they develop can be easily shared with other projects. Visual Studio Tools for Unity를 통해 Unity 프로젝트에서 이러한 DDL의 코드를 다른 코드와 함께 원활하게 디버그할 수 있습니다.Visual Studio Tools for Unity makes it easy to debug code in these DLLs seamlessly with other code in your Unity project.

참고

이때 Visual Studio Tools for Unity는 관리 DLL만 지원합니다.At this time, Visual Studio Tools for Unity only supports managed DLLs. C++에서 작성한 것과 같은 네이티브 코드 DLL의 디버깅은 지원하지 않습니다.It does not support debugging of native code DLLs, such as those written in C++.

여기에 설명된 시나리오에서는 사용자에게 소스 코드가 있다고 가정합니다. 즉, 자사 코드를 개발 또는 다시 사용하는 중이거나 타사 라이브러리에 대한 소스 코드가 있으며 이를 Unity 프로젝트에서 DLL로 배포하도록 계획 중이라고 가정합니다.Note that the scenario described here assumes that you have the source code—that is, you are developing or re-using your own first-party code, or you have the source code to a third-party library, and plan to deploy it in your Unity project as a DLL. 이 시나리오는 소스 코드가 없는 DLL 디버깅에 대해서는 설명하지 않습니다.This scenario does not describe debugging a DLL for which you do not have the source code.

Unity 프로젝트에서 사용되는 관리 DLL 프로젝트를 디버그하려면To debug a managed DLL project used in your Unity project
  1. Visual Studio Tools for Unity에서 생성한 Visual Studio 솔루션에 기존 DLL 프로젝트를 추가합니다.Add your existing DLL project to the Visual Studio solution generated by Visual Studio Tools for Unity. 새로운 관리 DLL 프로젝트를 시작하여 Unity 프로젝트에 코드 구성 요소를 포함하는 경우도 더러 있을 수 있습니다. 이러한 경우 새로운 관리 DLL 프로젝트를 Visual Studio 솔루션에 대신 추가할 수 있습니다.Less commonly, you might be starting a new managed DLL project to contain code components in your Unity project; if that's the case, you can add a new managed DLL project to the Visual Studio solution instead. 기존 또는 새 프로젝트를 솔루션에 추가하는 방법에 대한 자세한 내용은 방법: 솔루션에 프로젝트 추가를 참조하세요.For more information on adding a new or existing project to a solution, see How to: Add Projects to a Solution.

    기존 DLL 프로젝트를 솔루션에 추가합니다.Add your existing DLL project to the solution.

    두 경우 모두 Visual Studio Tools for Unity에서는 프로젝트 및 솔루션 파일을 다시 생성해야 하는 경우에도 프로젝트 참조를 유지하므로 이러한 단계는 한 번만 수행하면 됩니다.In either case, Visual Studio Tools for Unity maintains the project reference, even if it has to regenerate the project and solution files again, so you only need to perform these steps once.

  2. DLL 프로젝트에서 올바른 Unity 프레임워크 프로필을 참조하세요.Reference the correct Unity framework profile in the DLL project. Visual Studio의 DLL 프로젝트 속성에서 대상 프레임워크 속성을 사용 중인 Unity 프레임워크 버전으로 설정합니다.In Visual Studio, in the DLL project's properties, set the Target framework property to the Unity framework version you're using. 이는 Unity 전체, 마이크로, 또는 웹 기반 클래스 라이브러리 등 프로젝트가 대상으로 하는 API 호환성과 일치하는 Unity 기반 클래스 라이브러리입니다.This is the Unity Base Class Library that matches the API compatibility that your project targets, such as the Unity full, micro, or web base class libraries. 다른 프레임워크 또는 호환성 수준에 있지만 사용 중인 Unity 프레임워크 버전에는 없을 수 있는 프레임워크 메서드를 DLL에서 호출하는 것을 방지합니다.This prevents your DLL from calling framework methods that exist in other frameworks or compatibility levels, but which might not exist in the Unity framework version you're using.

    Unity 프레임워크에 DLL의 대상 프레임워크를 설정합니다.Set the DLL's target framework to Unity framework.

  3. Unity 프로젝트의 자산 폴더에 DLL을 복사합니다.Copy the DLL to your Unity project's Asset folder. Unity에서 자산은 런타임에 로드될 수 있도록 Unity 앱과 함께 배포되고 패키지되는 파일입니다.In Unity, assets are files that are packaged and deployed together with your Unity app so that they can be loaded at run-time. DLL은 런타임에 연결되므로 DDL을 자산으로 배포해야 합니다.Since DLLs are linked at runtime, DLLs must be deployed as assets. 자산으로 배포하기 위해 Unity 편집기는 Unity 프로젝트에서 자산 폴더 안에 DLL을 배치할 것을 요구합니다.To be deployed as an asset, the Unity Editor requires the DLLs to be put inside the Assets folder in your Unity project. 다음 두 가지 방법으로 이 작업을 수행할 수 있습니다.There are two ways you can do this:

    • DLL 프로젝트의 빌드 설정을 수정하여 해당 출력 폴더에서 Unity 프로젝트의 자산 폴더로 출력 DLL 및 PDB 파일을 복사하는 빌드 후 작업을 포함합니다.Modify the build settings of your DLL project to include a post-built task that copies the output DLL and PDB files from its output folder to the Assets folder of your Unity project.

    • DLL 프로젝트의 빌드 설정을 수정하여 Unity 프로젝트의 자산 폴더로 해당 출력 폴더를 설정합니다.Modify the build settings of your DLL project to set its output folder to be the Assets folder of your Unity project. DLL 및 PDB 파일은 모두 자산 폴더에 배치됩니다.Both DLL and PDB files will be placed in the Assets folder.

      PDB 파일은 DLL의 디버깅 기호를 포함하며 DLL 코드를 소스 코드 형태로 매핑하므로 디버깅에 필요합니다.The PDB files are needed for debugging because they contain the DLL's debugging symbols, and map the DLL code to its source code form. Visual Studio Tools for Unity에서는 DLL 및 PDB의 정보를 사용하여 Unity 스크립팅 엔진에서 사용되는 디버그 기호 형식인 DLL.MDB 파일을 만듭니다.Visual Studio Tools for Unity will use information from the DLL and PDB to create a DLL.MDB file, which is the debug symbol format used by the Unity scripting engine.

  4. 코드를 디버그합니다.Debug your code. 이제 Unity 프로젝트의 소스 코드와 함께 DLL 소스 코드를 디버그할 수 있으며 중단점 및 단계별 코드 실행 등 익숙한 디버깅 기능을 모두 사용할 수 있습니다.You can now debug your DLL source code together with your Unity project's source code, and use all the debugging features you are used to, such as breakpoints and stepping through code.