Xamarin 환경 확인Verify your Xamarin environment

설치 관리자가 완료되면(설정 및 설치 참조) 몇 분 동안 Xamarin 개발을 경험할 모든 준비가 되었는지 확인하세요.Once the installers have completed (see Setup and install), spend a few minutes to verify that everything is ready to experience Xamarin development.

이러한 확인을 완료한 후에는 다음 연습 중 하나 또는 두 연습을 모두 진행할 수 있습니다.Once you have completed these verifications, you can do either or both of the following walkthroughs:

모든 플랫폼All platforms

먼저 도구 > 옵션을 선택하고 Xamarin > 기타를 확장한 후에 업데이트에 대한 지금 확인 링크를 클릭합니다.First, select Tools > Options, expand Xamarin > Other, and click the Check now link for updates. 이전의 라이선스 문제를 방지하려면 Xamarin 4.0.3.214 이상 버전을 사용해야 합니다.You need to be using Xamarin 4.0.3.214 or later to avoid previous licensing issues.

그런 다음 Visual Studio에서 파일 > 새 프로젝트를 사용하여 Xamarin 솔루션을 새로 만들고, 대화 상자에서 템플릿 > 기타 언어 > Visual C# > 크로스 플랫폼을 확장하고, 비어 있는 앱(네이티브 이식 가능)을 선택하고, 확인을 클릭합니다.Then create a new Xamarin solution in Visual Studio using File > New Project, then in the dialog expand Templates > Other Languages > Visual C# > Cross-Platform, select Blank App (Native Portable), and click OK. 그러면 공유된 이식 가능한 클래스 라이브러리 프로젝트와 Android, iOS 및 Windows에 대한 개별 프로젝트가 포함된 솔루션이 생성됩니다.This creates a solution with a shared portable class library project and individual projects for Android, iOS, and Windows:

비어 있는 앱(네이티브 이식 가능) 템플릿에서 새 프로젝트를 만들기의 결과Results of creating a new project from the Blank App (Native Portable) template

참고

여기에 템플릿이 없으면 Xamarin 프로젝트 템플릿 누락 시 사용 방법(이 페이지의 맨 아래에 나와 있음)을 참조하세요.If the templates are not there, see Are the Xamarin project templates missing? Try this at the bottom of this page.

AndroidAndroid

  1. 도구 > Android > Android SDK Manager로 이동한 다음 최신 버전의 Android SDK 도구, Android SDK 플랫폼 도구 및 Android SDK 빌드 도구 구성 요소를 설치하여 최신 Android SDK 도구가 설치되었는지 확인합니다.Check that you have the latest Android SDK tools installed by going to Tools > Android > Android SDK Manager and installing the newest version of the Android SDK Tools, Android SDK Platform-tools, and Android SDK Build-tools components. 항상 최신 Android API 수준을 설치하지는 않아도 되며, 필요한 API는 대상으로 지정할 플랫폼 수준에 따라 달라집니다.Note that it is not necessary to always install the latest Android API level; the API you need depends on the platform level you want to target. 일반적으로 Xamarin을 설치하면 필요한 플랫폼 수준이 설치됩니다.In general, installing Xamarin will install the platform level it requires.

  2. Android 디자이너 유효성 검사: 솔루션 탐색기의 Android 프로젝트에서리소스 > 레이아웃 > Main.axml 파일을 엽니다.Validate the Android designer: in the Android project in Solution Explorer, open the Resources > Layout > Main.axml file. 이 파일이 바로 표시되지 않으면 솔루션 탐색기에서 파일을 검색해 보세요. 이 파일은 Android 프로젝트에만 있으며 iOS 프로젝트에는 없습니다.(If you aren't seeing this file directly, try searching for it in Solution Explorer; it exists in the Android project only and not in the iOS project.)

    • "설치된 Android SDK가 너무 오래되었습니다."라는 오류가 표시되면 이 메시지에서 Android SDK 열기를 클릭하고 위의 1단계에서와같이 사용 가능한 최신 SDK 버전 도구를 선택하여 설치합니다.If you receive an error saying "The installed Android SDK is too old", click Open Android SDK in that message to select and install the newest SDK version tools available as in step 1 above.
  3. 에뮬레이터(또는 장치)에서 빌드 및 디버깅 확인:Validate building and debugging in the emulator (or device):

    • 솔루션 탐색기에서 Android 프로젝트를 마우스 오른쪽 단추로 클릭하고 시작 프로젝트로 설정을 선택합니다.Right-click the Android project in Solution Explorer and select Set as Startup Project.

      Visual Studio 시작 프로젝트로 설정 옵션Visual Studio Set as Startup project option

    • 대상 Android 버전에 따라 적절한 에뮬레이터를 선택합니다. 컴퓨터에 연결된 Android 개발 장치가 있으면 에뮬레이터와 함께 여기에 나열됩니다.Select an appropriate emulator based on your target Android version; if you have an Android development device attached to your computer, you will also see it listed here alongside the emulators:

      • Windows 8+: 아래 표시된 대로 Visual Studio의 디버그 드롭다운에서 VS 에뮬레이터 대상을 선택하고 F5 키를 눌러 디버거를 시작합니다.Windows 8+: select a VS Emulator target in Visual Studio's debug drop-down as shown below and start the debugger by pressing F5. 자세한 내용은 Introducing Visual Studio's Emulator for Android(Visual Studio Emulator for Android 소개)(Visual Studio ALM 블로그)를 참조하세요.For more details, see Introducing Visual Studio's Emulator for Android (Visual Studio ALM blog). 에뮬레이터를 작동시키는 중 문제가 발생하면 Troubleshooting the Visual Studio Emulator for Android을 참조하세요.If you encounter problems getting the emulator to work, see Troubleshooting the Visual Studio Emulator for Android. 도구 > Visual Studio Emulator for Android...를 선택하여 에뮬레이터에 대한 새로운 장치 프로필을 만들 수도 있습니다.You can also create new device profiles for the emulator by selecting Tools > Visual Studio Emulator for Android....

        Visual Studio Emulator for Android를 디버그 대상으로 선택Selecting the Visual Studio Emulator for Android as a debug target

        참고: 도구 > Visual Studio Emulator for Android... 메뉴 옵션이 표시되지 않으면 에뮬레이터 자체가 설치되지 않은 것일 수 있습니다.Note: if you do not see the Tools > Visual Studio Emulator for Android... menu option, you may not have the emulator itself installed. 제어판 > 프로그램 및 기능으로 이동하여 Microsoft Visual Studio를 선택하고 변경을 클릭하여 설치 관리자를 다시 실행합니다.Go to Control Panel > Programs and Features, select Microsoft Visual Studio, and click Change to rerun the installer. 설치 관리자에서 수정을 클릭하고 플랫폼 간 모바일 개발 > Microsoft Visual Studio Emulator for Android 확인란을 선택한 후에 업데이트를 클릭합합니다.Click Modify in the installer, check the box for Cross Platform Mobile Development > Microsoft Visual Studio Emulator for Android, and click Update.

      • Windows 7 이하: 대신 드롭다운에서 Xamarin Player for Android를 선택하고 F5 키를 눌러 실행합니다.For Windows 7 and earlier: select the Xamarin Player for Android in the drop-down instead and press F5 to run. Xamarin Player, 해당 장치 관리자 및 문제 해결 팁에 대해서는 Xamarin Android Player (영문)(xamarin.com)를 참조하세요.For details on the Xamarin Player, its device manager, and troubleshooting tips, read Xamarin Android Player (xamarin.com).

참고

Visual Studio에서 도구 모음에 AVD(Android Emulator Manager) 단추가 표시되는 것을 알 수 있습니다(아래 그림 참조). 이 단추를 선택하면 Google Android 에뮬레이터를 구성하는 데 특별히 사용되는 장치 관리자가 열립니다.In Visual Studio, you may notice the presence of the Android Emulator Manager (AVD) button in the toolbar (show below), which opens the device manager that is specifically used for configuring the Google Android emulator. 이 단추는 프로필을 구성하는 자체 장치 관리자가 있는 Visual Studio Emulator for Android 또는 Xamarin Player에는 영향을 미치지 않습니다.This has no impact on either the Visual Studio Emulator for Android or the Xamarin Player, each of which has their own device manager for configuring profiles. 자세한 내용은 Introducing Visual Studio's Emulator for Android(Visual Studio Emulator for Android 소개)(Visual Studio ALM 블로그) 및 Xamarin Android Player(xamarin.com)를 참조하세요.See Introducing Visual Studio's Emulator for Android (Visual Studio ALM blog) and Xamarin Android Player (xamarin.com) for details.
CrossPlat Xamarin Verify 7CrossPlat Xamarin Verify 7

Windows PhoneWindows Phone

  1. Windows Phone 디자이너 확인: 솔루션 탐색기의 Windows Phone 프로젝트에서 MainPage.xaml 파일을 엽니다.Validate the Windows Phone designer: in the Windows Phone project in Solution Explorer, open the MainPage.xaml file.

  2. 에뮬레이터 또는 장치에서 빌드 및 디버깅 확인(참고: 이 단계를 수행하려면 Visual Studio를 통해 설치된 Windows Phone 에뮬레이터 또는 테더링된 장치가 있어야 함):Validate building and debugging in the emulator or on a device (note: you will need to have the Windows Phone emulator installed through Visual Studio setup for this step, or a tethered device):

    • 솔루션 탐색기에서 Windows Phone 프로젝트를 마우스 오른쪽 단추로 클릭하고 시작 프로젝트로 설정을 선택합니다.Right-click the Windows Phone project in Solution Explorer and select Set as Startup Project.

    • 아래 표시된 대로 Visual Studio의 디버그 드롭다운에서 Emulator 8.1 대상 또는 연결된 장치를 선택하고 F5 키를 눌러 디버거를 시작합니다.Select an Emulator 8.1 target or an attached device in Visual Studio's debug drop-down as shown below and start the debugger by pressing F5.

      Windows Phone 에뮬레이터를 디버그 대상으로는 선택Selecting a Windows Phone emulator as a debug target

    • 에뮬레이터를 작동하는 데 문제가 발생하는 경우 Windows Phone 8 Emulator 문제 해결(영문)을 참조하세요.If you encounter problems getting the emulator to work, read Troubleshooting the Windows Phone 8 Emulator.

iOSiOS

  1. Mac에 연결 (영문)(xamarin.com)에 설명된 대로 Mac이 네트워크에서 사용 가능하고 Visual Studio와 연결되었는지 확인합니다.Make sure your Mac is available on the network and paired with Visual Studio as described on Connecting to the Mac (xamarin.com).

  2. 스토리보드 디자이너 확인: 솔루션 탐색기의 iOS 프로젝트에서 Main.storyboard 파일을 엽니다.Validate the storyboard designer: in the iOS project in Solution Explorer, open the Main.storyboard file. 여기서 Visual Studio는 Mac에서 원격으로 실행 중인 디자이너를 호스트하고 있습니다.Here, Visual Studio is hosting the designer that's running remotely on the Mac.

  3. 빌드 및 디버깅 확인:Validate building and debugging:

    1. 솔루션 탐색기에서 iOS 프로젝트를 마우스 오른쪽 단추로 클릭하고 시작 프로젝트로 설정을 선택합니다.Right-click the iOS project in Solution Explorer and select Set as Startup Project.

    2. 아래 표시된 대로 Visual Studio의 빌드 드롭다운에서 iPhoneSimulator 대상을 선택하거나 테더링된 장치가 있는 경우 iPhone 대상을 선택합니다.Select the iPhoneSimulator target from Visual Studio's build drop-down as shown below, or the iPhone target if you have a tethered device. 시뮬레이터가 나열되지 않으면 Mac에서 Xcode를 시작하고 Xcode->기본 설정을 선택한 후에 다운로드를 클릭합니다.If no simulators are listed, launch Xcode on your Mac, select Xcode->Preferences, and click Download. 구성 요소 에 다운로드할 수 있는 시뮬레이터 버전이 표시되어야 합니다.Under Components you should see the simulator versions that are available to download. 디버깅에 대한 추가 지침은 Xamarin의 Debugging(디버깅) 페이지(xamarin.com)에서 확인할 수 있습니다.Additional instructions for debugging can be found on the Xamarin's Debugging page (xamarin.com).

      IPhoneSimulator 빌드 대상 선택Selecting the iPhoneSimulator build target

    3. 아래 표시된 대로 Visual Studio의 디버그 드롭다운에서 iPhone 대상을 선택하고 F5 키를 눌러 디버거를 시작합니다.Select an iPhone target from Visual Studio's debug drop-down as shown below and start the debugger by pressing F5. 그러면 앱을 조작할 Mac에서 시뮬레이터가 시작되고 동시에 Visual Studio에서 디버깅이 수행됩니다.This launches the simulator on the Mac where you'll interact with the app, while debugging happens in Visual Studio. 실제로 iPhone 또는 iPad가 Mac에 연결되어 있으면 여기에 나타나며, 해당 iPhone 또는 iPad를 대신 선택할 수 있습니다.If you have a physical iPhone or iPad connected to the Mac, it will appear here and you can select it instead. 나열된 장치 또는 시뮬레이터가 하나도 표시되지 않는다면 위의 1단계에서 연결된 항목을 검토하거나 도구 >iOS >Xamarin Mac 에이전트If you do not see any devices or simulators listed, check the connection to the Mac by reviewing the topic linked in step 1 above, or by going to Tools >iOS >Xamarin Mac Agent

      iPhone 디버그 대상 선택Selecting an iPhone debug target

    4. Mac에 연결할 때 문제가 발생하면 연결 문제 해결 (영문)(xamarin.com)을 참조하세요.If you encounter problems connecting to the Mac, read Connection Troubleshooting (xamarin.com).

    5. “No installed provisioning profiles match the installed iOS signing keys(설치된 프로비저닝 프로필이 설치된 iOS 서명 키와 일치하지 않습니다).”라는 오류가 표시되면 다음을 수행합니다.If you see an error saying "No installed provisioning profiles match the installed iOS signing keys, do the following:

      • Xcode에 사용자 계정 추가 (영문)(apple.com)에 설명된 대로 Mac의 Xcode에 Apple Id 계정이 추가되어 있는지 확인합니다.Check that your Apple Id account is added in Xcode on your Mac as described on Adding Your Account to Xcode (apple.com). 계정을 추가한 후 Visual Studio와 Xcode를 둘 다 다시 시작해야 합니다.After adding your account, be sure to restart both Visual Studio and Xcode.

        CrossPlat Xamarin Verify 8CrossPlat Xamarin Verify 8

      • iOS 번들 서명 탭의 iOS 프로젝트 속성에서 활성 디버그 구성을 위한 사용자 지정 권한 부여 필드가 비어 있는지 확인합니다.Verify that in your iOS project properties in the iOS bundle signing tab, that the Custom entitlement field is empty for the active debug configuration. 참고: 위의 오류 메시지가 발생하는 경우에만 이 설정을 제거합니다.Note: you should only try removing this setting if you've encountered the above error message.

Xamarin 프로젝트 템플릿 누락 시Are the Xamarin project templates missing? 사용 방법Try this

Visual Studio 2013과 Visual Studio 2015가 함께 설치되어 있는 경우 Xamarin 웹 사이트에서 직접 Xamarin을 설치하면 템플릿이 누락될 수 있습니다.Templates might be missing if you install Xamarin directly from the Xamarin website and you have Visual Studio 2013 and Visual Studio 2015 installed side-by-side. 쉽게 수정할 수 있습니다. Xamarin 설치 프로그램에서 Visual Studio 2015용 Xamarin 기능을 사용하도록 설정하기만 하면 됩니다.It's easy to fix, though: just enable the Xamarin for Visual Studio 2015 feature in the Xamarin setup program.

  1. 제어판에서 프로그램 및 기능을 열고 Xamarin 항목을 선택하고 변경을 클릭합니다.In Control Panel, open Programs and Features, choose the Xamarin item, and click Change.

  2. 표시되는 Xamarin 설정 마법사에서 다음 , 변경을 차례로 클릭합니다.In the setup wizard for Xamarin that appears, click Next and then Change.

  3. 설치할 선택적 기능 목록에서 Xamarin for Visual Studio 2015를 확장하고 will be installed on local drive(로컬 드라이브에 설치)를 선택하고 다음 을 클릭하여 기능을 추가합니다.In the list of optional features to install, expand Xamarin for Visual Studio 2015, choose will be installed on local drive, and click Next to proceed with adding the feature.