Visual Studio 및 Unity 시작Get started with Visual Studio and Unity

참고

이 가이드에서는 Unity 허브 프로그램을 사용 하 여 Unity를 이미 설치 했다고 가정 합니다.This guide assumes you already have installed Unity using the Unity Hub program. Unity를 처음 접하는 경우 unity에서 Unity Essentials learning 경로 를 학습 하 고 완료 하는 것이 좋습니다.If you are new to Unity, we recommend visiting Unity Learn and complete the Unity Essentials learning path first.

Visual Studio에 대 한 Unity 지원 설치Install Unity support for Visual Studio

Visual Studio Tools for Unity은 c # 등을 작성 하 고 디버깅 하는 기능을 제공 하는 무료 확장입니다.Visual Studio Tools for Unity is a free extension that provides support for writing and debugging C# and more. 확장 프로그램에 포함 된 내용에 대 한 전체 목록은 Unity 용 도구 개요 를 참조 하세요.Visit the Tools for Unity overview for a complete list of what the extensions includes.

참고

이 설치 가이드는 Visual Studio 용입니다.This installation guide is for Visual Studio. Visual Studio Code 사용 하는 경우 VS Code 설명서를 사용 하 여 Unity 개발을 참조 하세요.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

  1. Visual Studio 설치 관리자를 다운로드하거나 이미 설치 되어 있는 경우 실행 합니다.Download the Visual Studio installer, or run it if already installed.

  2. 원하는 Visual Studio 버전에 대해 수정(이미 설치된 경우) 또는 설치(새 설치의 경우)를 클릭합니다.Click Modify (if already installed) or Install (for new installations) for your desired version of Visual Studio.

  3. 작업 탭에서 게임 섹션으로 스크롤하고 Unity 워크 로드 를 사용 하 여 게임 개발 을 선택 합니다.On the Workloads tab, scroll to the Gaming section and select the Game development with Unity workload.

    설치 관리자에서 Unity를 사용한 게임 개발 작업 상자

참고

이 설치 가이드는 Mac용 Visual Studio에 대 한 것입니다.This installation guide is for Visual Studio for Mac. Visual Studio Code 사용 하는 경우 VS Code 설명서를 사용 하 여 Unity 개발을 참조 하세요.If you're using Visual Studio Code, please visit the Unity Development with VS Code documentation.

Unity 용 도구는 Mac용 Visual Studio 설치에 포함 되어 있으며 별도의 설치 단계가 필요 하지 않습니다.Tools for Unity is included with the installation of Visual Studio for Mac and no separate installation steps are required. Mac용 Visual Studio > Extensions > 게임 개발 메뉴에서이를 확인할 수 있습니다.You can verify this in the Visual Studio for Mac > Extensions > Game Development menu. Unity 용 Mac용 Visual Studio 도구 를 사용 하도록 설정 해야 합니다.Visual Studio for Mac Tools for Unity should be enabled.

Unity를 사용 하도록 설정 된 Mac용 Visual Studio 도구를 보여 주는 확장 관리자 보기

업데이트 확인Check for updates

최신 버그 수정, 기능 및 Unity 지원이 있도록 Visual Studio 및 Mac용 Visual Studio 업데이트를 유지 하는 것이 좋습니다.It's recommended to keep Visual Studio and Visual Studio for Mac updated so you have the latest bug fixes, features, and Unity support. Unity 버전의 업데이트는 필요 하지 않습니다.This doesn't require an update of Unity versions.

  1. 도움말 > 업데이트 확인 메뉴를 클릭 합니다.Click the Help > Check for Updates menu.

    Visual Studio 2019의 업데이트 확인 메뉴

  2. 업데이트를 사용할 수 있는 경우 Visual Studio 설치 관리자 새 버전이 표시 됩니다.If there is an update available, the Visual Studio Installer will show a new version. 업데이트 단추를 클릭합니다.Click the Update button.

  1. Mac용 Visual Studio > 업데이트 확인 ... 메뉴를 클릭 하 여 Visual Studio 업데이트 대화 상자를 엽니다.Click the Visual Studio for Mac > Check for Updates... menu to open the Visual Studio Update dialog.
  2. 업데이트를 사용할 수 있는 경우 설치 단추를 클릭 합니다.If there is an update available, click the Install button.

Visual Studio를 사용 하도록 Unity 구성Configure Unity to use Visual Studio

기본적으로 Unity는 Visual Studio를 사용 하거나 스크립트 편집기로 Mac용 Visual Studio을 사용 하도록 이미 구성 되어 있어야 합니다.By default, Unity should already be configured to use Visual Studio or Visual Studio for Mac as a script editor. 이를 확인 하거나 Unity 편집기에서 외부 스크립트 편집기를 특정 버전의 Visual Studio로 변경할 수 있습니다.You can confirm this or change the external script editor to a specific version of Visual Studio from the Unity Editor.

  1. Unity 편집기에서 > 기본 설정 편집 메뉴를 선택 합니다.In the Unity Editor, select the Edit > Preferences menu..

  2. 왼쪽에서 외부 도구 탭을 선택 합니다.Select the External Tools tab on the left.

  3. 외부 스크립트 편집기 드롭다운 목록에서 Visual Studio의 여러 설치를 선택 하는 방법을 제공 합니다.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. 드롭다운 목록에서 찾아보기 ... 를 클릭 하 여 목록에 없는 버전을 추가할 수도 있습니다.You can also click Browse... from the dropdown list to add an unlisted version.

    Windows에서 Unity 편집기의 외부 도구 기본 설정 메뉴

  4. 찾아보기... 를 선택한 경우 Visual Studio 설치 디렉터리 내부의 Common7/IDE 디렉터리로 이동하고 devenv.exe 를 선택합니다.If Browse... was selected, navigate to the Common7/IDE directory inside your Visual Studio installation directory and select devenv.exe. 그런 다음 열기 를 클릭 합니다.Then, click Open.

  5. 외부 스크립트 편집기 목록에서 Visual Studio를 선택한 후 편집기 연결 확인란이 선택되어 있는지 확인합니다.Once Visual Studio is selected in the External Script Editor list, confirm that the Editor Attaching checkbox is selected.

  6. 기본 설정 대화 상자를 닫아 구성 프로세스를 완료합니다.Close the Preferences dialog to complete the configuration process.

  1. Unity 편집기에서 unity > 기본 설정 메뉴 .를 선택 합니다.In the Unity Editor, select the Unity > Preferences menu..

  2. 왼쪽에서 외부 도구 탭을 선택 합니다.Select the External Tools tab on the left.

  3. 외부 스크립트 편집기 드롭다운 목록에서 Visual Studio의 여러 설치를 선택 하는 방법을 제공 합니다.The External Script Editor dropdown list provides a way to choose different installations of Visual Studio. 드롭다운 목록에서 찾아보기 ... 를 클릭 하 여 목록에 없는 버전을 추가할 수도 있습니다.You can also click Browse... from the dropdown list to add an unlisted version.

    MacOS에서 Unity 편집기의 외부 도구 기본 설정 메뉴

  4. 기본 설정 대화 상자를 닫아 구성 프로세스를 완료합니다.Close the Preferences dialog to complete the configuration process.

다음 단계Next steps

Visual Studio에서 Unity 프로젝트를 사용 하 여 작업 하 고 디버그 하는 방법을 알아보려면 Visual Studio Tools for Unity 사용을 참조 하세요.To learn how to work with and debug your Unity project in Visual Studio, visit Using Visual Studio Tools for Unity.