Visual Studio Tools for Unity 사용Use Visual Studio Tools for Unity

이 섹션에서는 Visual Studio Tools for Unity의 통합 및 생산성 기능을 사용하는 방법과 Unity 개발을 위해 Visual Studio 디버거를 사용하는 방법에 대해 배워 봅니다.In this section, you'll learn how to use Visual Studio Tools for Unity's integration and productivity features, and how to use the Visual Studio debugger for Unity development.

Visual Studio에서 Unity 스크립트 열기Open Unity scripts in Visual Studio

Visual Studio가 unity 용 외부 편집기로 설정되 면 unity 편집기에서 스크립트를 두 번 클릭 하면 자동으로 시작 되거나 visual studio로 전환 되 고 선택한 스크립트가 열립니다.Once Visual Studio is set as the external editor for Unity, double-clicking a script from the Unity editor will automatically launch or switch to Visual Studio and open the chosen script.

또는 Unity에서 c # 프로젝트 메뉴 열기 > 자산 을 선택 하 여 소스 편집기에서 스크립트가 열려 있지 않은 Visual Studio를 열 수 있습니다.Alternatively, you can open Visual Studio with no script open in the source editor by selecting the Assets > Open C# Project menu in Unity.

Visual Studio에서 c # 프로젝트 열기

Mac용 Visual Studio에서 c # 프로젝트 열기

Unity 설명서 액세스Unity documentation access

Visual Studio에서 신속하게 Unity 스크립팅 설명서에 액세스할 수 있습니다.You can access the Unity scripting documentation quickly from Visual Studio. Visual Studio Tools for Unity에서 로컬에 있는 API 설명서를 찾지 못하는 경우 온라인으로 찾기를 시도합니다.If Visual Studio Tools for Unity doesn't find the API documentation locally, it will try to find it online.

  • Visual Studio에서 알아보려는 Unity API를 강조 표시하거나 그 위로 커서를 가져간 다음, Ctrl+Alt+M , Ctrl+H 를 누릅니다.In Visual Studio, highlight or place the cursor over the Unity API you want to learn about, then press Ctrl+Alt+M , Ctrl+H
  • 또한 keybinding 대신 Help > UNITY API 참조 메뉴를 사용할 수 있습니다.You can also use the Help > Unity API Reference menu instead of the keybinding. Visual Studio의 Unity API 참조 메뉴The Unity API Reference menu in Visual Studio
  • Mac용 Visual Studio에서 자세한 정보를 보려는 Unity API를 강조 표시 하거나 커서를 놓고 Cmd 를 누릅니다. + 'In Visual Studio for Mac, highlight or place the cursor over the Unity API you want to learn about, then press Cmd+'
  • 또한 keybinding 대신 Help > UNITY API 참조 메뉴를 사용할 수 있습니다.You can also use the Help > Unity API Reference menu instead of the keybinding. Mac용 Visual Studio의 Unity API 참조 메뉴The Unity API Reference menu in Visual Studio for Mac

Unity API 메시지에 대한 IntelliSenseIntellisense for Unity API Messages

Intellisense 코드 완성을 사용하면 MonoBehaviour 스크립트에서 Unity API 메시지를 쉽게 구현하고 Unity API를 원활하게 학습할 수 있습니다.Intellisense code-completion makes it easy to implement Unity API messages in MonoBehaviour scripts, and assists with learning the Unity API. Unity 메시지에 대해 IntelliSense를 사용하는 방법은 다음과 같습니다.To use IntelliSense for Unity messages:

  1. MonoBehaviour에서 파생된 클래스 본문 안에서 새 줄에 커서를 놓습니다.Place the cursor on a new line inside the body of a class that derives from MonoBehaviour.

  2. OnTriggerEnter와 같은 Unity 메시지 이름을 입력합니다.Begin typing the name of a Unity message, such as OnTriggerEnter.

  3. 글자 “ ontri ”를 입력하면 IntelliSense 제안 목록이 나타납니다.Once the letters " ontri " have been typed, a list of IntelliSense suggestions appears.

Visual Studio에서 IntelliSense 사용

  1. 세 가지 방법으로 목록의 선택 항목을 변경할 수 있습니다.The selection on the list can be changed in three ways:

    • 위쪽아래쪽 화살표 키를 사용합니다.With the Up and Down arrow keys.

    • 원하는 항목을 마우스로 클릭합니다.By clicking with the mouse on the desired item.

    • 원하는 항목의 이름을 계속 입력합니다.By continuing to type the name of the desired item.

  2. IntelliSense에서는 다음과 같은 방법으로 필요한 매개 변수를 모두 포함하는 선택한 Unity 메시지를 삽입할 수 있습니다.IntelliSense can insert the selected Unity message, including any necessary parameters:

    • Tab 키를 누릅니다.By pressing Tab.

    • Enter 키를 누릅니다.By pressing Enter.

    • 선택한 항목을 두 번 클릭합니다.By double-clicking the selected item.

Visual Studio에서 IntelliSense의 Unity 메시지 삽입

Unity MonoBehavior 스크립팅 마법사Unity MonoBehavior scripting wizard

MonoBehavior 마법사를 사용하여 모든 Unity API 메서드의 목록을 보고 빈 정의를 빠르게 구현할 수 있습니다.You can use the MonoBehavior wizard to view a list of all the Unity API methods and quickly implement an empty definition. 특히 메서드 주석 생성 옵션이 사용하도록 설정하면 Unity API에서 사용 가능한 내용을 학습하는 경우 이 기능이 유용합니다.This feature, particularly with the Generate method comments option enabled, is helpful if you are still learning what's available in the Unity API.

MonoBehavior 마법사를 사용하여 빈 MonoBehavior 메서드 정의를 만들려면:To create empty MonoBehavior method definitions with the MonoBehavior wizard:

  1. Visual Studio에서 메서드를 삽입할 위치에 커서를 놓은 다음, Ctrl+Shift+M 을 눌러 MonoBehavior 마법사를 시작합니다.In Visual Studio, position the cursor where you want the methods to be inserted, then press Ctrl+Shift+M to launch the MonoBehavior wizard. Mac용 Visual Studio에서 Cmd + Shift + M 을 누릅니다.In Visual Studio for Mac, press Cmd+Shift+M.

  2. 스크립트 메서드 만들기 창에서 추가하려는 각 메서드 이름 옆의 확인란을 선택합니다.In the Create script methods window, mark the checkbox next to the name of each method you want to add.

  3. Framework 버전 드롭다운을 사용하여 원하는 버전을 선택합니다.Use the Framework version dropdown to select your desired version.

  4. 기본적으로 메서드는 커서의 위치에 삽입됩니다.By default, the methods are inserted at the position of the cursor. 또는 삽입 지점 드롭다운의 값을 원하는 위치로 변경하여 클래스에 이미 구현된 메서드 뒤에 삽입하도록 선택할 수 있습니다.Alternatively, you can choose to insert them after any method that's already implemented in your class by changing the value of the Insertion point dropdown to the location you want.

  5. 마법사가 선택한 방법에 대한 주석을 생성하게 하려면 메서드 주석 생성 확인란에 표시합니다.If you want the wizard to generate comments for the methods you selected, mark the Generate method comments checkbox. 이러한 주석은 해당 메서드를 호출하는 때가 언제인지, 해당 메서드가 담당하는 역할이 무엇인지 이해할 수 있기 위해 생성합니다.These comments are meant to help you understand when the method is called and what its general responsibilities are.

  6. 확인 단추를 선택하여 마법사를 종료하고 메서드를 코드에 삽입합니다.Choose the OK button to exit the wizard and insert the methods into your code.

Visual Studio의 monobehavior 마법사 대화 상자

Mac용 Visual Studio의 monobehavior 마법사 대화 상자

Unity 프로젝트 탐색기Unity Project Explorer

Unity 프로젝트 탐색기는 모든 Unity 프로젝트 파일과 디렉터리를 Unity 편집기와 동일한 방법으로 표시합니다.The Unity Project Explorer shows all of your Unity project files and directories in the same way that the Unity Editor does. 이는 Unity 스크립트를 Visual Studio에서 생성된 프로젝트 또는 솔루션으로 구성하는 일반적인 Visual Studio 솔루션 탐색기를 사용하여 Unity 스크립트를 탐색하는 것과 다릅니다.This is different than navigating your Unity scripts with the normal Visual Studio Solution Explorer, which organizes them into projects and a solution generated by Visual Studio.

  • 주 Visual Studio 메뉴에서 보기 > Unity 프로젝트 탐색기 를 선택합니다.On the main Visual Studio menu, choose View > Unity Project Explorer. 바로 가기 키: Alt + Shift + E  Unity 프로젝트 탐색기 창을 봅니다.Keyboard shortcut: Alt+Shift+E View the Unity Project Explorer window.
  • Mac용 Visual Studio에서 Solution Pad는 Unity 프로젝트를 열 때 자동으로 다음과 같이 동작 합니다.In Visual Studio for Mac, the Solution Pad automatically behaves like this when a Unity project is opened.

Unity 디버깅Unity debugging

Visual Studio Tools for Unity를 통해 Visual Studio의 강력한 디버거를 사용하여 Unity 프로젝트에 대해 편집기와 게임 스크립트를 모두 디버그할 수 있습니다.Visual Studio Tools for Unity lets you debug both editor and game scripts for your Unity project using Visual Studio's powerful debugger.

Unity 편집기에서 디버그Debug in the Unity editor

디버깅 시작Start debugging

  1. Unity에 연결 레이블이 지정된 재생 단추를 클릭하여 Visual Studio를 Unity에 연결하거나, 바로 가기 키 F5 키를 사용합니다.Connect Visual Studio to Unity by clicking the Play button labeled Attach to Unity , or use the keyboard shortcut F5. Visual Studio에서 [재생] 클릭Click Play in Visual Studio
  1. 재생 단추를 클릭하거나 Command+Return 또는 F5 키를 눌러 Visual Studio를 Unity에 연결합니다.Connect Visual Studio to Unity by clicking the Play button, or type Command + Return , or F5. 재생을 클릭 Mac용 Visual StudioClick Play in Visual Studio for Mac
  1. Unity로 전환하고 Play (플레이) 단추를 클릭하여 편집기에서 게임을 실행합니다.Switch to Unity and click the Play button to run the game in the editor.

Windows에서 Unity에서 재생을 클릭 합니다.

MacOS에서 Unity에서 재생을 클릭 합니다.

  1. Visual Studio에 연결된 Unity 편집기에서 게임을 실행하면 중단점에 도달할 때 게임 실행이 일시 중지되고 게임이 중단점에 도달한 코드 줄이 Visual Studio에 표시됩니다.When the game is running in the Unity editor while connected to Visual Studio, any breakpoints encountered will pause execution of the game and bring up the line of code where the game hit the breakpoint in Visual Studio.

디버깅 중지Stop debugging

Visual Studio에서 중지 단추를 클릭하거나, 바로 가기 키 Shift+F5 를 사용합니다.Click the Stop button in Visual Studio, or use the keyboard shortcut Shift + F5. Visual Studio에서 [중지] 클릭Click Stop in Visual Studio

Mac용 Visual Studio에서 중지 단추를 클릭하거나 Shift+Command+Return 을 누릅니다.Click the Stop button in Visual Studio for Mac, or press Shift + Command + Return. Mac용 Visual Studio에서 중지를 클릭 합니다.Click Stop in Visual Studio for Mac

Visual Studio의 디버깅에 대한 자세한 내용은 Visual Studio 디버거 개요를 참조하세요.To learn more about debugging in Visual Studio, see First look at the Visual Studio Debugger.

Unity에 연결 및 재생Attach to Unity and Play

더욱 편리하게 사용하려면 Unity에 연결 단추를 Unity에 연결 및 재생 모드로 변경합니다.For added convenience, you can change the Attach to Unity button to Attach to Unity and Play mode.

  1. Unity에 연결 단추 옆에 있는 작은 아래쪽 화살표 를 클릭합니다.Click the small down arrow next to the Attach to Unity button.
  2. 드롭다운 메뉴에서 Unity에 연결 및 재생 을 선택합니다.Select Attach to Unity and Play from the dropdown menu. Visual Studio에서 연결 및 재생Attach and play in Visual Studio

[재생] 단추에는 Unity에 연결 및 재생 레이블이 지정됩니다.The play button becomes labeled Attach to Unity and Play. 이 단추를 클릭하거나 바로 가기 키 F5 키를 사용하면 Visual Studio 디버거를 연결할 뿐 아니라 자동으로 Unity 편집기로 전환되고 편집기에서 게임이 실행됩니다.Clicking this button or using the keyboard shortcut F5 now automatically switches to the Unity editor and runs the game in the editor, in addition to attaching the Visual Studio debugger.

디버깅 시작 및 Unity 편집기 재생은 Unity에 연결 및 재생 구성을 선택하여 Mac용 Visual Studio에서 직접 한 번에 완료할 수 있습니다.Starting debugging and playing the Unity editor can be completed in a single step directly from Visual Studio for Mac by choosing the Attach to Unity and Play configuration.

Unity에 연결 및 재생을 선택 Mac용 Visual Studio

참고

Unity에 연결 및 재생 구성을 사용 하 여 디버깅을 시작한 경우에도 중지 단추를 클릭 하면 unity 편집기가 중지 됩니다.If you started debugging using the Attach to Unity and Play configuration, the Stop button will also stop the Unity Editor.

Unity 플레이어 빌드 디버그Debug Unity player builds

Visual Studio를 사용 하 여 Unity 선수의 개발 빌드를 디버그할 수 있습니다.You can debug development builds of Unity players with Visual Studio.

Unity 플레이어에서 스크립트 디버깅 사용Enable script debugging in a Unity player

  1. Unity에서 파일 > 빌드 설정 을 선택하여 빌드 설정을 엽니다.In Unity, open the Build Settings by selecting File > Build Settings.

  2. [빌드 설정] 창에서 개발 빌드스크립트 디버깅 확인란을 선택합니다.In the Build Settings window, mark the Development Build and Script Debugging checkboxes.

    디버깅을 위해 Unity 빌드 설정을 구성합니다.Configure the Unity build settings for debugging.

디버거를 연결할 Unity 인스턴스 선택Select a Unity instance to attach the debugger to

  • Visual Studio의 주 메뉴에서 디버그 > Unity 디버거 연결 을 선택합니다.In Visual Studio, on the main menu, choose Debug > Attach Unity Debugger.

    Unity 디버거를 연결합니다.Attach the debugger of Unity.

    Unity 인스턴스 선택 대화 상자는 연결할 수 있는 각 Unity 인스턴스에 대한 일부 정보를 표시합니다.The Select Unity Instance dialog displays some information about each Unity instance that you can connect to.

    연결할 Unity 인스턴스를 선택합니다.Choose an instance of Unity to connect to.

    프로젝트Project

    이 Unity의 인스턴스에서 실행되는 Unity 프로젝트의 이름입니다.The name of the Unity project that's running in this instance of Unity.

    컴퓨터 이 Unity가 실행되고 있는 컴퓨터 또는 디바이스의 이름입니다.Machine The name of the computer or device that this instance of Unity is running on.

    이 Unity의 인스턴스가 Unity 편집기의 일부로 실행되면 형식 편집기 이고, 이 Unity의 인스턴스가 독립 실행형 플레이어이면 플레이어 입니다.Type Editor if this instance of Unity is running as part of the Unity Editor; Player if this instance of Unity is a stand-alone player.

    포트 이 Unity의 인스턴스에서 통신하는 데 사용하는 UDP 소켓의 포트 번호입니다.Port The port number of the UDP socket that this instance of Unity is communicating over.

중요

Visual Studio Tools for Unity 및 Unity 인스턴스가 UDP 네트워크 소켓을 통해 통신 중 이므로 방화벽에서 허용 하는 규칙이 필요할 수 있습니다.Because Visual Studio Tools for Unity and the Unity instance are communicating over a UDP network socket, your firewall may need rule to allow it. 필요한 경우 VSTU 및 Unity가 통신할 수 있도록 연결에 권한을 부여 해야 합니다.If needed, you may see a prompt, you'll have to authorize the connection so that VSTU and Unity can communicate.

  • Mac용 Visual Studio의 상단 메뉴에서 실행 > 프로세스에 연결 을 선택 합니다.In Visual Studio for Mac, on the top menu, choose Run > Attach to Process.
  • 프로세스에 연결 대화 상자의 맨 아래에 있는 디버거 드롭다운 메뉴에서 Unity 디버거 옵션을 선택 합니다.In the Attach to Process dialog, select Unity Debugger option in the Debugger drop-down menu at the bottom.
  • 목록에서 Unity 인스턴스를 선택 하 고 연결 단추를 클릭 합니다.Select a Unity instance from the list and click the Attach button.

Unity 프로젝트에서 DLL 디버그Debug a DLL in your Unity project

많은 Unity 개발자가 개발하는 기능을 쉽게 다른 프로젝트와 공유할 수 있도록 코드 구성 요소를 외부 DLL로 작하고 있습니다.Many Unity developers are writing code components as external DLLs so that the functionality they develop can be easily shared with other projects. Visual Studio Tools for Unity를 통해 Unity 프로젝트에서 이러한 DDL의 코드를 다른 코드와 함께 원활하게 디버그할 수 있습니다.Visual Studio Tools for Unity makes it easy to debug code in these DLLs seamlessly with other code in your Unity project.

참고

이때 Visual Studio Tools for Unity는 관리 DLL만 지원합니다.At this time, Visual Studio Tools for Unity only supports managed DLLs. C++에서 작성한 것과 같은 네이티브 코드 DLL의 디버깅은 지원하지 않습니다.It does not support debugging of native code DLLs, such as those written in C++.

여기에 설명된 시나리오에서는 사용자에게 소스 코드가 있다고 가정합니다. 즉, 자사 코드를 개발 또는 다시 사용하는 중이거나 타사 라이브러리에 대한 소스 코드가 있으며 이를 Unity 프로젝트에서 DLL로 배포하도록 계획 중이라고 가정합니다.Note that the scenario described here assumes that you have the source code—that is, you are developing or re-using your own first-party code, or you have the source code to a third-party library, and plan to deploy it in your Unity project as a DLL. 이 시나리오는 소스 코드가 없는 DLL 디버깅에 대해서는 설명하지 않습니다.This scenario does not describe debugging a DLL for which you do not have the source code.

Unity 프로젝트에서 사용되는 관리 DLL 프로젝트를 디버그하려면To debug a managed DLL project used in your Unity project

  1. Visual Studio Tools for Unity에서 생성한 Visual Studio 솔루션에 기존 DLL 프로젝트를 추가합니다.Add your existing DLL project to the Visual Studio solution generated by Visual Studio Tools for Unity. 새로운 관리 DLL 프로젝트를 시작하여 Unity 프로젝트에 코드 구성 요소를 포함하는 경우도 더러 있을 수 있습니다. 이러한 경우 새로운 관리 DLL 프로젝트를 Visual Studio 솔루션에 대신 추가할 수 있습니다.Less commonly, you might be starting a new managed DLL project to contain code components in your Unity project; if that's the case, you can add a new managed DLL project to the Visual Studio solution instead.

    기존 DLL 프로젝트를 솔루션에 추가합니다.Add your existing DLL project to the solution.

    두 경우 모두 Visual Studio Tools for Unity에서는 프로젝트 및 솔루션 파일을 다시 생성해야 하는 경우에도 프로젝트 참조를 유지하므로 이러한 단계는 한 번만 수행하면 됩니다.In either case, Visual Studio Tools for Unity maintains the project reference, even if it has to regenerate the project and solution files again, so you only need to perform these steps once.

  2. DLL 프로젝트에서 올바른 Unity 프레임워크 프로필을 참조하세요.Reference the correct Unity framework profile in the DLL project. Visual Studio의 DLL 프로젝트 속성에서 대상 프레임워크 속성을 사용 중인 Unity 프레임워크 버전으로 설정합니다.In Visual Studio, in the DLL project's properties, set the Target framework property to the Unity framework version you're using. 이는 Unity 전체, 마이크로, 또는 웹 기반 클래스 라이브러리 등 프로젝트가 대상으로 하는 API 호환성과 일치하는 Unity 기반 클래스 라이브러리입니다.This is the Unity Base Class Library that matches the API compatibility that your project targets, such as the Unity full, micro, or web base class libraries. 다른 프레임워크 또는 호환성 수준에 있지만 사용 중인 Unity 프레임워크 버전에는 없을 수 있는 프레임워크 메서드를 DLL에서 호출하는 것을 방지합니다.This prevents your DLL from calling framework methods that exist in other frameworks or compatibility levels, but which might not exist in the Unity framework version you're using.

참고

다음은 Unity의 레거시 런타임을 사용하는 경우에만 필요합니다.The following is only required if you are using Unity's legacy runtime. 새 Unity 런타임을 사용하는 경우에는 해당 전용 3.5 프로필을 더 이상 사용할 필요가 없습니다.If you are using the new Unity runtime, you don't need to use those dedicated 3.5 profiles anymore. Unity 버전과 호환되는 .NET 4.x 프로필을 사용합니다.Use a .NET 4.x profile compatible with your Unity version.

DLL의 대상 프레임워크를 Unity 프레임워크로 설정합니다.Set the DLL's target framework to Unity framework.

  1. Unity 프로젝트의 자산 폴더에 DLL을 복사합니다.Copy the DLL to your Unity project's Asset folder. Unity에서 자산은 런타임에 로드될 수 있도록 Unity 앱과 함께 배포되고 패키지되는 파일입니다.In Unity, assets are files that are packaged and deployed together with your Unity app so that they can be loaded at run-time. DLL은 런타임에 연결되므로 DDL을 자산으로 배포해야 합니다.Since DLLs are linked at run time, DLLs must be deployed as assets. 자산으로 배포하기 위해 Unity 편집기는 Unity 프로젝트에서 자산 폴더 안에 DLL을 배치할 것을 요구합니다.To be deployed as an asset, the Unity Editor requires the DLLs to be put inside the Assets folder in your Unity project. 다음 두 가지 방법으로 이 작업을 수행할 수 있습니다.There are two ways you can do this:

    • DLL 프로젝트의 빌드 설정을 수정하여 해당 출력 폴더에서 Unity 프로젝트의 자산 폴더로 출력 DLL 및 PDB 파일을 복사하는 빌드 후 작업을 포함합니다.Modify the build settings of your DLL project to include a post-built task that copies the output DLL and PDB files from its output folder to the Assets folder of your Unity project.

    • DLL 프로젝트의 빌드 설정을 수정하여 Unity 프로젝트의 자산 폴더로 해당 출력 폴더를 설정합니다.Modify the build settings of your DLL project to set its output folder to be the Assets folder of your Unity project. DLL 및 PDB 파일은 모두 자산 폴더에 배치됩니다.Both DLL and PDB files will be placed in the Assets folder.

    PDB 파일은 DLL의 디버깅 기호를 포함하며 DLL 코드를 소스 코드 형태로 매핑하므로 디버깅에 필요합니다.The PDB files are needed for debugging because they contain the DLL's debugging symbols, and map the DLL code to its source code form. 레거시 런타임을 대상으로 지정하면 Visual Studio Tools for Unity에서는 DLL 및 PDB의 정보를 사용하여 레거시 Unity 스크립팅 엔진에서 사용되는 디버그 기호 형식인 DLL.MDB 파일을 만듭니다.If you are targeting the legacy runtime, Visual Studio Tools for Unity will use information from the DLL and PDB to create a DLL.MDB file, which is the debug symbol format used by the legacy Unity scripting engine. 새 런타임을 대상으로 지정하고 이식 가능한 PDB를 사용하면 새 Unity 런타임이 기본적으로 이식 가능한 PDB를 사용할 수 있으므로 Visual Studio Tools for Unity에서는 기호 변환을 수행하지 않습니다.If you are targeting the new runtime, and using Portable-PDB, Visual Studio Tools for Unity will not try to do any symbol conversion as the new Unity runtime is able to natively consume Portable-PDBs.

    PDB 생성에 대한 자세한 내용은 여기에서 확인할 수 있습니다.More information about PDB generation can be found here. 새 런타임을 대상으로 지정하는 경우 이식 가능한 PDB를 제대로 생성하려면 “디버깅 정보”가 “이식 가능”으로 설정되어 있는지 확인하세요.If you are targeting the new runtime, please make sure that "Debugging Information" is set to "Portable", in order to properly generate Portable-PDB. 레거시 런타임을 대상으로 지정하는 경우에는 “전체”를 사용해야 합니다.If you are targeting the legacy runtime, you need to use "Full".

  2. 코드를 디버그합니다.Debug your code. 이제 Unity 프로젝트의 소스 코드와 함께 DLL 소스 코드를 디버그할 수 있으며 중단점 및 단계별 코드 실행 등 익숙한 디버깅 기능을 모두 사용할 수 있습니다.You can now debug your DLL source code together with your Unity project's source code, and use all the debugging features you are used to, such as breakpoints and stepping through code.

바로 가기 키Keyboard shortcuts

바로 가기 키를 사용하여 Visual Studio 기능에 대한 Unity 도구에 신속하게 액세스할 수 있습니다.You can quickly access the Unity Tools for Visual Studio functionality by using their keyboard shortcuts. 다음은 사용할 수 있는 바로 가기를 정리한 것입니다.Here's a summary of the shortcuts that are available.

명령Command 바로 가기Shortcut 바로 가기 명령 이름Shortcut command name
MonoBehavior 마법사 열기Open the MonoBehavior Wizard Ctrl+Shift+MCtrl+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Unity 프로젝트 탐색기 열기Open the Unity Project Explorer Alt+Shift+EAlt+Shift+E View.UnityProjectExplorerView.UnityProjectExplorer
Unity 설명서 액세스Access Unity documentation Ctrl+Alt+M, Ctrl+HCtrl+Alt+M, Ctrl+H Help.UnityAPIReferenceHelp.UnityAPIReference
Unity 디버거(플레이어 또는 편집기)에 연결Attach to Unity debugger (player or editor) 기본값 없음no default Debug.AttachUnityDebuggerDebug.AttachUnityDebugger

기본값이 마음에 들지 않는 경우 바로 가기 키 조합을 변경할 수 있습니다.You can change the shortcut key combinations if you don't like the default. 변경 방법에 대한 자세한 내용은 Visual Studio에서 바로 가기 키 식별 및 사용자 지정을 참조하세요.For information on how to change it, see Identify and customize keyboard shortcuts in Visual Studio.

명령Command 바로 가기Shortcut 바로 가기 명령 이름Shortcut command name
MonoBehavior 마법사 열기Open the MonoBehavior Wizard Cmd + Shift + MCmd+Shift+M EditorContextMenus.CodeWindow.ImplementMonoBehavioursEditorContextMenus.CodeWindow.ImplementMonoBehaviours
Unity 설명서 액세스Access Unity documentation Cmd + 'Cmd+' Help.UnityAPIReferenceHelp.UnityAPIReference

기본값이 마음에 들지 않는 경우 바로 가기 키 조합을 변경할 수 있습니다.You can change the shortcut key combinations if you don't like the default. 이를 변경 하는 방법에 대 한 자세한 내용은 IDE 사용자 지정을 참조 하세요.For information on how to change it, see Customizing the IDE.