Visual Studio에서 프로젝트와 솔루션 빌드 및 정리Build and clean projects and solutions in Visual Studio

이 항목의 절차에 따라 솔루션에 포함된 프로젝트 또는 프로젝트 항목의 전체 또는 일부를 빌드, 다시 빌드 또는 정리할 수 있습니다.By using the procedures in this topic, you can build, rebuild, or clean all or some of the projects or project items in a solution. 단계별 자습서는 연습: 애플리케이션 빌드를 참조하세요.For a step-by-step tutorial, see Walkthrough: Building an application.

참고

이 토픽은 Windows용 Visual Studio에만 적용됩니다.This topic applies to Visual Studio on Windows. Mac용 Visual Studio는 Mac용 Visual Studio에서 프로젝트와 솔루션 빌드 및 정리를 참조하세요.For Visual Studio for Mac, see Build and clean projects and solutions in Visual Studio for Mac.

참고

사용 중인 Visual Studio 버전의 UI는 활성 설정에 따라 이 항목의 설명과 다를 수 있습니다.The UI in your edition of Visual Studio might differ from what this topic describes, depending on your active settings. 설정을 일반 또는 Visual C++ 설정 등으로 변경하려면 도구 > 설정 가져오기 및 내보내기 를 선택한 다음, 모두 다시 설정 을 선택합니다.To change your settings, for example to General or Visual C++ settings, choose Tools > Import and Export Settings, and then choose Reset all settings.

전체 솔루션을 빌드, 다시 빌드 또는 정리하려면To build, rebuild, or clean an entire solution

  1. 솔루션 탐색기 에서 솔루션을 선택하거나 엽니다.In Solution Explorer, choose or open the solution.

  2. 메뉴 모음에서 빌드 를 선택하고 다음 명령 중 하나를 선택합니다.On the menu bar, choose Build, and then choose one of the following commands:

    • 가장 최근 빌드 이후 변경된 프로젝트 파일 및 구성 요소만 컴파일하려면 빌드 또는 솔루션 빌드 를 선택합니다.Choose Build or Build Solution to compile only those project files and components that have changed since the most recent build.

      참고

      솔루션에 둘 이상의 프로젝트가 포함된 경우에는 빌드 명령이 솔루션 빌드 로 표시됩니다.The Build command becomes Build Solution when a solution includes more than one project.

    • 솔루션을 "정리"한 다음 모든 프로젝트 파일과 구성 요소를 빌드하려면 솔루션 다시 빌드 를 선택합니다.Choose Rebuild Solution to "clean" the solution and then build all project files and components.

    • 중간 파일과 출력 파일을 모두 삭제하려면 솔루션 정리 를 선택합니다.Choose Clean Solution to delete any intermediate and output files. 그런 다음 프로젝트 및 구성 요소 파일만 유지하여 중간 파일과 출력 파일의 새 인스턴스를 빌드할 수 있습니다.With only the project and component files left, new instances of the intermediate and output files can then be built.

단일 프로젝트를 빌드 또는 다시 빌드하려면To build or rebuild a single project

  1. 솔루션 탐색기 에서 프로젝트를 선택하거나 엽니다.In Solution Explorer, choose or open the project.

  2. 메뉴 모음에서 빌드 를 선택한 다음 ProjectName 빌드 또는 ProjectName 다시 빌드 을 선택합니다.On the menu bar, choose Build, and then choose either Build ProjectName or Rebuild ProjectName.

    • 가장 최근 빌드 이후 변경된 프로젝트 구성 요소만 빌드하려면 ProjectName 빌드 를 선택합니다.Choose Build ProjectName to build only those project components that have changed since the most recent build.

    • 프로젝트를 "정리"한 후 프로젝트 파일과 모든 프로젝트 구성 요소를 빌드하려면 ProjectName 다시 빌드 를 선택합니다.Choose Rebuild ProjectName to "clean" the project and then build the project files and all project components.

시작 프로젝트 및 해당 종속성만 빌드하려면To build only the startup project and its dependencies

  1. 메뉴 모음에서 도구 > 옵션 을 차례로 선택합니다.On the menu bar, choose Tools > Options.

  2. 옵션 대화 상자에서 프로젝트 및 솔루션 노드를 확장하고 빌드 및 실행 페이지를 선택합니다.In the Options dialog box, expand the Projects and Solutions node, and then choose the Build and Run page.

    빌드 및 실행 > 프로젝트 및 솔루션 > 옵션 대화 상자가 열립니다.The Build and Run > Projects and Solutions > Options dialog box opens.

  3. 실행할 때 시작 프로젝트와 종속성만 빌드 확인란을 선택합니다.Select the Only build startup projects and dependencies on Run check box.

    이 확인란을 선택하면 다음 단계 중 하나를 수행할 때 현재 시작 프로젝트와 해당 종속성만 빌드됩니다.When this check box is selected, only the current startup project and its dependencies are built when you perform either of the following steps:

    • 메뉴 모음에서 디버그 > 시작(F5)을 선택합니다.On the menu bar, choose Debug > Start (F5).

    • 메뉴 모음에서 빌드 > 솔루션 빌드(Ctrl+Shift+B)를 선택합니다.On the menu bar, choose Build > Build Solution (Ctrl+Shift+B).

    이 확인란의 선택을 취소하면 이전 명령 중 하나를 실행할 때 모든 프로젝트, 해당 종속성 및 솔루션 파일이 빌드됩니다.When this check box is cleared, all projects, their dependencies, and the solution files are built when you run either of the preceding commands. 기본적으로이 확인란의 선택을 취소 합니다.By default, this check box is cleared.

선택한 Visual C++ 프로젝트만 빌드하려면To build only the selected Visual C++ project

Visual C++Visual C++ 프로젝트를 선택한 다음, 메뉴 모음에서 빌드 > 프로젝트만 해당, 다음 명령 중 하나를 차례로 선택합니다.Choose a Visual C++Visual C++ project, and then, on the menu bar, choose Build > Project Only, and one of the following commands:

  • ProjectName 만 빌드Build Only ProjectName

  • ProjectName 만 다시 빌드Rebuild Only ProjectName

  • ProjectName 만 정리Clean Only ProjectName

  • ProjectName 만 링크Link Only ProjectName

이러한 명령은 프로젝트 종속성 또는 솔루션 파일을 빌드, 다시 빌드, 정리 또는 링크하지 않고 선택한 Visual C++Visual C++ 프로젝트에만 적용됩니다.These commands apply only to the Visual C++Visual C++ project that you chose, without building, rebuilding, cleaning, or linking any project dependencies or solution files. 사용 중인 Visual StudioVisual Studio 버전에 따라 프로젝트만 하위 메뉴에 추가 명령이 포함될 수 있습니다.Depending on your version of Visual StudioVisual Studio, the Project Only submenu might contain more commands.

여러 C++ 프로젝트 항목을 컴파일하려면To compile multiple C++ project items

솔루션 탐색기 에서 작업으로 컴파일할 수 있는 여러 파일을 선택하고 해당 파일 중 하나의 바로 가기 메뉴를 연 다음 컴파일 을 선택합니다.In Solution Explorer, choose multiple files that have can be compiled actions, open the shortcut menu for one of those files, and then choose Compile.

파일에 종속성이 있는 경우 종속성 순서에 따라 파일이 컴파일됩니다.If the files have dependencies, the files will be compiled in dependency order. 컴파일 시 사용할 수 없는 미리 컴파일된 헤더가 파일에 필요한 경우 컴파일 작업이 실패합니다.The compile operation will fail if the files require a precompiled header that isn't available when you compile. 컴파일 작업은 현재 활성 솔루션 구성을 사용합니다.The compile operation uses the current active solution configuration.

빌드를 중지하려면To stop a build

다음 단계 중 하나를 수행합니다.Perform either of the following steps:

  • 메뉴 모음에서 빌드 > 취소 를 선택합니다.On the menu bar, select Build > Cancel.

  • Ctrl+중단 을 누릅니다.Press Ctrl+Break.

참고 항목See also