솔루션 및 프로젝트 만들기Create solutions and projects

프로젝트는 Visual Studio에서 소스 코드 파일, 비트맵, 아이콘, 구성 요소 및 서비스 참조 등, 앱을 빌드하는 데 필요한 항목을 저장하는 논리적 컨테이너입니다.Projects are logical containers in Visual Studio that hold the items needed to build your app, such as source code files, bitmaps, icons, and component and service references. 새 프로젝트를 만들 때 Visual Studio는 해당 프로젝트를 포함할 솔루션을 만듭니다.When you create a new project, Visual Studio creates a solution to contain the projects. 그런 다음 원하는 경우 새 프로젝트나 기존 프로젝트를 솔루션에 추가할 수 있습니다.You can then add new or existing projects to the solution if you want. 또한, 솔루션은 특정 프로젝트에 연결되어 있지 않은 파일을 포함할 수도 있습니다.Solutions can also contain files not connected to any specific project.

솔루션/프로젝트 계층 구조

솔루션 탐색기라고 하는 도구 창에서 솔루션과 프로젝트를 볼 수 있습니다.You can view your solutions and projects in a tool window called Solution Explorer. 다음 스크린샷은 솔루션 탐색기에서 두 개의 프로젝트(BikeSharing.Clients.Core 및 BikeSharing.Clients.Windows)가 포함된 예제 솔루션을 보여줍니다.The following screenshot shows an example solution in Solution Explorer (BikeSharing.Xamarin-UWP) that contains two projects: BikeSharing.Clients.Core and BikeSharing.Clients.Windows. 각 프로젝트에는 여러 파일, 폴더 및 참조가 포함되어 있습니다.Each project contains multiple files, folders, and references. 굵게 표시된 프로젝트 이름은 시작 프로젝트, 즉 앱 실행 시 시작하는 프로젝트입니다.The project name in bold is the startup project; that is, the project that starts when you run the app. 어떤 프로젝트가 시작 프로젝트인지 지정할 수 있습니다.You can specify which project is the startup project.

프로젝트와 솔루션 탐색기

필요한 파일을 추가하여 프로젝트를 직접 구성할 수 있지만, Visual Studio는 시작할 수 있는 프로젝트 템플릿 모음을 제공합니다.While you can construct a project yourself by adding the necessary files to it, Visual Studio offers a selection of project templates to give you a head start. 템플릿에서 새 프로젝트를 만들면 해당 프로젝트 형식에 대한 기본 사항이 포함된 프로젝트가 제공되며 파일 이름을 변경하거나 새 또는 기존 코드는 물론, 필요에 따라 기타 리소스를 추가할 수 있습니다.Creating a new project from a template gives you a project with the essentials for that project type, and you can rename the files or add new or existing code and other resources to it as needed.

Visual Studio에서 앱을 개발하는 데 솔루션과 프로젝트는 필요하지 않습니다.That being said, solutions and projects are not required to develop apps in Visual Studio. 클릭할 수도 Git에서 복제 하거나 다른 위치에서 다운로드 하는 코드를 열 수 있습니다.You can also just open code that you have cloned from Git or downloaded elsewhere. 자세한 내용은 프로젝트 또는 솔루션 없이 Visual Studio에서 코드 개발을 참조하세요.For more information, see Develop code in Visual Studio without projects or solutions.

참고

이 항목의 설명은 Visual Studio Community 버전을 기반으로 합니다.The descriptions in this topic are based on the Visual Studio Community edition. 표시되는 대화 상자 및 메뉴 명령은 설정 또는 Visual Studio 버전에 따라 여기에 설명된 내용과 다를 수 있습니다.The dialog boxes and menu commands you see might differ from those described here, depending on your settings or Visual Studio edition. 설정을 일반 또는 Visual C++ 설정 등으로 변경하려면 도구, 설정 가져오기 및 내보내기를 선택한 다음 모두 다시 설정을 선택합니다.To change your settings, for example to General or Visual C++ settings, choose Tools, Import and Export Settings, and then choose Reset all settings.

프로젝트 템플릿에서 프로젝트를 만들려면To create a project from a project template

  1. Visual Studio에서 새 프로젝트를 만드는 여러 방법이 있습니다.There are multiple ways to create a new project in Visual Studio. 시작 페이지에서 프로젝트 템플릿 검색 상자에 프로젝트 템플릿의 이름을 입력하거나 새 프로젝트 만들기 링크를 선택하여 새 프로젝트 대화 상자를 엽니다.On the Start Page, enter the name of a project template in the Search project templates box, or choose the Create new project link to open the New Project dialog box. 또한 메뉴에서 파일, 새로 만들기, 프로젝트...를 선택하거나 도구 모음에서 새 프로젝트 단추를 선택할 수도 있습니다.You can also choose File, New, Project... on the menu, or choose the New Project button on the toolbar.

    시작 페이지

    새 프로젝트 대화 상자에서 사용 가능한 프로젝트 템플릿은 템플릿 범주 아래에 목록으로 나타납니다.In the New Project dialog box, available project templates appear in a list under the Templates category. 템플릿은 Visual C#, JavaScript 및 Azure Data Lake 등의 프로그래밍 언어 및 프로젝트 형식으로 구성되어 있습니다.Templates are organized by programming language and project type, such as Visual C#, JavaScript, and Azure Data Lake.

    새 프로젝트 대화 상자

    참고

    표시되는 사용 가능한 언어 및 프로젝트 템플릿 목록은 실행 중인 Visual Studio의 버전 및 설치된 워크로드에 따라 다릅니다.The list of available languages and project templates that appears depends on the version of Visual Studio you are running and the workloads that are installed. 추가 워크로드를 설치하는 방법에 대해 자세히 알아 보려면 작업과 구성 요소를 추가하거나 제거하여 Visual Studio 2017 수정을 참조하세요.To learn about how to install additional workloads, see Modify Visual Studio 2017 by adding or removing workloads and components.

  2. 언어 이름 옆에 있는 삼각형을 선택하여 사용할 프로그래밍 언어에 대한 템플릿 목록을 표시한 다음 프로젝트 형식을 선택합니다.Show the list of templates for the programming language you want to use by choosing the triangle next to the language name, and then choose a project type. 다음 예제에서는 Visual C# 웹 프로젝트에 사용할 수 있는 프로젝트 템플릿을 보여줍니다.The following example shows the project templates available for Visual C# web projects.

    프로젝트 템플릿

  3. 이름 상자에 새 프로젝트의 이름을 입력합니다.Enter a name for the new project in the Name box. 시스템의 기본 위치에 프로젝트를 저장하거나 찾아보기 단추를 선택하여 다른 위치를 찾을 수 있습니다.You can choose to save the project in the default location on your system, or choose the Browse button to find another location.

    또한, 옵션으로 솔루션 이름을 변경하거나 소스 제어에 추가를 선택하여 Git 리포지토리에 새 프로젝트를 추가할 수도 있습니다.You can also optionally choose to change the solution name, or add the new project to a Git repository by choosing Add to Source Control.

  4. 확인 단추를 선택하여 솔루션 및 프로젝트를 만듭니다.Choose the OK button to create the solution and project.

  5. 솔루션에 추가 프로젝트를 추가하려는 경우 솔루션 탐색기에서 솔루션 노드를 선택한 다음, 노드에서 프로젝트, 새 항목 추가를 선택합니다.If you want to add an additional project to a solution, choose the solution node in Solution Explorer, and then on the menu, choose Project, Add New Item.

기존 코드 파일에서 프로젝트 만들기Create a project from existing code files

코드 소스 파일의 컬렉션이 있는 경우 프로젝트에 쉽게 추가할 수 있습니다.If you have a collection of code source files, you can easily add them to a project.

  1. 메뉴에서 파일, 새로 만들기, 기존 코드의 프로젝트를 차례로 선택합니다.On the menu, choose File, New, Project From Existing Code.

  2. 기존 코드 파일에서 프로젝트 만들기 마법사에서 만들 프로젝트 형식 드롭다운 목록 박스에서 원하는 프로젝트 형식을 선택하고 다음 단추를 선택합니다.In the Create Project from Existing Code Files wizard, choose the project type you want in the What type of project would you like to create? drop-down list box, and then choose the Next button.

  3. 마법사에서 파일의 위치로 이동한 다음 이름 상자에 새 프로젝트에 대한 이름을 입력합니다.In the wizard, browse to the location of the files and then enter a name for the new project in the Name box. 완료되면 마침 단추를 선택합니다.When you are done, choose the Finish button.

참고

이 옵션은 상대적으로 간단한 파일 컬렉션에 적합합니다.This option works best for a relatively simple collections of files. 현재, Visual C++, Apache Cordova, Visual Basic 및 Visual C# 프로젝트 형식만 지원됩니다.Currently, only Visual C++, Apache Cordova, Visual Basic, and Visual C# project types are supported.

솔루션에 파일 추가Add files to a solution

솔루션의 readme 파일과 같이 여러 프로젝트에 적용되는 파일 또는 특정 프로젝트 아래가 아니라 논리적으로 솔루션 수준에 속하는 기타 파일이 있을 경우 솔루션 자체에 추가할 수 있습니다.If you have a file that applies to multiple projects, such as a readme file for the solution, or other files that logically belong at the solution level rather than under a specific project, then you can add them to the solution itself. 솔루션에 항목을 추가하려면 솔루션 탐색기에서 솔루션 노드를 컨텍스트(마우스 오른쪽 단추로 클릭) 메뉴에서 추가, 새 항목 또는 추가, 기존 항목을 선택합니다.To add an item to a solution, on the context (right-click) menu of the solution node in Solution Explorer, choose Add, New Item, or Add, Existing Item.

.NET Framework의 특정 버전을 대상으로 하는 .NET 프로젝트 만들기Create a .NET project that targets a specific version of the .NET Framework

프로젝트를 만들 경우 프로젝트에서 사용하려는 특정 버전의 .NET Framework를 지정할 수 있습니다.When you create a project, you can specify a specific version of the .NET Framework that you want the project to use. .NET Framework 버전을 지정하려면 새 프로젝트 대화 상자에서 .NET Framework 버전 드롭다운 메뉴를 선택합니다.To specify a .NET framework version, choose the .NET Framework version drop-down menu in the New Project dialog box. .NET Core 템플릿에서 프로젝트를 만드는 경우 드롭다운에서 선택한 .NET Framework 버전은 무시됩니다.If you are creating a project from a .NET Core template, the .NET Framework version you select in the drop-down is ignored.

.NET Framework 버전 선택기

프로젝트 템플릿을 선택하기 전에.NET Framework 버전을 설정하면 Visual Studio은 해당 .NET Framework 버전과 호환되는 템플릿만 표시합니다.If you set the .NET Framework version before selecting a project template, then Visual Studio will only show templates that are compatible with that .NET Framework version.

.NET Framework 4 이전 버전의 .NET Framework 버전에 액세스하려면 시스템에 .NET Framework 3.5가 설치되어 있어야 합니다.You must have .NET Framework 3.5 installed on your system to access .NET Framework versions earlier than .NET Framework 4.

빈 솔루션 만들기Create empty solutions

프로젝트가 없는 빈 솔루션을 만들 수도 있습니다.You can also create empty solutions that have no projects. 솔루션 및 프로젝트를 처음부터 만들려는 경우에 좋을 수 있습니다.This might be preferable in cases where you want to construct your solution and projects from scratch.

빈 솔루션을 만들려면To create an empty solution

  1. 메뉴에서 파일, 새로 만들기, 프로젝트를 차례로 선택합니다.On the menu, choose File, New, Project.

  2. 왼쪽(템플릿) 창의 확장된 목록에서 기타 프로젝트 형식, Visual Studio 솔루션을 선택합니다.In the left (Templates) pane, choose Other Project Types, Visual Studio Solutions in the expanded list.

  3. 가운데 창에서 빈 솔루션을 선택합니다.In the middle pane, choose Blank Solution.

  4. 솔루션의 이름위치 값을 입력한 다음 확인을 선택합니다.Enter Name and Location values for your solution, then choose OK.

빈 솔루션을 만든 후 프로젝트 메뉴에서 새 항목 추가 또는 기존 항목 추가를 선택하여 새 프로젝트나 항목 또는 기존 프로젝트나 항목을 추가할 수 있습니다.After you create an empty solution, you can add new or existing projects or items to it by choosing Add New Item or Add Existing Item on the Project menu.

앞어 언급했듯이 또한 솔루션이 필요 없이 코드 프로젝트를 열 수도 있습니다.As mentioned earlier, you can also open code projects without needing a solution. 솔루션 필요 없이 코드를 여는 방법에 대해 알아보려면 프로젝트 또는 솔루션 없이 Visual Studio에서 코드 개발을 참조하세요.To learn about opening code without requiring a solution, see Develop code in Visual Studio without projects or solutions.

임시 프로젝트 만들기(C# 및 Visual Basic)Create a temporary project (C# and Visual Basic)

디스크 위치를 지정하지 않고 .NET 기반 프로젝트를 만들 경우 임시 프로젝트입니다.If you create a .NET-based project without specifying a disk location, it is a temporary project. 임시 프로젝트를 통해 .NET 프로젝트로 실험할 수 있습니다.Temporary projects enable you to experiment with .NET projects. 임시 프로젝트로 작업하는 동안 언제든지 프로젝트를 저장하거나 삭제할 수 있습니다.At any time while you are working with a temporary project, you can choose to save it or discard it.

임시 프로젝트를 만들려면 먼저 도구, 옵션, 프로젝트 및 솔루션, 일본으로 이동하여 만들어질 때 새 프로젝트 저장 확인란을 선택 취소합니다.To create a temporary project, first go to Tools, Options, Projects and Solutions, General, and uncheck the Save new projects when created checkbox. 그런 다음, 일반적인 방법으로 새 프로젝트를 엽니다.Then open the New Project dialog box as usual.

솔루션, 프로젝트 또는 항목 삭제Delete a solution, project, or item

Visual Studio IDE를 사용하지 않고 솔루션 및 해당 콘텐츠를 영구적으로 삭제할 수 있습니다.You can delete solutions and their contents permanently, but not by using the Visual Studio IDE. Visual Studio 내에서 항목를 삭제하면 현재 솔루션 또는 프로젝트에서만 제거됩니다.Deleting items within Visual Studio only removes them from the current solution or project. 시스템에서 솔루션 또는 기타 구성 요소를 영구적으로 삭제하려면 파일 탐색기를 사용하여 .sln 및 .suo 솔루션 파일을 포함한 폴더를 삭제합니다.To permanently delete a solution or other component from your system, use File Explorer to delete the folder that contains the .sln and .suo solution files. 그러나 솔루션을 영구적으로 삭제하기 전에 다시 필요한 경우에 대비하여 프로젝트 또는 파일을 백업하는 것이 좋습니다.However, before permanently deleting a solution, it's recommended that you back up any projects or files in case you need them again.

참고

.suo 파일은 파일 탐색기의 기본 설정으로는 표시되지 않는 숨김 파일입니다.The .suo file is a hidden file that is not displayed under the default File Explorer settings. 숨겨진 파일을 표시하려면 파일 탐색기의 보기 메뉴에서는 숨겨진 항목 확인란을 선택합니다.To show hidden files, on the View menu in File Explorer, select the Hidden Items checkbox.

솔루션을 영구적으로 삭제하려면To permanently delete a solution

  1. 솔루션 탐색기에서 삭제하려는 솔루션의 상황에 맞는 메뉴에서 파일 탐색기에서 폴더 열기를 선택합니다.In Solution Explorer, on the context menu of the solution you want to delete, choose Open folder in File Explorer.

  2. 파일 탐색기에서 한 수준 위로 이동합니다.In File Explorer, navigate up one level.

  3. 솔루션을 포함하는 폴더를 선택한 다음 DELETE 키를 선택합니다.Choose the folder containing the solution and then choose the DELETE key.

참고 항목See Also

솔루션 및 프로젝트Solutions and Projects
GitHub에 있는 Microsoft의 오픈 소스 리포지토리Microsoft's open source repositories on GitHub
Visual Studio 샘플Visual Studio Samples
개발자 코드 샘플Developer code samples