프로젝트 또는 솔루션 없이 Visual Studio에서 코드 개발Develop code in Visual Studio without projects or solutions

Visual Studio 2017에서는 솔루션이나 프로젝트 파일 없이 거의 모든 유형의 디렉터리 기반 프로젝트에서 Visual Studio로 코드를 열 수 있습니다.In Visual Studio 2017, you can open code from nearly any type of directory-based project into Visual Studio without the need for a solution or project file. 예를 들어 GitHub에서 리포지토리를 복제하여 Visual Studio로 직접 열고 솔루션이나 프로젝트를 만들지 않고도 개발을 시작할 수 있습니다.This means you can, for example, clone a repo on GitHub, open it directly into Visual Studio, and begin developing, without having to create a solution or project. 필요한 경우 간단한 JSON 파일을 통해 사용자 지정 빌드 작업을 지정하고 매개 변수를 실행할 수 있습니다.If needed, you can specify custom build tasks and launch parameters through simple JSON files.

Visual Studio에서 코드 파일을 연 후 솔루션 탐색기에는 폴더의 모든 파일이 표시됩니다.After you open your code files in Visual Studio, Solution Explorer displays all the files in the folder. 파일을 클릭하여 편집을 시작할 수 있습니다.You can click on any file to begin editing it. 백그라운드에서 Visual Studio는 IntelliSense, 탐색 및 리팩터링 기능을 사용할 수 있도록 파일 인덱싱을 시작합니다.In the background, Visual Studio starts indexing the files to enable IntelliSense, navigation, and refactoring features. 파일을 편집, 생성, 이동 또는 삭제하면 Visual Studio는 변경 내용을 자동으로 추적하고 해당 IntelliSense 인덱스를 계속해서 업데이트합니다.As you edit, create, move, or delete files, Visual Studio tracks the changes automatically and continuously updates its IntelliSense index. 코드는 구문 색 지정으로 표시되며, 대부분의 경우 기본 IntelliSense 문 완성을 포함합니다.Code will appear with syntax colorization and, in many cases, include basic IntelliSense statement completion.

코드 열기Open any code

Visual Studio에서 다음과 같은 방법으로 코드를 열 수 있습니다.You can open code into Visual Studio in any of the following ways:

  • Visual Studio 메뉴 모음에서 파일 > 열기 > 폴더를 선택한 다음, 코드 위치로 이동합니다.On the Visual Studio menu bar, choose File > Open > Folder, and then browse to the code location.
  • 코드가 포함된 폴더의 상황에 맞는 메뉴(마우스 오른쪽 단추 클릭)에서 Visual Studio에서 열기 명령을 선택합니다.On the context (right-click) menu of a folder containing code, choose the Open in Visual Studio command.
  • Visual Studio 시작 페이지에서 폴더 열기 링크를 선택합니다.Choose the Open Folder link on the Visual Studio Start Page.
  • 키보드 사용자인 경우 Visual Studio에서 Ctrl+Shift+Alt+O를 누릅니다.If you are a keyboard user, press Ctrl+Shift+Alt+O in Visual Studio.
  • 복제된 GitHub 리포지토리에서 코드를 엽니다.Open code from a cloned GitHub repo.

복제된 GitHub 리포지토리에서 코드를 열려면To open code from a cloned GitHub repo

다음 예제에서는 GitHub 리포지토리를 복제한 다음 Visual Studio에서 해당 코드를 여는 방법을 보여 줍니다.The following example shows how to clone a GitHub repo and then open its code in Visual Studio. 이 절차를 따르려면 GitHub 계정이 있어야 하고, 시스템에 Git for Windows가 설치되어 있어야 합니다.To follow this procedure, you must have a GitHub account and Git for Windows installed on your system. 자세한 내용은 새 GitHub 계정 등록(영문) 및 Git for Windows(영문)를 참조하세요.See Signing up for a new GitHub account and Git for Windows for more information.

  1. GitHub에서 복제하려는 리포지토리로 이동합니다.Go to the repo you want to clone on GitHub.

  2. 복제 또는 다운로드 단추를 선택한 다음, 드롭다운 메뉴에서 클립보드로 복사 단추를 선택하여 GitHub 리포지토리에 대한 보안 URL을 복사합니다.Choose the Clone or Download button and then choose the Copy to Clipboard button in the dropdown menu to copy the secure URL for the GitHub repo.

    GitHub 복제 단추

  3. Visual Studio에서 팀 탐색기 탭을 선택하여 팀 탐색기를 엽니다.In Visual Studio, choose the Team Explorer tab to open Team Explorer. 탭이 표시되지 않으면 보기 > 팀 탐색기에서 엽니다.If you don't see the tab, open it from View > Team Explorer.

  4. [팀 탐색기]의 로컬 Git 리포지토리 섹션에서 복제 명령을 선택한 다음, GitHub 페이지의 URL을 텍스트 상자에 붙여넣습니다.In Team Explorer, under the Local Git Repositories section, choose the Clone command and then paste the URL of the GitHub page into the text box.

    프로젝트 복제

  5. 복제 단추를 선택하여 프로젝트 파일을 로컬 Git 리포지토리에 복제합니다.Choose the Clone button to clone the project's files to a local Git repository. 리포지토리의 크기에 따라 이 프로세스에는 몇 분이 걸릴 수 있습니다.Depending on the size of the repo, this process could take several minutes.

  6. 시스템에 리포지토리를 복제한 후에 팀 탐색기에서 새로 복제된 리포지토리의 상황에 맞는 메뉴(마우스 오른쪽 단추 클릭)에서 열기 명령을 선택합니다.After the repo has been cloned to your system, in Team Explorer, choose the Open command on the context (right-click) menu of the newly cloned repo.

    복제된 리포지토리

  7. 폴더 보기 표시 명령을 선택하여 솔루션 탐색기에서 파일을 봅니다.Choose the Show Folder View command to view the files in Solution Explorer.

    폴더 보기 표시

    이제 복제된 리포지토리에서 폴더와 파일을 탐색하고 Visual Studio 코드 편집기에서 구문 색 지정 및 기타 기능을 사용하여 완성된 코드를 보고 검색할 수 있습니다.You can now browse folders and files in the cloned repo, and view and search the code in the Visual Studio code editor, complete with syntax colorization and other features.

동영상에 대한 비디오 카메라 아이콘 Visual Studio의 GitHub 리포지토리에서 코드를 복제하고 여는 방법에 대한 비디오를 시청합니다.Watch a video on how to clone and open code from a GitHub repo in Visual Studio.

코드 실행 및 디버그Run and debug your code

Visual Studio에서 프로젝트 또는 솔루션 없이 코드를 디버그할 수 있습니다.You can debug your code in Visual Studio without a project or solution! 일부 언어를 디버그하려면 스크립트, 실행 파일 또는 프로젝트와 같은 유효한 ‘시작 파일’을 코드베이스에서 지정해야 할 수 있습니다.To debug some languages, you may need to specify a valid startup file in the codebase, such as a script, executable, or project. 도구 모음의 시작 단추 옆에 있는 드롭다운 목록 상자에서는 Visual Studio에서 검색한 모든 시작 항목과 특별히 지정한 항목을 나열합니다.The drop-down list box next to the Start button on the toolbar lists all of the startup items that Visual Studio detects, as well as items you specifically designate. 코드를 디버그할 때는 먼저 이 코드를 Visual Studio에서 실행합니다.Visual Studio runs this code first when you debug your code.

Visual Studio에서 실행되도록 코드를 구성하는 것은 해당 코드의 종류 및 빌드 도구에 따라 달라집니다.Configuring your code to run in Visual Studio differs depending on what kind of code it is, and what the build tools are.

MSBuild를 사용하는 코드베이스Codebases that use MSBuild

MSBuild 기반 코드베이스에는 시작 단추의 드롭다운 목록에 나타나는 여러 빌드 구성이 포함될 수 있습니다.MSBuild-based codebases can have multiple build configurations that appear in the Start button's drop-down list. 시작 항목으로 사용할 파일을 선택한 다음, 시작 단추를 선택하여 디버깅을 시작합니다.Select the file that you want to use as the startup item, and then choose the Start button to begin debugging.

참고

C# 및 Visual Basic 코드베이스의 경우 .NET 데스크톱 개발 워크로드가 설치되어 있어야 합니다.For C# and Visual Basic codebases, you must have the .NET desktop development workload installed. C++ 코드베이스의 경우 C++를 사용한 데스크톱 개발 워크로드가 설치되어 있어야 합니다.For C++ codebases, you must have the Desktop development with C++ workload installed.

사용자 지정 빌드 도구를 사용하는 코드베이스Codebases that use custom build tools

코드베이스에서 사용자 지정 빌드 도구를 사용하는 경우 .json 파일에 정의된 ‘빌드 작업’을 사용하여 코드 빌드 방법을 Visual Studio에 알려야 합니다.If your codebase uses custom build tools, then you must tell Visual Studio how to build your code using build tasks that are defined in a .json file. 자세한 내용은 빌드 및 디버그 작업 사용자 지정을 참조하세요.For more information, see Customize build and debug tasks.

Python 또는 JavaScript 코드를 포함하는 코드베이스Codebases that contain Python or JavaScript code

코드베이스에 Python 또는 JavaScript 코드가 포함된 경우에는 .json 파일을 구성할 필요가 없지만 해당 워크로드를 설치해야 합니다.If your codebase contains Python or JavaScript code, you don't have to configure any .json files, but you do have to install the corresponding workload. 시작 스크립트도 구성해야 합니다.You must also configure the startup script:

  1. 도구 > 도구 및 기능 가져오기... 를 선택하거나 Visual Studio를 닫고 Visual Studio 설치 관리자를 실행하는 방법으로 Node.js 개발 또는 Python 개발 워크로드를 설치합니다.Install the Node.js development or Python development workload by choosing Tools > Get Tools and Features..., or by closing Visual Studio and running the Visual Studio Installer.

    Node.js 및 Python 개발 워크로드

  2. 솔루션 탐색기의 JavaScript 또는 Python 파일의 마우스 오른쪽 단추 메뉴나 상황에 맞는 메뉴에서 시작 항목으로 설정 명령을 선택합니다.In Solution Explorer, on the right-click or context menu of a JavaScript or Python file, choose the Set as Startup Item command.

  3. 시작 단추를 선택하여 디버깅을 시작합니다.Choose the Start button to begin debugging.

C++ 코드를 포함하는 코드베이스Codebases that contain C++ code

Visual Studio에서 솔루션이나 프로젝트 없이 C++ 코드를 여는 방법에 대한 자세한 내용은 C++의 폴더 열기 프로젝트를 참조하세요.For information about opening C++ code without solutions or projects in Visual Studio, see Open Folder projects for C++.

Visual Studio 프로젝트를 포함하는 코드베이스Codebases that contain a Visual Studio project

코드 폴더에 Visual Studio 프로젝트가 포함된 경우 프로젝트를 시작 항목으로 지정할 수 있습니다.If your code folder contains a Visual Studio project, you can designate the project as the startup item.

프로젝트를 시작 항목으로 설정

프로젝트가 시작 항목임을 반영하도록 시작 단추의 텍스트가 변경됩니다.The Start button's text changes to reflect that the project is the startup item.

시작 단추에 대한 프로젝트

참고 항목See also