인코딩 및 줄 바꿈Encodings and Line Breaks

Visual Studio에서 다음 문자는 줄 바꿈으로 해석됩니다.The following characters are interpreted as line breaks in Visual Studio:

  • CR LF: 캐리지 리턴 + 줄 바꿈, 유니코드 문자 000D + 000ACR LF: Carriage return + line feed, Unicode characters 000D + 000A

  • LF: 줄 바꿈, 유니코드 문자 000ALF: Line feed, Unicode character 000A

  • NEL: 다음 줄, 유니코드 문자 0085NEL: Next line, Unicode character 0085

  • LS: 줄 구분 기호, 유니코드 문자 2028LS: Line separator, Unicode character 2028

  • PS: 단락 구분 기호, 유니코드 문자 2029PS: Paragraph separator, Unicode character 2029

다른 응용 프로그램에서 복사되는 텍스트는 원래 인코딩 및 줄 바꿈 문자를 유지합니다.Text that is copied from other applications keeps the original encoding and line break characters. 예를 들어 메모장에서 텍스트를 복사하고 Visual Studio의 텍스트 파일로 붙여넣으면 텍스트에는 메모장의 텍스트와 같은 설정이 포함됩니다.For example, when you copy text from Notepad and paste it into a text file in Visual Studio, the text has the same settings that it had in Notepad.

다른 줄 바꿈 문자가 포함된 파일을 열 경우 일치하지 않는 줄 바꿈 문자를 정규화할지 여부 및 선택할 줄 바꿈 형식을 묻는 대화 상자가 표시될 수 있습니다.When you open a file that has different line break characters, you may see a dialog box that asks whether the inconsistent line break characters should be normalized, and which type of line breaks to choose.

파일, 고급 저장 옵션 대화 상자를 사용하여 원하는 줄 바꿈 문자의 형식을 결정할 수 있습니다.You can use the File, Advanced Save Options dialog box to determine the type of line break characters you want. 같은 설정을 사용하여 파일의 인코딩을 변경할 수도 있습니다.You can also change the encoding of a file with the same settings.

고급 저장 옵션 대화 상자

참고

파일 메뉴에서 고급 저장 옵션이 보이지 않으면 추가할 수 있습니다.If you don't see Advanced Save Options on the File menu, you can add it. 도구, 사용지 지정...을 선택한 다음 명령 탭을 선택합니다. 메뉴 모음 드롭다운 목록에서 파일을 선택한 다음 명령 추가... 단추를 선택합니다.Choose Tools, Customize..., and then choose the Commands tab. In the Menu bar drop-down list, choose File, then choose the Add Command... button. 명령 추가 대화 상자의 범주에서 파일을 선택하고 명령 목록에서 고급 저장 옵션...을 선택합니다. 확인을 선택한 다음 아래로 이동 단추를 선택하여 명령을 메뉴에서 임의의 위치로 이동합니다.In the Add Command dialog box, under Categories, choose File, and then in the Commands list, choose Advanced Save Options.... Choose OK and then choose the Move Down button to move the command to any place in the menu. 닫기를 선택하여 사용자 지정 대화 상자를 닫습니다.Choose Close to close the Customize dialog box. 자세한 내용은 메뉴 및 도구 모음 사용자 지정을 참조하세요.For more information, see Customize menus and toolbars.

또는, 파일, 다른 이름으로 <파일> 저장...을 선택하여 고급 저장 옵션에 액세스할 수 있습니다. 다른 이름으로 파일 저장 대화 상자에서 저장 단추 옆의 드롭다운 삼각형을 선택하고 인코딩하여 저장...을 선택합니다.Alternatively, you can access the Advanced Save Options dialog box by choosing File, Save <file> As.... In the Save File As dialog box, choose the drop-down triangle next to the Save button and choose Save with encoding....

참고 항목See also

편집기에서코 코드 작성Writing code in the editor