CodeLens에서 코드 변경 내용 및 기타 기록 찾기Find code changes and other history with CodeLens

CodeLens를 통해 코드에 대한 정보를 찾는 동안 편집기에서 나가지 않고–계속 작업에 집중할 수 있습니다.CodeLens lets you stay focused on your work while you find out what happened to your code–without leaving the editor. 코드 조각 참조, 코드 변경 내용, 연결된 버그, 작업 항목, 코드 검토 및 단위 테스트를 확인할 수 있습니다.You can find references to a piece of code, changes to your code, linked bugs, work items, code reviews, and unit tests.

참고

CodeLens는 Visual Studio Enterprise 및 Visual Studio Professional 버전에서만 사용할 수 있습니다.CodeLens is available only in Visual Studio Enterprise and Visual Studio Professional editions. Visual Studio Community 버전에서는 사용할 수 없습니다.It is not available in Visual Studio Community edition.

솔루션에서 코드의 개별 부분을 사용하는 위치 및 방법 확인:See where and how the individual parts of your code are used in your solution:

코드 편집기의 CodeLens 표시기

편집기를 종료하지 않고 코드 변경에 대해 팀에 문의:Contact your team about changes to your code without leaving the editor:

CodeLens - 팀에 문의

확인하려는 지표를 선택하거나 CodeLens를 설정 또는 해제하려면 도구 > 옵션 > 텍스트 편집기 > 모든 언어 > CodeLens로 이동합니다.To choose the indicators that you want to see, or to turn CodeLens off and on, go to Tools > Options > Text Editor > All Languages > CodeLens.

코드에 대한 참조 찾기Find references to your code

C# 또는 Visual Basic 코드에 대한 참조를 찾을 수 있습니다.You can find references in C# or Visual Basic code.

  1. 참조 표시기를 선택하거나 Alt+2를 누릅니다.Choose the references indicator, or press Alt+2.

    CodeLens 참조

    참고

    표시기에 0 참조가 표시된 경우 C# 또는 Visual Basic 코드의 참조가 없습니다.If the indicator shows 0 references, you have no references from C# or Visual Basic code. 하지만 .xaml.aspx 파일 등 다른 항목의 참조가 있을 수 있습니다.However, there may be references in other items such as .xaml and .aspx files.

  2. 참조 코드를 보려면 목록에서 참조 위에 마우스를 놓습니다.To view the referencing code, mouse over the reference in the list.

    CodeLens - 참조 피킹

  3. 참조가 포함된 파일을 열려면 참조를 두 번 클릭합니다.To open the file that contains the reference, double-click the reference.

코드 맵Code maps

이 코드와 해당 참조 간의 관계를 확인하려면 코드 맵을 만듭니다.To see relationships between the code and its references, create a code map. 코드 맵 바로 가기 메뉴에서 선택 모든 참조 표시를 선택합니다.In the code map shortcut menu, select Show All References.

CodeLens - 코드 맵의 참조

코드에서 변경 내용 찾기Find changes in your code

코드 기록을 검사하여 코드에 수행된 작업을 확인합니다.Inspect your code's history to find out what happened to your code. 또는 다른 분기의 변경 내용이 코드에 어떤 영향을 미칠 수 있는지 잘 파악할 수 있도록 변경 내용을 코드에 병합하기 전에 검토합니다.Or, review changes before they're merged into your code so you can better understand how changes in other branches might affect your code.

다음이 필요합니다.You need:

  • Visual Studio Enterprise 또는 Visual Studio ProfessionalVisual Studio Enterprise or Visual Studio Professional

  • Team Foundation Server 2013 이상, Visual Studio Team Services 또는 GitTeam Foundation Server 2013 or later, Visual Studio Team Services, or Git

  • 코드 편집기에서 팀에 연락하려는 경우 비즈니스용 Skype 또는 Lync 2010 이상Skype for Business, or Lync 2010 or later, to contact your team from the code editor

TFVC(Team Foundation 버전 제어) 또는 Git으로 저장된 C# 또는 Visual Basic 코드의 경우 클래스 및 메서드 수준에서 CodeLens 세부 정보를 가져옵니다(코드 요소 수준 표시기).For C# or Visual Basic code that's stored with Team Foundation Version Control (TFVC) or Git, you get CodeLens details at the class and method levels (code element-level indicators). Git 리포지토리가 TfGit에서 호스트되는 경우 TFS 작업 항목에 대한 링크도 가져올 수 있습니다.If your Git repository is hosted in TfGit, you also get links to TFS work items.

코드 요소 수준 표시기

.cs 또는 .vb 이외 파일 형식의 경우, 창 맨 아래의 한 지점에서 전체 파일에 대한 CodeLens 세부 정보를 가져옵니다(파일 수준 표시기).For file types other than .cs or .vb, you get CodeLens details for the entire file in one place at the bottom of the window (file-level indicators).

파일 수준 CodeLens 표시기

코드 요소 수준 표시기Code element-level indicators

코드 요소 수준 표시기를 통해 코드를 변경한 사람 및 변경된 내용을 확인할 수 있습니다.Code element-level indicators let you see who changed your code, and what changes they made. 코드 요소 수준 표시기는 C# 및 Visual Basic 코드에 대해 제공됩니다.Code element-level indicators are available for C# and Visual Basic code.

Team Foundation Server 또는 Visual Studio Team Services에서 TFVC(Team Foundation 버전 제어)를 사용하는 경우에 표시됩니다.This is what you see when you use Team Foundation Version Control (TFVC) in Team Foundation Server or Visual Studio Team Services:

CodeLens: TFVC에서 코드에 대한 변경 기록 가져오기

기본 기간은 지난 12 개월입니다.The default time period is the last 12 months. 코드가 Team Foundation Server에 저장되는 경우 TFSConfig 명령CodeIndex 명령/indexHistoryPeriod 플래그와 함께 실행하여 기간을 변경할 수 있습니다.If your code is stored in Team Foundation Server, you can change the time period by running the TFSConfig command with the CodeIndex command and the /indexHistoryPeriod flag.

1년 이상 전의 변경 내용을 포함하여 모든 변경 내용에 대한 자세한 기록을 보려면 모든 파일 변경 내용 표시를 선택합니다.To see a detailed history of all the changes, including those from more than a year ago, choose Show all file changes:

모든 코드 변경 내용 표시

기록 창이 열립니다.The History window opens:

모든 코드 변경 내용에 대한 기록 창

파일이 Git 리포지토리에 있고 코드 요소 수준 변경 표시기를 선택하면 다음이 표시됩니다.When your files are in a Git repository and you choose the code element-level changes indicator, this is what you see:

CodeLens: GIT에서 코드에 대한 변경 기록 가져오기

파일 수준 표시기File-level indicators

창 맨 아래의 파일 수준 표시기에서 전체 파일에 대한 변경 내용을 찾습니다.Find changes for an entire file in the file-level indicators at the bottom of the window:

CodeLens: 코드 파일 세부 정보 가져오기

참고

파일 수준 표시기는 C# 및 Visual Basic 코드에는 제공되지 않습니다.File-level indicators are not available for C# and Visual Basic files.

변경 내용에 대한 자세한 정보를 얻으려면 해당 항목을 마우스 오른쪽 단추로 클릭합니다.To get more details about a change, right-click that item. TFVC 또는 Git을 사용하는지에 따라 파일의 버전을 비교하고 세부 정보를 보고 변경 집합을 추적하고 선택한 버전의 파일을 가져오고 해당 변경 내용을 만든 이에게 메일을 보낼 수 있는 옵션을 사용할 수 있습니다.Depending on whether you are using TFVC or Git, there are options to compare the versions of the file, view details and track the changeset, get the selected version of the file, and email the author of that change. 이러한 세부 정보 중 일부는 팀 탐색기에 표시됩니다.Some of these details appear in Team Explorer.

시간별로 코드를 변경한 사용자를 확인할 수도 있습니다.You can also see who changed your code over time. 이는 팀의 변경 내용에서 패턴을 찾고 해당 영향을 평가하는 데 도움이 될 수 있습니다.This can help you find patterns in your team's changes and assess their impact.

CodeLens: 코드 변경 내용 기록을 그래프로 보기

현재 분기에서 변경 내용 찾기Find changes in your current branch

안정적인 코드가 손상되는 위험을 줄이기 위해 팀에 여러 분기(Main 분기 및 자식 개발 분기)가 있을 수 있습니다.Your team may have multiple branches, for example a main branch and a child development branch, to reduce the risk of breaking stable code.

CodeLens: 코드가 분기된 시기 찾기

Alt+6을 눌러 Main 분기에서 코드를 변경한 사용자의 수 및 변경된 내용의 수를 찾을 수 있습니다.You can find out how many people changed your code and how many changes were made in the main branch by pressing Alt+6:

CodeLens: 자신의 분기에서의 변경 내용 수 찾기

코드가 분기된 시점 찾기Find when your code was branched

코드가 분기된 시점을 찾으려면 자식 분기의 코드로 이동합니다.To find when your code was branched, navigate to your code in the child branch. 그런 다음, 변경 표시기를 선택하거나 Alt+6을 누릅니다.Then, select the changes indicator or pressAlt+6:

CodeLens: 코드가 분기된 시기 찾기

다른 분기에서 들어오는 변경 내용 찾기Find incoming changes from other branches

CodeLens: 다른 분기에서의 코드 변경 내용 찾기

들어오는 변경 내용을 볼 수 있습니다.You can view incoming changes. 다음 스크린샷에 버그 수정은 “Dev” 분기에서 이루어졌습니다.In the following screenshot, a bug fix was made in the "Dev" branch:

CodeLens: 다른 분기로 체크인된 변경 내용

다음과 같이 현재 분기(“Main”)를 벗어나지 않고 변경 내용을 검토할 수 있습니다.You can review the change without leaving your current branch ("Main"):

CodeLens: 다른 분기에서 들어온 변경 내용 확인인

변경 내용이 병합된 경우 찾기Find when changes got merged

변경 내용이 병합된 시기를 확인할 수 있으므로 분기에 어떤 변경 내용이 포함되는지 확인할 수 있습니다.You can see when changes got merged, so you can determine which changes are included in your branch:

CodeLens - 분기 사이에서 병합된 변경 내용

예를 들어 지금 Main 분기의 코드에는 “Dev” 분기의 버그 수정이 반영되어 있습니다.For example, your code in the Main branch now has the bug fix from the "Dev" branch:

CodeLens - 분기 사이에서 병합된 변경 내용

들어오는 변경 내용을 로컬 버전과 비교Compare an incoming change with your local version

Shift+F10을 누르거나 변경 집합을 두 번 클릭하여 들어오는 변경 내용을 로컬 버전과 비교합니다.Compare an incoming change with your local version by pressing Shift+F10, or by double-clicking the changeset.

CodeLens: 로컬과 들어오는 변경 내용 비교

분기 아이콘Branch icons

분기 열에 있는 아이콘은 분기가 작업 중인 분기와 어떻게 관련되어 있는지를 보여 줍니다.The icon in the Branch column tells you how the branch is related to the branch you're working in.

아이콘Icon 변경이 발생한 위치:The change came from:
CodeLens - 현재 분기에서 변경 아이콘 현재 분기The current branch
CodeLens: 부모 분기에서 변경 아이콘 부모 분기The parent branch
CodeLens: 하위 분기에서 변경 아이콘 자식 분기A child branch
CodeLens: 피어 분기에서 변경 아이콘 피어 분기A peer branch
CodeLens: 먼 분기에서 추가로 변경 아이콘 부모, 자식 또는 피어보다 더 먼 분기A branch further away than a parent, child, or peer
CodeLens: 상위에서 병합 아이콘 부모 분기에서 자식 분기로 병합A merge from the parent branch to a child branch
CodeLens - 하위 분기에서 병합 아이콘 자식 분기에서 부모 분기로 병합A merge from a child branch to the parent branch
CodeLens - 관련 없는 분기에서 병합 아이콘 관련 없는 분기에서 병합(기본 파일이 없는 병합)A merge from an unrelated branch (baseless merge)

연결된 작업 항목Linked work items

작업 항목 표시기를 선택하거나 Alt+8을 눌러 연결된 작업 항목을 찾습니다.Find linked work items by selecting the work items indicator or by pressing Alt+8.

CodeLens - 특정 코드에 대한 작업 항목 찾기

연결된 코드 검토Linked code reviews

검토 표시기를 선택하여 연결된 코드 검토를 찾습니다.Find linked code reviews by selecting the reviews indicator. 키보드를 사용하려면 Alt 키를 누른 상태에서 왼쪽 화살표 또는 오른쪽 화살표를 눌러 표시기 옵션을 탐색합니다.To use the keyboard, hold down the Alt key and then press Left arrow or Right arrow to navigate the indicator options.

CodeLens - 코드 검토 요청 보기

연결된 버그Linked bugs

버그 표시기를 선택하거나 Alt+7을 눌러 연결된 버그를 찾습니다.Find linked bugs by selecting the bugs indicator or by pressing Alt+7.

CodeLens - 변경 집합에 연결된 버그 찾기

항목 소유자에게 문의Contact the owner of an item

만든 이 표시기를 선택하거나 Alt+5를 눌러 항목의 만든 이를 찾습니다.Find the author of an item by selecting the authors indicator or by pressing Alt+5.

항목 소유자에게 문의

연락처 옵션을 보려면 항목에 대한 바로 가기 메뉴를 엽니다.Open the shortcut menu for an item to see the contact options. Lync 또는 비즈니스용 Skype를 설치한 경우 이러한 옵션이 표시됩니다.If you have Lync or Skype for Business installed, you see these options:

항목에 대한 연락처 옵션

연결된 단위 테스트Associated unit tests

테스트 탐색기를 열지 않고 C# 또는 Visual Basic 코드에 대한 단위 테스트를 확인할 수 있습니다.You can discover unit tests that exist for your C# or Visual Basic code without opening Test Explorer.

  1. 연결된 단위 테스트 코드가 있는 응용 프로그램 코드로 이동합니다.Go to application code that has associated unit test code.

  2. 아직 수행하지 않은 경우 CodeLens 테스트 지표를 로드하도록 응용 프로그램을 빌드합니다.If you have not already, build your application to load the CodeLens test indicators. 빌드된 어셈블리에 의한 검색이 설정되어 있는지 확인합니다.Make sure discovery by built assemblies is turned on.

  3. Alt+3을 눌러 코드에 대한 테스트를 검토합니다.Review the tests for the code by pressing Alt+3.

    CodeLens - 코드 편집기에서 테스트 상태 선택

  4. 경고 아이콘If you see a warning icon 경고 아이콘테스트가 아직 실행되지 않았으므로 실행합니다., the tests haven't run yet, so run them.

    CodeLens - 아직 실행하지 않은 단위 테스트 보기

  5. 테스트의 정의를 검토하려면 CodeLens 표시기 창에서 테스트 항목을 두 번 클릭하여 편집기에서 코드 파일을 엽니다.To review a test's definition, double-click the test item in the CodeLens indicator window to open the code file in the editor.

    CodeLens - 단위 테스트 정의로 이동

  6. 테스트 결과를 검토하려면 테스트 상태 표시기(테스트 실패 아이콘 또는 테스트 성공 아이콘)를 선택하거나 Alt+1을 누릅니다.To review the test's results, choose the test status indicator (test failed icon or test passed icon), or press Alt+1.

    CodeLens - 단위 테스트 결과 표시

  7. 이 테스트를 변경한 사용자와 그 수 또는 이 테스트에 대해 수행된 변경 작업 수를 확인하려면 코드 기록 및 연결된 항목을 찾아보세요.To see how many people changed this test, who changed this test, or how many changes were made to this test, find your code's history and linked items.

바로 가기 키Keyboard shortcuts

키보드를 사용하여 표시기를 선택하려면 Alt 키를 길게 눌러 관련 숫자 키를 표시한 다음, 선택하려는 표시기에 해당하는 숫자를 누릅니다.To use the keyboard to select indicators, press and hold the Alt key to display the related number keys, then press the number that corresponds to the indicator you want to select.

키보드 액세스 번호

참고

검토 표시기를 선택하려면 Alt를 누른 상태에서 왼쪽 및 오른쪽 화살표 키를 사용하여 탐색합니다.To select the reviews indicator, hold down Alt while using the left and right arrow keys to navigate.

Q&AQ & A

Q: CodeLens를 설정 또는 해제하거나 확인할 표시기를 선택하려면 어떻게 할까요?Q: How do I turn CodeLens off or on, or choose which indicators to see?

A: 참조 지표를 제외하고, 지표를 설정하거나 해제할 수 있습니다.A: You can turn indicators off or on, except for the references indicator. 도구 > 옵션 > 텍스트 편집기 > 모든 언어 > CodeLens로 이동합니다.Go to Tools > Options > Text Editor > All Languages > CodeLens.

지표가 설정되어 있으면 해당 지표에서 CodeLens 옵션을 열 수도 있습니다.When the indicators are turned on, you can also open the CodeLens options from the indicators.

CodeLens - 표시기 설정 또는 해제

편집기 창의 맨 아래에 있는 펼침 단추 아이콘을 사용하여 CodeLens 파일 수준 표시기를 켜거나 끕니다.Turn CodeLens file-level indicators on and off using the chevron icons at the bottom of the editor window.

파일 수준 표시기 설정 및 해제

Q: CodeLens는 어디에 있나요?Q: Where is CodeLens?

A: CodeLens는 메서드, 클래스, 인덱서 및 속성 수준에서 C# 및 Visual Basic 코드에 표시됩니다.A: CodeLens appears in C# and Visual Basic code at the method, class, indexer, and property level. CodeLens는 기타 모든 형식의 파일에 대해 파일 수준에서 표시됩니다.CodeLens appears at the file level for all other types of files.

  • CodeLens가 설정되어 있는지 확인합니다.Make sure CodeLens is turned on. 도구 > 옵션 > 텍스트 편집기 > 모든 언어 > CodeLens로 이동합니다.Go to Tools > Options > Text Editor > All Languages > CodeLens.

  • 코드가 TFS에 저장되는 경우 CodeIndex 명령TFS 구성 명령을 함께 사용하여 코드 인덱싱이 설정되어 있는지 확인합니다.If your code is stored in TFS, make sure that code indexing is turned on by using the CodeIndex command with the TFS Config command.

  • TFS 관련 지표는 작업 항목이 코드와 링크되어 있는 경우 및 링크된 작업 항목을 열 권한이 있는 경우에만 나타납니다.TFS-related indicators appear only when work items are linked to the code and when you have permissions to open linked work items. 팀 멤버 권한이 있는지 확인합니다.Confirm that you have team member permissions.

  • 단위 테스트 지표는 응용 프로그램 코드에서 단위 테스트를 하지 않은 경우 나타나지 않습니다.Unit test indicators don't appear when application code doesn't have unit tests. 테스트 상태 지표는 테스트 프로젝트에 자동으로 나타납니다.Test status indicators appear automatically in test projects. 응용 프로그램 코드에 단위 테스트가 있지만 테스트 표시기가 나타나지 않는 경우 솔루션 빌드를 시도해 보세요(Ctrl+Shift+B).If you know that your application code has unit tests, but the test indicators don't appear, try building the solution (Ctrl+Shift+B).

Q: 커밋에 대한 작업 항목 정보가 나타나지 않습니다.Q: Why don't I see the work item details for a commit?

A: CodeLens가 TFS의 작업 항목을 찾을 수 없기 때문에 이러한 현상이 발생할 수 있습니다.A: This might happen because CodeLens can't find the work items in TFS. 작업 항목이 포함된 팀 프로젝트에 연결되어 있으며 해당 작업 항목을 볼 수 있는 권한이 있는지 확인하세요.Check that you're connected to the team project that has those work items, and that you have permissions to see those work items. 커밋 설명에 TFS의 작업 항목 ID에 대한 잘못된 정보가 포함된 경우 작업 항목 정보가 표시되지 않을 수 있습니다.Work item details might not also not show if the commit description has incorrect information about the work item IDs in TFS.

Q: Skype 표시기가 나타나지 않습니다.Q: Why don't I see the Skype indicators?

A: 비즈니스용 Skype에 로그인하지 않았거나, 설치하지 않았거나, 지원되는 구성이 없을 경우 Skype 표시기가 나타나지 않습니다.A: Skype indicators don't appear if you're not signed into Skype for Business, don't have it installed, or don't have a supported configuration. 하지만 이메일은 보낼 수 있습니다.However, you can still send email:

CodeLens - 변경 집합 소유자에게 메일로 문의

어떤 Skype 및 Lync 구성이 지원되나요?Which Skype and Lync configurations are supported?

  • 비즈니스용 Skype(32비트 또는 64비트)Skype for Business (32-bit or 64-bit)

  • Lync 2010 이상 독립형(32비트 또는 64비트) 단, Windows 8.1의 Lync Basic 2013 제외Lync 2010 or later alone (32-bit or 64-bit), but not Lync Basic 2013 with Windows 8.1

CodeLens는 다른 버전의 Lync 또는 Skype가 설치되는 것을 지원하지 않습니다.CodeLens doesn't support having different versions of Lync or Skype installed. 다른 버전의 Lync 또는 Skype는 Visual Studio의 모든 지역화된 버전에 지역화되지 않을 수 있습니다.They might not be localized for all localized versions of Visual Studio.

Q: CodeLens의 글꼴과 색을 변경하려면 어떻게 해야 하나요?Q: How do I change the font and color for CodeLens?

A: 도구 > 옵션 > 환경 > 글꼴 및 색으로 이동합니다.A: Go to Tools > Options > Environment > Fonts and Colors.

CodeLens - 글꼴 및 색상 설정 변경

키보드를 사용하려면To use the keyboard:

  1. Alt+T+O를 눌러 옵션 대화 상자를 엽니다.Press Alt+T+O to open the Options dialog box.

  2. 위쪽 화살표 또는 아래쪽 화살표 를 눌러 환경 노드로 이동한 다음 왼쪽 화살표 를 눌러 노드를 확장합니다.Press Up Arrow or Down Arrow to go to the Environment node, then press Left Arrow to expand the node.

  3. 아래쪽 화살표 를 눌러 글꼴 및 색으로 이동합니다.Press Down Arrow to go to Fonts and Colors.

  4. Tab을 눌러 설정 표시 목록으로 이동한 다음, 아래쪽 화살표 를 눌러 CodeLens를 선택합니다.Press Tab to go to the Show settings for list, and then press Down Arrow to select CodeLens.

Q: CodeLens 헤드업 표시를 이동할 수 있습니까?Q: Can I move the CodeLens heads-up display?

A: 예, 도킹 아이콘을 선택하여 CodeLens를 창으로 도킹합니다.A: Yes, choose Dock icon to dock CodeLens as a window.

CodeLens 표시기 창의 도킹 단추

도킹된 CodeLens 참조 창

Q: 지표를 새로 고치려면 어떻게 합니까?Q: How do I refresh the indicators?

A: 지표에 따라 다릅니다.A: This depends on the indicator:

  • 참조: 이 지표는 코드가 변경될 때 자동으로 업데이트됩니다.References: This indicator updates automatically when the code changes. 참조 표시기가 별도의 창으로 도킹된 경우 새로 고침을 선택하여 표시기를 새로 고칩니다.If the References indicator is docked as a separate window, refresh the indicator by selecting Refresh:

    CodeLens 참조의 [새로 고침] 단추

  • : 오른쪽 클릭 메뉴에서 CodeLens 팀 지표 새로 고침을 선택하여 이러한 표시기를 새로 고칩니다.Team: Refresh these indicators by selecting Refresh CodeLens Team Indicators from the right-click menu:

    CodeLens 팀 지표 새로 고침 메뉴 항목

  • 테스트: 코드에 대한 단위 테스트를 찾아 테스트 표시기를 새로 고칩니다.Test: Find unit tests for your code to refresh the Test indicator.

Q: "로컬 버전"이란 무엇인가요?Q: What's "Local Version"?

A: 로컬 버전 화살표는 파일의 로컬 버전에 있는 최신 변경 집합을 가리킵니다.A: The Local Version arrow points at the most recent changeset in your local version of a file. 서버에 최신 변경 집합이 있는 경우, 변경 집합을 정렬하는 순서에 따라 로컬 버전 화살표의 위 또는 아래에 나타납니다.When the server has more recent changesets, they appear above or below the Local Version arrow, depending on the order used to sort the changesets.

Q: CodeLens가 코드를 처리하여 기록 및 연결된 항목을 표시하는 방법을 관리할 수 있나요?Q: Can I manage how CodeLens processes code to show history and linked items?

A: 예.A: Yes. 코드가 TFS에 있는 경우 CodeIndex 명령TFS 구성 명령을 함께 사용합니다.If your code is in TFS, use the CodeIndex command with the TFS Config command.

Q: 내 CodeLens 테스트 지표는 솔루션을 처음 열 때 내 파일에 더 이상 나타나지 않습니다.Q: My CodeLens test indicators no longer appear in my file when I first open my solution. 로드하려면 어떻게 하나요?How can I load them?

A: CodeLens 테스트 지표를 가져오는 프로젝트를 다시 빌드하여 파일에서 로드합니다.A: Rebuild your project to get CodeLens test indicators to load in your file. 빌드된 어셈블리에 의한 검색이 설정되어 있는지 확인합니다.Make sure discovery by built assemblies is turned on. 성능을 향상시키기 위해 코드 파일을 로드하는 경우 Visual Studio는 테스트 지표에 대한 원본 정보를 더 이상 페치하지 않습니다.To improve performance, Visual Studio no longer fetches source information for test indicators when code files are loaded. 빌드 후에 또는 테스트 탐색기를 두 번 클릭하여 테스트로 이동할 때 테스트 지표가 로드됩니다.Test indicators are loaded after a build, or when you navigate to a test by double-clicking on it in Test Explorer.

참고 항목See also