Visual Studio에서 C++ 시작Get started with C++ in Visual Studio

이 빠른 시작을 완료하면 Visual Studio를 사용하여 C++로 응용 프로그램을 개발할 때 사용할 수 있는 여러 도구 및 대화 상자에 익숙해집니다.Complete this quickstart to become familiar with many of the tools and dialog boxes that you can use when you develop applications in C++ with Visual Studio. 간단한 "Hello, World" 스타일 콘솔 응용 프로그램을 만들면서 IDE(통합 개발 환경)에서 작업하는 방법을 배워 보겠습니다.Create a "Hello, World"-style console application while you learn more about working in the integrated development environment (IDE).

전제 조건Prerequisites

이 빠른 시작을 완료하려면 C++에 익숙하지 않아도 되지만 몇 가지 일반적인 프로그래밍 및 디버깅 개념을 잘 알고 있어야 합니다.You don't need to be familiar with C++ to complete this quickstart, but you should be familiar with some general programming and debugging concepts. Visual Studio 설명서에서는 C++로 프로그래밍하는 방법을 설명하지 않습니다.The Visual Studio documentation doesn't teach you how to program in C++. C++ 학습 리소스에 도움이 되는 가이드는 ISO C++ 웹 사이트의 시작 페이지에 있습니다.A good guide to C++ learning resources is the Get started page on the ISO C++ website.

단계를 따르려면 C++를 사용한 데스크톱 개발 워크로드가 설치된 Visual Studio 2017 버전 15.3 이상의 복사본이 필요합니다.To follow along, you need a copy of Visual Studio 2017 version 15.3 or later, with the Desktop development with C++ workload installed. 빠른 설치 가이드는 Visual Studio에서 C++ 지원 설치를 참조하세요.For a fast guide to installation, see Install C++ support in Visual Studio.

콘솔 앱 만들기Create a console app

Visual Studio를 아직 실행하지 않는 경우 시작합니다.If it's not running yet, start Visual Studio.

Visual C++ 설정이 적용된 IDE

Visual Studio를 열면 IDE의 세 가지 기본 부분인 도구 창, 메뉴 및 도구 모음, 주 창 공간을 확인할 수 있습니다.After you open Visual Studio, you can see the three basic parts of the IDE: tool windows, menus and toolbars, and the main window space. 도구 창은 앱 창의 왼쪽과 오른쪽에 고정됩니다.Tool windows are docked on the left and right sides of the app window. 빠른 실행 상자, 메뉴 모음 및 표준 도구 모음은 맨 위에 표시됩니다.The Quick Launch box, the menu bar, and the standard toolbar are found at the top. 창의 가운데에는 시작 페이지가 있습니다.The center of the window contains the Start Page. 솔루션 또는 프로젝트를 열면 편집기와 디자이너가 이 공간에 나타납니다.When you open a solution or project, editors and designers appear in this space. 앱을 개발할 때 이 중앙 영역을 가장 많이 사용합니다.When you develop an app, most of your time is spent in this central area.

Visual Studio는 프로젝트를 사용하여 앱에 대한 코드를 구성하고 솔루션을 사용하여 프로젝트를 구성합니다.Visual Studio uses projects to organize the code for an app, and solutions to organize your projects. 프로젝트에는 앱을 빌드하는 데 사용되는 모든 옵션, 구성 및 규칙이 포함됩니다.A project contains all the options, configurations, and rules used to build your apps. 또한 프로젝트의 모든 파일과 외부 파일 간의 관계를 관리합니다.It also manages the relationship between all the project's files and any external files. 앱을 만들려면 먼저 새 프로젝트 및 솔루션을 만듭니다.To create your app, first, you create a new project and solution.

콘솔 앱 프로젝트를 만들려면To create a console app project

  1. 메뉴 모음에서 파일 > 새로 만들기 > 프로젝트를 선택하여 새 프로젝트 대화 상자를 엽니다.On the menu bar, choose File > New > Project to open the New Project dialog box.

    메뉴 모음에서 [파일] > [새로 만들기] > [프로젝트]를 차례로 선택합니다.

  2. 아직 선택하지 않은 경우 새 프로젝트 대화 상자에서 설치됨 > Visual C++ 를 선택합니다.In the New Project dialog, select Installed > Visual C++ if it isn't selected already. 가운데 창에서 Windows 콘솔 응용 프로그램 템플릿을 선택합니다.In the center pane, select the Windows Console Application template. 이름 편집 상자에서 HelloApp을 입력합니다.In the Name edit box, enter HelloApp.

    새 프로젝트 대화 상자를 사용하여 앱 프로젝트를 만듭니다.

    대화 상자는 이전에 설치한 Visual Studio 워크로드 및 구성 요소에 따라 선택 항목이 다를 수 있습니다.Your dialog box may have different choices, depending on the Visual Studio workloads and components you've installed. Visual C++ 프로젝트 템플릿이 표시되지 않으면 Visual Studio 설치 관리자를 다시 실행하고 C++를 사용한 데스크톱 개발 워크로드를 설치해야 합니다.If you don't see Visual C++ project templates, you need to run the Visual Studio installer again and install the Desktop development with C++ workload. 새 프로젝트 대화 상자에서 직접 수행할 수 있습니다.You can do this directly from the New Project dialog. 설치 관리자를 시작하려면 대화 상자에서 Visual Studio 설치 관리자 열기 링크를 선택합니다.To launch the installer, choose the Open Visual Studio Installer link on the dialog.

  3. 확인 단추를 선택하여 앱 프로젝트 및 솔루션을 만듭니다.Choose the OK button to create your app project and solution.

    Windows 콘솔 앱의 기본 파일과 함께 HelloApp 프로젝트 및 솔루션을 만들고 솔루션 탐색기에 자동으로 로드합니다.The HelloApp project and solution, with the basic files for a Windows console app, are created and automatically loaded into Solution Explorer. HelloApp.cpp 파일이 코드 편집기에서 열립니다.The HelloApp.cpp file is opened in the code editor. 다음 항목이 솔루션 탐색기에 나타납니다.These items appear in Solution Explorer:

    솔루션 탐색기의 솔루션 파일

앱에 코드 추가Add code to the app

다음으로 콘솔 창에 "Hello"를 표시하는 코드를 추가합니다.Next, add code to display the word "Hello" in the console window.

편집기에서 코드를 편집하려면To edit code in the editor

  1. HelloApp.cpp 파일에서 return 0; 줄 앞에 빈 줄을 입력하고 다음 코드를 입력합니다.In the HelloApp.cpp file, enter a blank line before the line return 0; and then enter this code:

    cout << "Hello\n";
    

    cout아래에 빨간색 물결선이 나타납니다.A red squiggly line appears under cout. 그 위로 포인터를 가져가면 오류 메시지가 나타납니다.If you hover the pointer over it, an error message appears.

    cout에 대한 오류 텍스트

    이 오류 메시지는 오류 목록 창에도 나타납니다.The error message also appears in the Error List window. 메뉴 모음에서 보기>오류 목록을 선택하여 이 창을 표시할 수 있습니다.You can display this window by choosing View > Error List on the menu bar.

    오류 목록 창의 오류

    코드는 <iostream> 헤더 파일에서 찾을 수 있는 std::cout에 대한 선언을 누락했습니다.Your code is missing a declaration for std::cout, which is found in the <iostream> header file.

  2. iostream 헤더를 포함하려면 #include "stdafx.h" 뒤에 다음 코드를 입력합니다.To include the iostream header, enter this code after #include "stdafx.h":

    #include <iostream>
    using namespace std;
    

    코드를 입력하면 상자가 나타나는 것을 확인할 수 있습니다.You probably noticed that a box appeared as you entered code. 이 상자에는 입력한 문자에 대한 자동 완성 제안이 포함됩니다.This box contains auto-completion suggestions for the characters that you enter. 이 기능은 C++ IntelliSense의 일부로, 클래스 또는 인터페이스 멤버 및 매개 변수 정보를 비롯한 코딩 프롬프트를 제공합니다.It's part of C++ IntelliSense, which provides coding prompts, including class or interface members and parameter information. 또한 미리 정의된 코드 블록인 코드 조각을 사용할 수도 있습니다.You can also use code snippets, which are pre-defined blocks of code. 자세한 내용은 Using IntelliSenseCode Snippets을 참조하세요.For more information, see Using IntelliSense and Code snippets.

    편집기의 고정된 코드

    cout 아래의 빨간색 물결선은 오류를 해결하면 사라집니다.The red squiggly line under cout disappears when you fix the error.

  3. 파일의 변경 내용을 저장하려면 Ctrl+S를 누릅니다.To save the changes to the file, press Ctrl+S.

앱 빌드Build the app

코드를 작성하는 것이 쉽습니다.It's easy to build your code. 메뉴 모음에서 빌드 > 솔루션 빌드를 선택합니다.On the menu bar, choose Build > Build Solution. Visual Studio는 HelloApp 솔루션을 빌드하고 출력 창에서 진행률을 보고합니다.Visual Studio builds the HelloApp solution, and reports progress in the Output window.

HelloApp 솔루션 빌드

앱 디버그 및 테스트Debug and test the app

HelloApp을 디버그하여 단어 "Hello"가 콘솔 창에 표시되는지 여부를 확인할 수 있습니다.You can debug HelloApp to see whether the word "Hello" appears in the console window.

앱을 디버깅하려면To debug the app

디버거를 시작하려면 메뉴 모음에서 디버그 > 디버깅 시작을 선택합니다.To start the debugger, choose Debug > Start Debugging on the menu bar.

디버그 메뉴의 디버깅 시작 명령

디버거가 시작되고 코드가 실행됩니다.The debugger starts and runs the code. 콘솔 창(명령 프롬프트외 비슷한 별도의 창)이 몇 초간 나타나지만 디버거에서 실행이 중지되면 바로 닫힙니다.The console window (a separate window that looks like a command prompt) appears for a few seconds but closes quickly when the debugger stops running. 텍스트를 보려면 중단점을 설정하여 프로그램 실행을 중지해야 합니다.To see the text, you need to set a breakpoint to stop program execution.

중단점을 추가하려면To add a breakpoint

  1. 편집기에서 return 0; 줄에 커서를 놓습니다.In the editor, put the cursor on the line return 0;. 메뉴 모음에서 디버그 > 중단점 설정/해제를 선택합니다.On the menu bar, choose Debug > Toggle Breakpoint. 왼쪽 여백을 클릭하여 중단점을 설정할 수도 있습니다.You can also click in the left margin to set a breakpoint.

    디버그 메뉴의 중단점 설정/해제 명령

    편집기 창의 맨 왼쪽 여백 코드 줄 옆에 빨간색 원이 나타납니다.A red circle appears next to the line of code in the far left margin of the editor window.

    창 여백에 표시된 중단점

  2. 디버깅을 시작하려면 F5 키를 누릅니다.To start debugging, press F5.

    디버거가 시작되고 단어 Hello를 표시하는 콘솔 창이 나타납니다.The debugger starts, and a console window appears showing the word Hello.

    콘솔 창의 Hello 텍스트

  3. 디버깅을 중지하려면 Shift+F5 키를 누릅니다.To stop debugging, press Shift+F5.

콘솔 프로젝트 디버깅에 대한 자세한 내용은 콘솔 프로젝트를 참조하세요.For more information about console project debugging, see Console projects.

앱 릴리스 버전 빌드Build a release version of the app

모든 것이 작동하는 것을 확인했으므로 응용 프로그램의 릴리스 빌드를 준비할 수 있습니다.Now that you've verified that everything works, you can prepare a release build of the application. 릴리스 빌드는 디버깅 정보를 두고 컴파일러 최적화 옵션을 사용하여 더 작고 빠른 코드를 만듭니다.Release builds leave out the debugging information, and use compiler optimization options to create smaller, faster code.

솔루션 파일을 정리하고 릴리스 버전을 빌드하려면To clean the solution files and build a release version

  1. 메뉴 모음에서 빌드 > 솔루션 정리를 선택하여 이전 빌드 과정에서 만들어진 중간 파일과 출력 파일을 삭제합니다.On the menu bar, choose Build > Clean Solution to delete intermediate files and output files that were created during previous builds.

    빌드 메뉴의 솔루션 정리 명령

  2. 디버그부터 릴리스까지 HelloApp에 대한 솔루션 구성을 변경하려면 도구 모음에서 솔루션 구성 컨트롤에 대한 드롭다운을 선택한 다음 릴리스를 선택합니다.To change the solution configuration for HelloApp from Debug to Release, in the toolbar, select the dropdown on the Solution Configurations control and then choose Release.

    응용 프로그램 릴리스 버전 빌드

  3. 솔루션을 빌드합니다.Build the solution. 메뉴 모음에서 빌드 > 솔루션 빌드를 선택합니다.On the menu bar, choose Build > Build Solution.

이 빌드가 완료되면 명령 프롬프트 창에서 복사하고 실행할 수 있는 앱이 만들어집니다.When this build completes, you've created an app that you can copy and run in any command prompt window. 많은 작업을 수행하지 않지만 더 많은 작업에 대한 게이트웨이입니다.It may not do much, but it's the gateway to greater things.

이 빠른 시작을 완료한 것을 축하 드립니다!Congratulations on completing this quickstart! 더 많은 예제를 탐색하려는 경우 Visual Studio 샘플을 참조하세요.If you want to explore more examples, see Visual Studio samples.

참고 항목See also