방법: Visual Studio에서 메뉴 및 도구 모음 사용자 지정How to: Customize menus and toolbars in Visual Studio

메뉴 모음의 도구 모음 및 메뉴를 추가 및 제거하는 방법뿐만 아니라 지정된 도구 모음 또는 메뉴의 명령을 제거하여 Visual Studio를 사용자 지정할 수 있습니다.You can customize Visual Studio not only by adding and removing toolbars and menus on the menu bar, but also by adding and removing commands on any given toolbar or menu.

경고

도구 모음 또는 메뉴를 사용자 지정한 후 확인란이 사용자 지정 대화 상자에서 선택되었는지 확인합니다.After you customize a toolbar or menu, make sure that its check box remains selected in the Customize dialog box. 그렇지 않으면 Visual Studio를 닫았다가 다시 연 후 변경 사항이 유지되지 않습니다.Otherwise, your changes won't persist after you close and reopen Visual Studio.

메뉴 모음의 메뉴 추가, 제거 또는 이동Add, remove, or move a menu on the menu bar

  1. 메뉴 모음에서 도구 > 사용자 지정을 선택합니다.On the menu bar, choose Tools > Customize.

    사용자 지정 대화 상자가 열립니다.The Customize dialog box opens.

  2. 명령 탭에서 메뉴 모음 옵션 단추를 선택된 상태로 두고 그 옵션 옆의 목록에서 메뉴 모음을 선택한 상태로 둔 후 다음 단계 중 하나를 수행합니다.On the Commands tab, leave the Menu bar option button selected, leave Menu Bar selected in the list next to that option, and then perform one of the following sets of steps:

    • 메뉴를 추가하려면 새 메뉴 추가 단추를 선택하고 선택 사항 수정 단추를 선택한 다음 추가할 메뉴의 이름을 지정합니다.To add a menu, choose the Add New Menu button, choose the Modify Selection button, and then name the menu that you want to add.

      메뉴 추가 방법을 표시하는 사용자 지정 대화 상자

    • 메뉴를 제거하려면 컨트롤 목록에서 선택한 다음 삭제 단추를 선택합니다.To remove a menu, choose it in the Controls list, and then choose the Delete button.

    • 메뉴 모음에서 메뉴를 이동하려면 컨트롤 목록에서 메뉴를 선택한 다음 위로 이동 또는 아래로 이동 단추를 선택합니다.To move a menu within the menu bar, choose the menu in the Controls list, and then choose the Move Up or Move Down button.

도구 모음 추가, 제거 또는 이동Add, remove, or move a toolbar

  1. 메뉴 모음에서 도구 > 사용자 지정을 선택합니다.On the menu bar, choose Tools > Customize.

    사용자 지정 대화 상자가 열립니다.The Customize dialog box opens.

  2. 도구 모음 탭에서 다음 단계 중 하나를 수행합니다.On the Toolbar tab, perform one of the following sets of steps:

    • 도구 모음을 추가하려면 새로 만들기 단추를 선택하고 추가할 도구 모음의 이름을 지정한 다음 확인 단추를 선택합니다.To add a toolbar, choose the New button, specify a name for the toolbar that you want to add, and then choose the OK button.

      도구 모음 추가 방법을 표시하는 사용자 지정 대화 상자

    • 사용자 지정 도구 모음을 제거하려면 도구 모음 목록에서 선택한 다음 삭제 단추를 선택합니다.To remove a custom toolbar, choose it in the Toolbars list, and then choose the Delete button.

      중요

      만든 도구 모음은 삭제할 수 있지만 기본 도구 모음은 삭제할 수 없습니다.You can delete toolbars that you create but not default toolbars.

    • 도구 모음을 다른 도킹 위치로 이동하려면 도구 모음 목록에서 선택 사항 수정 단추를 선택한 다음 나타나는 목록에서 위치를 선택합니다.To move a toolbar to a different docking location, choose it in the Toolbars list, choose the Modify Selection button, and then choose a location in the list that appears.

      도구 모음의 왼쪽 가장자리를 주 도킹 영역에서 원하는 위치로 끌어 도구 모음을 이동할 수도 있습니다.You can also drag a toolbar by its left edge to move it anywhere in the main docking area.

      참고

      도구 모음의 사용 가능성과 내게 필요한 옵션 기능을 향상시키는 방법에 대한 자세한 내용은 방법: IDE 내게 필요한 옵션 설정을 참조하세요.For more information about how to improve the usability and accessibility of toolbars, see How to: Set IDE accessibility options.

메뉴 또는 도구 모음 사용자 지정Customize a menu or a toolbar

  1. 메뉴 모음에서 도구 > 사용자 지정을 선택합니다.On the menu bar, choose Tools > Customize.

    사용자 지정 대화 상자가 열립니다.The Customize dialog box opens.

  2. 명령 탭에서 사용자 지정할 요소의 형식에 대한 옵션 단추를 선택합니다.On the Commands tab, choose the option button for the type of element that you want to customize.

  3. 해당 요소 형식에 대한 목록에서 사용자 지정할 메뉴 또는 도구 모음을 선택한 후 다음 단계 중 하나를 수행합니다.In the list for that type of element, choose the menu or toolbar that you want to customize, and then perform one of the following sets of steps:

    • 명령을 추가하려면 명령 추가 단추를 선택합니다.To add a command, choose the Add Command button.

      명령 추가 대화 상자에서 범주 목록의 항목을 선택하고 명령 목록의 항목을 선택한 다음 확인 단추를 선택합니다.In the Add Command dialog box, choose an item in the Categories list, choose an item in the Commands list, and then choose the OK button.

      Visual Studio의 명령 추가 대화 상자

    • 명령을 삭제하려면 컨트롤 목록에서 선택한 다음 삭제 단추를 선택합니다.To delete a command, choose it in the Controls list, and then choose the Delete button.

    • 명령을 다시 정렬하려면 컨트롤 목록에서 명령을 선택한 다음 위로 이동 또는 아래로 이동 단추를 선택합니다.To reorder commands, choose a command in the Controls list, and then choose the Move Up or Move Down button.

    • 가로 선 아래로 명령을 그룹화하려면 컨트롤 목록에서 첫 명령을 선택하고 선택 사항 수정 버튼을 선택한 다음 나타나는 메뉴에서 그룹 시작을 선택합니다.To group commands under a horizontal line, choose the first command in the Controls list, choose the Modify Selection button, and then choose Begin a Group in the menu that appears.

메뉴 또는 도구 모음 다시 설정Reset a menu or a toolbar

  1. 메뉴 모음에서 도구 > 사용자 지정을 선택합니다.On the menu bar, choose Tools > Customize.

    사용자 지정 대화 상자가 열립니다.The Customize dialog box opens.

  2. 명령 탭에서 사용자 다시 설정할 요소의 형식에 대한 옵션 단추를 선택합니다.On the Commands tab, choose the option button for the type of element that you want to reset.

  3. 해당 요소 형식에 대한 목록에서 다시 설정할 메뉴 또는 도구 모음을 선택합니다.In the list for that type of element, choose the menu or toolbar that you want to reset.

  4. 선택 사항 수정 단추를 선택한 다음 나타나는 메뉴에서 다시 설정을 선택합니다.Choose the Modify Selection button, and then choose Reset in the menu that appears.

    모두 다시 설정 단추를 선택하면 모든 메뉴 및 도구 모음을 다시 설정할 수도 있습니다.You can also reset all menus and toolbars by choosing the Reset All button.

참고 항목See also