방법: 프로젝트 템플릿과 항목 템플릿 찾기 및 구성How to: Locate and organize project and item templates

Visual Studio에서 인식할 수 있는 위치에 템플릿 파일이 있어야 새 프로젝트새 항목 추가 대화 상자에 템플릿이 나타납니다.Template files must be placed in a location that Visual Studio recognizes, for the templates to appear in the New Project and Add New Item dialog boxes. 템플릿에 대한 사용자 지정 하위 범주를 만들어 이러한 하위 범주가 대화 상자에 나타나도록 할 수도 있습니다.You can create custom subcategories for templates that will also appear in the dialog boxes.

템플릿 찾기Locating templates

설치된 템플릿과 사용자 템플릿은 서로 다른 두 위치에 저장됩니다.Installed templates and user templates are stored in two different locations. .vstemplate 파일을 포함하는 압축된 파일이 이러한 위치에 있는 경우 템플릿은 새 프로젝트 또는 새 항목 추가 대화 상자에 나타납니다.If a compressed file that includes a .vstemplate file exists in these locations, the template will appear in the New Project or Add New Item dialog box.

도구 > 옵션 > 프로젝트 및 솔루션 > 위치에서 사용자 템플릿의 위치를 설정할 수 있습니다.You can set the location for user templates in Tools > Options > Projects and Solutions > Locations.

설치된 템플릿Installed templates

기본적으로 Visual Studio와 함께 설치되는 템플릿은 다음 위치에 있습니다.By default, templates installed with Visual Studio are located in:

  • \VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\프로그래밍 언어\로캘 ID\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\Programming Language\Locale ID

  • \VisualStudioInstallationDirectory\Common7\IDE\ProjectTemplates\프로그래밍 언어\로캘 ID\VisualStudioInstallationDirectory\Common7\IDE\ProjectTemplates\Programming Language\Locale ID

예를 들어 다음 디렉터리에는 영어용 Visual Basic 프로젝트 템플릿(LCID 1033)이 포함되어 있습니다.For example, the following directory contains the Visual Basic item templates for English (LCID 1033):

C:\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\VisualBasic\1033\C:\VisualStudioInstallationDirectory\Common7\IDE\ItemTemplates\VisualBasic\1033\

사용자 템플릿User templates

기본적으로 사용자 템플릿은 다음 위치에 있습니다.By default, user templates are located in:

  • %USERPROFILE%\Documents\Visual Studio <버전>\Templates\ProjectTemplates%USERPROFILE%\Documents\Visual Studio <Version>\Templates\ProjectTemplates

  • %USERPROFILE%\Documents\Visual Studio <버전>\Templates\ItemTemplates%USERPROFILE%\Documents\Visual Studio <Version>\Templates\ItemTemplates

예를 들어 다음 디렉터리에는 C#용 사용자 프로젝트 템플릿이 포함되어 있습니다.For example, the following directory contains user project templates for C#:

C:\Users\UserName\Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#\C:\Users\UserName\Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#\

참고

사용자 템플릿 위치에는 지역화된 템플릿에 대한 로캘 하위 디렉터리가 포함되지 않습니다.The user template location does not include locale subdirectories for localized templates.

프로젝트 및 솔루션 > 위치옵션 대화 상자에서 사용자 템플릿의 기본 디렉터리를 변경할 수 있습니다.You can change the default directory for user templates in the Options dialog box, under Projects and Solutions > Locations.

템플릿 구성Organizing templates

새 프로젝트새 항목 추가 대화 상자의 범주는 설치된 템플릿과 사용자 템플릿 위치에 있는 디렉터리 구조를 반영합니다.The categories in the New Project and Add New Item dialog boxes reflect the directory structures that exist in the installed template and user template locations. 이러한 디렉터리 구조를 수정하여 이해할 수 있는 방식으로 템플릿을 구성할 수 있습니다.You can modify these directory structures to organize your templates in a way that makes sense to you.

참고

프로그래밍 언어 수준에서 새 범주를 만들 수 없습니다.You cannot create a new category at the programming language level. 새 범주는 각 언어 내에서만 만들어질 수 있습니다.New categories can only be created within each language.

참고

특정 언어의 설치된 템플릿과 사용자 템플릿의 디렉터리 구조가 동일하지 않을 경우(즉, 한 폴더에는 디렉터리가 있지만 다른 폴더에는 없는 경우) 모든 범주가 새 프로젝트 대화 상자에 표시됩니다.If the directory structures for installed and user templates for a particular language are not the same (that is, there are directories under one folder but not the other), all the categories are shown in the New Project dialog box.

사용자 템플릿 구성Organizing user templates

사용자 템플릿 위치에 새 폴더를 추가하여 사용자 템플릿을 독자적인 범주로 구성할 수 있습니다.User templates can be organized into their own categories by adding new folders in the user template location. 새 프로젝트 대화 상자는 템플릿 범주에 수행된 모든 변경 내용을 반영합니다.The New Project dialog box reflects any changes you make to your template categories.

사용자 프로젝트 템플릿 범주를 새로 만들려면To create new user project template categories

  1. 사용자 프로젝트 템플릿 디렉터리의 프로그래밍 언어 폴더에 폴더를 만듭니다.Create a folder in the programming language folder in the user project template directory. 예를 들어 C# 프로젝트 템플릿에 대해 HelloWorld 범주를 만들려면 다음 디렉터리를 만듭니다.For example, to establish a HelloWorld category for C# project templates, create the following directory:

    %USERPROFILE%\Documents\Visual Studio <버전>\Templates\ProjectTemplates\Visual C#\HelloWorld\%USERPROFILE%\Documents\Visual Studio <Version>\Templates\ProjectTemplates\Visual C#\HelloWorld\

  2. 이 범주의 모든 템플릿을 새 폴더에 넣습니다.Place all the templates for this category in the new folder.

  3. 파일 메뉴에서 새로 만들기 > 프로젝트를 차례로 선택합니다.On the File menu, choose New > Project.

    HelloWorld 범주가 새 프로젝트 대화 상자의 설치됨 > Visual C# 아래에 나타납니다.The HelloWorld category appears in the New Project dialog box, under Installed > Visual C#.

사용자 항목 템플릿 범주를 새로 만들려면To create new user item template categories

  1. 사용자 항목 템플릿 디렉터리의 프로그래밍 언어 폴더에 폴더를 만듭니다.Create a folder in the programming language folder in the user item template directory. 예를 들어 C# 항목 템플릿에 대해 HelloWorld 범주를 만들려면 다음 디렉터리를 만듭니다.For example, to establish a HelloWorld category for C# item templates, create the following directory:

    %USERPROFILE%\Documents\Visual Studio <버전>\Templates\ItemTemplates\Visual C#\HelloWorld\%USERPROFILE%\Documents\Visual Studio <Version>\Templates\ItemTemplates\Visual C#\HelloWorld\

  2. 이 범주의 모든 템플릿을 새 폴더에 넣습니다.Place all the templates for this category in the new folder.

  3. 프로젝트를 만들거나 기존 프로젝트를 엽니다.Create a project or open an existing project. 그런 다음 프로젝트 메뉴에서 새 항목 추가를 선택합니다.Then, on the Project menu, choose Add New Item.

    HelloWorld 범주가 새 항목 추가 대화 상자의 설치됨 > Visual C# 항목 아래에 나타납니다.The HelloWorld category appears in the Add New Item dialog box, under Installed > Visual C# Items.

부모 범주에 템플릿 표시Displaying templates in parent categories

.vstemplate 파일에서 NumberOfParentCategoriesToRollUp 요소를 사용하여 하위 범주의 템플릿이 부모 범주에 표시되도록 할 수 있습니다.You can enable templates in subcategories to be displayed in their parent categories by using the NumberOfParentCategoriesToRollUp element in the .vstemplate file. 이 단계는 프로젝트 템플릿과 항목 템플릿에 대해 동일합니다.These steps are identical for project templates and item templates.

템플릿을 부모 범주에 표시하려면To display templates in parent categories

  1. 템플릿을 포함하는 .zip 파일을 찾습니다.Locate the .zip file that contains the template.

  2. .zip 파일의 압축을 풉니다.Extract the .zip file.

  3. Visual Studio에서 .vstemplate 파일을 엽니다.Open the .vstemplate file in Visual Studio.

  4. TemplateData 요소에서 NumberOfParentCategoriesToRollUp 요소를 추가합니다.In the TemplateData element, add a NumberOfParentCategoriesToRollUp element. 예를 들어 다음 코드에서는 템플릿이 부모 범주에 표시되고 더 높은 범주에는 표시되지 않도록 합니다.For example, the following code makes the template visible in the parent category, but no higher.

    <TemplateData>
        ...
        <NumberOfParentCategoriesToRollUp>
            1
        </NumberOfParentCategoriesToRollUp>
        ...
    </TemplateData>
    
  5. .vstemplate 파일을 저장한 다음 닫습니다.Save and close the .vstemplate file.

  6. 템플릿에 있는 파일을 선택하고 마우스 오른쪽 단추를 클릭한 다음 보내기 > 압축(ZIP) 폴더를 선택합니다.Select the files in your template, right-click the selection, and choose Send to > Compressed (zipped) folder.

    파일이 .zip 파일로 압축됩니다.The files are compressed into a .zip file.

  7. 추출된 템플릿 파일과 이전 템플릿 .zip 파일을 삭제합니다.Delete the extracted template files and the old template .zip file.

  8. 새 .zip 파일을 삭제된 .zip 파일이 있던 디렉터리에 넣습니다.Put the new .zip file in the directory that had the deleted .zip file.

참고 항목See also

템플릿 사용자 지정Customizing Templates
Visual Studio 템플릿 스키마 참조(확장성)Visual Studio Template Schema Reference (Extensibility)
NumberOfParentCategoriesToRollUp(Visual Studio 템플릿)NumberOfParentCategoriesToRollUp (Visual Studio Templates)
방법: 프로젝트 템플릿 만들기How to: Create Project Templates
방법: 항목 템플릿 만들기How to: Create Item Templates