Visual Studio 2017의 문제를 보고하는 방법How to report a problem with Visual Studio 2017

Visual Studio에 문제가 발생하는 경우와 관련하여 자세히 알려고 합니다.If you experience a problem with Visual Studio, we want to know about it. 진단하고 해결할 수 있도록 개발자 커뮤니티에 대한 문제를 보고하는 방법은 다음과 같습니다.Here's how to report the problem to Developer Community so that we can diagnose and fix it.

Visual Studio를 사용하여 문제 보고Report a problem by using Visual Studio

Visual Studio에 대한 문제를 보고하려면 Visual Studio 또는 Visual Studio 설치 관리자에서 보고서를 시작해야 합니다.To report a problem for Visual Studio, you must initiate the report from Visual Studio or the Visual Studio Installer. 개발자 커뮤니티 웹 사이트를 통해 직접 수행할 수 없습니다.You can't do it directly through the Developer Community website. Visual Studio를 통해 보고하면 진단 정보를 보고서에 자동으로 포함할 수 있습니다.Reporting through Visual Studio allows for diagnostic information to be automatically included in the report.

Visual Studio 개발자 커뮤니티에 대한 문제 팝업 보고

  1. Visual Studio에서 도움말 > 피드백 보내기 > 문제 보고를 선택합니다.In Visual Studio, select Help > Send Feedback > Report a Problem.

    Visual Studio 설치를 완료할 수 없거나 Visual Studio 내에서 피드백 도구에 액세스할 수 없는 경우 Visual Studio 설치 관리자를 사용하여 문제를 보고할 수 있습니다.If you can't complete the Visual Studio installation or you can't access the feedback tool within Visual Studio, you can report a problem by using the Visual Studio Installer. 이렇게 하려면 Visual Studio 설치 관리자의 오른쪽 위에서 피드백 아이콘을 선택합니다.To do so, choose the feedback icon in the upper-right corner of the Visual Studio Installer.

  2. 로그인되지 않은 경우 다음 스크린샷과 같이 도구 오른쪽에 있는 로그인을 선택합니다.If you are not signed in, select Sign In; it's on the right-hand side of the tool, as shown in the following screenshot. 화면의 지침에 따라 로그인합니다.Follow the instructions on-screen to sign in.

    로그인하여 문제 보고

    로그인할 때 발생하는 문제를 보고할 수 있습니다.When you sign in, you can report a problem that you're experiencing. 게시한 다른 문제에 대해 투표하거나 주석으로 처리할 수도 있습니다.You can also vote or comment on any other problem that you see posted.

  3. 로그인하면 팔로우한 항목 화면에서 문제작업을 확인할 수 있습니다.Once signed in, you will be able to see your Problems and Activity in the Items I follow screen

    팔로우한 항목

  4. Visual Studio는 문제를 검색하고 다른 사용자가 보고했는지를 확인하는 인터페이스를 제공합니다.Visual Studio provides an interface to search for your problem and see if others have reported it. 다른 사용자가 이미 보고한 경우 "투표"하여 알려 주시기 바랍니다.If someone has reported it, "up-vote" it to let us know.

    참고

    검색하기 위해 검색 상자에 원하는 텍스트를 입력하고 Enter 키를 클릭하거나 검색 아이콘을 누릅니다.In order to search, please input the desired text into the search box and either click Enter or press the Search icon.

    유사한 문제 검색 및 투표

  5. 발생한 문제를 찾을 수 없는 경우 화면 맨 아래에서 새 문제 보고를 선택합니다.If you don’t find the problem you encountered, choose Report new problem at the bottom of the screen.

    참고

    새 문제 보고 단추는 개발자 커뮤니티에 대한 Visual Studio 인터페이스에만 표시됩니다.The Report new problem button only appears in the Visual Studio interface for Developer Community. 개발자 커뮤니티 웹 사이트에서 직접 문제를 보고할 수 없습니다.You can't report a problem directly on the Developer Community website.

  6. 올바른 Visual Studio 팀에게 전달될 수 있도록 문제에 대한 설명이 포함된 제목을 입력합니다.Create a descriptive title for the problem that helps us route it to the correct Visual Studio team.

  7. 추가 세부 정보와 문제를 재현을 위한 단계(가능한 경우)를 제공합니다.Give us any additional details, and if possible, provide us with the steps to reproduce the problem.

    새 문제 보고

  8. 다음을 선택하여 첨부 파일 탭으로 이동합니다. 여기에서 현재 화면을 캡처하여 Microsoft로 보낼 수 있습니다.Select Next to move to the Attachments tab. Here, you can capture your current screen to send it to Microsoft. 추가 스크린샷 또는 다른 파일을 첨부하려면 추가 파일 첨부를 선택합니다.To attach additional screenshots or other files, choose Attach Additional Files.

    Visual Studio 문제 보고서에 스크린샷 첨부

  9. 스크린샷을 첨부하지 않거나 재현을 기록하지 않으려는 경우 다음을 선택하여 요약 탭으로 이동합니다.If you don't want to attach a screenshot or record a repro, select Next to move to the Summary tab.

  10. 제출을 선택하여 이미지 및 추적 또는 덤프 파일과 함께 보고서를 보냅니다.Select Submit to send your report, along with any images and trace or dump files. 제출 단추가 회색으로 표시되는 경우 보고서의 제목과 설명을 입력했는지 확인합니다.(If the Submit button is grayed out, make sure that you've provided a title and description for the report.)

    수집되는 데이터에 대한 자세한 내용은 수집한 데이터를 참조하세요.For information about what data is collected, see Data we collect.

재현 기록Record a repro

추적 및 힙 덤프 파일은 문제를 진단하는 데 유용합니다.Trace and heap dump files are useful in helping us diagnose problems. 문제 보고 도구를 사용하여 재현 단계를 기록하여 데이터를 Microsoft로 보내 주시면 감사하겠습니다.We appreciate it when you use the Report a Problem tool to record your repro steps and send the data to Microsoft. 방법은 다음과 같습니다.Here's how to do so:

  1. 문제에 대한 제목과 설명을 입력한 후에 다음을 선택하여 첨부 파일 탭으로 이동합니다.After you enter a title and description for your problem, select Next to move to the Attachments tab.

  2. 레코드 탭을 선택합니다.Select the Record tab.

  3. 문제를 재현할 수 있는 경우 작업 기록에서 Visual Studio의 현재 인스턴스를 선택합니다.Under Record your actions, select the current instance of Visual Studio if you can reproduce the problem there. 예를 들어 Visual Studio가 정지되어 수행할 수 없는 경우 <새 인스턴스 만들기> 를 선택하여 Visual Studio의 새 인스턴스에서 작업을 기록합니다.If you can't, for example if Visual Studio is hung, select <Create a new instance> to record the actions in a new instance of Visual Studio.

  4. 기록 시작을 선택합니다.Select Start Recording. 도구를 실행할 수 있는 권한을 제공합니다.Give permission to run the tool.

    Visual Studio 문제 보고에서 추적 및 힙 덤프 파일을 제공하도록 "기록 시작" 선택

  5. 단계 레코더 도구가 나타나면 문제를 재현하는 단계를 수행합니다.When the Steps Recorder tool appears, perform the steps that reproduce the problem.

  6. 작업이 완료되면 기록 중지 단추를 선택합니다.When you're done, choose the Stop Record button.

  7. Visual Studio에서 기록된 정보를 수집하여 패키징하는 동안 몇 분 정도 기다립니다.Wait a few minutes for Visual Studio to collect and package the information that you recorded.

    수집되는 데이터에 대한 자세한 내용은 수집한 데이터를 참조하세요.For information about what data is collected, see Data we collect.

추가 정보가 필요한 경우(추가 정보 필요)When further information is needed (Need More Info)

Visual Studio 2017 버전 15.5 부터는 사용자가 문제 보고에 대한 추가 정보를 제공할 수 있는 새 워크플로가 있습니다.Starting in Visual Studio 2017 Version 15.5, there's a new workflow to help users provide additional information about problem reports.

  1. Microsoft 엔지니어가 Visual Studio 개발자 커뮤니티 문제를 추가 정보 필요 상태로 설정하는 경우 문제에 대해 게시하거나, 투표하거나, 주석을 처리한 사용자는 Visual Studio의 문제 보고 도구에서 알림을 받습니다.When a Microsoft engineer sets the Visual Studio Developer Community problem to the Need More Info state, any user that posted, voted, followed, or commented on the problem gets a notification in the Report A Problem tool in Visual Studio.

    Visual Studio의 추가 정보 필요 알림

  2. 문제 보기 링크를 클릭하여 주의가 필요한 문제에 대한 보기를 필터링하고 정렬합니다.Click on the View Problems link to filter and sort the view to the problems that need attention. 이러한 문제에는 옆에 지표가 있어서 일반적인 검색에서 구분합니다.These problems also have an indicator next to them, to differentiate them in general search.

  3. 문제를 클릭하여 문제 세부 정보 보기를 봅니다.Click on a problem to see the problem details view.

    추가 정보 필요 알림

  4. 추가 정보 필요 요청을 보려면 문제 세부 정보 보기에서 해당 요청 및 응답 보기 링크를 클릭합니다.To view the Need More Info request, click the View their request and respond link in the problem details view. 대화 상자에는 다음 요청이 표시됩니다.A dialog box shows the request.

    추가 정보 필요 알림

  5. 주석, 첨부 파일 또는 기록 단계를 추가하여 자세한 정보를 제공할 수 있습니다.You can provide more information by adding comments, attachments, or recording steps. 이 환경은 문제에 투표하는 경우 새 문제 보고하거나 추가 정보를 제공하는 작업과 비슷합니다.This experience is similar to reporting a new problem or providing additional information when voting on a problem.

  6. 요청한 Microsoft 엔지니어는 제공된 추가 정보에 대한 알림을 받습니다.The requesting Microsoft engineer receives a notification about the extra information provided. 조사하는 데 충분한 정보가 있으면 문제 상태를 변경합니다.If they have enough information to investigate, the problem state changes. 그렇지 않으면 엔지니어도 추가 정보를 요청합니다.Otherwise, the engineer asks for even further information.

    참고

    • 회신하면 알림이 사라집니다.When you reply, the notification goes away. 해당 위치에는 감사의 말씀을 전하고 더 많은 정보를 제공하는 방법을 용이하게 하는 배너가 표시됩니다.In its place, you see a banner that thanks you and facilitates a way to provide even more information.
    • 문제가 상태를 변경하면 문제를 팔로우하는 모든 사용자에 대한 알림이 사라집니다.Once the issue changes state, the notification goes away for everyone that's following the issue.
    • 두 명 이상이 동일한 추가 정보 필요 요청에서 회신할 수 있습니다.More than one person can reply on the same Need More Info request.
    • 웹 브라우저를 통해 직접 액세스할 수 있는 경우 개발자 커뮤니티추가 정보 필요 워크플로가 없지만 거기에서 주석 및 첨부 파일을 제공할 수도 있습니다.There isn't a Need More Info workflow on Developer Community when you access it directly through a web browser, but you can also provide comments and attachments there.

솔루션 검색 또는 피드백 제공Search for solutions or provide feedback

문제를 보고하기 위해 Visual Studio를 사용할 수 없거나 원하지 않는 경우 Visual Studio 개발자 커뮤니티 페이지에 문제가 이미 보고되고 솔루션이 게시됐을 수 있습니다.If you don't want to or can't use Visual Studio to report a problem, there's a chance that the problem has already been reported and a solution posted on the Visual Studio Developer Community page.

보고할 문제가 없지만 제품 피드백 또는 제안을 제공하려는 경우 따로 위치가 정해져 있습니다.If you don't have a problem to report but want to provide product feedback or a suggestion, there's a place for that, too. 자세한 내용은 UserVoice 페이지를 참조하세요.For more information, see the UserVoice page.

참고 항목See also