방법: 인코딩을 사용하여 파일 저장 및 열기How to: Save and Open Files with Encoding

양방향 언어를 지원하기 위해 특정 문자 인코딩을 사용하여 파일을 저장할 수 있습니다.You can save files with specific character encoding to support bi-directional languages. Visual Studio에 파일이 제대로 표시되도록 파일을 열 때 인코딩을 지정할 수 있습니다.You can also specify an encoding when opening a file, so that Visual Studio displays the file correctly.

인코딩을 사용하여 파일을 저장하려면To save a file with encoding

  1. 파일 메뉴에서 다른 이름으로 파일 저장을 선택하고 저장 단추 옆의 드롭다운 단추를 클릭합니다.From the File menu, choose Save File As, and then click the drop-down button next to the Save button.

    고급 저장 옵션 대화 상자가 표시됩니다.The Advanced Save Options dialog box is displayed.

  2. 인코딩에서 파일에 사용할 인코딩을 선택합니다.Under Encoding, select the encoding to use for the file.

  3. 선택적으로 줄 끝에서 줄 끝 문자의 형식을 선택합니다.Optionally, under Line endings, select the format for end-of-line characters.

    파일을 다른 운영 체제의 사용자와 교환하려는 경우 이 옵션이 유용합니다.This option is useful if you intend to exchange the file with users of a different operating system.

    알고 있는 특정 방법으로 인코딩된 파일을 사용하려면 파일을 열 때 해당 인코딩을 사용하도록 Visual Studio에 알릴 수 있습니다.If you want to work with a file that you know is encoded in a specific way, you can tell Visual Studio to use that encoding when opening the file. 사용할 방법은 파일이 프로젝트에 포함되는지에 따라 달라집니다.The method you use depends on whether the file is part of your project.

프로젝트에 포함된 인코딩된 파일을 열려면To open an encoded file that is part of a project

  1. 솔루션 탐색기에서 파일을 마우스 오른쪽 단추로 클릭하고 연결 프로그램을 선택합니다.In Solution Explorer, right-click the file and choose Open With.

  2. 연결 프로그램 대화 상자에서 파일을 열 편집기를 선택합니다.In the Open With dialog box, choose the editor to open the file with.

    양식 편집기와 같은 대부분의 Visual Studio 편집기에서는 인코딩을 자동 검색하고 적절하게 파일을 엽니다.Many Visual Studio editors, such as the forms editor, will auto-detect the encoding and open the file appropriately. 인코딩을 선택할 수 있는 편집기를 선택하면 인코딩 대화 상자가 표시됩니다.If you choose an editor that allows you to choose an encoding, the Encoding dialog box is displayed.

  3. 인코딩 대화 상자에서 편집기에서 사용해야 하는 인코딩을 선택합니다.In the Encoding dialog box, select the encoding that the editor should use.

프로젝트에 포함되지 않은 인코딩된 파일을 열려면To open an encoded file that is not part of a project

  1. 파일 메뉴에서 열기를 가리키고 파일 또는 웹 파일을 선택하고 나서 열 파일을 선택합니다.On the File menu, point to Open, choose File or File From Web, and then select the file to open.

  2. 열기 단추 옆의 드롭다운 단추를 클릭하고 연결 프로그램을 선택합니다.Click the drop-down button next to the Open button and choose Open With.

  3. 이전 절차에서 2단계 및 3단계를 수행합니다.Follow Steps 2 and 3 from the preceding procedure.

참고 항목See Also

인코딩 및 Windows Forms 전역화 Encoding and Windows Forms Globalization
응용 프로그램 전역화 및 지역화Globalizing and Localizing Applications