방법: 기존 템플릿 업데이트How to: Update existing templates

템플릿을 만들고 파일을 .zip 파일로 압축한 후 템플릿을 수정하려고 할 수 있습니다.After you create a template and compress the files into a .zip file, you may want to modify the template. 템플릿의 파일을 수동으로 변경하거나 해당 템플릿을 기반으로 하는 프로젝트에서 새 템플릿을 내보내는 방법으로 이 작업을 수행할 수 있습니다.You can do this by manually changing the files in the template, or by exporting a new template from a project that is based on the template.

템플릿 내보내기 마법사를 사용하여 기존 프로젝트 템플릿 업데이트Using the Export Template Wizard to update an existing project template

Visual Studio에서는 기존 템플릿을 업데이트하는 데 사용할 수 있는 템플릿 내보내기 마법사를 제공합니다.Visual Studio provides an Export Template Wizard that can be used to update an existing template:

  1. 파일 > 새로 만들기 > 프로젝트를 선택하여 새 프로젝트 대화 상자를 엽니다.Open the New Project dialog box by choosing File > New > Project.

  2. 업데이트할 템플릿을 선택하고 프로젝트의 이름과 위치를 입력한 다음 확인을 선택합니다.Select the template that you want to update, enter a name and location for your project, and choose OK.

  3. Visual Studio에서 프로젝트를 수정합니다.Modify the project in Visual Studio.

  4. 프로젝트 메뉴에서 템플릿 내보내기...를 선택합니다.On the Project menu, choose Export Template....

    템플릿 내보내기 마법사가 열립니다.The Export Template Wizard opens.

  5. 마법사에서 표시되는 메시지를 따라 템플릿을 .zip 파일로 내보냅니다.Follow the prompts in the wizard to export the template as a .zip file.

  6. (선택 사항) 새 프로젝트 대화 상자에 템플릿을 추가하려면 %USERPROFILE%\Documents\Visual Studio <버전>\Templates\ProjectTemplates 디렉터리에 .zip 파일을 추가합니다.(Optional) To add the template to the New Project dialog box, place the .zip file in the following directory: %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates. 템플릿 내보내기 마법사에서 템플릿을 자동으로 Visual Studio로 가져오기 옵션을 선택하지 않은 경우 이 단계를 수행해야 합니다.You'll need to perform this step if you did not select the option Automatically import the template into Visual Studio in the Export Template Wizard.

  7. 이전 템플릿 .zip 파일을 삭제합니다.Delete the old template .zip file.

기존 템플릿 수동 업데이트Manually updating an existing template

압축된 .zip 파일에 있는 파일을 수정하여 템플릿 내보내기 마법사를 사용하지 않고 기존 템플릿을 업데이트할 수 있습니다.You can update an existing template without using the Export Template Wizard, by modifying the files in the compressed .zip file.

기존 템플릿을 수동으로 업데이트하려면To manually update an existing template

  1. 템플릿을 포함하는 .zip 파일을 찾습니다.Locate the .zip file that contains the template. 사용자 프로젝트 템플릿은 일반적으로 %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates에 있습니다.User project templates are usually located at %USERPROFILE%\Documents\Visual Studio <version>\Templates\ProjectTemplates.

  2. .zip 파일의 압축을 풉니다.Extract the .zip file.

  3. 현재 템플릿 파일을 수정 또는 삭제하거나 템플릿에 새 파일을 추가합니다.Modify or delete the current template files, or add new files to the template.

  4. .vstemplate XML 파일을 열어서 수정한 다음 저장하여 업데이트된 동작 또는 새 파일을 처리합니다.Open, modify, and save the .vstemplate XML file to handle updated behavior or new files.

    .vstemplate 스키마에 대한 자세한 내용은 Visual Studio 템플릿 스키마 참조(확장성)를 참조하세요.For more information about the .vstemplate schema, see Visual Studio template schema reference (Extensibility). 원본 파일에서 매개 변수화할 수 있는 항목에 대한 자세한 내용은 템플릿 매개 변수를 참조하세요.For more information about what you can parameterize in the source files, see Template parameters.

  5. 템플릿에 있는 파일을 선택하고 마우스 오른쪽 단추를 클릭하면 나타나는 메뉴, 즉 바로 가기 메뉴에서 보내기 > 압축(ZIP) 폴더를 선택합니다.Select the files in your template, and from the right-click or context menu, and choose Send to > Compressed (zipped) folder.

    선택한 파일이 .zip 파일로 압축됩니다.The files that you selected are compressed into a .zip file.

  6. 새 .zip 파일을 이전 .zip 파일과 같은 디렉터리에 넣습니다.Put the new .zip file in the same directory as the old .zip file.

  7. 추출된 템플릿 파일과 이전 템플릿 .zip 파일을 삭제합니다.Delete the extracted template files and the old template .zip file.

참고 항목See also

템플릿 사용자 지정Customizing Templates
프로젝트 템플릿 및 항목 템플릿 만들기Creating Project and Item Templates
Visual Studio 템플릿 스키마 참조Visual Studio Template Schema Reference
템플릿 매개 변수Template Parameters
방법: 시작 키트 만들기How to: Create Starter Kits